Atario

Members
  • Content Count

    14
  • Joined

  • Last visited

Community Reputation

3 Neutral

About Atario

  • Rank
    Bottle Rocketeer

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Obvious things I hope will no longer be an issue: Anything "Space Kraken" related (Shaking Station Syndrome, spontaneous flinging into the sky at mach 35, etc.) Frame rates going down the tubes with anything remotely ambitiously built Less obvious things: I hope vessels will no longer be represented as a tree (root part, child parts, grandchild parts, etc.) but as an arbitrary undirected graph, so we no longer have to worry about any of that nonsense I hope friction will be fixed (as it is now, nothing can be counted on to stay in one spot on the ground long-term) My personal wish list: Availability DRM-free (yes, that means outside of Steam) Something to relieve the pain of Mod Version Hell
  2. Hi @blackheart612! I don't know if this is the right place for bug reports to you, but I hope so. I'm having a perplexing issue with crew transfers. Check out this little crew shuttle I made: Base crew shuttle Mk II.craft I'd pare the sample down to remove dependency on other mods, but tiny changes to the vessel have effects that ruin what I'm trying to show. Mods needed for parts: Airplane Plus (obviously) Procedural Parts (Tidal Stream Branch) Freedom Textures (maybe?) Modular Rocket Systems FTL Drive Continued ModularPods Wheels Collection MechJeb 2 Kerbal Engineer Redux Additionally, TweakScale has been used on several of the parts. Dunno if not having it installed will muck it up. First thing to try is to launch the vessel as-is, with one Kerbal aboard. Then try transferring him from one of the Size 2 Crew Cabins to another a few times. Problem: all such attempts will try to put him in one particular cabin, regardless of which one you clicked. Next thing to try is removing the illuminator part and relaunch as before. Now all transfers work as intended with no problem. (???) This also works with some of the other parts. Next thing to try is putting the illuminator back, but attached to some different part from before. Some placements will give the original problem; some will make it work fine; still others will make some cabins work fine and others redirect. Lots of tiny changes will have unpredictable effects like this, and I'm a bit at a loss as to what's going on here…
  3. Hi! Would have left this as an enhancement-issue on Github, but the issues tab doesn't seem to be enabled there. Could we get this: …as a toggleable option somewhere? Having them enabled all the time is really messing me up, since I use WASD Editor Camera Continued. Thank you in advance!
  4. Side note: anyone feel like GameData\Chatterer\Sounds\chatter\valentina\capsuleF\capsule_25.ogg sounds like she's saying "We need to resist them and make them give us the best EVAs"?
  5. This mod is great and belongs on CKAN! Also, do you think I could prevail upon you to also invoke this when vessels dock or undock? I'm having a heck of a problem winching small wheeled rovers to anything without them flinging themselves wildly into the sky…
  6. I don't see a Github bug tracker or the like, so I thought I'd post a bug report here. I'm on KSP 1.3.1, and WalkAbout 1.7.1. While controlling a walking kerbal, this is spammed into the log, seemingly once per frame: In addition, the Perpetual Motion key seems to do nothing.
  7. This is incorrect. The actual number is 750kW, per the in-game specs and the .cfg file setting, so you can run three processes at once for 600KW total without overheating, given sufficient cooling.
  8. So the mod is capable of choosing which part gets control upon a separation?
  9. I might have the dumb right now, but what does "priority" actually do?
  10. Am I doing something wrong, or are the PAL Wheels… uh… violent? I'm talking about this one, looks like this: If I just attach four of these to a PAL Truss, set deployment to an action group, and stick a command module on, then deploying the wheels while on the KSC Launch Pad destroys the launch pad! I also tried putting four on a vessel that weighs 126 tons. Deploying them on the ground launches it maybe a dozen meters in the air. Doing it on Minmus gives an apoapsis of about 500m above terrain. Is there a "don't deploy like Mjölnir" setting? (I'm on KSP v.1.2.2 x64, for what it's worth)
  11. Hi, question about how wet/dry fuel level is expected to affect center of mass for weldments vs. how it actually does. I have a ship-core that's mostly fuel tanks, arranged symmetrically, plus a few bits and bobs that are not symmetrical, but which are arranged so as to put the CoM right at the center when the whole finished craft is put together. Everything is fine in the pre-welded state; the CoM stays right along the center column as the fuel level is changed, and the torque readout in KER stays at zero. Post-welding, the CoM moves a bit horizontally depending on fuel level, and the torque number changes. So it seems like the dry CoM is not the same after welding (or maybe the CoM of the fuel itself is being placed oddly during welding?). Is this expected behavior? Or something of a bug or limitation of the mod? EDIT: Also the cost. Things get weird if you weld something with partially-filled tanks. Up to and including parts that cost negative amounts but only when actually placed on the vessel (normal amount shows in parts list hover box).
  12. @cdm86, they did explode while building and after switching to
  13. @cdm86, that's an interesting finding. My design starts with a basic sawhorse-looking module, and all others are built on that. The plain sawhorse has: Count Name Physicsless? 4 LT-2 Landing Strut 4 M-Beam 200 I-Beam 5 Structural Fuselage 4 SP-L 1x6 Photovoltaic Panels 5 Clamp-O-Tron Docking Port 1 Z-1k Rechargeable Battery Bank 1 RC-001S Remote Guidance Unit 2 Illuminator Mk2 Y 4 BZ-52 Radial Attachment Point Y 10 EAS-4 Strut Connector Y So, 16 of my 40 parts are physicsless, 40%. The variations on the empty sawhorse are things like a fuel tank module (add one big fuel tank plus another four struts), or a drilling module (add another fuselage, a couple of drills, a cooler, and a couple of fuel cell arrays, and swap the solar panels to gigantors), stuff like that. There is one module that has a metric boatload of octagonal struts, and in retrospect that was not the best idea, both for part count and for physicsless (I was optimizing for weight), but I tried excluding that one and it still happens. Also it's kind of curious that I can add some modules together and everything's fine, but then beyond a certain number (around 10-ish), it blows up. The physicsless ratio should not significantly change in doing that. (Side note: do EAS-4 struts really exacerbate the problem the same as other physicsless parts? That would run contrary to the doctrine of MOAR STRUTS…) EDIT: regarding your note about adding parts if my computer could handle it: I have a pretty beefy machine, and currently the base-area physics bubble runs around 3-5 FPS. That is not a typo, three to five frames per second. Total part count of all vessels inside the bubble is 1452.
  14. I built a ferry to connect the same way the crawler does, but has rockets and RCS and stuff to land them, one by one (dock in orbit, land, undock, drive, refuel, launch, rendezvous with next module, repeat). Then the crawler takes over to actually connect them (the ferry doesn't have the wheel count nor the better hauling/installing geometry my crawler does). However. After laboriously flying twenty of these modules, plus support vehicles, down to Minmus, I learned to my chagrin that bases of any significant size made this way will inevitably get Shaking Station Syndrome and explode. Mine only gets about half the modules connected before it magically shimmies itself into a flying fireball of doom. Nothing I do prevents it. Including design time, I estimate I've wasted at least eighty hours of work on this. Bug-riddled games are awesome.