Jump to content

Search the Community

Showing results for tags 'part tools'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General
    • Announcements
    • The Daily Kerbal
  • Kerbal Space Program 2
    • KSP 2 Discussion
    • KSP 2 Dev Diaries
    • KSP 2 Suggestions & Development Discussion
    • Show and Tell
  • Kerbal Space Program
    • KSP Discussion
    • KSP Suggestions & Development Discussion
    • Challenges & Mission ideas
    • The Spacecraft Exchange
    • KSP Fan Works
  • Community
    • Welcome Aboard
    • Science & Spaceflight
    • Kerbal Network
    • The Lounge
  • Gameplay and Technical Support
    • Gameplay Questions and Tutorials
    • Technical Support (PC, unmodded installs)
    • Technical Support (PC, modded installs)
    • Technical Support (PlayStation 4, XBox One)
  • Add-ons
    • Add-on Discussions
    • Add-on Releases
    • Add-on Development
  • Making History Expansion
    • Making History Missions
    • Making History Discussion
    • Making History Support
  • Breaking Ground Expansion
    • Breaking Ground Discussion
    • Breaking Ground Support
  • International
    • International
  • KerbalEDU Forums
    • KerbalEDU
    • KerbalEDU Website

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Skype


Twitter


About me


Location


Interests

Found 8 results

  1. Hello there! I am new on the ksp forum, i've been playing ksp for a long time now and wanted to make some IVAs using rpm and moardv. I looked up on google and on the ksp forum and using this thread I found out that I have to use Unity 2019.2.2f1 and KSP Part Tools. ◄ I install Unity 2019.2.2f1 from unity's site► ◄ I deleted and installed a fresh KSP copy from steam so to not havy any issues ► ◄ I opened Unity and installed the part tools ► ◄ I removed TextMesh Pro that came pre-installed with Unity, and followed the thread ► ◄ I opened the KSP part tool window in unity and I set up the GameData folder to the GameData folder of the fresh KSP install ► ◄ I spawn a cupolaInternal IVA and this happens► https://ibb.co/5Y1PHvy ▲ Unity Viewport is bugged with incorrect shaders and textures https://ibb.co/jz0VV2W ▲ The errors that Unity gives me about missing models/textures I've alredy spent some days looking for some doumentation but all I could find was little to nothing, I hope that I was clear with the problem. Thanks in advance !
  2. I have a quadcopter part thats basically a probe core with 4 attachment points and it works fine except the model doesnt show up so i cant select it. Ill upload a few pics here Also how do i 'assign KSP shaders', i cant find any ksp shaders other than the particle shaders also also what is the 'File URL' in the Part tools script
  3. So whilst trying to put together some new model for a current mod I opened the project in unity (5.4.1) which I had built the entire mod in originally only to find tat the 'Part Tools' in the inspector is broken. I have no function for the KSP Part Tools (script) no option to set 'game data directory', no option to 'write', Nothing! The little expand arrow expands nothing, there is no option. As you can imagine I find this concerning as presently I can creating no new models as a result. So far I have tried: Re-installing the latest PartTools (both onto my machine and into the project). Restarting my machine (numerous times!) un-installing and re-installing my current version of Unity (5.4.1) Installing the latest version of Unity (5.5.1) and importing the project there. The result is the same; my KSP part tools script in the inspector has no functions/options. I have google'd and scoured the site and I can't see any solutions, any clues?
  4. Where did part tools go? I want to make a KSP mod but we don't have part tools anymore, at least that I know of.
  5. So after looking through the archives here and finding next to no discussion of the changes that Unity 5 KSP 1.1 caused I thought I would create this thread. First change. The form factor radii appear to all have changed, F0 = 0.25, F1 = 0.5, F2 = 1, F3 = 1.5 Second change. How you import your part tools has changed. Note: like with PT 0.23 I simply created an empty template with part tools and copy it for each new part. Third change of course we are using part tools 11-2 Forth change is there are a whole bunch of new assets that I'm not to sure how to use. Before installing the New Unity I tried to mod an old part with my old Unity today and it gave me a version warning, not sure why, so now I am unable access my old project.
  6. Hi! (and sorry for my bad english...) I do all processes, but in time to compile the mod for the game displays this error by clicking "Set GameData Directory": MissingMethodException: Method not found: 'UnityEditor.EditorWindow.set_titleContent'. KSPPartTools.PartToolsInspector.OnInspectorGUI () PartToolsEditor.OnInspectorGUI () (at Assets/PartTools/Editor/PartToolsEditor.cs:18) UnityEditor.InspectorWindow.DrawEditor (UnityEditor.Editor editor, Int32 editorIndex, Boolean forceDirty, System.Boolean& showImportedObjectBarNext, UnityEngine.Rect& importedObjectBarRect, Boolean eyeDropperDirty) (at C:/buildslave/unity/build/Editor/Mono/Inspector/InspectorWindow.cs:1150) UnityEditor.DockArea:OnGUI() Some notion of what can be?
  7. I'm looking for instructions on how to use new Part Tools for KSP 1.1 for part creation. Besides Nifty255's intro video and creating KSPedia entries by BahamutoD i haven't found anything resembling a setup guide. With old Part Tools 0.23 it was straightforward as adding ksp script component with KSP > Part Tools to game object, setting up output folders and pressing "write" button. Now there are two entries "KSPAssets.KSPedia" and "KSPAssets.Loaders". I assume " KSPAssets.Loaders" is right way to go, but rest is just "white noise" to me. I don't get it - there are many plugins and part packs updated for KSP 1.1+ but none of the tutorials for new Part Tools ???
  8. Hi all, I noticed that with KSP 1.0.5, we have some new props and interiors available such as the mk1InlineInternal, Seat_Passenger, and CargoBagA. When I try to load these props or new spaces into Unity, Unity hangs and eventually crashes. Has anybody else experienced this? Is anybody able to successfully load the new spaces/props? If so, how? Thanks for your help.
×
×
  • Create New...