Jump to content

[1.8.x] KerboKatz - SmallUtilities - 18.10.2019


Recommended Posts

Windows 8 64bit / Kerbal 1.0.2 32bit

Silly question, but... how do you get the auto-balancing landing legs to work?

I landed on the side of the hill alongside the runway but it doesn't balance at all; the lander just tilts over like normal. And I was using the specific balancing legs, not the stock ones.

I noticed there was a button relating to locking the springs... that didn't seem to do anything...?

Thanks in advance for your help. :)

Did you use the KerboKatz autobalaning legs? Not the addon, the part - this addon adds new versions of the landing legs with the autobalancing code, it doesn't change the stock legs.

They work exactly like the stock legs otherwise, though, or at least as far as I can tell.

Link to post
Share on other sites

Hi,

I've been trying out your AutoBalancingLandingLeg mod.

I'm testing it on a 1.0.4 install.

Got the following problems:

1. Mechjeb doesn't automatically extend the legs (I selected the LT-2 Landing Strut KerboKatz)

2. It doesn't seem to work. I landed on a slope, and it didn't do what your pics showed.

LGG

Link to post
Share on other sites
Hi,

I've been trying out your AutoBalancingLandingLeg mod.

I'm testing it on a 1.0.4 install.

Got the following problems:

1. Mechjeb doesn't automatically extend the legs (I selected the LT-2 Landing Strut KerboKatz)

Mechjeb most likely is searching for the stock landing legs. It's not something i can change/fix.

2. It doesn't seem to work. I landed on a slope, and it didn't do what your pics showed.

Make sure you use the right legs for the right craft weight and planet/moon.
Link to post
Share on other sites
Mechjeb most likely is searching for the stock landing legs. It's not something i can change/fix.

Make sure you use the right legs for the right craft weight and planet/moon.

I see three diferent landing legs: LT-05, LT-1 and LT-02 (BTW, the LT-05 version you created does NOT have the Kerbokatz in the name)

For Minmus, which one should I use?

Thanks

LGG

Link to post
Share on other sites
I see three diferent landing legs: LT-05, LT-1 and LT-02 (BTW, the LT-05 version you created does NOT have the Kerbokatz in the name)

I noticed this a few days ago and will be fixed with the next update.

For Minmus, which one should I use?

Most likely LT-05. It requires a bit of trial and error.

Link to post
Share on other sites
I noticed this a few days ago and will be fixed with the next update.

Most likely LT-05. It requires a bit of trial and error.

OK.

Might I suggest that you add some notes to the first page/instructions talking about the differences between the landing gear?

FYI, I was using the LT-02 because of the vertical height it provides, to provide clearance for the engine.

Thanks

Link to post
Share on other sites
OK.

Might I suggest that you add some notes to the first page/instructions talking about the differences between the landing gear?

FYI, I was using the LT-02 because of the vertical height it provides, to provide clearance for the engine.

Thanks

Just an FYI, I did see it work, very nice.

Link to post
Share on other sites
I just tested something similar to your lander and as i thought the LT-05 Micro Landing Strut is more in the region of its weight.

http://i.imgur.com/KloLVh5m.png

Did it using the smaller legs as suggested, and it worked. It's really slow to balance, though; the lander still landed and tilted over - it balances itself over the course of about a minute. This is really only useful if you're building a surface base and need to level the structure for a docking port.

While I appreciate your work and effort, SpaceTiger, the legs balance too slowly to be of use when landing an ordinary lander on a slope and hoping to prevent it from toppling over.

I was hoping the mod would do something like

(which dynamically measures the distance to the ground from the bottom of each landing leg and extends/retracts each leg in real time so that the craft is perfectly level at the moment of touchdown). (The reason I don't use kOS is that this solution requires extra parts, and I'm already hitting the memory limit, so I was hoping to have a solution that includes everything in the one automated part).

Is there any chance you could do something like this, please?

Link to post
Share on other sites
Autobalancing landing legs... how to make it work? Mod is installed, modulemanager is installed... Lander still flips at puny 3 degree slope when not using SAS/RCS.

- - - Updated - - -

Nevermind. It was a WEIRD config that created unexpected new parts instead of upgrading existing ones.

Hey, De. Jet! How did you fix this?

I'm having the same issue...

Link to post
Share on other sites
Hey, De. Jet! How did you fix this?

I'm having the same issue...

The AutoBalancingLandingLeg mod adds its own version of the stock landinglegs. You have to use those to notice any difference. You can identify them by the name and module that they have.

Link to post
Share on other sites

How exactly does the FPS Limiter work.

There are several methods to limit fps, some of which have more impact on active-run performance as well as GPU power consumption.

Another thing, is to switch windowed mode and reduce the rendered resolution when in the background. As far as the game is concerned there is no difference in simulation between rendering to 720x1280 from rendering 1080x1920. However, from a side of GPU consumption there is a major difference. This provides a decent thumbnail for the window managing system (Aero on Windows, Aqua on OS X and the Compositor on Linux) while further reducing graphic consumption. One could also turn off Antialiasing and aniso filtering because nobody will notice that they are missing.

If one really wanted to tinker in settings, one could reduce the quality of the mip-mapping bias when in this mode as well. This would even further reduce GPU consumption. However, it would also add unnecessary bulk to the mod that might not be worth it.

Another mod I'd like to see is overburn functionality to engines. This would allow LFO Rocket engines to run at 200% power, at the cost of overheating if kept on, and a possible loss of efficiency. This is an actual functionality put into real world engines.

Finally, is there a way you could replace the GUI heat gauge on parts with a simple heat warning, that is a small icon that flashes over the part when the heat gauge would almost be full. If the heat gauge could be put in the right click menu instead, that would also be a nice mini tool.

Edited by Ruedii
Added a second and third request
Link to post
Share on other sites

for afteburner, there is ToggleAfterBurner event, could you also add an EnableAfterBurner and DisableAfterBurner plz?:)

edit: enabling afterburner should also set throttle to max

normal engine operation is more efficiency, afterburners is literally dumping fuel into the exhaust for extra thrust

so nobody in their right mind should use afterburner without max thrust

that said i'm sure some nut would complain, so perhaps a KSPField SetThrootleMax = false

then if config sets true, it acts as i suggested, else works current way :)

edit: just realized throttle applies to all engines uh...

some way to max throttle / ignore throttle + set full while afterburner on?

edit: XD maybe some extra fiery exhaust effect while afterburner active

dont hate me for bein a thinker! :(

Edited by Scientist
Link to post
Share on other sites

It seems the Legs do work most of the time, but sometimes they get bugged. Not working at all in extreme conditions, ok, but i got 1 ship which exploded after F9 with Kerbokatz Legs, send several kerbals and missions to hell. I'm still trying to recover this but theres no command module on that ship (jeb on a rover), even with cheats on its no easy job to rescue the save. Sorry but this means i will uninstall the Legs asap.

Link to post
Share on other sites

I'm finding the legs _usually_ work, but sometimes just don't. As well, if you've had a... mishap... and ended up with a craft on it's side, it's near impossible to recover it because the legs won't lift it up properly. I suspect that later bit is inevitable given how they work, however.

Link to post
Share on other sites
  • 3 weeks later...

Getting an odd error when toggling the landing legs that have the auto-balancing applied to them in the editor:

NullReferenceException: Object reference not set to an instance of an object
KerboKatz.ModuleAutoBalancingLandingLeg.lowerLeg ()
KerboKatz.ModuleAutoBalancingLandingLeg.toggleLeg ()
KerboKatz.ModuleAutoBalancingLandingLeg.toggleLegEditor ()
BaseEvent.Invoke ()
UIPartActionButton.OnClick ()

Specifically, I'm only getting this error when the module is applied to the LT-1 landing legs, the rest seem immune to it.

Link to post
Share on other sites

After the EditorCamExtensions upgrade I had an issue. In the VAB first part selected on a new craft appeared where expected. Second part selected from the list appeared partway in the floor. I was unable to move any parts after clicking on them although nodes would appear as usual when you click on parts. I did not try to load any craft.

Assuming it was EditorCamExtensions as the problem went away after uninstalling. Hope this helps. If you need more info from me just ask.

ps. I forgot how painfully slow scrolling was without the mod. Thanks for your work.

Edited by PhilTact
words wrong.
Link to post
Share on other sites
nice mod, however a question:

if i create a ship with the new kerbokatz AutoBalancingLandingLeg, will the "in flight" ship be available with the standard legs if i remove the plugin later?

Yes, it only adds the module to the landing legs so if you remove the mod the landing legs will behave like in stock again.

After the EditorCamExtensions upgrade I had an issue. In the VAB first part selected on a new craft appeared where expected. Second part selected from the list appeared partway in the floor. I was unable to move any parts after clicking on them although nodes would appear as usual when you click on parts. I did not try to load any craft.

Assuming it was EditorCamExtensions as the problem went away after uninstalling. Hope this helps. If you need more info from me just ask.

ps. I forgot how painfully slow scrolling was without the mod. Thanks for your work.

It seems that there is a little glitch. But luckily there is an easy fix: Open the EditorCamExtension settings, toggle the "Extend hanger" option on. This will allow you to build like usual and if you don't change any of the new settings the VAB/SPH will stay the same size. Edited by SpaceTiger
Link to post
Share on other sites

Since the last update, I can't build anything with landing legs, they just can't be selected in the VAB.

I'm using kerbokatz utilities and autobalancinglandinglegs.

Also, I tried uninstalling this mod, but my vessels with the autobalancing legs went missing. Luckily I had a backup save!

Is there anyone else that can check this, or is it only me?

Link to post
Share on other sites

So, I'm having a bit of an issue with the camera extender. When in the SPH, the camera jiggles when trying to adjust the height of the camera (usually with the mouse wheel). As such, I really can't use it. Unfortunately this is one of those issues that comes with absolutely no errors or anything because it thinks it's performing as intended.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...