JPLRepo

[1.7.x] TAC - Life Support v0.13.13 - Release 29th Jun 2019

Recommended Posts

So instead of problems, i had a suggestion for once :P 

what about a customizable alarm limits, so you could change the percentage left alarm. just thought of it because im getting alarms about my LS refuler only having a few years lifesupport left :P 

i figured kerbal days would be too complicated or too much processing power so my idea was just a slider in the options for the amount left.

Share this post


Link to post
Share on other sites

Hello JPLRepo!


Would it be possible to explain the following circumstance that occurs both under KSP 1.3.0 with TACLS 0.13.5 and KSP 1.3.1 with TACLS 0.13.6?

In both cases, backround processing is active.


Life Support Monitoring displays only the first manned object in space. As long as the specified object has not been loaded, only negative values are displayed which have nothing to do with the actual status of the object. Only with the loading of the first object correct data will be shown, but only for the loaded object. With good luck, a second and third are displayed after loading the first manned object, but the values of the other objects are again exclusively negative. If one of the other objects loaded, all entries for all objects with negative values appear.

All in all, I do not understand the logic that could hide behind it.

Calculating charging cycles and used EC are also terribly wrong and lead to the loss of crews at unpredictable intervals.
Funny to mention that the death of crews by repeated loading of the same savegame at different times or, in rarer cases, does not occur at all.

Share this post


Link to post
Share on other sites
1 hour ago, hraban said:

Hello JPLRepo!


Would it be possible to explain the following circumstance that occurs both under KSP 1.3.0 with TACLS 0.13.5 and KSP 1.3.1 with TACLS 0.13.6?

In both cases, backround processing is active.


Life Support Monitoring displays only the first manned object in space. As long as the specified object has not been loaded, only negative values are displayed which have nothing to do with the actual status of the object. Only with the loading of the first object correct data will be shown, but only for the loaded object. With good luck, a second and third are displayed after loading the first manned object, but the values of the other objects are again exclusively negative. If one of the other objects loaded, all entries for all objects with negative values appear.

All in all, I do not understand the logic that could hide behind it.

Calculating charging cycles and used EC are also terribly wrong and lead to the loss of crews at unpredictable intervals.
Funny to mention that the death of crews by repeated loading of the same savegame at different times or, in rarer cases, does not occur at all.

Nope, that would be a futile attempt at predicting what is going on with your install.
No Logs = No support. If you can supply logs as a start, that would go some of the way to understanding your issue.

Share this post


Link to post
Share on other sites
2 minutes ago, JPLRepo said:

Nope, that would be a futile attempt at predicting what is going on with your install.
No Logs = No support. If you can supply logs as a start, that would go some of the way to understanding your issue.

The thing has not yet completely clarified, but a complete removal of the mod with subsequent loading and saving has probably removed all scrap. The reinstallation now seems to work. I'm curious how long.  At the next occurrence of the problem there is a log between your eyes. :wink:

 

Share this post


Link to post
Share on other sites
21 hours ago, JPLRepo said:

Nope, that would be a futile attempt at predicting what is going on with your install.
No Logs = No support. If you can supply logs as a start, that would go some of the way to understanding your issue.

Ok, here the same error after save a game out of  "Game Paused" menu. Immediately after saving, the values in Life Support Monitoring changed to negative. The link to the log created after reloading the savegames comes by PM.

Share this post


Link to post
Share on other sites

I'm running 1.2.2 KSP version and TAC 0.13.0. My Electric charge consumption is being reported as fairly wrong, I imagine (the estimated duration is fairly lowon the VAB, and once I launch it shows as being able to last much longer), and I imagine I end up overstacking on batteries. By the changelogs, it seems like the bug have been fixed on a newer version. My question is, if I can update my TAC to latest version (0.13.6) and run it with my current 1.2.2 game version?

Edited by Podesta

Share this post


Link to post
Share on other sites
2 hours ago, Piratepete5 said:

Anyone else kerbals dying from oxygen toxicity randomly even though the bases are in sunlight with active solar panels?

Yes but I am on 1.3.0 still so can't make a proper report as I'm not running the latest version. I can tell you that in my case it seems to be to do with going to maximum timewarp, anything below that is fine.

Share this post


Link to post
Share on other sites
6 minutes ago, severedsolo said:

Yes but I am on 1.3.0 still so can't make a proper report as I'm not running the latest version. I can tell you that in my case it seems to be to do with going to maximum timewarp, anything below that is fine.

Same! I found infinite electricity is the only way to fix it for now. Im on 1.3.1

Share this post


Link to post
Share on other sites

Just a small note for @JPLRepo (assuming you have anything to do with CKAN support):

I've found that CKAN does not add Community Category Kit as a dependency for TAC-LS, and without it the parts are inaccessible in the editor menu.

Share this post


Link to post
Share on other sites
17 hours ago, Bottle Rocketeer 500 said:

Is there a way to find how much of each resource can fit in a part in a balanced way?

You could compare the volume of the part, estimate the capacity available for resource storage, then compare the density of the resource with the space available. This only really works for Resources that are supposed to be solid or liquid and therefore incompressible. Resources in a gaseous state, like oxygen, could be compressed, like in a scuba diver's air tank. 

I do not believe there is an automated way of doing this in-game.

Share this post


Link to post
Share on other sites
On ‎10‎/‎19‎/‎2017 at 10:40 PM, Piratepete5 said:

Anyone else kerbals dying from oxygen toxicity randomly even though the bases are in sunlight with active solar panels?

Using fuel cells causes the problem for me.  As long as I don't use them, the bug doesn't occur.

Share this post


Link to post
Share on other sites

Hi there I tried to use this profile, for a combination of TAC an Kerbalism

Although it is for 1.3 it seems to -more or less- work, but apparently some kerbalism resources (Nitrogen) are deactivated.
Is there a profile to make TAC-LS perfectly fit into kerbalism system?

Thank you

Share this post


Link to post
Share on other sites
8 minutes ago, Bersagliere81 said:

Hi there I tried to use this profile, for a combination of TAC an Kerbalism

Although it is for 1.3 it seems to -more or less- work, but apparently some kerbalism resources (Nitrogen) are deactivated.
Is there a profile to make TAC-LS perfectly fit into kerbalism system?

Thank you

None that I am aware of. Don't use kerbalism. Perhaps someone else has one.

Share this post


Link to post
Share on other sites

I use this mod with KPBS. I have made a self-sustaining base. With the base loaded I can warp for years and none of the resources drops.

When I warp from the spacecenter the resources drops and dont save the wastes.

Here some screenshots and a more detailed description: https://forum.kerbalspaceprogram.com/index.php?/topic/133606-130131-kerbal-planetary-base-systems-v157-13october-2017/&do=findComment&comment=3209868

Log with google drive: https://drive.google.com/file/d/0B9ohK6KWrFiPRDFYVGJYcjAtalk/view

Thanks!!

 

Edited by kerbalfreak

Share this post


Link to post
Share on other sites
On 20/10/2017 at 4:40 AM, Piratepete5 said:

Anyone else kerbals dying from oxygen toxicity randomly even though the bases are in sunlight with active solar panels?

On 20/10/2017 at 7:03 AM, Piratepete5 said:

Same! I found infinite electricity is the only way to fix it for now. Im on 1.3.1

I wasn't having this issue, but now it's suddenly cropped up. I've got a craft on route back from Minmus and is has fully charged batteries, solar panels in direct sunlight and an RTG (and are all stock parts), yet it says it has run out of electricity (and is now -1h before the crew gets killed).  I've tried switching on infinite electricity but that doesn't seem to make any difference. Are there any known workarounds for this, or a way to completely disable electricity as a life support requirement (and have that effect in flight craft)?  

 

EDIT - ah!!! ahha! I found I thing! 
So I went poking around in the save file to see if there was anything I could change and noticed this;
In the TacLifeSupport SCENARIO section, in the info for this craft I noticed that the times for last<resource> all had the same timestamp, except for lastElectricity which had a slightly lower timestamp.  Here's the section for that craft;

VesselInfo
{
  vesselName = CT-8-LR
  vesselType = Plane
  vesselSituation = ESCAPING
  vesselIsPreLaunch = False
  numCrew = 10
  numFrozenCrew = 0
  numOccupiedParts = 3
  lastUpdate = 8927049.5977627598
  lastFood = 8927049.5977627598
  lastWater = 8927049.5977627598
  lastOxygen = 8927049.5977627598
  lastElectricity = 8920822.707542222
  remainingFood = 248.91619888612885
  remainingWater = 164.52282228941004
  remainingOxygen = 25197.894737724058
  remainingElectricity = 350
  remainingCO2 = 6900.3936632799514
  remainingWaste = 7.1744741504804894
  remainingWasteWater = 66.404339919180458
  maxFood = 327.80844091796877
  maxWater = 216.66722412109374
  maxOxygen = 33184.197093750001
  maxElectricity = 350
  estimatedElectricityConsumptionRate = 0.20541666666666666
  hibernating = False
  recoveryvessel = False
  windowOpen = False
  Guid = 289822b7-d2d7-40c4-8dba-ebf35a7b52b4
}

So I edited my quicksave.sfs and just set the value for lastElectricity to be the same as the others, then reloaded that quicksave and now the TAC info is showing the correct time remaining for Electricity remaining and my crew aren't going to die in a manner most ghastly! yay! 
I'm not sure if that info is of any use to you @JPLRepo, but it might be a workaround for other players if they have this issue.

 

Share this post


Link to post
Share on other sites

Does anybody know of a list of other mods designed to work with TAC LS? Like new models for storage Containers or bigger converters, stuff like that?

Share this post


Link to post
Share on other sites
7 hours ago, Herbiems89 said:

Does anybody know of a list of other mods designed to work with TAC LS? Like new models for storage Containers or bigger converters, stuff like that?

The ones I use are Pathfinder which has some nice containers that can be configured to TAC resources, Planetary bases which has TAC containers and life support infrastructure (green houses, air filters, water purifiers/drills).  Universal storage also has some nice containers and infrastructure which work with TAC, and I also like using  Configurable Containers which lets you change the contents of any tank which is great if you want to stick with stock style parts.  

Share this post


Link to post
Share on other sites
Quote

Aside from turning off EC use for unloaded vessels, is there any other way to add other EC sources?
TAC LS is one of the mods I always use and It'd be difficult to just remove it.
(all my kerbaled vessels and stations have TAC LS modules installed)

Still trying to work around this issue. I've been using TAC LS since Scott Manley did his video on Explode-o-Matic staging. It's one of the first mods I add when I re-do my build. I specifically use it in conjunction with things like Remote Tech & Scan Sat to increase difficulty. Unfortunately, KSPIE is also one of those. Although it'll work, I'd really rather not just disable background processing.  That disables food, water, oxygen & waste processing as well. Having the mod just for the parts and making it look like it's working seems kind of pointless. 

The vessels I'm having trouble with are equipped with a two gigawatt reactors. Power shouldn't be a problem, but with the thermal generators being ignored, it turns out to be. 

Is there some way to shut off background processing of EC without effecting the rest.

Short of enough solar panels and batteries to run the vessel, is there something that could be added? (I'd need *a lot* of panels and batteries) 

Is there something that could be edited in the .pst file to satisfy background EC processing?

I'm kinda grasping at straws here. I don't want to delete TAC LS or render it useless, but I'm far enough along in my career game that it's become an issue.

Is there something that can be done?

Share this post


Link to post
Share on other sites
On 11/13/2017 at 3:30 PM, tmbomber said:

Still trying to work around this issue. I've been using TAC LS since Scott Manley did his video on Explode-o-Matic staging. It's one of the first mods I add when I re-do my build. I specifically use it in conjunction with things like Remote Tech & Scan Sat to increase difficulty. Unfortunately, KSPIE is also one of those. Although it'll work, I'd really rather not just disable background processing.  That disables food, water, oxygen & waste processing as well. Having the mod just for the parts and making it look like it's working seems kind of pointless. 

The vessels I'm having trouble with are equipped with a two gigawatt reactors. Power shouldn't be a problem, but with the thermal generators being ignored, it turns out to be. 

Is there some way to shut off background processing of EC without effecting the rest.

Short of enough solar panels and batteries to run the vessel, is there something that could be added? (I'd need *a lot* of panels and batteries) 

Is there something that could be edited in the .pst file to satisfy background EC processing?

I'm kinda grasping at straws here. I don't want to delete TAC LS or render it useless, but I'm far enough along in my career game that it's become an issue.

Is there something that can be done?

Turn off 'Unloaded Vessel Processing' in the TAC LS difficulty settings if you are having issues.

I have been struggling to find any spare/free time to look at this lately. But hope to find some in the coming weeks to address the issues everyone has been having.

Share this post


Link to post
Share on other sites
On 11/8/2017 at 12:39 PM, katateochi said:

I wasn't having this issue, but now it's suddenly cropped up. I've got a craft on route back from Minmus and is has fully charged batteries, solar panels in direct sunlight and an RTG (and are all stock parts), yet it says it has run out of electricity (and is now -1h before the crew gets killed).  I've tried switching on infinite electricity but that doesn't seem to make any difference. Are there any known workarounds for this, or a way to completely disable electricity as a life support requirement (and have that effect in flight craft)?  

 

EDIT - ah!!! ahha! I found I thing! 
So I went poking around in the save file to see if there was anything I could change and noticed this;
In the TacLifeSupport SCENARIO section, in the info for this craft I noticed that the times for last<resource> all had the same timestamp, except for lastElectricity which had a slightly lower timestamp.  Here's the section for that craft;

So I edited my quicksave.sfs and just set the value for lastElectricity to be the same as the others, then reloaded that quicksave and now the TAC info is showing the correct time remaining for Electricity remaining and my crew aren't going to die in a manner most ghastly! yay! 
I'm not sure if that info is of any use to you @JPLRepo, but it might be a workaround for other players if they have this issue.

 

Yes Thanks, I think this helped me to find the problem.
I will do a dev build sometime today that will only be on github for people to try.
I will do a full release when confirmed and when I've finished adding support for fuel cells and reactors.

Share this post


Link to post
Share on other sites

v0.13.7Dev Build is available here.
Looking for feedback on the EC issue in particular.

https://github.com/KSP-RO/TacLifeSupport/releases/tag/v0.13.7Dev

 

A Bit more info for people on how EC consumption works. There are a few difficulty settings available that you can tweak:

In the TAC-LS difficulty settings under the "TAC LS Limits" column on the far right you will find a setting at the top called "Max Delta Time:" This setting is the maximum time that TAC LS will use when consuming resources (such as EC) in one cycle of processing. In Seconds. So you can reduce this and it will not consume more than that setting vs the actual time since you last had EC/Water/etc

The second setting to be aware of is the one below it called "Max Delta Time (Electricity):" This setting will increase the allowed "Buffer", for want of a better description, that you are allowed when timewarp is on and no resource is available.

The third setting to be aware of is the ones below this which are the "Max time without x" (x = food, water, oxygen, electricity) - This setting is the maximum time a kerbal can go without those resources. and this setting is used combined with the previous one I mentioned when calculating how long a kerbal can go without, before bad things happen to them.

Share this post


Link to post
Share on other sites
11 hours ago, JPLRepo said:

v0.13.7Dev Build is available here.
Looking for feedback on the EC issue in particular.

Awesome dude! thanks for all the work on this. I'll start using the dev build and see if the EC issue crops up again. 

Share this post


Link to post
Share on other sites
On 11/18/2017 at 2:33 PM, JPLRepo said:

Turn off 'Unloaded Vessel Processing' in the TAC LS difficulty settings if you are having issues.

I have been struggling to find any spare/free time to look at this lately. But hope to find some in the coming weeks to address the issues everyone has been having.

Glad to hear you're working on this.

As a short term fix, could you split out background EC processing and have that disable-able in the difficulty screen?
(That way everything else would still function and you'd only be disabling the function that's at issue)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.