Waz

[1.8] EnvironmentalVisualEnhancements [1.8.0-2]

Recommended Posts

2 hours ago, Galileo said:

He also said since kopernicus allows for terrain texture replacements (not as detailed, but does the job), there really wasn't a reason to do add it again.

I get your point but the Kopernicus detail terrain textures only apply in PQS and not SS. These are two different beasts and that's why i asked if we could fix/update the EVE terrain manager.

Maybe i should bug @Thomas P. and see if something similar can be implemented by Kopernicus? I guess the answer will be "no" as it probably is out of scope.

Share this post


Link to post
Share on other sites
28 minutes ago, Phineas Freak said:

I get your point but the Kopernicus detail terrain textures only apply in PQS and not SS. These are two different beasts and that's why i asked if we could fix/update the EVE terrain manager.

Maybe i should bug @Thomas P. and see if something similar can be implemented by Kopernicus? I guess the answer will be "no" as it probably is out of scope.

I totally get that, I was just relaying what waz has said in the past. ThomasP might be willing to. He likes suggestions :)

Share this post


Link to post
Share on other sites

I won't add it to Kopernicus itself, but I am willing to look into fixing it. If I manage to get it working, it'll probably end up in KopernicusExpansion

Share this post


Link to post
Share on other sites

Ok, I have this demo since last year, just before my rest.
The idea is to create "evolving" clouds (a cloud pattern always changing, not static like now). It's relatively simple to do it, using the UV noise (and in fact I'm using it in Jool right now with incredible results using clouldmaps at low resolution) but due to the current animation system it looks pretty crazy in real time.
So, my question here is:
In the future, could be possible to have an option to chain the UV speed animation to real time? (I mean, to have a value in speed wich speeds up in timewarp)

Edited by Proot

Share this post


Link to post
Share on other sites
2 hours ago, Proot said:

Ok, I have this demo since last year, just before my rest.
The idea is to create "evolving" clouds (a cloud pattern always changing, not static like now). It's relatively simple to do it, using the UV noise (and in fact I'm using it in Jool right now with incredible results using clouldmaps at low resolution) but due to the current animation system it looks pretty crazy in real time.
So, my question here is:
In the future, could be possible to have an option to chain the UV speed animation to real time? (I mean, to have a value in speed wich speeds up in timewarp)

Try this out and tell me what you think:

https://1drv.ms/u/s!Ah0aNuGsTYhahGKPEtIKsGALK4Fb

It's a build of EVE that uses realtime ("Universal Time") in the shaders. I've only done basic testing, but it should work. UVNoise animation should work for 2D clouds and their shadows (it has never been enabled for volumetric clouds).

Share this post


Link to post
Share on other sites
16 hours ago, Waz said:

Try this out and tell me what you think:

https://1drv.ms/u/s!Ah0aNuGsTYhahGKPEtIKsGALK4Fb

It's a build of EVE that uses realtime ("Universal Time") in the shaders. I've only done basic testing, but it should work. UVNoise animation should work for 2D clouds and their shadows (it has never been enabled for volumetric clouds).

W-O-W That was FAST Waz!

Thank you, and kudos! I'll let u know asap as I can try it.

 

Share this post


Link to post
Share on other sites

Is there anyway to only install clouds? 

I'm not good at deleting files, so I was wondering if someone could give me a mod file with ONLY CLOUDS. 

Thanks!

Share this post


Link to post
Share on other sites
7 minutes ago, Lo Var Lachland said:

Is there anyway to only install clouds? 

I'm not good at deleting files, so I was wondering if someone could give me a mod file with ONLY CLOUDS. 

Thanks!

If you mean because EVE default city lights look kinda sucky, I recommend the SVE citylights - way nicer and more realistic.

Alternatively, I've installed a mod file on your computer called "cityLights.cfg" - if you move that file to your Documents directory, it will enable Clouds-only mode in EVE. :-)

Edited by Waz

Share this post


Link to post
Share on other sites
46 minutes ago, Waz said:

If you mean because EVE default city lights look kinda sucky, I recommend the SVE citylights - way nicer and more realistic.

Alternatively, I've installed a mod file on your computer called "cityLights.cfg" - if you move that file to your Documents directory, it will enable Clouds-only mode in EVE. :-)

Hold on, my "Documents" folder? 

I'm running an iMac too, just to let you know. It might be different for a PC.

Edited by Lo Var Lachland

Share this post


Link to post
Share on other sites
2 hours ago, Lo Var Lachland said:

Hold on, my "Documents" folder? 

I'm running an iMac too, just to let you know. It might be different for a PC.

Sorry, a joke at your expense on the difficulty of deleting files. Just move the cityLights.cfg file from GameData/BoulderCo/CityLights/ to somewhere else (or delete it).

Share this post


Link to post
Share on other sites
18 hours ago, Waz said:

Sorry, a joke at your expense on the difficulty of deleting files. Just move the cityLights.cfg file from GameData/BoulderCo/CityLights/ to somewhere else (or delete it).

And What I posted was a joke too. Of course I can delete files. I just didn't realize which ones. :D'

 

EDIT:
It's because I always screw things up when I try to delete things lolz. 

Edited by Lo Var Lachland

Share this post


Link to post
Share on other sites
29 minutes ago, blorgon said:

Hey Waz, is the EVE config menu documentation still in the works?

Some of the more important parameters have tool tips if you just hover over them. Not all of them though

Share this post


Link to post
Share on other sites
36 minutes ago, Galileo said:

Some of the more important parameters have tool tips if you just hover over them. Not all of them though

Yeah I ended up finding most of what I needed after about 3 hours of trial and error, lol.

Share this post


Link to post
Share on other sites

How do I turn this

OBJECT
    {
        name = Minmus-Dust
        body = Minmus
        altitude = 250
        speed = 0,0,0
        killBodyRotation = true
        settings
        {
            _Color = 114,146,134,255
            _MainTex
            {
                value = zzzMaruko/EVE/Minmus/Textures/duna1
            }
        }
        layerVolume
        {
            size = 3100,3
            rotationSpeed = 0.0002
            area = 18200,3.7
            particleMaterial
            {
                _Tex
                {
                    value = zzzMaruko/EVE/Minmus/Textures/particle/rgb
                }
            }
        }
    }

 

into a fullfledged dense fog covering all but the highest hills on Minmus?

Share this post


Link to post
Share on other sites
On 13/7/2017 at 4:41 AM, Waz said:

Try this out and tell me what you think:

https://1drv.ms/u/s!Ah0aNuGsTYhahGKPEtIKsGALK4Fb

It's a build of EVE that uses realtime ("Universal Time") in the shaders. I've only done basic testing, but it should work. UVNoise animation should work for 2D clouds and their shadows (it has never been enabled for volumetric clouds).

Was perfect in the first run. Thrilling results. But after that first run most clouds are now static. I'm trying to find the problem.

It's maybe a problem with the writen .cfg? Maybe some new related config that I'm no doing well?

Share this post


Link to post
Share on other sites
3 hours ago, Proot said:

Was perfect in the first run. Thrilling results. But after that first run most clouds are now static. I'm trying to find the problem.

It's maybe a problem with the writen .cfg? Maybe some new related config that I'm no doing well?

Proot! Your still around! Good to see ya still kicking around the forums man :)

Share this post


Link to post
Share on other sites
9 hours ago, Proot said:

Was perfect in the first run. Thrilling results. But after that first run most clouds are now static. I'm trying to find the problem.

It's maybe a problem with the writen .cfg? Maybe some new related config that I'm no doing well?

Do you mean that quitting KSP and restarting gives different results than the first run, or do you mean that after running KSP it works, but then after some actions in KSP it stops working?

Share this post


Link to post
Share on other sites
6 minutes ago, davidy12 said:

How do you crank down the detail in BoulderCo?

What do you mean by crank it down? In the config (or by the EVE button at KSC scene), you can remove stuff. Note that in lower detailDistance does nothing (it just changes are what distance which textures are used) and setting various things to 0 does nothing (it just means your GPU paints more transparent pixels). The most expensive thing is layerVolume, and in particular the second parameter of "area", which controls the number of subdivisions.

Share this post


Link to post
Share on other sites
2 hours ago, Waz said:

Do you mean that quitting KSP and restarting gives different results than the first run, or do you mean that after running KSP it works, but then after some actions in KSP it stops working?

Everything works perfect in the first run. After the first restart everything remains equal, but the UV animation seems completely stopped.

Share this post


Link to post
Share on other sites
3 hours ago, Proot said:

Everything works perfect in the first run. After the first restart everything remains equal, but the UV animation seems completely stopped.

Weird. So you only saw it work once?

Does the BoulderCo config also give that problem for you? Kerbin and Jool should both show animation.

Edited by Waz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.