allista

[1.7] Global Construction

Recommended Posts

14 hours ago, Brigadier said:

Thanks for the answers.

  1. Ok, surprise, surprise!, this works as advertised.  I also noted the available volume at the top of the dialog which I hadn't seen before.
  2. See first sentence of 1, above.  I now understand that I need to free up some space from the default SP and MK tanks before I add any new tank, including a saved config.  To enable the Add button, a volume has to be specified.  Got it.
  3. Makes sense.

The empty costs of the OAL (2,250,122), the GAL (1,500,055) and OW (250,045.20), while the Inline Workshop is only 17,500, seem high.  By far, the most expensive parts by an order of magnitude.  While I understand that this construction capability is enormous leverage, is this also expected (I'm running a GPP+GEP install)?

A cool feature I wasn't expecting: configs are retained across game saves.  Nice touch.

Would it make sense to have a button to merge tanks holding the same contents?

I don't think it would, as a part in KSP cannot hold two volumes of the same resource. So there's actually nothing to merge.

As for the empty costs -- that's weird! From the configs:

  • GAL 300k + 100u Machinery
  • OAL 450k + 100u Machinery
  • OW  50k
  • IW 3.5k

I've just looked in-game, figures almost match (for some reason the parts cost a little less in Editor; also strange). Even full they cost less than you say... :confused:

rPi2x7L.png

Edited by allista

Share this post


Link to post
Share on other sites
22 hours ago, goldenpsp said:

Well considering @allista's modeling situation and your desires, he'd accept some assistance in that arena :D

Do you think it'd be possible to get RoverDude's permission or assistance in retexturing a 3.75m Tundra part with GC logos? Perhaps something similar just scaled up to 5m?

 

(I was considering a MM patch to clone a 3.75 Tundra part in my personal gameplay.)

I would do it myself but I don't know how to texture/UV-map and can barely model in Blender myself.

Share this post


Link to post
Share on other sites

@allista Have a request.  I built my Karbondium collector ship but the separators I use have solid fuel, and now I have no way of filling them.  Can you add solid fuel to the construction process of the ship?  I would think this would be much needed if trying to launch off of Eve or something.

Thanks!   

Share this post


Link to post
Share on other sites
2 hours ago, Teslamax said:

Do you think it'd be possible to get RoverDude's permission or assistance in retexturing a 3.75m Tundra part with GC logos? Perhaps something similar just scaled up to 5m?

 

(I was considering a MM patch to clone a 3.75 Tundra part in my personal gameplay.)

I would do it myself but I don't know how to texture/UV-map and can barely model in Blender myself.

You would have to ask @RoverDude as I am pretty sure his models are licensed ARR.

And everyone starts out not knowing how to model/texture.  Gotta start somewhere.

Share this post


Link to post
Share on other sites
2 hours ago, goldenpsp said:

And everyone starts out not knowing how to model/texture.  Gotta start somewhere.

True!

Share this post


Link to post
Share on other sites
2 hours ago, overkill13 said:

Hmmm... This works in orbit now?  Guess I'll have to think about switching over from EPL.

Do it!  You know you want to :D

Seriously, if you use Roverdude's MKS, GC is the selected replacement for EPL.

Share this post


Link to post
Share on other sites
On 9/15/2018 at 8:01 PM, Critter79606 said:

@allista Have a request.  I built my Karbondium collector ship but the separators I use have solid fuel, and now I have no way of filling them.  Can you add solid fuel to the construction process of the ship?  I would think this would be much needed if trying to launch off of Eve or something.

Thanks!   

That's an intended limitation.

Honestly, I don't think I should've allowed to carry gunpowder grain inside DIY Kits at all; but as it is now, you can pack SF from Kerbin where it's produced. On the other hand, if you assemble a new kit off-world, you don't have the luxury of including resources into the kit because as a rule you don't have any. Indeed, does your base produce SF to add it to the kit from which the separatrons will be build? Even if it did, there's no way to transfer it, because, well, it's solid.

This is not a trivial problem, actually. There're a number of resources that are required for some parts to work (consider reactors that use Uranium), but which you cannot produce, transport or transfer; they only come with the parts on Kerbin. It stands to reason that you can take a complete part, disassemble it and add to the kit; but you cannot create such a kit from scratch, because even if you make all the pieces on 3D-printer, they're not enough for the part to work; and 3D printers can produce enriched radioisotopes no more than gunpowder.

Share this post


Link to post
Share on other sites

Is there a way to make it so that if you have convert-o-trons making material kits while constructing a ship that if you run out of stored kits that it just continuous construction at the rate your making kits instead of just stopping or add a way to store lots the material kits ahead of time?

Share this post


Link to post
Share on other sites

Is this backwards compatible with 1.4.2 or am i going to have to update?

Edit: i'll try it out.

Edited by RazorFang95

Share this post


Link to post
Share on other sites
5 hours ago, RazorFang95 said:

Is this backwards compatible with 1.4.2 or am i going to have to update?

Edit: i'll try it out.

I may be compatible with 1.4.3, but I'm not so sure about the older versions.

Tell is what you'll find.

7 hours ago, Mcglin250 said:

Is there a way to make it so that if you have convert-o-trons making material kits while constructing a ship that if you run out of stored kits that it just continuous construction at the rate your making kits instead of just stopping or add a way to store lots the material kits ahead of time?

If you're using USI there's containers for all the needed resources to accumulate. If not, I recommend Configurable Containers for the task. There full version with the patches for most of the container parts.

As for the the reduced construction speed: this mechanisms is actually implemented from the beginning, but there's a threshold to it. Kerbals won't do a 0.1% percent of work they able of; nobody would :) And the conversion is very slow compared to most construction requirements (which vary per part).

So the intended operation is: first accumulate, then build.

Share this post


Link to post
Share on other sites
1 hour ago, allista said:

I may be compatible with 1.4.3, but I'm not so sure about the older versions.

Tell is what you'll find.

So far, so good.

Share this post


Link to post
Share on other sites

If I tweak scaled an assembly line could it make bigger kits? Edit: Never mind you can't. But could we?

Edited by Mcglin250

Share this post


Link to post
Share on other sites
11 hours ago, Mcglin250 said:

If I tweak scaled an assembly line could it make bigger kits? Edit: Never mind you can't. But could we?

You can add MM patch for TweakScale, but why do it, if you simply can make an empty container, then assemble a kit in it without any size restrictions?

Share this post


Link to post
Share on other sites
On 9/17/2018 at 12:50 PM, allista said:

That's an intended limitation.

Honestly, I don't think I should've allowed to carry gunpowder grain inside DIY Kits at all; but as it is now, you can pack SF from Kerbin where it's produced. On the other hand, if you assemble a new kit off-world, you don't have the luxury of including resources into the kit because as a rule you don't have any. Indeed, does your base produce SF to add it to the kit from which the separatrons will be build? Even if it did, there's no way to transfer it, because, well, it's solid.

This is not a trivial problem, actually. There're a number of resources that are required for some parts to work (consider reactors that use Uranium), but which you cannot produce, transport or transfer; they only come with the parts on Kerbin. It stands to reason that you can take a complete part, disassemble it and add to the kit; but you cannot create such a kit from scratch, because even if you make all the pieces on 3D-printer, they're not enough for the part to work; and 3D printers can produce enriched radioisotopes no more than gunpowder.

@allista I was just hoping.  I'll just have to redesign the ones that use them.

I finally got to the point of trying out the new orbital parts and am having a couple major issues.

I'm trying to build a Coyote freighter to colonize the system, and when I try to add it to the empty, docked container it destroys my space station.  Note the red 000000m.

uc?export=view&id=1FUmB3wkWr8TBLynbBK5KA

So I thought I would build an extension to push it out further from my station, as it is HUGE, but I ran into this...

uc?export=view&id=1mN3j_Dabxm11586_ht83K

Loaded into the box ok, but as it finishes deploying it jumps to the center line.

uc?export=view&id=1s-RAZH6sWX1QEZTpuEwOh

 

uc?export=view&id=1bIZ4GMhs-ncekckl7W5zI

Also, it would help if the docking port buttons are labeled differently in the menu so you could tell which is being undocked.

When loading the coyote into the box, it also freaks out my graphics by making a lot of ship/station pieces of any scene transparent, including the KSP launch complex.  I have to restart the app to fix it.

For smaller ships it is working mostly fine.  I build the sky crane with the new box and had an overlap issue which I had to force it out of.  I've built many things on the ground without any issues that were really big (this entire station as one piece except for the docked ship, and cargo lander attached), so all I can figure is that it is associated with being docked.

Let me know what you need to help run this down.

Thanks!

 

 

Edited by Critter79606

Share this post


Link to post
Share on other sites
3 hours ago, Critter79606 said:

@allista I was just hoping.  I'll just have to redesign the ones that use them.

I finally got to the point of trying out the new orbital parts and am having a couple major issues.

I'm trying to build a Coyote freighter to colonize the system, and when I try to add it to the empty, docked container it destroys my space station.  Note the red 000000m.

So I thought I would build an extension to push it out further from my station, as it is HUGE, but I ran into this...

Loaded into the box ok, but as it finishes deploying it jumps to the center line.

Also, it would help if the docking port buttons are labeled differently in the menu so you could tell which is being undocked.

When loading the coyote into the box, it also freaks out my graphics by making a lot of ship/station pieces of any scene transparent, including the KSP launch complex.  I have to restart the app to fix it.

For smaller ships it is working mostly fine.  I build the sky crane with the new box and had an overlap issue which I had to force it out of.  I've built many things on the ground without any issues that were really big (this entire station as one piece except for the docked ship, and cargo lander attached), so all I can figure is that it is associated with being docked.

Let me know what you need to help run this down.

Thanks!

Thanks for the report. Please, share the output_log.txt (Player.log on mac/linux) after the crash; there have to be some exceptions that cause this. I will try it myself when there's time, but you'll probably make it faster then me.

I concur, it would be great to have the possibility to name docking ports. But since they're Sqad's modules which are, truth be told, not intended to be used multiple times in a single part, I unfortunately cannot do nothing about it (and believe me, I already tried), There's a pretty useful mod:

that claims to add the capability to name docking ports. But I'm not sure they do consider multiple-module parts.

Hm... I've just had a thought about how it could be done, though. Let me try it out... :rolleyes:

Edited by allista

Share this post


Link to post
Share on other sites

Surprisingly, it works like a charm! :cool:

Yea, I know it says "Rename Kit". I've already fixed that :rolleyes:

 

Share this post


Link to post
Share on other sites
On 9/24/2018 at 6:10 AM, Critter79606 said:

When loading the coyote into the box, it also freaks out my graphics by making a lot of ship/station pieces of any scene transparent, including the KSP launch complex.  I have to restart the app to fix it.

This mod haven't been updated in a while and is marked as "for KSP 1.3.1". So it seems like their problem, not GC.

Share this post


Link to post
Share on other sites
On 9/23/2018 at 3:41 AM, allista said:

You can add MM patch for TweakScale, but why do it, if you simply can make an empty container, then assemble a kit in it without any size restrictions?

I said that before seeing to new update and with that feature.

Share this post


Link to post
Share on other sites
21 hours ago, COL.R.Neville said:

is there a new usi_tools that has the update for the missing construction skill? 

Is it missing from all Kerbals or just some?

Do you have any other mods installed?

Share this post


Link to post
Share on other sites

[ERR 20:22:13.214] ExperienceTrait: Cannot add effect 'ConstructionSkill' as it does not exist. is the log spam i get

this is an engineer/technician only trait. 

I have around 137 mods. I've tried backing the entry  all the way back to the traits.cfg in the squad folder in case something was coming behind the engineer.cfg in groundconstruction and overwriting something with module manager. but these are the only instances of ConstructionSkill that I have in gamedata. 

engineer.cfg in groundconstruction

groundassembly.cfg in groundconstruction

orbitalassembley.cfg in groundconstruction

kolonists.cfg in mks

traits.cfg in squad where i changed the definition which is what the engineer.cfg in groundconstruction is doing

this is what i have for the engineer entry now in the squad folder. 

EXPERIENCE_TRAIT
{
    name = Engineer
    title = #autoLOC_500103 //#autoLOC_500103 = Engineer
    desc = #autoLOC_500104 //#autoLOC_500104 = Engineers are capable of repairing broken parts, if at all possible.

    EFFECT
    {
        name = RepairSkill
    }
    EFFECT
    {
        name = ConverterSkill
    }
    EFFECT
    {
        name = DrillSkill
    }
    EFFECT
    {
        name = FailureRepairSkill
    }
    EFFECT
    {
    name = ConstructionSkill
    }
    EFFECT
    {
        name = GeeForceTolerance
        modifiers = 1.1, 1.2, 1.3, 1.4, 1.5
    }
}

i noticed this was a problem back in 17 looks like it was fixed though? but looks like something got reverted maybe. dunno know

https://github.com/UmbraSpaceIndustries/UmbraSpaceIndustries/issues/107

looks like everything is where its supposed to be but the actual definition for the trait itself is missing now? 

Share this post


Link to post
Share on other sites
On 8/30/2018 at 1:09 PM, allista said:

 

There's actually a workaround; the GameData/000_AT_Utils/Plugins/PluginData/000_AT_Utils/000_AT_Utils.glob file contains the BadParts option that lists part names (separated by spaces) for which an alternative metric calculation approach should be used. Currently there's only the stock RadialDrill; but you may add MKS drills there as well (and tell me their names, so I could include them in the distribution).

Having just encountered this problem (DIY kits with drills inflating until they explode) I've been trying to apply this workaround, but so far without success...  Space-separating things seems to break it even for the stock drill.  I tried comma-separation just in case, and RadialDrill survives, but I can't make it work with any other part.

Is there some processing done with periods / underscores or something?  Has anyone else managed to make this work?

Share this post


Link to post
Share on other sites
5 hours ago, ChrisF0001 said:

Having just encountered this problem (DIY kits with drills inflating until they explode) I've been trying to apply this workaround, but so far without success...  Space-separating things seems to break it even for the stock drill.  I tried comma-separation just in case, and RadialDrill survives, but I can't make it work with any other part.

Is there some processing done with periods / underscores or something?  Has anyone else managed to make this work?

Unfortunately, this mechanism is actually broken; a bug that I've discovered (with the help of the fx-pain) just two days ago.

I'm working on a release tonight that has a fix for that (aside from some cool new features :)).

Share this post


Link to post
Share on other sites
5 minutes ago, allista said:

Unfortunately, this mechanism is actually broken; a bug that I've discovered (with the help of the fx-pain) just two days ago.

I'm working on a release tonight that has a fix for that (aside from some cool new features :)).

Great, thanks!  (I'm a little relieved that I wasn't just being an idiot... :) )

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.