politas

CKAN (The Comprehensive Kerbal Archive Network); v1.26.4 - Orion

Recommended Posts

17 hours ago, Gargamel said:

Along the same vein, sometimes the only way to find a glitchy or conflicting mod is to pull half your mods, and then half again, etc etc, until you locate the offending mod.  It'd be really neat if CKAN had this option, where it let you mark mods, from the list of installed mods, to be removed in a bug hunt.   Everytime you clicked "next" it would pull out half the remaining mods.   Just a little automation to help out a tedious process.    And I fully understand if you guys have a collective "Oh heck no" to that request.  

An extension of that would be, instead of a next, having two selections to distinguish between having the bug go away or not.

So, if you selected "issue still  present" CKAN would note that the removed mods aren't the problem and move on to the ones not removed while selecting "issue gone" would mark the unremoved modes as fine and put half of the removed ones back.

Share this post


Link to post
Share on other sites

I'm not sure if this bug report belongs here or in the mod author's thread.

But USI-MKS isn't showing as install-able for me on 1.4.4, even though it seems to say that it should be compatible with all versions of 1.4?  All of RD's other mods show up at install-able for 1.4.4

EkJBgua.jpg

Share this post


Link to post
Share on other sites
7 hours ago, tsaven said:

But USI-MKS isn't showing as install-able for me on 1.4.4, even though it seems to say that it should be compatible with all versions of 1.4?

Check the dependencies; that mod depends on a chain of things that only go up to 1.4.3:

j9LdnTe.png

Share this post


Link to post
Share on other sites

Hmm. @HebaruSan, something is fishy. USI-MKS should not strong depend on SETI Ctt at all. I think that Ground Construction Core is only necessary for Konstruction mod. Konstruction mod is also optional, not necessary for USI-MKS (life support and base parts). I'm not 100% sure for Ground Construction, though, something might be changed for KSP 1.4.3 and KSP 1.4.4., so take this with a grain of salt.

Might be good to ping @RoverDude about it for clarification.

Edited by kcs123

Share this post


Link to post
Share on other sites
27 minutes ago, kcs123 said:

Hmm. @HebaruSan, something is fishy. USI-MKS should not strong depend on SETI Ctt at all.

That alert icon means "conflicts". It's easier to tell in-app because there's a tooltip to explain it.

27 minutes ago, kcs123 said:

I think that Ground Construction Core is only necessary for Konstruction mod. Konstruction mod is also optional, not necessary for USI-MKS (life support and base parts). I'm not 100% sure for Ground Construction, though, something might be changed for KSP 1.4.3 and KSP 1.4.4., so take this with a grain of salt.

All of this metadata is directly maintained by Roverdude himself:

Share this post


Link to post
Share on other sites
20 minutes ago, HebaruSan said:

That alert icon means "conflicts". It's easier to tell in-app because there's a tooltip to explain it.

All of this metadata is directly maintained by Roverdude himself:

Thanks for the information and clarification.  I'll ask over in RD's MKS thread, usually he's pretty on top of compatibility for latest releases (given that he works for them).

Share this post


Link to post
Share on other sites

Having an issue where v23.0 of AirplanesPlus is failing to download:

CKAN.InvalidModuleFileKraken: AirplanePlus 23.0: C:\Users\Frank\AppData\Local\Temp\tmp4B48.tmp has length 93226203, should be 93226015
   at CKAN.NetModuleCache.Store(CkanModule module, String path, String description, Boolean move)
   at CKAN.NetAsyncModulesDownloader.ModuleDownloadsComplete(NetModuleCache cache, Uri[] urls, String[] filenames, Exception[] errors)

I downloaded the package manually and it is indeed 93226203 bytes, so not sure if this is a CKAN issue or something in the mod.

Share this post


Link to post
Share on other sites
1 hour ago, GrubbyZebra said:

Having an issue where v23.0 of AirplanesPlus is failing to download:

I downloaded the package manually and it is indeed 93226203 bytes, so not sure if this is a CKAN issue or something in the mod.

This is because the original download was replaced, and CKAN is expecting it to match the one that was originally indexed. To fix this we'll need to contact our server admin to purge that file out of the cache of the NetKAN bot, although when this has happened recently it has been more common for the author to fix it by releasing a new version instead.

Share this post


Link to post
Share on other sites
20 minutes ago, HebaruSan said:

This is because the original download was replaced, and CKAN is expecting it to match the one that was originally indexed. To fix this we'll need to contact our server admin to purge that file out of the cache of the NetKAN bot, although when this has happened recently it has been more common for the author to fix it by releasing a new version instead.

will copy your reply in the mod thread

Share this post


Link to post
Share on other sites
23 hours ago, GrubbyZebra said:

Having an issue where v23.0 of AirplanesPlus is failing to download:

I downloaded the package manually and it is indeed 93226203 bytes, so not sure if this is a CKAN issue or something in the mod.

This should be fixed now, if you click Refresh in CKAN.

Share this post


Link to post
Share on other sites

Hi! I seem to have mistakenly put an extra dot in the tag for an older version of my mod, causing other newer versions to not be downloaded.

What would be the correct way to fix this? Can I just delete this release? 

I have tried changing the tag in github but I was not able to - I'm not very experienced it git...

https://github.com/KSPKatten/AnimatedAttachment/releases/tag/v.1.2.2

Edit: I've tried to change the tag, I'll see what happens next time netkan updates

Edited by Katten

Share this post


Link to post
Share on other sites
2 hours ago, Katten said:

Hi! I seem to have mistakenly put an extra dot in the tag for an older version of my mod, causing other newer versions to not be downloaded.

What would be the correct way to fix this? Can I just delete this release? 

I've updated the metadata, so it should be fixed in CKAN after you click Refresh.

Share this post


Link to post
Share on other sites
8 hours ago, HebaruSan said:

I've updated the metadata, so it should be fixed in CKAN after you click Refresh.

Nice, thanks! I noticed that even after a refresh, CKAN would correctly tell me that the latest version is "v2.1.0", the installed is "v.1.2.2", but the update button wouldn't be visible. I didn't try to restart CKAN unfortunately, but it was resolved after clicking Reinstall. I think the solution is to ask users to click the Reinstall button manually?

Share this post


Link to post
Share on other sites
3 hours ago, Katten said:

Nice, thanks! I noticed that even after a refresh, CKAN would correctly tell me that the latest version is "v2.1.0", the installed is "v.1.2.2", but the update button wouldn't be visible. I didn't try to restart CKAN unfortunately, but it was resolved after clicking Reinstall. I think the solution is to ask users to click the Reinstall button manually?

Yes. Unfortunately, their locally installed version doesn't get overridden by the change in server metadata. A reinstall replaces their local metadata with fresh metadata from the server.

Share this post


Link to post
Share on other sites

Note that the following .version file:

{
  "NAME"     : "B9 Part Switch",
  "DOWNLOAD" : "https://github.com/blowfishpro/B9PartSwitch/releases",
  "URL"      : "https://s3.amazonaws.com/blowfish-ksp-b9partswitch-avc/ksp-1.4.4/B9PartSwitch.version",
  "GITHUB" : {
    "USERNAME"   : "blowfishpro",
    "REPOSITORY" : "B9PartSwitch"
  },
  "VERSION" : {
    "MAJOR" : 2,
    "MINOR" : 3,
    "PATCH" : 2
  },
  "KSP_VERSION" : {
    "MAJOR" : 1,
    "MINOR" : 4,
    "PATCH" : 4
  }
}

 

is causing CKAN to show an update is available on a 1.4.3 install.  This is wrong.

 

Share this post


Link to post
Share on other sites
3 hours ago, linuxgurugamer said:

Note that the following .version file:

 

is causing CKAN to show an update is available on a 1.4.3 install.  This is wrong.

That's the version file for 2.3.2, right? Here is the 2.3.3 release:

Are you sure CKAN is doing something wrong? If so, what is it?

Share this post


Link to post
Share on other sites
9 minutes ago, HebaruSan said:

That's the version file for 2.3.2, right? Here is the 2.3.3 release:

Are you sure CKAN is doing something wrong? If so, what is it?

Sorry, you missed this:

"URL"      : "https://s3.amazonaws.com/blowfish-ksp-b9partswitch-avc/ksp-1.4.4/B9PartSwitch.version",

Doesn't matter what's in the repo, he hasn't yet updated his s3 file. 

A bit of clarification:  Somehow, CKAN installed the 1.4.4 version in this game even though it was a 1.4.3 game. 

 

Edit:  Oh, I think I know what's going on.  I have CKAN set to allow all 1.4, and it updated with newer ones as well as the older ones.

Not sure how to deal with this, but you can close the bug report on github.

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
11 minutes ago, linuxgurugamer said:

Sorry, you missed this:


"URL"      : "https://s3.amazonaws.com/blowfish-ksp-b9partswitch-avc/ksp-1.4.4/B9PartSwitch.version",

Doesn't matter what's in the repo, he hasn't yet updated his s3 file. 

Yes, it does matter what's in the repo. That's how CKAN finds new versions, and if there's a new version, it shows up as an available update.

Share this post


Link to post
Share on other sites
10 hours ago, HebaruSan said:

Yes, it does matter what's in the repo. That's how CKAN finds new versions, and if there's a new version, it shows up as an available update.

Well, it seems that blowfish creates a new .version file for each release of KSP.  Which, from a user's point of view, can suck when updates are done, because AVC wasn't designed with his use case in mind.

Re. CKAN, I thought that it was looking at the #vref, my mistake.  

Share this post


Link to post
Share on other sites

Hello,

 i am back to KSP after long time,

I updated game to version 1.4.5, downloaded latest CKAN and i am trying to find some essential visual enhancement mods, like Scatterer, Stock visual enhancement, stock visual terrain, BUT I CANNOT SEE THEM IN CKAN.

 

How is that possible? are they not included in CKAN anymore? i need to install them manually ?

EDIT: it looks like mods i am looking for are available only till version 1.4.2  ---- where i can get this version of game?? on STEAM it ssems i can get only latest version 1.4.5

thanks for help, if anyone knows

Edited by papuchalk

Share this post


Link to post
Share on other sites
1 hour ago, papuchalk said:

EDIT: it looks like mods i am looking for are available only till version 1.4.2  ---- where i can get this version of game?? on STEAM it ssems i can get only latest version 1.4.5

thanks for help, if anyone knows

In Steam, right click Kerbal Space Program, select properties. Go to the Betas tab, select 1.4.2 from the list. Once it's updated the files, you'll have a 1.4.2 install.

Share this post


Link to post
Share on other sites
2 hours ago, strudo76 said:

In Steam, right click Kerbal Space Program, select properties. Go to the Betas tab, select 1.4.2 from the list. Once it's updated the files, you'll have a 1.4.2 install.

wow great, it worked

Share this post


Link to post
Share on other sites
On 7/29/2018 at 6:45 AM, papuchalk said:

Hello,

 i am back to KSP after long time,

I updated game to version 1.4.5, downloaded latest CKAN and i am trying to find some essential visual enhancement mods, like Scatterer, Stock visual enhancement, stock visual terrain, BUT I CANNOT SEE THEM IN CKAN.

 

How is that possible? are they not included in CKAN anymore? i need to install them manually ?

EDIT: it looks like mods i am looking for are available only till version 1.4.2  ---- where i can get this version of game?? on STEAM it ssems i can get only latest version 1.4.5

thanks for help, if anyone knows

I also restarted playing, (was last playing 1.3.1) and also got the 1.4.5. I downloaded the visual enhancement mods latest versions (EVE, SVE & Scatter) and while some are not listed as updated to 1.4.5 they do appear to work. (manually added the ones CKAN said were not compatible.) [Your millage may vary]

 

Which brings up another point...

I remember when I manually installed various mods, that CKAN would "Auto Detect" that I had manually installed some mods and list them with "AD" in the installed column. But none of the 3-4 mods I have installed manually in 1.4.5 are showing up in CKAN as installed by showing "AD" in the installed column. (ex, Scatter, SVE, & (X)Science) 

I have 53 other mods installed through CKAN.

Was this CKAN feature dropped?

Share this post


Link to post
Share on other sites

i downloaded version 1.4.2 in which all mentioned mods are officialy included as CKAN compatible. i didnt like manually installing them while CKAN wasn to able to recognize them in 1.4.5. i feared some collisions in gameplay.

now, i dont mind playing 1.4.2 , it runs well

Edited by papuchalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.