Steven Mading

[1.7.3] kOS v1.1.9.0 : kOS Scriptable Autopilot System

Recommended Posts

39 minutes ago, Steven Mading said:

Arrrg dangit.

Чтобы исправить проблему с вращающейся картой, мне пришлось заблокировать еще несколько блокировок ввода в терминале в последних обновлениях kOS. (Я на 100% убежден, что проблема с вращающейся картой заключается в том, что кто-то в SQUAD использовал входные блокировки в качестве косвенного теста на побочный эффект, который предполагал, что мы не в режиме просмотра карты, если блокировки установлены определенным образом, и поэтому камера должна поворачиваться в соответствовать кораблю, когда установлена блокировка цели.) Нет смысла в том, что возможность менять цель нажатием - это тест на наличие на карте, за исключением того, что казалось, что он делает именно это. Чтобы остановить ошибку поворота вида карты, мне пришлось изменить способ работы терминала с блокировками ввода. Это может быть побочным эффектом этого, потому что, возможно, я заблокировал возможность изменять временную деформацию.

Можете ли вы написать хорошее подробное описание того, что вызывает проблему (в основном то, что вы написали здесь на форуме) на github? Сейчас я ухожу и читаю это на своем телефоне, поэтому я не могу легко сделать это сам.

Автопосадка этапов - очень сложная операция, которую, как мне кажется, не делает Мечеб для вас. kOS * может * сделать это, но только если вы пишете программу (или кто-то другой написал) для нее. Это не проблема с простым решением «из коробки».

(Любое такое решение * также * будет включать в себя необходимость установки мода FMRS, что необходимо для того, чтобы избежать проблемы, связанной с тем, что космическая программа Kerbal не будет работать, если вы попытаетесь расширить физический пузырь "слишком большой, чтобы иметь возможность 1-я ступень и 2-я ступень одновременно активно толкаются на расстоянии 60 км друг от друга.)

Я предполагаю, что Гудлифер является носителем русского языка из криминального текста в посте. Я знаю, что в этой ветке форума есть несколько человек, свободно говорящих на английском и русском языках. Может ли кто-нибудь сделать мне одолжение сделать хороший перевод того, что я напечатал выше для Гудлифер?

If you mean to translate into Russian, what you wrote, then there is no need I understand you perfectly. but I have the next question I asked above. Is it possible somewhere to download only need the script for this program. after all, someone wrote it and experienced, especially the developers.

Share this post


Link to post
Share on other sites
49 minutes ago, Steven Mading said:

(Any such solution will *also* involve having to install the FMRS mod as well, which is needed to avoid the problem that Kerbal Space Program doesn't work if you try to extend the physics bubble" too large to be able to have the 1st stage and 2nd stage both actively thrusting at the same time while 60km apart from each other.)

To be fair, you can manage SpaceX style boost back if you have good enough TWR with just kOS. The general idea is

  1. steeper initial ascent than for typical rockets. which leaves you with higher vertical and lower horizontal speed at stage separation - which is also what makes the boost back maneuver cheaper
  2. with first stage turning back straight after separation you can even manage to complete the boost back before leaving physics range for atmospheric flight (I would still recommend to increase the packing/unloading range for the stage to something like 35-40 km for both atmospheric and space flight)
  3. now here is a notable TWR limitation for the upper stage - you have limited time until the first stage passes its apoapsis and then falls back into the denser layers of the atmosphere (that's why vertical speed on stage separation is so important; you might want to perform the boost back angled slightly upward if you have problems with first stage falling back way too soon). In this time the second stage has to leave the atmosphere and either complete orbital insertion or (for higher target orbits) get trajectory with enough time to apoapsis to land the first stage in the meantime and then switch back for circularization.
  4. and then you switch to the first stage (which should be reentering by then) and perform the landing

And that's what my fully reusable 2-stage shuttle does. The orbiter completes orbital insertion (yes, it involves a bit of pointing downwards for circularization) before the launcher reenters. However, having wings and jets, the first stage aims for 40 km undershoot, falls almost vertically, pulls 9g turn and then glides back to runway.

Of course, with a rocket you would aim for some overshoot taking into account the drag and then perform some braking corrections as you approach the landing site. I once did a bit of experimenting with that, but never actually completed what is required for precision landing in atmosphere.

Share this post


Link to post
Share on other sites
3 hours ago, Steven Mading said:

Arrrg dangit.

In order to fix the rotating map problem, I had to lock out a few more input locks in the terminal in the recent updates to kOS. (I am 100% convinced the rotating map problem is because someone at SQUAD used the input locks as an indirect side-effect test that presumed we are not in map view if the locks are set a certain way, and therefore the camera should rotate to match the ship when the target lock is set.)  It makes zero sense that the ability to change target by clicking is the test for being on map view, except it seemed to be doing exactly that.  To stop the map view rotation bug, I had to change how the terminal deals with the input locks.  This may be a side-effect of that because it's possible I ended up locking out the ability to alter time warp too.

Can you write up a good careful description of what triggers the problem (basically what you wrote here in the forum) over on github?  I am away at the moment reading this on my phone so I can't easily do it myself.

Will do but it'll be a couple of days as I'm away a well  now.

Share this post


Link to post
Share on other sites
On 3/10/2019 at 8:53 PM, Gudlifer said:

If you mean to translate into Russian, what you wrote, then there is no need I understand you perfectly. but I have the next question I asked above. Is it possible somewhere to download only need the script for this program. after all, someone wrote it and experienced, especially the developers.

MJ can land on target .

TCA can land on target.

KOS whit a good script can land on target.

non of them can land if the rocket landing  is more then 2K from the active vessel.
for that you need to use trick/mod like FMRS

 

Share this post


Link to post
Share on other sites
On 3/10/2019 at 7:13 PM, Steven Mading said:

Arrrg dangit.

In order to fix the rotating map problem, I had to lock out a few more input locks in the terminal in the recent updates to kOS. (I am 100% convinced the rotating map problem is because someone at SQUAD used the input locks as an indirect side-effect test that presumed we are not in map view if the locks are set a certain way, and therefore the camera should rotate to match the ship when the target lock is set.)  It makes zero sense that the ability to change target by clicking is the test for being on map view, except it seemed to be doing exactly that.  To stop the map view rotation bug, I had to change how the terminal deals with the input locks.  This may be a side-effect of that because it's possible I ended up locking out the ability to alter time warp too.

Can you write up a good careful description of what triggers the problem (basically what you wrote here in the forum) over on github?  I am away at the moment reading this on my phone so I can't easily do it myself.

Unfortunately it appears I can't unless someone can explain how the hell to get past the "Unable to verify your captcha response" when I try and sign up to Guthub.  Tried it on 2 different browsers on the PC, and on my phone on both wifi and data. :/ 

Happy to post a detailed writeup here for someone else to put on it you like.

Share this post


Link to post
Share on other sites

for KSP v1.6.1 Downloads this release

v1.1.7.0 Lets get Serial

Mostly fixes. The motivation for this release is to get fixes
out to the public before KSP 1.7 comes.

Built for KSP 1.6.1

Github download: https://github.com/KSP-KOS/KOS/releases/tag/v1.1.7.0
Spacedock download: https://spacedock.info/mod/60/kOS:%20Scriptable%20Autopilot%20System
Curse download: https://kerbal.curseforge.com/projects/kos-scriptable-autopilot-system/files/2697100

BREAKING CHANGES

  • Compatibility for the old Infernal Robotics is officially removed
    in favor of support for the "IR Next" mod.

NEW FEATURES

  • Support for the "IR Next" mod. (The only infernal robotics
    mod was no longer being updated anyway and didn't work on
    KSP 1.6.1. But IR Next, although not officially released yet,
    does work on 1.6.1, so we switched to that.
    pull request
  • More types are now serializable as messages or JSON files:
    Notevalue, Direction, RGBAcolor, and HSVAcolor.
    pull request
  • CORE:TAG is now settable
    pull request
  • KUNIVERSE:PAUSE suffix added.
    pull request
  • Added a new TIME(seconds) Constructor to make a
    Timespan out of a Universal timestamp.
    pull request
  • New LIST FONTS. feature so the user can see which font
    names are loaded into Unity for use in user GUIs.
    pull request

BUG FIXES

  • Several documentation alterations:
    pull request
    pull request
  • kOS would throw a Nullref if a script tried to check for a CommNet
    connection to a vessel that has been classified as type "debris".
    pull request
  • Sometimes kOS broke the Space Center, making the buildings impossible
    to click on. This was caused by input locks not letting go when the
    terminal is open while the kOS physical part gets exploded.
    pull request
  • Fix to the kOS icon being broken (showing just a purple square) in Blizzy
    Toolbar mod.
    [pull request(https://github.com//pull/2454)
  • GeoPosition was written improperly in messages or JSON files.
    pull request
  • The "hue" part of HSV colors was never quite implemented properly from
    when it was first introduced. (It was mapping all hue numbers down
    into just 1/6th of the full range of hues, so greens and blues
    were not available.)
    pull request
  • When using the message queue system while Remote Tech is installed,
    you could not send messages to vessels far away outside the load
    distance bubble (i.e. 2.5km-ish). This is fixed.
    pull request
  • Vecdraws were incapable of drawing dark colors like black because they
    were using an additive-only shader.
    pull request
  • Fix a case where cooked steering from the terminal refused to let go if
    a subsequent kerboscript error is typed into the same terminal.
    pull request
  • If "run once" was used, and the system chose not to run the program
    because it was already run, it was possible for the stack to get
    corrupted in a way that confused defaulted parameters to programs.
    pull request
  • Fixed Multimode engine bug that was introduced in v1.1.6.1.
    pull request
  • Moved kOS dialog box to a new position to fix a clickthrough
    problem that caused you to secretly pick a kOS connectivity
    manager without realizing it when you click on things in the
    Remote Tech dialog box.
    pull request

Share this post


Link to post
Share on other sites
12 hours ago, hvacengi said:

NEW FEATURES

  • Support for the "IR Next" mod. (The only infernal robotics
    mod was no longer being updated anyway and didn't work on
    KSP 1.6.1. But IR Next, although not officially released yet,
    does work on 1.6.1, so we switched to that.

That one alone have made me to find more time for KSP, even diregarding other real life commitments. I having some ideas for aircraft with variable swept wings that is controled by IR/kOS for a long time, have yet to try something with those.

Share this post


Link to post
Share on other sites

I know it's real early to start asking, but anyone got a line a on a fix for 1.7?

Share this post


Link to post
Share on other sites

Question for the devs.

I compiled 1.1.7 for KSP 1.3.1 for my RO game. When I loaded into the flight scene my cpu was power starved despite the ship being on the launch clamps. I couldn't see anything obvious that had changed in the power handling.

I then compiled 1.1.5 and it worked fine.

Share this post


Link to post
Share on other sites
1 hour ago, hotwag said:

I know it's real early to start asking, but anyone got a line a on a fix for 1.7?

Works totally fine for me on 1.7. Always worth it to just try it out.

Share this post


Link to post
Share on other sites
49 minutes ago, Kartoffelkuchen said:

Works totally fine for me on 1.7. Always worth it to just try it out.

I'm not able to open the terminal in 1.7.

Share this post


Link to post
Share on other sites
4 hours ago, hotwag said:

I'm not able to open the terminal in 1.7.

Do you have Kerbal Wind Tunnel installed?  If you do, try removing it as a test.  It ships with an external library DLL file that breaks any other mod's attempt to do the Reflection call GetTypes(), making it throw an error.  It's causing kOS to abort partway through its initialization.

Share this post


Link to post
Share on other sites

I also can't open the terminal. And I have no Kerbal Wind Tunnel (although lots of other mods).

Share this post


Link to post
Share on other sites
10 hours ago, garwel said:

I also can't open the terminal. And I have no Kerbal Wind Tunnel (although lots of other mods).

Usually if the terminal won't open, there is something being complained about in the unity log.  Usually the terminal won't open because something is throwing an error during kOS's initial setup, so the rest of kOS's initialization got skipped. Behind the scenes, there's usually a lot more that's "broken" than the terminal, it's just that trying to open the terminal is the first step toward doing most other things, so it's the step where you first notice kOS isn't working.

Can you put the full output log somewhere I can read it?  (Don't try to trim it down to just the parts you think are relevant - find somewhere that will let you post the entire log from the start of the game to the point when you attempted to open the terminal.  Sometimes the actual first cause of the problem occurs much earlier than the snippet users show me, and the part they show is just the effect, not the cause.)

Share this post


Link to post
Share on other sites
3 hours ago, Steven Mading said:

Usually if the terminal won't open, there is something being complained about in the unity log.  Usually the terminal won't open because something is throwing an error during kOS's initial setup, so the rest of kOS's initialization got skipped. Behind the scenes, there's usually a lot more that's "broken" than the terminal, it's just that trying to open the terminal is the first step toward doing most other things, so it's the step where you first notice kOS isn't working.

Can you put the full output log somewhere I can read it?  (Don't try to trim it down to just the parts you think are relevant - find somewhere that will let you post the entire log from the start of the game to the point when you attempted to open the terminal.  Sometimes the actual first cause of the problem occurs much earlier than the snippet users show me, and the part they show is just the effect, not the cause.)

https://my.pcloud.com/publink/show?code=XZYINE7Zv6hqUXghjwykCKgYkXpDr7uB2pyV

the log

on KSP 1.6.1

KOS 1.1.6.3 works 

1.1.7.0 dos not

Share this post


Link to post
Share on other sites
Posted (edited)
24 minutes ago, danielboro said:

https://my.pcloud.com/publink/show?code=XZYINE7Zv6hqUXghjwykCKgYkXpDr7uB2pyV

the log

on KSP 1.6.1

KOS 1.1.6.3 works 

1.1.7.0 dos not

See above comment.  You have Wind Tunnel installed.  Its including a DLL that isn't working and it wrecks kOS.

The relevant part of your log is this:

Non platform assembly: C:\Users\user\Downloads\Kerbal Space Program\GameData\WindTunnel\Plugins\Accord.dll (this message is harmless)
ADDON BINDER: Cannot resolve assembly: System.ComponentModel.DataAnnotations, Culture=neutral, PublicKeyToken=31bf3856ad364e35
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

ADDON BINDER: Cannot resolve assembly: System.ComponentModel.DataAnnotations, Culture=neutral, PublicKeyToken=31bf3856ad364e35
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

AssemblyLoader: Exception loading 'Accord': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

https://github.com/DBooots/KerbalWindTunnel/issues/5

 

I was more interested in seeing the log of @garwel who reports having the problem *without* Wind Tunnel installed, which means it might be a different problem than this one I've already seen.

Edited by Steven Mading

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, Steven Mading said:

See above comment.  You have Wind Tunnel installed.  Its including a DLL that isn't working and it wrecks kOS.

The relevant part of your log is this:


Non platform assembly: C:\Users\user\Downloads\Kerbal Space Program\GameData\WindTunnel\Plugins\Accord.dll (this message is harmless)
ADDON BINDER: Cannot resolve assembly: System.ComponentModel.DataAnnotations, Culture=neutral, PublicKeyToken=31bf3856ad364e35
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

ADDON BINDER: Cannot resolve assembly: System.ComponentModel.DataAnnotations, Culture=neutral, PublicKeyToken=31bf3856ad364e35
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

AssemblyLoader: Exception loading 'Accord': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

https://github.com/DBooots/KerbalWindTunnel/issues/5

 

I was more interested in seeing the log of @garwel who reports having the problem *without* Wind Tunnel installed, which means it might be a different problem than this one I've already seen.

way 1.1.6.3 works but 1.1.7.0 dos not?

and is the problem somting easy to fix in wind Tunnel? doing some reding

Edited by danielboro

Share this post


Link to post
Share on other sites
4 hours ago, danielboro said:

way 1.1.6.3 works but 1.1.7.0 dos not?

It is possible that something accidentally changed in how I compiled 1.1.7.0 such that it's not the same version of .net, but I don't *think* I changed any settings.

Share this post


Link to post
Share on other sites

Anyone have problems with clicking buttons in KSP (like the toolbar buttons at the bottom right of the screen) after installing kOS in KSP 1.7?

Share this post


Link to post
Share on other sites
5 hours ago, Someone2018 said:

Anyone have problems with clicking buttons in KSP (like the toolbar buttons at the bottom right of the screen) after installing kOS in KSP 1.7?

I had trouble getting rid of the incompatible mods warning once. After showing up while KSP was loading, i could dismiss it, but it showed up again. Clicking on it didn't have any effect, finally I got rid of it by hitting ESC. Not sure if that helps you in any way?

Share this post


Link to post
Share on other sites
4 hours ago, infinite_monkey said:

I had trouble getting rid of the incompatible mods warning once. After showing up while KSP was loading, i could dismiss it, but it showed up again. Clicking on it didn't have any effect, finally I got rid of it by hitting ESC. Not sure if that helps you in any way?

It might help for that case, but I have permanent UI breakage once I install kOS. Of buttons I actually need to use in order to play the game.

Share this post


Link to post
Share on other sites

I'm also in 1.7 and the last version of the mod don't show the consol when I click on the button. Never tried with another version.

I don't have the mod " Wind Tunnel" installed as far as I know...

Here is le list of mod and files in my GameData folder, if it can help.

Spoiler

BasicDeltaV/
BasicOrbit/
BoulderCo/
ClickThroughBlocker.dll*
CommunityCategoryKit/
CommunityResourcePack/
CTTP/
DistantObject/
EnvironmentalVisualEnhancements/
FreeIva/
GEAFlags/
KerbalReusabilityExpansion/
Kopernicus/
kOS/
KSPModFileLocalizer.dll*
lang/
ManeuverNodeEvolved/
MechJeb2/
ModularFlightIntegrator/
ModuleManager.3.0.7.dll*
ModuleManager.4.0.2.dll*
ModuleManager.ConfigCache
ModuleManager.ConfigSHA
ModuleManager.Physics
ModuleManager.TechTree
ModuleManagerLicense.md
RealPlume/
RealPlume-Stock/
REPOSoftTech/
scatterer/
SmokeScreen/
Squad/
SurfaceLights/
TextureReplacer/
ThunderAerospace/
TriggerTech/

 

Share this post


Link to post
Share on other sites

Again, could someone who does NOT have WInd Tunnel installed but DOES have this problem with the terminal not appearing please post their log?

So far the only people who have posted their log have all had Wind Tunnel installed, and removing that mod has fixed the problem for them.

For me to help the people who do NOT have Wind Tunnel, I need to see *their* logs.  I haven't *seen* any examples yet of this case because all the examples I've been shown so far have been with Wind Tunnel.

Share this post


Link to post
Share on other sites

After much annoyance and seemingly non-deterministic behavior I've managed to reproduce with only ModuleManager (4.0.2) and kOS.

But the effect is only for the first game launched after starting KSP. Load the game again and the effect is gone. I will post a log soonish.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.