Jump to content

[1.3.1] BDArmory Continued - Public BETA of v1.1.0 - Damage and Armor Overhaul


gomker
 Share

Recommended Posts

34 minutes ago, jrodriguez said:

@DiscoveryPlanet Maybe I'm wrong but I don't think that is an issue related with this beta right?  I mean you don't need to use this beta to see exactly the same behaviour that with the last official release. Am I right?

exactly, this anomaly actually happened when i first time used BDArmory (not remember about the version)

just want to share because when i updated my BDarmory mod,  this anomaly still happen 

Link to comment
Share on other sites

3 minutes ago, DiscoveryPlanet said:

exactly, this anomaly actually happened when i first time used BDArmory (not remember about the version)

just want to share because when i updated my BDarmory mod,  this anomaly still happen 

That's fine. But this thread is specific for this Beta testing and its new features. I think you should be using the main thread of BDArmory  and of course to report Issues you should go here:

https://github.com/PapaJoesSoup/BDArmory/issues

Edited by jrodriguez
Link to comment
Share on other sites

I know its probably for lag control, or variable fx lengths for the damage system, or maybe it is an issue, but I think the fire fx is pretty short. Got my fuel tank hit and fire burned for a few seconds and then just stopped.

Another question, does the damage system take range into account? Not trying to make things complicated, just a suggestion if you really dare to do it :) 

Link to comment
Share on other sites

11 hours ago, SuicidalInsanity said:

Is it possible to set part minimum armor thickness to something lower than 10? I'm not having any luck trying to change armor values below the default minimum with MM for some select parts.

So I guess I should have looked in here first before answering you in the BAD T thread :rolleyes:

There are some parts that needed custom hp and armor settings which are probably the parts you are having problems with .... I posted a bunch of info in the BAD T thread but will link the post here for others who are following this

 

17 hours ago, Murican_Jeb said:

I know its probably for lag control, or variable fx lengths for the damage system, or maybe it is an issue, but I think the fire fx is pretty short. Got my fuel tank hit and fire burned for a few seconds and then just stopped

Yes, that would be mainly for controlling lag .... think about large battles and having multiple hits on multiple craft at the same time, this would bring your computer to it's knees if the fires were burning all over the place for long periods

No sense in having lots of cool visuals if it makes the game unplayable for the majority of users

Edited by DoctorDavinci
Link to comment
Share on other sites

4 hours ago, DoctorDavinci said:

Yes, that would be mainly for controlling lag .... think about large battles and having multiple hits on multiple craft at the same time, this would bring your computer to it's knees if the fires were burning all over the place for long periods

No sense in having lots of cool visuals if it makes the game unplayable for the majority of users

Is there a way i can change it via a cfg or looking into the code itself?

Link to comment
Share on other sites

2 hours ago, Murican_Jeb said:

Is there a way i can change it via a cfg or looking into the code itself?

https://github.com/jrodrigv/DestructionEffects/blob/master/Distribution/GameData/DestructionEffects/settings.cfg

I added a part config ignore settings. Looks for the name if it "contains" and will exclude (https://github.com/jrodrigv/DestructionEffects/blob/master/FlamingJoints.cs#L189)

19 hours ago, SuicidalInsanity said:

Is it possible to set part minimum armor thickness to something lower than 10? I'm not having any luck trying to change armor values below the default minimum with MM for some select parts.

To make this work there has to be _some_ armor , think of it as simulating thickness of metal, not so much the "type" of metal, there is no physical material difference in KSP.
When I calculate penetration for ballistic damage I need to have at least 0.1 or you will get no damage or as a multiply by 0 may occur. 10 is the minimum and really won't stop anything ballistic or otherwise. 

Link to comment
Share on other sites

1 hour ago, gomker said:

I meant the burn time itself, I can't seem to find it in @SpannerMonkey(smce)'s link he gave me

Please forgive my stupidity, I'm a noob at coding and can only do a little bit of lua languaged scripting :blush:

Link to comment
Share on other sites

30 minutes ago, Murican_Jeb said:

I meant the burn time itself, I can't seem to find it in @SpannerMonkey(smce)'s link he gave me

Please forgive my stupidity, I'm a noob at coding and can only do a little bit of lua languaged scripting :blush:

https://github.com/jrodrigv/DestructionEffects/blob/master/FlamingJointScript.cs#L10-L12

Higher numbers shrink faster

Edited by gomker
Link to comment
Share on other sites

@Murican_Jeb and I'd also question the validity of the pursuit.  This pic below is using DFX and BDA of course nothing else, the smoke you see are coming from fuel fires on the lower decks, this vessel is 120 meters long,  it lasted for another 5 mins before it sunk, and at no time in that 5 mins did the smoke diminish much, and the fires still raged as it wen tdown, now this is one ship, the other s out of scene, and half the size of the BB's . More parts more detail more individual rather than merged module more FX, You're never going to get great FX from six parts resembling an aircraft , smoke and flames, but nothing like below.

And as a matter of interest we're getting explosions in Dev testing that are hauling monster overclocked machines down to clockwork frame rates, so be very careful what you do, as it wil have repercussions at some point.

cCwnHi3.png

Spoiler

 

 

Link to comment
Share on other sites

1 hour ago, igorqrus said:
Album https://imgur.com/a/kk25M will appear when post is submitted
1. No tracers
2. Low fps when shooting from a machine gun
 

 

Yeah QA should not be done at 2AM - I broke the bullets - fixed here

https://github.com/PapaJoesSoup/BDArmory/releases/download/v1.1.0/BDArmory.1.1.0.23998_12232017.zip

Link to comment
Share on other sites

I have two suggestions.

1. AFAIK, making armor thicker has no effect on mass.

2. I think the blast radius parameter should be user-customizable. It allows greater flexibility for making different weapons. 

Link to comment
Share on other sites

14 minutes ago, dundun92 said:

I have two suggestions.

1. AFAIK, making armor thicker has no effect on mass.

2. I think the blast radius parameter should be user-customizable. It allows greater flexibility for making different weapons. 

Regarding 1. We are aware of that and we don't like either but so far we didn't find a way to increase it. On the other hand you can always use armor panels instead. 

Regarding 2. The blast radius parameter is an auto calculated value depending on the explosive mass of the missile. If you want the flexibility you can always use modular missiles that will allow you to add enough tnt to blow up the entire KSC 

Link to comment
Share on other sites

3 minutes ago, jrodriguez said:

Regarding 1. We are aware of that and we don't like either but so far we didn't find a way to increase it. On the other hand you can always use armor panels instead. 

Regarding 2. The blast radius parameter is an auto calculated value depending on the explosive mass of the missile. If you want the flexibility you can always use modular missiles that will allow you to add enough tnt to blow up the entire KSC 

What I meant by "flexibility" was this: take a look at a bunker buster bomb. They have high power, but not a large blast radius. Now look at napalm. It has the opposite. It affects a large area, but isnt very powerfull against non-flammable objects. IMO, the TNT mass+Blast radius combination seems most realistic and user flexible. Just my opinion. :)

Link to comment
Share on other sites

In the latest build, every single gun has a muzzle velocity of 1030m/s, regardless of ammo type or what speed they've been configured to have in the BD_Bullets.cfg,
Also of note, any round with 'caliber = x.xx' set to something less than 11mm will not do more than 0.01 damage, regardless of muzzle velocity or projectile weight.

Link to comment
Share on other sites

15 hours ago, SuicidalInsanity said:

In the latest build, every single gun has a muzzle velocity of 1030m/s, regardless of ammo type or what speed they've been configured to have in the BD_Bullets.cfg,
Also of note, any round with 'caliber = x.xx' set to something less than 11mm will not do more than 0.01 damage, regardless of muzzle velocity or projectile weight.

I don't think I've had the muzzle vel problem, but yes, every gun under 11mm seems to do 0.01 damage.

Link to comment
Share on other sites

Has anyone of you got the issue that weapons would deplete all ammo, ignoring rpm settings, and do no damage at all?

[LOG 17:31:30.089] [BDArmory]=== Loading settings.cfg ===
[LOG 17:31:30.093] [BDArmory]: Error Loading Bullet Config | System.ArgumentNullException: Argument cannot be null.
Parameter name: s
  at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0 
  at System.Single.Parse (System.String s) [0x00000] in <filename unknown>:0 
  at BDArmory.Armor.BulletInfo.Load () [0x00000] in <filename unknown>:0 
[LOG 17:31:30.098] [BDArmory]=== Loading settings.cfg ===
[LOG 17:31:30.103] [BDArmory]: Error Loading Bullet Config | System.ArgumentNullException: Argument cannot be null.
Parameter name: s
  at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0 
  at System.Single.Parse (System.String s) [0x00000] in <filename unknown>:0 
  at BDArmory.Armor.BulletInfo.Load () [0x00000] in <filename unknown>:0 
[LOG 17:31:30.122] Getting value. Currently: False
[LOG 17:31:30.123] New value: False
[LOG 17:31:30.128] Getting value. Currently: False
[LOG 17:31:30.129] New value: False
[ERR 17:31:30.219] Module ModuleWeapon threw during OnStart: System.NullReferenceException: Object reference not set to an instance of an object
  at BDArmory.ModuleWeapon.SetupBullet () [0x00000] in <filename unknown>:0 
  at BDArmory.ModuleWeapon.OnStart (StartState state) [0x00000] in <filename unknown>:0 
  at Part.ModulesOnStart () [0x00000] in <filename unknown>:0 

I guess this might be an issue with custom particle effects, since no actual change has been applied to old parts. A part has been submitted to @gomker and hopefully we could work out a solution, or ALL NAS weapons would be completely useless.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...