Jump to content

[1.9.X] Tantares and BDB now in Colors!


Recommended Posts

On 4/6/2018 at 12:22 PM, sslaptnhablhat said:

Just wanna confirm, does this work fine with 1.4.2? Nvm it works fine as far as I can tell.

Do you think Beale could incorporate this into Tantares with the new 1.4 texture switching?

Also, do you think you could make the Mir docking module paintable white, like ISS' Rassvet?

I guess not, this will be always an alternate pack.

Yup sure, let me see if I have the source files

On 4/7/2018 at 1:29 PM, Derb said:

Anyone having a problem with the heat shield shrouds not retaining their color when put on the launchpad? v1.4.2

Working fine here on 1.4.3

4 hours ago, notJebKerman said:

@Drakenex Are you planning to switch to stock texture switch or keep using Firespitter (which is not a problem for me since I'll still keep it for some other mods)?

Well, it is a lot of work, basically redoing all config files, but I guess I will!

Edited by Drakenex
Link to post
Share on other sites
1 hour ago, Drakenex said:

Working fine here on 1.4.3

Still having the problem with 1.4.3. Are you using the latest version of Tantares with the stock color switch options?

Link to post
Share on other sites

Dm7ZqGY.png

 

Tantares now in Colors - Vintage edition

 

Introducing the all new but vintage green! After many hours of sorting many shades of green, finally came to a tone of real life looking Soviet era looking color.

 

V 1.2:

  •   Update to new VA/Alnair/TKS revamp, now in Vintage green
  • Added Vintage Green to all FGB parts
  • Soyuz Spacecraft now in Vintage Green (Including RCS)
  • ASTP variant for legacy engine
  • Rasvet/Mir adapter now in gray
  • N1 Rocket now in L3 and Vintage Green colors
  • Soyuz Rocket now in Light Gray and Vintage Green/Frozen Gray
  • Various textures fixes here and there

 

See OP for download links

Thanks to @HooHungLow for suggestions and beta testing.

 

 

 

Link to post
Share on other sites
On 5/5/2018 at 8:34 AM, notJebKerman said:

@Drakenex Are you planning to switch to stock texture switch or keep using Firespitter (which is not a problem for me since I'll still keep it for some other mods)?

Firespitter has much better backwards compatibility. 

Link to post
Share on other sites
On 5/5/2018 at 3:40 PM, Derb said:

Still having the problem with 1.4.3. Are you using the latest version of Tantares with the stock color switch options?

Looking into the issue, very weird problem!

Link to post
Share on other sites
Just now, Drakenex said:

Looking into the issue, very weird problem!

You seeing it now? I feel like it very well might be some conflict with the stock color switch, firespitter, and toggle-able bits like fairings.

Link to post
Share on other sites
3 minutes ago, Derb said:

You seeing it now? I feel like it very well might be some conflict with the stock color switch, firespitter, and toggle-able bits like fairings.

yup, I was using and old version of tantares :sticktongue: sorry! No, I don't thin stock switch is the culprit but I'm going to check. I'm currently far from my PC, can you please check if the same happens for the Soyuz rocket upper stage and the N1 upper stages? they also have fairings who are colored by the same method.

Thanks!

Link to post
Share on other sites
Just now, Drakenex said:

yup, I was using and old version of tantares :sticktongue: sorry! No, I don't thin stock switch is the culprit but I'm going to check. I'm currently far from my PC, can you please check if the same happens for the Soyuz rocket upper stage and the N1 upper stages? they also have fairings who are colored by the same method.

Thanks!

Soyuz and N1 are working just fine. Beale didn't add stock color switching to those though - that's where my suspicions arise. I suppose one could try adding stock color switching to those parts to test it. I might figure out how to do that. :D

Link to post
Share on other sites
6 minutes ago, Derb said:

Soyuz and N1 are working just fine. Beale didn't add stock color switching to those though - that's where my suspicions arise. I suppose one could try adding stock color switching to those parts to test it. I might figure out how to do that. :D

Is very easy*, but may be you can test it deleting the stock texture switch from that part, let me know if you need help!

* but takes a long time to do it, converting from firespitter to stock for just the crew part (as seen on the video) took like 45 minutes.

 

Edited by Drakenex
Link to post
Share on other sites
30 minutes ago, Drakenex said:

deleting the stock texture switch from that part

Now there's an idea!

Removed the stock switcher from the heat shield - the fairing still won't retain the color.

Edited by Derb
Link to post
Share on other sites
7 hours ago, Derb said:

Now there's an idea!

Removed the stock switcher from the heat shield - the fairing still won't retain the color.

Tried several things to no avail, so .. I´ve migrated the heat shield to the stock system (cheap solution I know!)

 

Please try it and let me now

Link to post
Share on other sites
7 hours ago, Drakenex said:

Tried several things to no avail, so .. I´ve migrated the heat shield to the stock system (cheap solution I know!)

 

Please try it and let me now

Soyuz heat shield shroud now works, but needs to be applied to TKS heat shield as well. I also notice that the military green color is now missing from the return capsule, return engine, return control block, and heat shield of the TKS. (Temporarily removed due to changes to the parts?) All good so far otherwise - I'll let you know if I find anything else. :)

 

P.S. I love the new Soyuz colors.

Edited by Derb
Link to post
Share on other sites

Hmm, something rather odd is occurring with my game after installing the latest version of this mod. Everything works fine, but for some reason the vintage textures are garbled on the VA parts, I can't select green for the VA parts either, and about half the colours don't work for both Soyuz 7K and Shenzhou's orbital modules.

Link to post
Share on other sites
1 hour ago, sslaptnhablhat said:

Hmm, something rather odd is occurring with my game after installing the latest version of this mod. Everything works fine, but for some reason the vintage textures are garbled on the VA parts, I can't select green for the VA parts either, and about half the colours don't work for both Soyuz 7K and Shenzhou's orbital modules.

The VA parts have been updated but are not in a formal release yet (I think that's also why the regular green is not there yet, it needs redone). Download the latest version of the Tantares repository, not from the releases tab to get them with ungarbled vintage green. :wink: https://github.com/Tantares/Tantares

Not all the colors work for the cylindrical modules for now - I think I asked Drakenex to add this because they previously had no colors at all. It is possible to delete the ones that aren't from the configs if you don't want them to show up though.

Edited by Derb
more info
Link to post
Share on other sites
3 hours ago, Derb said:

The VA parts have been updated but are not in a formal release yet (I think that's also why the regular green is not there yet, it needs redone). Download the latest version of the Tantares repository, not from the releases tab to get them with ungarbled vintage green. :wink: https://github.com/Tantares/Tantares

Not all the colors work for the cylindrical modules for now - I think I asked Drakenex to add this because they previously had no colors at all. It is possible to delete the ones that aren't from the configs if you don't want them to show up though.

Ah, I just realised my mistake! Thanks!

Link to post
Share on other sites
  • 4 weeks later...

Well, I was a happy man drinking my beer and updating configs but I've just hit a wall ... it seems that "ModulePartVariants" function doesn't have a method to select which mesh you want to apply the texture switch, so, because all TLV rockets use a separate texture for the nozzles and verniers, said function changes them to the main texture too, creating a big mess. There's a way to select materials but not meshes. Anyone knows how to do that?  If there's no way around that I guess I'll have to make a hybrid (fugly) release. @Electrocutor @cakepie@Beale any idea? Thanks!

Link to post
Share on other sites
34 minutes ago, Drakenex said:

Well, I was a happy man drinking my beer and updating configs but I've just hit a wall ... it seems that "ModulePartVariants" function doesn't have a method to select which mesh you want to apply the texture switch, so, because all TLV rockets use a separate texture for the nozzles and verniers, said function changes them to the main texture too, creating a big mess. There's a way to select materials but not meshes. Anyone knows how to do that?  If there's no way around that I guess I'll have to make a hybrid (fugly) release. @Electrocutor @cakepie@Beale any idea? Thanks!

Hmmmm, I am actually unsure, of course you can provide the material - but that does not work?

Link to post
Share on other sites
1 minute ago, Beale said:

Hmmmm, I am actually unsure, of course you can provide the material - but that does not work?

Nope, for example:

 

@PART[TLV_2_Engine_1]
{
    %MODULE[ModulePartVariants]
    {
    primaryColor = #A6A6A6
    secondaryColor = #565656
    baseDisplayName = Default
    baseThemeName = TantaresGrey
    VARIANT
    {
        name = Soyuz MS
        displayName = MS
        themeName = TNIC
        primaryColor = #4a7248
        secondaryColor = #4a7248
        TEXTURE
        {
            materialName=TLV_2_Engine_1
            mainTextureURL = DnD_Alt/LV/TLV/Texture_TLV_General_MS3
        }
        TEXTURE
        {
            materialName=Nozzles1
            mainTextureURL = TantaresLV/Parts/SOYUZ/Texture_TLV_2_Engine_1_Nozzle
        }
        TEXTURE
        {
            materialName=Vernier1
            mainTextureURL = TantaresLV/Parts/SOYUZ/Texture_TLV_2_Engine_1_Vernier
        }
    }

May be those are not the correct material names?

Link to post
Share on other sites
5 minutes ago, Drakenex said:

Nope, for example:

 

@PART[TLV_2_Engine_1]
{
    %MODULE[ModulePartVariants]
    {
    primaryColor = #A6A6A6
    secondaryColor = #565656
    baseDisplayName = Default
    baseThemeName = TantaresGrey
    VARIANT
    {
        name = Soyuz MS
        displayName = MS
        themeName = TNIC
        primaryColor = #4a7248
        secondaryColor = #4a7248
        TEXTURE
        {
            materialName=TLV_2_Engine_1
            mainTextureURL = DnD_Alt/LV/TLV/Texture_TLV_General_MS3
        }
        TEXTURE
        {
            materialName=Nozzles1
            mainTextureURL = TantaresLV/Parts/SOYUZ/Texture_TLV_2_Engine_1_Nozzle
        }
        TEXTURE
        {
            materialName=Vernier1
            mainTextureURL = TantaresLV/Parts/SOYUZ/Texture_TLV_2_Engine_1_Vernier
        }
    }

May be those are not the correct material names?

Ohhh, yes that's correct, the correct names are:

  • TLV_2_Engine_1_TLV_2_Engine_1_auvMat
  • TLV_2_Engine_1_Nozzles_TLV_2_Engine_1_Nozzles_auvMat
  • TLV_2_Engine_1_Vernier_TLV_2_Engine_1_Vernier_auvMat

For, the body, nozzles and verniers respectively (Yes, the material names are that awkward).

Link to post
Share on other sites
21 minutes ago, Beale said:

Ohhh, yes that's correct, the correct names are:

  • TLV_2_Engine_1_TLV_2_Engine_1_auvMat
  • TLV_2_Engine_1_Nozzles_TLV_2_Engine_1_Nozzles_auvMat
  • TLV_2_Engine_1_Vernier_TLV_2_Engine_1_Vernier_auvMat

For, the body, nozzles and verniers respectively (Yes, the material names are that awkward).

No problemo, let me try

 

Edit:

wuScfdh.png

 

Worky worky!!!! Big thanks, now to HxD all your .mu hehe

 

Edited by Drakenex
Link to post
Share on other sites

Loving the new colours, but I think I found a bug, the VA control block's antenna texture is garbled and the upper node fairing is jet black, but only when painted vintage.

EDIT: It appears there's no way for me to select the gray Mir docking module texture, and the Mir core module power bank's textures don't work.

QPGqj3Y.jpg

Edited by golkaidakhaana
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...