Nertea

[1.7.x] Stockalike Station Parts Redux (May 21st)

Recommended Posts

On 5/10/2019 at 5:30 PM, Nertea said:

screenshot190.png

screenshot145.png

screenshot91.png

screenshot77.png

I had to share these awesome screenshots from @Orbital_phoenix. They're just beautiful.

What visual mods are you using? How do you find/install them? (in CKAN?)

Share this post


Link to post
Share on other sites

I have seen this same error discussed a little bit in the B9 main thread, but I haven't seen it discussed specifically here. I get a B9 error during loading that seems traceable to Stockalike Station Parts. The relevant lines in KSP.log are:

[WRN 09:29:59.717] Warning on PartSubtype BlackHandles on module ModuleB9PartSwitch (moduleID='endcapSwitch') on part unknownPart: No transforms named 'Ladders' found

[WRN 09:29:59.812] Warning on PartSubtype BlackHandles on module ModuleB9PartSwitch (moduleID='endcapSwitch') on part sspx-expandable-centrifuge-375-2: No transforms named 'Ladders' found

While there are various other warnings in the logs for other minor issues, this is the only thing B9 complains about with a dialog box requiring acknowledgment on load. It doesn't affect game loading and doesn't seem to affect gameplay, though I have not yet unlocked the module in question in my current 1.7 career save so I can't say for certain.

Thanks.

Share this post


Link to post
Share on other sites
18 hours ago, LameLefty said:

I have seen this same error discussed a little bit in the B9 main thread, but I haven't seen it discussed specifically here. I get a B9 error during loading that seems traceable to Stockalike Station Parts. The relevant lines in KSP.log are:

[WRN 09:29:59.717] Warning on PartSubtype BlackHandles on module ModuleB9PartSwitch (moduleID='endcapSwitch') on part unknownPart: No transforms named 'Ladders' found

[WRN 09:29:59.812] Warning on PartSubtype BlackHandles on module ModuleB9PartSwitch (moduleID='endcapSwitch') on part sspx-expandable-centrifuge-375-2: No transforms named 'Ladders' found

While there are various other warnings in the logs for other minor issues, this is the only thing B9 complains about with a dialog box requiring acknowledgment on load. It doesn't affect game loading and doesn't seem to affect gameplay, though I have not yet unlocked the module in question in my current 1.7 career save so I can't say for certain.

Thanks.

Addressed as an issue in the repository and on the previous page of the thread.

It's harmless, the popup makes it sound very bad. I just haven't had time to send up a new version (planned to do it on the weekend, but didn't want to do it when Spacedock was down). 

Share this post


Link to post
Share on other sites
17 minutes ago, Nertea said:

Addressed as an issue in the repository and on the previous page of the thread.

It's harmless, the popup makes it sound very bad. I just haven't had time to send up a new version (planned to do it on the weekend, but didn't want to do it when Spacedock was down). 

I didn't see the reference on the previous page - apologies. I may have been distracted by the pretty screenshots. :)

Thanks for confirmation that it's just a harmless annoyance, however. Would be nice if B9 wasn't crying wolf here and making users worry needlessly. 

Share this post


Link to post
Share on other sites

I love this! Just a one request:

Can you please make multi-way adapters for 3.75m? It's really annoying (and removes structural integrity) when I have to use adapters and the 2.5m modules.

Share this post


Link to post
Share on other sites
20 hours ago, TeslaPenguin1 said:

I love this! Just a one request:

Can you please make multi-way adapters for 3.75m? It's really annoying (and removes structural integrity) when I have to use adapters and the 2.5m modules.

Nah. You have 3.75m attach points, use those. 

Just uploaded version 1.2.1:

  • Updated B9PartSwitch to 2.7.1
  • Fixed a harmless B9PartSwitch warning that bothered people
  • Updates to Russian localization (Sool3)
  • Updates to localized strings in general (Sool3)

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Nertea said:

Nah. You have 3.75m attach points, use those. 

Just uploaded version 1.2.1:

  • Updated B9PartSwitch to 2.7.1
  • Fixed a harmless B9PartSwitch warning that bothered people
  • Updates to Russian localization (Sool3)
  • Updates to localized strings in general (Sool3)

 

 

Спасибо (Spasiba)!

Share this post


Link to post
Share on other sites
Posted (edited)
On 5/10/2019 at 4:30 PM, Nertea said:

screenshot91.png

I absolutely LOVE the way the 6-way adapter looks with the variant docking ports on it. Looks like like a Russian docking node thingy. So awesome @Orbital_phoenix!

Edited by scottadges

Share this post


Link to post
Share on other sites
Posted (edited)

I was looking through this mods patches for contracts today.  I noticed that the patch to add the lab to station contracts adds the cupola module instead.  Is this intended?

In SSPXR-Contracts.cfg:

// 3.75m labs count for contracts
@Contracts
{
	@Base
	{
		@PART_REQUEST:HAS[#Part[Large.Crewed.Lab]]
		{
			Part = sspx-lab-375-1
		}
	}
	@Station
	{
		@PART_REQUEST:HAS[#Part[Large.Crewed.Lab]]
		{
			Part = sspx-cupola-375-1               <----------
		}
	}
}

 

Edited by Thorbane

Share this post


Link to post
Share on other sites
17 hours ago, Thorbane said:

I was looking through this mods patches for contracts today.  I noticed that the patch to add the lab to station contracts adds the cupola module instead.  Is this intended?

In SSPXR-Contracts.cfg:

 

This has been fixed, but it's pretty minor so I won't do a full release right now to fix it. If you need the fix, it's in the Github dev branch. 

Share this post


Link to post
Share on other sites
Tell me what to do. After May 30, the game started to run. On the download line, he says that he loads the StationPartsExpansionRedux \ Internals \ station-375 \ sspx-expandable-centrifuge-375-1-iva file and that's it. The game does not load further. Why?

Share this post


Link to post
Share on other sites

I have the same message. Could it have something to do with version 1.7.1?

Share this post


Link to post
Share on other sites
7 hours ago, Vadym said:

Tell me what to do. After May 30, the game started to run. On the download line, he says that he loads the StationPartsExpansionRedux \ Internals \ station-375 \ sspx-expandable-centrifuge-375-1-iva file and that's it. The game does not load further. Why?

Are you running out of RAM?

if so check the FAQ in the OP.

Share this post


Link to post
Share on other sites
1 hour ago, Nightside said:

Are you running out of RAM?

if so check the FAQ in the OP.

It's not the RAM. The problem with inflatable parts of the mod. I removed the centrifuges, but I got the exact same message on the inflatable hubs.

Share this post


Link to post
Share on other sites

Logs? Mod lists? Not seeing any of the things that help me find problems.

Share this post


Link to post
Share on other sites

In version 1.7.0 with the same mods no problem. Something is connected with 1.7.1. The log I will try to download later.

Maybe it's B9PartSwitch?. I have the transition from version 1.6.1 to 1.7.0, too, was the message associated with the centrifuges, but the game was run. After the update  B9PartSwitch the problem is gone.

Share this post


Link to post
Share on other sites
49 minutes ago, Sokol_323 said:

In version 1.7.0 with the same mods no problem. Something is connected with 1.7.1. The log I will try to download later.

Maybe it's B9PartSwitch?. I have the transition from version 1.6.1 to 1.7.0, too, was the message associated with the centrifuges, but the game was run. After the update  B9PartSwitch the problem is gone.

I haven't downloaded 1.7.1 so I'll try to check that out this weekend.

If it was B9PS, way more thing that would be broken - practically every part uses it in some form, not just the centrifuges. 

Share this post


Link to post
Share on other sites
Posted (edited)
11 minutes ago, Sokol_323 said:

Here is the latest log:    https://drive.google.com/open?id=1QX6_nOrzU93zbHVkPwEfLgTotQhLGdOH  

And this is a screenshot of the GameData folder. The list of mods has not changed since version 1.6.0: https://drive.google.com/open?id=1kUrFCqSFFuAztypmP94SZArvRXdeY9xA

Honestly looks like a RAM issue. Check through there and you'll see that all the SSPXr stuff loads with no errors - there's a few hundred lines after the last centrifuge part loads. The last messages before the end of the log are EVE things, but there's no error or anything, which for me is what happens when the things runs out of resources. 

I'll still test things in 1.7.1 when I can, but I had not heard of any breaking API changes between 1.7 and 1.7.1.

Edited by Nertea

Share this post


Link to post
Share on other sites

Then I don't. The same mods in 1.7.0 are loaded and working. When the game is loaded and other processes (browser, Explorer, etc.) use about 70% of memory. And 1.7.1 is not loaded at all and hangs on the message that is given above.

And my computer has 16GB of RAM. Isn't that enough?????

Now I will test on a clean 1.7.1 and only with this mod and its dependencies.

Share this post


Link to post
Share on other sites

I’ve really been enjoying this mod so far; definitely my favorite crew parts expansion. However I am not sure about the greenhouse and fishing science modules. They require restoration to be used more than once, but I’m finding I cannot restore them even with two scientists. What do I need to restore them? In addition, do they act like the goo + material bays in that they only recognize biomes when landed on the surface, or do they also recognize biomes while flying or in space?

Share this post


Link to post
Share on other sites

Clean installation with only SSPXr and dependencies, starts without problems. What mod then breaks ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.