Jump to content

[1.9.1 - 1.10.x] Beyond Home 1.5.0 (Supports Parallax)


Recommended Posts

15 minutes ago, WasteL67 said:

If it didn't change since, you need to install the mod Kerbal Konstructs. Then, the Lua base will be available to unlock with in-game money from the VAB at the top-right button.

I looked, and theres only a 1.8 version of Kerbal konstructs, and i'm on 1.11. Do i have to start a 1.8 save?

Link to post
Share on other sites
1 hour ago, NovakiddPrime said:

I looked, and theres only a 1.8 version of Kerbal konstructs, and i'm on 1.11. Do i have to start a 1.8 save?

Players have reported that the latest KK version works fine on the latest versions of KSP so I think you're pretty safe to use it on your 1.11 save. Backup your save before testing, as usual ;-)

Link to post
Share on other sites

I'm having trouble getting Beyond Home to work at 2.5x scale on KSP 1.10.1, I've downloaded sima dimensions and everything else, Rhodes atmo still ends at 50km (according to the tracking station so unless thats wrong). I didnt get any errors on startup so /shrug.  I can provide any log files or screenshots of my Game Data, appreciate any help.

Edited by Mtshaw113
Link to post
Share on other sites
2 hours ago, Mtshaw113 said:

I'm having trouble getting Beyond Home to work at 2.5x scale on KSP 1.10.1, I've downloaded sima dimensions and everything else, Rhodes atmo still ends at 50km (according to the tracking station so unless thats wrong). I didnt get any errors on startup so /shrug.  I can provide any log files or screenshots of my Game Data, appreciate any help.

Sigma dimensions alone is not enough, you need a rescale config that tells SD which values to adjust and at what scale. There's a bunch of standard options available for this (common one being Rescale) but it's easy to adjust them for your own preference.

Link to post
Share on other sites

I wonder where I can find the config about terrain scatter and how to adjust it("Upon starting the game YOU MUST go to settings and enable terrain scatters and turn the density up to 100% for key features of the mod to work!"). The surface turns white but in map it seems OK

Sorry for my poor English

Link to post
Share on other sites
9 hours ago, Morphisor said:

Sigma dimensions alone is not enough, you need a rescale config that tells SD which values to adjust and at what scale. There's a bunch of standard options available for this (common one being Rescale) but it's easy to adjust them for your own preference.

Oh okay that makes sense, I thought I was missing a config somewhere but I couldnt really find directions (maybe im stupid). So downloading rescale and a 2.5x config SHOULD make it a bigger system then? A quick google search makes it seem like Rescale Continued isnt updated for 1.10.1, would that be an issue?

Edited by Mtshaw113
Link to post
Share on other sites
3 hours ago, pershing127 said:

I wonder where I can find the config about terrain scatter and how to adjust it("Upon starting the game YOU MUST go to settings and enable terrain scatters and turn the density up to 100% for key features of the mod to work!"). The surface turns white but in map it seems OK

Sorry for my poor English

It sounds like you miss one of the dependencies or you might have the EVE stock planet configs still installed. Check these and also make sure there is no file called "BoulderCo" in your gamedata (that's EVE default config).

Edited by Neebel
Link to post
Share on other sites
2 hours ago, Mtshaw113 said:

Oh okay that makes sense, I thought I was missing a config somewhere but I couldnt really find directions (maybe im stupid). So downloading rescale and a 2.5x config SHOULD make it a bigger system then? A quick google search makes it seem like Rescale Continued isnt updated for 1.10.1, would that be an issue?

I use sigma and a JNSQ like config (about 2.5x) for BH. Don’t know about rescale.

Link to post
Share on other sites
2 hours ago, Mtshaw113 said:

Oh okay that makes sense, I thought I was missing a config somewhere but I couldnt really find directions (maybe im stupid). So downloading rescale and a 2.5x config SHOULD make it a bigger system then? A quick google search makes it seem like Rescale Continued isnt updated for 1.10.1, would that be an issue?

I would recommend the original rescale configs, not the later continued version. They're really just config files, they don't need to updated to a new ksp version unless Sigma dimensions itself changes the syntax needed.

Link to post
Share on other sites
30 minutes ago, Morphisor said:

I would recommend the original rescale configs, not the later continued version. They're really just config files, they don't need to updated to a new ksp version unless Sigma dimensions itself changes the syntax needed.

Thank you! Okay so I went ahead and did that, and now it seems mostly correctly scaled. Atmo at 84.5 km, Eq. Radius is 2,813 km, but KSC is floating above the ground like 50-100m, and the atmo pressure seems low at 0.65. I believe the atmo is correct, someone else said it was supposed to be 84.5km and 1575 km in diameter, so a little confused there as my game is almost double that number on the radius... Any ideas?

Link to post
Share on other sites
2 hours ago, Mtshaw113 said:

Thank you! Okay so I went ahead and did that, and now it seems mostly correctly scaled. Atmo at 84.5 km, Eq. Radius is 2,813 km, but KSC is floating above the ground like 50-100m, and the atmo pressure seems low at 0.65. I believe the atmo is correct, someone else said it was supposed to be 84.5km and 1575 km in diameter, so a little confused there as my game is almost double that number on the radius... Any ideas?

Make sure to compare values with the original without rescale to make sure everything is working correctly. The values you mention in your last sentence are from my 3.5x scale config, not from the generic rescale configs.

Link to post
Share on other sites

Is this compatible with 1.1? I downloaded this and the most recent kopernicus and parallax releases but the ground for the planets just appears white. Do i still need to use the old parallax release as indicated on the first page? The link for it 404s so i just got the most recent parallax but i'm curious if thats causing this issue i'm having.

Link to post
Share on other sites
43 minutes ago, bdole92 said:

Is this compatible with 1.1? I downloaded this and the most recent kopernicus and parallax releases but the ground for the planets just appears white. Do i still need to use the old parallax release as indicated on the first page? The link for it 404s so i just got the most recent parallax but i'm curious if thats causing this issue i'm having.

Yes, Beyond Home 1.5.2 is compatible with KSP 1.11.2 given that you use the right Kopernicus version (release 37 is fine).
You still need the right version of Parallax for Beyond Home though (1.0.1). You can find it here : https://github.com/Gameslinx/Tessellation/releases/tag/1.0.1

Link to post
Share on other sites

After transitioning to RSS and Realism Overhaul I found it hard to go back to stock or near stock KSP.  There just wasn't enough 'newness' or novelty to keep me interested. I figured I'd give Beyond Home a shot, particularly as it used Parallax , and I was not disappointed. 

Building that first super basic airplane is fun again, and the view while flying is interesting again. Thank you guys so much for your hard work and for bringing back a little of that old feeling of "wow look at that!!" back for me. Great job!!

Link to post
Share on other sites
On 3/21/2021 at 4:52 PM, bdole92 said:

Is this compatible with 1.1? I downloaded this and the most recent kopernicus and parallax releases but the ground for the planets just appears white. Do i still need to use the old parallax release as indicated on the first page? The link for it 404s so i just got the most recent parallax but i'm curious if thats causing this issue i'm having.

I've fixed the link now :) 

Link to post
Share on other sites
On 3/20/2021 at 5:39 PM, Morphisor said:

Make sure to compare values with the original without rescale to make sure everything is working correctly. The values you mention in your last sentence are from my 3.5x scale config, not from the generic rescale configs.

The moment you realize you are playing a 3.5x rescale instead of a 2.5x rescale :o. I double checked and yep, I’m using your rescale @Morphisor. Thanks for the great work! Just landing on Lua reminded me of my first manned Duna landing! It’s somewhere around 4,500 - 5,000 m/s to orbit which makes my LVs much more realistically sized (it may be less than this my gravity turns are questionable at best). 

Link to post
Share on other sites
On 3/26/2021 at 12:28 AM, Folkhoer said:

Does Beyond Home have comets? Because I never seem to spot any.

AFAIK, it's not implemented yet.

 

On 4/2/2021 at 10:26 PM, HelloMaxxo said:

What version can be use on 1.8.1?

 

I think you can use 1.4.2, be careful to use the right Kopernicus version for KSP 1.8.1 !

Link to post
Share on other sites
  • 3 weeks later...

I have recently installed Beyond Home. Unfortunately, Parallax can't load the planet textures, and they are completely magenta (or more accurately bubblegum pink). I tried many version combinations; my latest combination is Parallax 1.0.1 and Beyond Home 1.5.2 installed by hand, and everything else, including Kopernicus release 38, installed through CKAN. This seems to be identical to what CKAN installed, however. Additionally, I can't get Parallax to stop z-fighting scatterer. I'd uninstall scatterer, but CKAN lists its sunflare as a dependency to Beyond Home, so just to be safe, I'm not uninstalling it. My KSP.log is here. The relevant lines seem to be:

Spoiler

[LOG 10:24:44.874] 	Beginning material creation
[LOG 10:24:44.878] 	 - _SurfaceTexture is BeyondHome/Terrain/DDS/rustedsand00
[LOG 10:24:44.883] 	 - _DispTex is BeyondHome/Terrain/DDS/Talon00
[LOG 10:24:44.887] 	 - _BumpMap is BeyondHome/Terrain/DDS/rustedsand01
[LOG 10:24:44.891] 	 - _SteepTex is BeyondHome/Terrain/DDS/cliff_sediment00
[LOG 10:24:44.891] 	 - _SteepPower is 6
[LOG 10:24:44.891] 	 - _SurfaceTexture is 0.022
[LOG 10:24:44.891] 	 - _Parallax is 1.5
[LOG 10:24:44.891] 	 - _SteepTex is 0.01
[LOG 10:24:44.891] 	 - _Metallic is 0.1
[LOG 10:24:44.896] 	 - _SurfaceTextureMid is BeyondHome/Terrain/DDS/dust00
[LOG 10:24:44.900] 	 - _SurfaceTextureHigh is BeyondHome/Terrain/DDS/rockyground001
[LOG 10:24:44.905] 	 - _BumpMapMid is BeyondHome/Terrain/DDS/dust01
[LOG 10:24:44.911] 	 - _BumpMapHigh is BeyondHome/Terrain/DDS/rockyground01
[LOG 10:24:44.917] 	 - _BumpMapSteep is BeyondHome/Terrain/DDS/cliff_sediment01
[LOG 10:24:44.917] 	 - _LowStart is 100
[LOG 10:24:44.917] 	 - _LowEnd is 400
[LOG 10:24:44.917] 	 - _HighStart is 2500
[LOG 10:24:44.917] 	 - _HighEnd is 3260
[LOG 10:24:44.917] 	 - _PlanetRadius is 500000
[LOG 10:24:44.917] 	 - _MetallicTint is 1,1,1
[LOG 10:24:44.924] 	 - _InfluenceMap is BeyondHome/Terrain/DDS/Talon01
[LOG 10:24:44.924] 	 - _TessellationRange is 99
[LOG 10:24:44.930] 	 - _FogTexture is 
[LOG 10:24:44.930] 	 - _FogRange is 0
[LOG 10:24:44.930] 	 - _UseReflections is false
[LOG 10:24:44.930] [Parallax] - Created material successfully
[LOG 10:24:44.930]  - Applied config nodes
[LOG 10:24:44.931] [Parallax]Parallax took 1.735199 milliseconds [0.001735199 seconds] to load from start to finish.

[EDITOR'S NOTE: irrelevant TextureReplacer lines about the skybox removed]

[LOG 10:24:45.261] [Kopernicus] ShaderLoader: GetShader Kopernicus/Rings
[WRN 10:24:45.278] Cannot find preset 'Default' for pqs 'Fury'
[LOG 10:24:45.280] [OD] ERROR: getting pixelFloatD with unloaded map BeyondHome/PluginData/Fury_Height.dds of path BeyondHome/PluginData/Fury_Height.dds, autoload = True
[LOG 10:24:45.319] [OD] ---> Map BeyondHome/PluginData/Fury_Height.dds enabling self. Path = BeyondHome/PluginData/Fury_Height.dds

[EDITOR'S NOTE: this set of errors and warnings is repeated for every body; text truncated]

[LOG 10:24:46.910] [OD] <--- ScaledSpaceDemand.UnloadTextures destroying BeyondHome/PluginData/Fury_Color.dds and BeyondHome/PluginData/Fury_Normal.dds

[EDITOR'S NOTE: repeat this for every body; text truncated]

[LOG 10:24:46.983] [OD] --> ScaledSpaceDemand.LoadTextures loading BeyondHome/PluginData/Ash_Color.dds and BeyondHome/PluginData/Ash_Normal.dds

[EDITOR'S NOTE: repeat this for every body; text truncated]

[LOG 10:24:47.404] [Kopernicus]: Post-Spawn
[LOG 10:24:47.406] Found max distance 1130034971650.78
[LOG 10:24:47.437] [OD] <--- ScaledSpaceDemand.UnloadTextures destroying BeyondHome/PluginData/Verna_Color.dds and BeyondHome/PluginData/Verna_Normal.dds
[LOG 10:24:47.437] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Verna

[EDITOR'S NOTE: repeat this for every body; text truncated]

 

An example of my problem is here:

Spoiler

14io7lamfau61.png

edit: I have tested this with both PlanetShine and scatterer uninstalled (both individually and together). It doesn't fix anything, except that uninstalling scatterer stops the z-fighting artifacts (duh). Meanwhile, I've also noticed that only Kerbol has a sunflare with scatterer; Destiny and Fate don't have so much as a shine. I assume this could be fixed just by installing the correct scatterer config. I don't think I noticed a link to one, though.

Edited by mszegedy
update info
Link to post
Share on other sites
9 hours ago, mszegedy said:

I have recently installed Beyond Home. Unfortunately, Parallax can't load the planet textures, and they are completely magenta (or more accurately bubblegum pink). I tried many version combinations; my latest combination is Parallax 1.0.1 and Beyond Home 1.5.2 installed by hand, and everything else, including Kopernicus release 38, installed through CKAN. This seems to be identical to what CKAN installed, however. Additionally, I can't get Parallax to stop z-fighting scatterer. I'd uninstall scatterer, but CKAN lists its sunflare as a dependency to Beyond Home, so just to be safe, I'm not uninstalling it. My KSP.log is here. The relevant lines seem to be:

  Reveal hidden contents

[LOG 10:24:44.874] 	Beginning material creation
[LOG 10:24:44.878] 	 - _SurfaceTexture is BeyondHome/Terrain/DDS/rustedsand00
[LOG 10:24:44.883] 	 - _DispTex is BeyondHome/Terrain/DDS/Talon00
[LOG 10:24:44.887] 	 - _BumpMap is BeyondHome/Terrain/DDS/rustedsand01
[LOG 10:24:44.891] 	 - _SteepTex is BeyondHome/Terrain/DDS/cliff_sediment00
[LOG 10:24:44.891] 	 - _SteepPower is 6
[LOG 10:24:44.891] 	 - _SurfaceTexture is 0.022
[LOG 10:24:44.891] 	 - _Parallax is 1.5
[LOG 10:24:44.891] 	 - _SteepTex is 0.01
[LOG 10:24:44.891] 	 - _Metallic is 0.1
[LOG 10:24:44.896] 	 - _SurfaceTextureMid is BeyondHome/Terrain/DDS/dust00
[LOG 10:24:44.900] 	 - _SurfaceTextureHigh is BeyondHome/Terrain/DDS/rockyground001
[LOG 10:24:44.905] 	 - _BumpMapMid is BeyondHome/Terrain/DDS/dust01
[LOG 10:24:44.911] 	 - _BumpMapHigh is BeyondHome/Terrain/DDS/rockyground01
[LOG 10:24:44.917] 	 - _BumpMapSteep is BeyondHome/Terrain/DDS/cliff_sediment01
[LOG 10:24:44.917] 	 - _LowStart is 100
[LOG 10:24:44.917] 	 - _LowEnd is 400
[LOG 10:24:44.917] 	 - _HighStart is 2500
[LOG 10:24:44.917] 	 - _HighEnd is 3260
[LOG 10:24:44.917] 	 - _PlanetRadius is 500000
[LOG 10:24:44.917] 	 - _MetallicTint is 1,1,1
[LOG 10:24:44.924] 	 - _InfluenceMap is BeyondHome/Terrain/DDS/Talon01
[LOG 10:24:44.924] 	 - _TessellationRange is 99
[LOG 10:24:44.930] 	 - _FogTexture is 
[LOG 10:24:44.930] 	 - _FogRange is 0
[LOG 10:24:44.930] 	 - _UseReflections is false
[LOG 10:24:44.930] [Parallax] - Created material successfully
[LOG 10:24:44.930]  - Applied config nodes
[LOG 10:24:44.931] [Parallax]Parallax took 1.735199 milliseconds [0.001735199 seconds] to load from start to finish.

[EDITOR'S NOTE: irrelevant TextureReplacer lines about the skybox removed]

[LOG 10:24:45.261] [Kopernicus] ShaderLoader: GetShader Kopernicus/Rings
[WRN 10:24:45.278] Cannot find preset 'Default' for pqs 'Fury'
[LOG 10:24:45.280] [OD] ERROR: getting pixelFloatD with unloaded map BeyondHome/PluginData/Fury_Height.dds of path BeyondHome/PluginData/Fury_Height.dds, autoload = True
[LOG 10:24:45.319] [OD] ---> Map BeyondHome/PluginData/Fury_Height.dds enabling self. Path = BeyondHome/PluginData/Fury_Height.dds

[EDITOR'S NOTE: this set of errors and warnings is repeated for every body; text truncated]

[LOG 10:24:46.910] [OD] <--- ScaledSpaceDemand.UnloadTextures destroying BeyondHome/PluginData/Fury_Color.dds and BeyondHome/PluginData/Fury_Normal.dds

[EDITOR'S NOTE: repeat this for every body; text truncated]

[LOG 10:24:46.983] [OD] --> ScaledSpaceDemand.LoadTextures loading BeyondHome/PluginData/Ash_Color.dds and BeyondHome/PluginData/Ash_Normal.dds

[EDITOR'S NOTE: repeat this for every body; text truncated]

[LOG 10:24:47.404] [Kopernicus]: Post-Spawn
[LOG 10:24:47.406] Found max distance 1130034971650.78
[LOG 10:24:47.437] [OD] <--- ScaledSpaceDemand.UnloadTextures destroying BeyondHome/PluginData/Verna_Color.dds and BeyondHome/PluginData/Verna_Normal.dds
[LOG 10:24:47.437] [OD] <--- OnDemandStorage.DisableBodyCBMaps destroying Verna

[EDITOR'S NOTE: repeat this for every body; text truncated]

 

An example of my problem is here:

  Hide contents

14io7lamfau61.png

 

what GPU do you use? that might be a contributing factor but I dont know

Link to post
Share on other sites
Quote

what GPU do you use? that might be a contributing factor but I dont know

here's the output of neofetch:

Spoiler

                   -`                    [email protected] 
                  .o+`                   ------------------ 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: AERO 15WV8 
               `+oooooo:                 Kernel: 5.11.13-arch1-1 
               -+oooooo+:                Uptime: 18 hours, 22 mins 
             `/:-:++oooo+:               Packages: 1965 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.8 
           `/++++++++++++++:             Resolution: 1920x1080 
          `/+++ooooooooooooo/`           WM: i3 
         ./ooosssso++osssssso+`          Theme: Arc [GTK3] 
        .oossssso-````/ossssss+`         Icons: Numix [GTK3] 
       -osssssso.      :ssssssso.        Terminal: guake 
      :osssssss/        osssso+++.       CPU: Intel i7-8750H (12) @ 4.100GHz 
     /ossssssss/        +ssssooo/-       GPU: Intel UHD Graphics 630 
   `/ossssso+/:-        -:/+osssso+-     GPU: NVIDIA GeForce GTX 1060 Mobile 
  `+sso+:-`                 `.-/+oso:    Memory: 24996MiB / 64171MiB 
 `++:.                           `-/+/
 .`                                 `/                           

 

the command i use to run ksp is prime-run ./KSP.x86_64. the demo utilities glxinfo, glxgears, and vkcube run fine with prime-run, so i don't think it's on the level of my gpu or my drivers.

Edited by mszegedy
incorrect quote
Link to post
Share on other sites
31 minutes ago, mszegedy said:

here's the output of neofetch:

  Reveal hidden contents

                   -`                    [email protected] 
                  .o+`                   ------------------ 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Host: AERO 15WV8 
               `+oooooo:                 Kernel: 5.11.13-arch1-1 
               -+oooooo+:                Uptime: 18 hours, 22 mins 
             `/:-:++oooo+:               Packages: 1965 (pacman) 
            `/++++/+++++++:              Shell: zsh 5.8 
           `/++++++++++++++:             Resolution: 1920x1080 
          `/+++ooooooooooooo/`           WM: i3 
         ./ooosssso++osssssso+`          Theme: Arc [GTK3] 
        .oossssso-````/ossssss+`         Icons: Numix [GTK3] 
       -osssssso.      :ssssssso.        Terminal: guake 
      :osssssss/        osssso+++.       CPU: Intel i7-8750H (12) @ 4.100GHz 
     /ossssssss/        +ssssooo/-       GPU: Intel UHD Graphics 630 
   `/ossssso+/:-        -:/+osssso+-     GPU: NVIDIA GeForce GTX 1060 Mobile 
  `+sso+:-`                 `.-/+oso:    Memory: 24996MiB / 64171MiB 
 `++:.                           `-/+/
 .`                                 `/                           

 

the command i use to run ksp is prime-run ./KSP.x86_64. the demo utilities glxinfo, glxgears, and vkcube run fine with prime-run, so i don't think it's on the level of my gpu or my drivers.

Yeah I have no ideas, I just experienced lag on parallax on my old GPU when I upgraded it fixed it so I thought that might be a issue, I know nothing about tech

Link to post
Share on other sites

Does anyone have comments on these minor issues I've encountered? If they are install-related I'd like to get them fixed early in my playthrough.

1) Vessels sometimes sink partway into the ground. It seems like a visual bug and I haven't experienced explosions. Cycling landing gear raises the vessel, but that doesn't help craft without wheels or legs. I'm using Parallax 1.0.1 not the newest, as per the top post. Is this a known issue? If not, I'll look for steps to replicate the problem then post logs.

2) Has anyone managed to get Kerbal Alarm Clock's transfer windows to give correct results for Beyond Home? I installed Astrogator so I'm not completely lost but I do miss that KAC feature.

3) The biggest bug I've encountered is with the binary stars blocking solar panels. I understand this is a known Kopernicus issue. I keep getting the "blocked by Destiny" message in my panel window and drained batteries. My workaround is to keep opening Hyperedit to refill batteries, but I might just turn off electricity consumption in the cheat menu. Is there a better workaround?

@GameslinxThanks for this mod. I've only visited Rhode's moons so far but I'm already in love with Beyond Home. I expected to do a 2.5x rescale but I'm leaving it at 1x; I can spend less time building rockets, more time exploring.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...