Jump to content

[1.8.x, 1.9.x, 1.10.x] Orbital Decay Updated


Recommended Posts

Here is anohter beta:

1.7.0.3 Beta 4

  • Removed all N-Body references
  • Fixed the initializaiton of the Current Decay Multiplier and Resource drain rate multiplier to be 1
  • Excluded following from calcs:   VesselType.SpaceObject, VesselType.Unknown, VesselType.Debris

https://github.com/linuxgurugamer/OrbitalDecay/releases/tag/1.7.0.3

Please pay close attention to the active vessel, using both types of timewarping.  I haven't really looked at unloaded vessels that much, I've been concentrating on this.

Assuming no issues, then move on to other vessels.

Also, Check your settings and make sure that Orbital Drift Compensation is ENABLED, it's on the General tab of the main settings screen.

One of the issues was the mod disabling that, and was getting strange results.

Link to post
Share on other sites

@linuxgurugamerUsed the last version (1.7.0.3 beta) with my savefile in KSP 1.8.1 and there are never ending messages that my satellites has no engines. Stationkeeping is not available.

Also: there asre thousands of this entries in my log:

Quote

[LOG 19:16:06.875] VesselData: Vessel not found: 7e4e623c-cd0e-490c-bd57-ed5ee309d5fe

My log has now a size of 178MB.

Edited by Cheesecake
Link to post
Share on other sites
3 hours ago, Cheesecake said:

@linuxgurugamerUsed the last version (1.7.0.3 beta) with my savefile in KSP 1.8.1 and there are never ending messages that my satellites has no engines. Stationkeeping is not available.

Does your satellite have engines?

55 minutes ago, Starseeker said:

Wait, why is debris excluded from calculations? One of the main reasons I was interested in this mod was that it'd remove the need for retrorockets on my upper stages :(

I was getting distracted by messages of debris, sorry, I should have been clearer.  It will be put back.

3 hours ago, Cheesecake said:

VesselData: Vessel not found: 7e4e623c-cd0e-490c-bd57-ed5ee309d5fe

Can you check the save file and tell me what vessel that is?

Link to post
Share on other sites

Alrighty, so, the active vessel has proper decay (and at rates that seem to match the predictions in the VAB) in both no-warp, physics warp, and timewarp! Plus, the stationkeeping works, and seems to consume fuel at a reasonable rate. I'll do testing with unloaded vessels now!

However, when stationkeeping isn't enabled, the vessel's orientation appears to be "locked"; even with RCS and SAS enabled, I can't alter the vessel's attitude in any way. Turning stationkeeping on (and thus preventing decay from happening) allows free rotation of the craft.

Additionally, debris seems to "freeze" when detached; I decoupled a piece of my craft in orbit and it stick where it was at the moment of detachment, with its orbital path a straight line down but its altitude never changing.

Here's my log: https://drive.google.com/file/d/1XAg4lZ6GtWcOPdyAsvgV9g5OnD4DhXaT/view?usp=sharing

EDIT: Did some unloaded-vessel testing, and it seems that stationkeeping is perpetually enabled on unloaded vessels, including those without any method of doing stationkeeping (in which case "<craftname> has no operational engines or RCS modules, station keeping disabled" perpetually displays in the tracking station)

Also, a suggestion: could the "kill timewarp and display message when craft enters hard atmo" feature be made toggleable?

Edited by Starseeker
Link to post
Share on other sites
10 minutes ago, linuxgurugamer said:

No, although it goes without saying that you should have a backup.  And did that satellite have an engine?

Quote

Does your satellite have engines? -->no

Can you check the save file and tell me what vessel that is? --> all vessels that are in orbit (~12)

 

Link to post
Share on other sites
6 hours ago, Cheesecake said:

 

 

6 hours ago, Cheesecake said:

Can you check the save file and tell me what vessel that is? --> all vessels that are in orbit (~12)

ok.  Do you see that message for the active vessel?  or is it only showing up for vessels which are on rails?

And, if there aren't too many mods in that save, could you send me the save file, please

Link to post
Share on other sites
16 minutes ago, linuxgurugamer said:

 

ok.  Do you see that message for the active vessel?  or is it only showing up for vessels which are on rails?

And, if there aren't too many mods in that save, could you send me the save file, please

Oh, there are a lot of mods in my save. Including JNSQ and Kerbalism, if it is important. :confused:

The messages are shown already at KSC. They run through for every vessel that is in orbit. Again and again.

Edited by Cheesecake
Link to post
Share on other sites

ok, thanks.  I'll be working on this over the weekend, you've all given me some good feedback.

Thank you for your patience, this is a very complicated mod, and the math makes it even harder.  I'm slowly getting a grip on it, which is why I'm mainly dealing with one thing at a time right now

 

Edited by linuxgurugamer
Link to post
Share on other sites
  • 3 weeks later...

@linuxgurugamer testing this with my latest orbital mission and I forgot to install it before launch. I loaded up the probe in flight after installing and now when I go to the tracking station I can see it recognized by the decay simulation however it doesn't disable station keeping. Whether I toggle it on or off the LF/O keeps getting drained and the orbit stayed maintained. This is the log from the session where I time warped a lot to see any effects - orbit remained constant. Also changing the time settings from 6hr to 24hr days did not affect the orbital decay estimate time

Link to post
Share on other sites
31 minutes ago, Drew Kerman said:

@linuxgurugamer testing this with my latest orbital mission and I forgot to install it before launch. I loaded up the probe in flight after installing and now when I go to the tracking station I can see it recognized by the decay simulation however it doesn't disable station keeping. Whether I toggle it on or off the LF/O keeps getting drained and the orbit stayed maintained. This is the log from the session where I time warped a lot to see any effects - orbit remained constant. Also changing the time settings from 6hr to 24hr days did not affect the orbital decay estimate time

The current beta is stale, I need to do a major revamp, and I'm taking a break from it for a bit while it jells in my mind

Link to post
Share on other sites
1 hour ago, Minmus Taster said:

This mod is the definition of gamebreaking.

I cannot control my ship in orbit and the orbit itself is all messed up in map view.

 

On 9/15/2020 at 8:11 PM, linuxgurugamer said:

The current beta is stale, I need to do a major revamp, and I'm taking a break from it for a bit while it jells in my mind

 

Link to post
Share on other sites
  • 3 weeks later...
30 minutes ago, dorin6565 said:

Love the mod!!  Has anyone tried it with principa?  I was going to try it tonight, but thought I would ask any advice before I did.

IIRC, Principia states it's explicitly incompatible with this mod.

Link to post
Share on other sites
  • 1 month later...
1 hour ago, Snoman314 said:

Following this thread hoping to see it working again one day. I feel like this mod throughout it's history has spent most of it's time not working, but I remember when it did and miss it. Love your work @linuxgurugamer! :D 

Sorry to say, I'm most likely not going to be continuing this, at least in it's current form.  It is trying to be too smart and does too much for what the game needs

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...