Jump to content

Environmental Visual Enhancements Maintenance Releases


Recommended Posts

These are maintanance (AKA bugfix) releases for Environmental Visual Effects, AKA EVE.  You can read more about it (assuming you don't know what it is) at the previous maintainers thread here (Thanks @Waz!):

Some important FAQ to start us off:

1.) Why "Maintanance Releases?"

A.)  Because people needed this updated and no one else was available to do so.  I really really didn't need another project on my plate with being a full Kopernicus dev, and make no mistake, this is the bottom of my priority totem pole.  But if no one else had a working build (and pretty much no one else did), I figured I'd post what I had.  This mod is important to KSP, and until someone else picks it up I will keep it running as best as I am able.  That said, PLEASE BE PATIENT and please DO NOT request new features, ONLY REPORT BUGS IN EXISTING ONES!  I simply haven't the time.

2.) Ok, so you want someone to fork this?

A.)  Yes, please.  But only if you can actually keep it up.  Otherwise I just have to come back.  @Waz did great for a long time, so use him as a standard example of what I'd expect.

3.) So what did you fix?

A.)  Clouds were horribly broken in 1.9 and 1.10 as you rose in altitude.  Plumes from rockets also blended with them.  Both those bugs have been fixed by myself.  I also integrated some fixes to the terrain shader from @BIOZ, who deserves a serious gold star for his work.  Scenes from orbit/scaledspace look better than ever now with the right terrain pack, IMO.  I also made sure both 1.9.x and 1.10.x still run with the 1.10 builds, if you need 1.8.x @Waz's build works fine.

4.) Gimme screenshot!

Ok fine.  Here is a random picture from "above the clouds" EVE running with Astronomers Visual Pack,  which I heartily recommend if you want both beauty and to murder your FPS.  Uses EVE!  Note I have tweaked the sun in my system to be more orange in line with a class G star, and that said mod also uses Scatterer, another awesome visual tool for your toolbelt.  There is probably some parts packs and maybe even a plume mod in there too, but hey, you wanted a picture.

screenshot45.png

4.) Gimme download!

Below, friend:

Latest releases: https://github.com/R-T-B/EnvironmentalVisualEnhancements/releases

Source code (OSS MIT License with minor exceptions as stated in the source at github): https://github.com/R-T-B/EnvironmentalVisualEnhancements

 

Edited by R-T-B
Link to post
Share on other sites
9 minutes ago, hemeac said:

Do you have a way that we can buy you a coffee or a beverage of choice?

I wish it were that simple.  I have a paypal I could accept donations at, but my favorite beverage is out in my local town! 

At any rate, I'm hesitant to ask for donations and not even sure the forums allow for such.  Not only that, but I do this for myself first and others second, so donations won't really affect the work.  Something to keep in mind. 

My kerbal game breaking along with all of yours?  That'll probably motivate me to fix something... We need to play, afterall. ;)

 

 

Edited by R-T-B
Link to post
Share on other sites

I tried installing scatterer and EVE last night, but got an error in game saying I needed a config file. I wasn't sure where to look for those and couldn't seem to find anyone else mentioning where they were, so I uninstalled them until I could find a way to ask comfortably for more support. Would you mind pointing me in the right direction? I hope I'm not asking too much >.< I know you're super busy.

Link to post
Share on other sites
21 minutes ago, R-T-B said:

I wish it were that simple.  I have a paypal I could accept donations at, but my favorite beverage is out in my local town! 

At any rate, I'm hesitant to ask for donations and not even sure the forums allow for such.  Not only that, but I do this for myself first and others second, so donations won't really affect the work.  Something to keep in mind. 

My kerbal game breaking along with all of yours?  That'll probably motivate me to fix something... We need to play, afterall. ;)

 

 

I have seen a few asset creators have it on their opening page and I know that spacedock has a donate option.  But really appreciate the help you've done.  I did a quick check of the clouds in AVP and given I hadn't played for awhile didn't even realize that the glitchiness wasn't a current limitation.  Much improved!  

@James M, If you are playing stock, EVE/Scatterer configs would come packed alongside Astronomers Visual Pack or Spectra, both of which will work with 1.9.1.  In regards to planet packs, they should be bundled along with the packs themselves.

Edited by hemeac
Link to post
Share on other sites
1 minute ago, hemeac said:

I have seen a few asset creators have it on their opening page and I know that spacedock has a donate option.  But really appreciate the help.  I did a quick check of the clouds in AVP and given I hadn't played for awhile didn't even realize that the glitchiness wasn't a current limitation.  

@James M, If you are playing stock, EVE/Scatterer, the configs would come alongside Astronomers Visual Pack or Spectra, both of which will work with 1.9.1

Dude! Thank you!

Link to post
Share on other sites
13 minutes ago, James M said:

I tried installing scatterer and EVE last night, but got an error in game saying I needed a config file. I wasn't sure where to look for those and couldn't seem to find anyone else mentioning where they were, so I uninstalled them until I could find a way to ask comfortably for more support. Would you mind pointing me in the right direction? I hope I'm not asking too much >.< I know you're super busy.

Nah, I'm busy but never too busy for questions.  It's the people who want immediate updates who get me... ;)

You'll generally want to install these alongside a texture pack of some kind.  If you really want the old stock eve Config (it's pretty dated), I believe this release has it bundled and should work:

https://github.com/WazWaz/EnvironmentalVisualEnhancements/releases/download/EVE-1.2.2-1/EnvironmentalVisualEnhancements-Configs-1.2.2.1.zip

3 minutes ago, James M said:

Dude! Thank you!

He beat me to it, but yeah, Spectra is the non murdery one for FPS.  Still looks pretty darn good too.  Astronomers is gorgeous but at least in my experience, can tank a system hard.

All strictly my opinion, of course.

Edited by R-T-B
Link to post
Share on other sites
10 minutes ago, Entropian said:

Nice!  Does this fix the white/transparent atmosphere bug in 1.9.1?

It might.  I've never actually confirmed what causes it.  It MIGHT be a scatterer bug.  But the newer shader files can't hurt.

Link to post
Share on other sites
19 hours ago, Entropian said:

Ok, I fired up RSS in 1.9.1 and I got this.  Relevent (probably) mods: RVE64k, EVE, Scatterer.  I don't know if this is EVE or Scatterer so I'm posting this here and in the Scatterer thread.

Sounds like it may be a scatterer thing unfortunately, which was what I thought but figured it did not hurt to try.  I'll talk to blackrack and see if we can't figure it out between us.

Link to post
Share on other sites

Heads up @Entropian and others, while not certain we are the cause of the white atmospheric issue on scatterer with certain hardware, we pulled our latest release as a precaution.  I would advise all users to revert to the 1.9 release still up on github if they are having issues of any kind.  We think there might be something up with the shaders bundle (think, haven't confirmed yet, but are just being careful).

It won't hurt your savegame or anything, just may introduce visual bugs.  The 1.9 release is identical in bugfixes, runs on 1.10, and is missing only one feature that hasn't been in EVE in ages so no on has had the change to reuse it yet in a texture pack.  Tl;dr, you aren't missing anything by reverting.

Link to post
Share on other sites
4 hours ago, Entropian said:

Ok, I just tested the previous version, it definitely has more visual bugs, but the white atmosphere still persists.  I posted the logs and a photo here:

 

Thanks.  I thought it had the same bugfixes but maybe the shader package rebuild did fix some things.  I'll restore the latest build.

So in other words, all that panic over nothing.  Download freely, people.

I do hope you work our the source of your white atmospheric bug though.  That is weird as heck.

Edited by R-T-B
Link to post
Share on other sites
  • 4 weeks later...
4 hours ago, Travelbysakura said:

Is it possible to run this on a 32-bit version of KSP without large visual issues? (on an iMac, currently just trying to make the best looking KSP game I can run.) 

I compile against a 64-bit target, so technically it could be done, but I doubt the releases as posted will work.

I just assumed anyone would run it on a 64-bit install, I guess.  I can post a 32-bit binary and have you test, though.  It wouldn't be hard.  That said you probably should be careful with visual mods on old hardware like that because they can really tank your FPS quick.

If you still want a 32-bit build despite all that, PM me tomorrow and I'll see to it.  Going to bed for now.  Yes, even coders sleep... lol.

On another note, regarding the white atmopshere bug:

I want to take a moment to try to fix this, but I have no idea what's causing it.  If you are affected by it, please post the following details to help me investigate:

1.)  A standard KSP.log file from your KSP install folder.

2.)  What OS and GPU you have.

A quick fix I'd attempt if you are having the white atmopshere issue is to update your GPU drivers to the latest from AMD/NVIDIA/Intel (whoever made your card really) and then see if that helps.  I strongly believe this to be some kind of driver bug.

Edited by R-T-B
Link to post
Share on other sites

I had EVE running great on 1.10.1+BG and I just did a reinstall (for unrelated reasons) and am trying to get EVE going again.  I have all the same versions of everything as before when I had EVE running great on 1.10.1 with BG, but now all planets in map view are bright pink spheres.  Even the planet in the background on the initial splash/menu screen is just a bright pink sphere.  The Alt-0 popup terrain and atmo "tabs" say I need to "create a EVE_TERRAIN and EVE_ATMOSPHERE config" but I don't know where that file would be or what to call it and the textbox with the error message won't let me type anything in it, so I'm unsure what to do.  I have the 1.2.2.1 config file mod installed via CKAN (which I think is a different version from the one on my old install; CKAN found the newer file I suppose).  I did a brute force grep of my old install for EVE_TERRAIN and EVE_ATMOSPHERE and came up empty.  The good part is I *know* it works; I just need to figure out what is holding it up, thanks!

[Edit] This may be a SCANsat issue, looking into that

Edited by darthgently
Link to post
Share on other sites
5 hours ago, darthgently said:

I had EVE running great on 1.10.1+BG and I just did a reinstall (for unrelated reasons) and am trying to get EVE going again.  I have all the same versions of everything as before when I had EVE running great on 1.10.1 with BG, but now all planets in map view are bright pink spheres.  Even the planet in the background on the initial splash/menu screen is just a bright pink sphere.  The Alt-0 popup terrain and atmo "tabs" say I need to "create a EVE_TERRAIN and EVE_ATMOSPHERE config" but I don't know where that file would be or what to call it and the textbox with the error message won't let me type anything in it, so I'm unsure what to do.  I have the 1.2.2.1 config file mod installed via CKAN (which I think is a different version from the one on my old install; CKAN found the newer file I suppose).  I did a brute force grep of my old install for EVE_TERRAIN and EVE_ATMOSPHERE and came up empty.  The good part is I *know* it works; I just need to figure out what is holding it up, thanks!

[Edit] This may be a SCANsat issue, looking into that

I suspect a SCANsat or other mod issue as well.  Let us know if you can't work it out.

Link to post
Share on other sites

There seems to be a regression with 1.10.1-2 on Linux (or at least on my installation): Bodies with atmosphere are rendered as pink blobs (see image). This happens pretty much everywhere: In the map view, in the tracking station, and even in the flight view if you zoom out far enough. KSP.log for the session where I did the screenshot is at https://gist.github.com/rkunze/a21ee512e555e9cb5c2cb30433845703.

Version 1.10.1-1 is fine.

screenshot0.png

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...