Jump to content

[1.8.0-1.12.3] Kopernicus Stable branch (Last Updated August 12th, 2022)


R-T-B
 Share

Recommended Posts

On 12/2/2021 at 8:51 AM, dave1904 said:

I forgot to mention that FPS takes a horrible hit too when the terrain loads. Kerbin is not effected at all but the mun, minmus and ike. I remember you fixed the performance issue. With all my mods I play at around 50-60fps. Once I get into low orbit and start loading assets fps tanks to 10. Once I land and reload FPS is back at 60. Stock game wtih kopernicus(and rescale) is the same thing but not as extreme. FPS goes from 60 to 130 after I reload. 

As per the poll the scatterer subsystem is the next thing I'll be working on.  Unfortunately the bugfix for sinking terrain I thought was the "mirracle cure" has too many side effects, so good news (for you at least) is I'll be working on this more or less immediately and dropping that for now.  Next update should improve things somewhat in the performance/buggy scatter department.

Edited by R-T-B
Link to comment
Share on other sites

13 hours ago, JoshTheKerbal said:

iOEZ1w0.pngI don't know how is this still happening in the newest version

The fix we deployed for this seemingly only works for bodies orbiting the stock sun, sadly.

We are working on another fix that covers more scenarios but it is a very complex issue that involves stock code bugs, unity bugs, PhysX bugs, and all sorts of fun.  That's why.  So many systems are interacting that it makes it very confusing.

You can try enabling the experimental fix we do have by downloading this cfg and plopping it somewhere in your Kopernicus folder:

https://github.com/Kopernicus/Kopernicus/releases/download/release-66/AddWatchdog.cfg

Bear in mind it may break some mods, and it doesn't always work outside bodies not orbiting the star that is the system root.

On 12/5/2021 at 4:46 AM, Kerbal Productions said:

@R-T-Bwill scatters appearing at incorrect elevations be fixed soon if not later?

It's fine on stock already, but it's kinda irritating on other mod planets like Ecumenopolis.

I'll be stoked if this will be fixed soon! :)

This is next on the fix list.  Scatter elevation fix is first priority followed by a hopefully big performance-improving rewrite.  I hope to have it all done by Decembers end, maybe in time for Christmas/holidays. :).  The sinking gear on distant body issue is on the backburner to prioritize this (not forgotten though, will probably look at it again in January), as per the guidance poll I held.

I also hope to fix stock shadows, just because I can (most likely).

Edited by R-T-B
Link to comment
Share on other sites

1 hour ago, R-T-B said:

The fix we deployed for this seemingly only works for bodies orbiting the stock sun, sadly.

We are working on another fix that covers more scenarios but it is a very complex issue that involves stock code bugs, unity bugs, PhysX bugs, and all sorts of fun.  That's why.  So many systems are interacting that it makes it very confusing.

You can try enabling the experimental fix we do have by downloading this cfg and plopping it somewhere in your Kopernicus folder:

https://github.com/Kopernicus/Kopernicus/releases/download/release-66/AddWatchdog.cfg

Bear in mind it may break some mods, and it doesn't always work outside bodies not orbiting the star that is the system root.

This is next on the fix list.  Scatter elevation fix is first priority followed by a hopefully big performance-improving rewrite.  I hope to have it all done by Decembers end, maybe in time for Christmas/holidays. :).  The sinking gear on distant body issue is on the backburner to prioritize this (not forgotten though, will probably look at it again in January), as per the guidance poll I held.

I also hope to fix stock shadows, just because I can (most likely).

That's why i applied the fix and it still does not work... ;.;

Link to comment
Share on other sites

21 hours ago, JoshTheKerbal said:

That's why i applied the fix and it still does not work... ;.;

yeah.  Probably not the stock sun you are orbiting.  We have not forgotten you guys, we are working on a more comprehensive fix but it will probably take until beyond Christmas, sadly.

Edited by R-T-B
Link to comment
Share on other sites

Kopernicus release-67

 
@R-T-BR-T-B released this

New in this latest version release-67:

1.) First attempt to fix scatter subsystem. This represents a major rewrite. It has gone through extensive testing but I am still curious a.) how it performs on lower end hardware and b.) if it really eliminated the vertical elevation bug.

2.) The old Kopernicus_Config.cfg options relating to scatters are now deprecated and no longer function. With any luck, the new system won't need any of those complex parameters anyways, as it should perform and function better "out of the box."

3.) I upped the shadow map size to attempt to fix the glitchy stock shadows. Untested, but may help.

Known Bugs:

1.) The ingame shadows without an external mod like scatterer can be glitchy. It is advisable to use an external mod for best experience at the moment.

2.) Land scatters can appear at incorrect elevations if you don't use Kopernicus option "UsePureStockSCatters," which sadly, only works on pure stock systems.

2.) At interstellar ranges, heat can sometimes behave strangely, sometimes related to map zoom (be careful zooming out). It is best to turn off part heating when traveling far far away.

3.) When zooming out all the way out in map view at interstellar ranges, the navbal furthermore sometimes behaves oddly. We are working on this and nmonitoring all the interstellar bugs actively.

4.) 1.) Very Old craft files may complain about a missing module. This is a cosmetic error and can be ignored. Reload and re-save the craft to remove the error.

Known Caveats:

1.) The 1.12.x release series works on 1.12.x,1.11.x,1.10.x, and 1.9.x. The 1.8 release is for 1.8.x.

2.) Mutlistar Solar panel support requires an additonal config file, attatched to release.

3.) If you use the "AddWatchdog.cfg" file, A fake celestial body isthen used to fix the distant landing-gear sinking bug. This body is called "KopernicusWatchdog" and will a.) intentionally keep it's distance from you at all times and is b.) invisible. The body is usually hidden from in game processes, but this is new territory having to use another moving celestial to correct a bug, so there may be side effects. Also, Principia does not benefit from this fix at this time, unfortunately. Those users may try "MakingLessHistory" mod, the old workaround.

4.) When using the ultra/atlas shader, ocean effect customization (color etc) is unreliable. Please use only high shader level (shader level 2) or lower if working with stock ocean effects. This does not effect scatterer or other ocean rendering mods.

Link to comment
Share on other sites

First experience:
At Space Center, timewarping (KCT), as soon as sun is low and shadows are long the fps drop, compared to previous version. At noon or at night the fps increase.

Checking the log I see that even in the Space Center the Mun and Minmus are loaded and unloaded by ScaledSpaceDemand - is this a new feature?

The overall responsiveness/performance at the Space Center seems slower.

Link to comment
Share on other sites

9 minutes ago, Gordon Dry said:

Checking the log I see that even in the Space Center the Mun and Minmus are loaded and unloaded by ScaledSpaceDemand - is this a new feature?

No, I don't think so.  At least not intentionally.  That is odd.  I wonder why it's happening.

Regardless, ScaledSpaceDemand's agressiveness has been a little buggy for some time.  If you have a decent amount of ram, you can try working around this by using the following in a cfg anywhere in Kopernicus folder (name it like DisableOnDemand.cfg).  Inside that file put this code:

@Kopernicus:FINAL
{
	%useOnDemand = false
}

I do intend to try and improve performance of OnDemand at some point as it can be rather too aggressive as you noted.  But that may take a bit.

9 minutes ago, Gordon Dry said:

At Space Center, timewarping (KCT), as soon as sun is low and shadows are long the fps drop, compared to previous version. At noon or at night the fps increase.

This could also be because of enlarged shadow maps to attempt to fix stock shadows.  Hard to say.  Do the shadows behave better, in that respect?  As in less glitchy.

Edited by R-T-B
Link to comment
Share on other sites

16 minutes ago, Gordon Dry said:

I know, but I don't have a "decent amount of RAM" - I got a semi-decent-potato-rig, no internal graphics, but still ... see the sig.

In that case, keep OnDemand on.  It will still help and I'll see if I can't squeeze in some tweaks to make it "think" better in following tuneup releases that will be sure to follow.

EDIT:  8GBs might be ok for OnDemand off with the stock system, but wouldn't put it much beyond that.

Also, something to keep in mind:  The performance increase was not the main goal of this first release, fixing the incorrectly elevated scatters was.  Performance will be the next thing we work on with gusto.  Any increase at this point is more a side effect of the rewrite than a true objective I was focusing on.

Edited by R-T-B
Link to comment
Share on other sites

5 hours ago, R-T-B said:

It has gone through extensive testing but I am still curious a.) how it performs on lower end hardware and b.) if it really eliminated the vertical elevation bug.

Brief test:

On old computer, i5-4670 @ 3.4 GHz, GTX 780M, and plenty of RAM, scatter on the Mun looks fine at the right height. I previously had turned off scatter because the bug was creating floating rock fields. I didn't notice a performance hit or anything now. Did scatter there previously have more variability in size and spacing? Things seem a little uniform, but like I said, I've been playing without it for a while.

I didn't really look at shadows, but I'm already using scatterer.

Link to comment
Share on other sites

1 hour ago, danfarnsy said:

Did scatter there previously have more variability in size and spacing?

I have not tweaked anything in that regard.

Thank you kindly for the report.

Link to comment
Share on other sites

Release 67 breaks my 1.10.1 RSS/RO/RP1 build in an interesting way: If I try to quicksave or exit a flight in any way (recover, go the space center, go to tracking, even exit to main menu) all I get a bunch of null ref errors and then nothing happens. I'm just stuck there, game still running, physics still happening, no more null refs, but: YOU! SHALL! NOT! LEAVE! (or do anything that results in a save)

I just rolled back to previous release and sure enough everything is fine. I'll have to roll forward again tomorrow to reproduce the error and get a log copy.

Link to comment
Share on other sites

11 hours ago, Omnipius said:

Release 67 breaks my 1.10.1 RSS/RO/RP1 build in an interesting way: If I try to quicksave or exit a flight in any way (recover, go the space center, go to tracking, even exit to main menu) all I get a bunch of null ref errors and then nothing happens. I'm just stuck there, game still running, physics still happening, no more null refs, but: YOU! SHALL! NOT! LEAVE! (or do anything that results in a save)

I just rolled back to previous release and sure enough everything is fine. I'll have to roll forward again tomorrow to reproduce the error and get a log copy.

That's very interesting.  May be some mod interaction playing up badly with the rewrite, as I do not see it in pure stock (or in my fairly custom modset I play with). A log file would help me investigate.

Edited by R-T-B
Link to comment
Share on other sites

Xeon E5-2650v2 + 32Gb RAM + GTX760
Good news: performance is better;
Bad news: stones go weeeee!

New version behaves strange. My GPU works on 100% load for minute or two after I load quicksave, change vessel to another planet or like so. But overall performance is much better.
---
Forgot to mention: stones went flying after I rode my rover for 15 km or so. Not on savegame load.
Also, KSP consumes less ram. I think it's because of  ScaledSpaceDemand behavior...

Edited by SuppaTenko
Link to comment
Share on other sites

On 12/8/2021 at 6:55 AM, R-T-B said:

1.) First attempt to fix scatter subsystem. This represents a major rewrite. It has gone through extensive testing but I am still curious a.) how it performs on lower end hardware and b.) if it really eliminated the vertical elevation bug.

Scatters don't float anymore but if landing with HyperEdit (and possibly the stock set position) it still floats, apparently. But it's easily fixed by going to tracking station and back.

 

Link to comment
Share on other sites

5 hours ago, SuppaTenko said:

Bad news: stones go weeeee!

So that's not with hyperedit?

Darn up until now I only heard of it happening with hyperedit which I took as "good enough."  Looks like it may need yet another look.  As research for this particular incident, I have to ask, have you changed any physics related settings?  Particularly that delta one in the main settings menu?

Moving on, for those of you with shadow-fix-performance issues from the last update, there's this:

Kopernicus release-68

 
@R-T-BR-T-B released this now
 

New in this latest version release-68:

1.) The upped shadow map size in last release was hurting performance for some users and outright crashing for others, so we reverted that. I am trying a different shadow fix with this release that should work with all hardware, and not just "modern" cards.

Known Bugs:

1.) The ingame shadows without an external mod like scatterer can be glitchy. It is advisable to use an external mod for best experience at the moment.

2.) Land scatters can appear at incorrect elevations if you don't use Kopernicus option "UsePureStockSCatters," which sadly, only works on pure stock systems.

2.) At interstellar ranges, heat can sometimes behave strangely, sometimes related to map zoom (be careful zooming out). It is best to turn off part heating when traveling far far away.

3.) When zooming out all the way out in map view at interstellar ranges, the navbal furthermore sometimes behaves oddly. We are working on this and nmonitoring all the interstellar bugs actively.

4.) 1.) Very Old craft files may complain about a missing module. This is a cosmetic error and can be ignored. Reload and re-save the craft to remove the error.

Known Caveats:

1.) The 1.12.x release series works on 1.12.x,1.11.x,1.10.x, and 1.9.x. The 1.8 release is for 1.8.x.

2.) Mutlistar Solar panel support requires an additonal config file, attatched to release.

3.) If you use the "AddWatchdog.cfg" file, A fake celestial body isthen used to fix the distant landing-gear sinking bug. This body is called "KopernicusWatchdog" and will a.) intentionally keep it's distance from you at all times and is b.) invisible. The body is usually hidden from in game processes, but this is new territory having to use another moving celestial to correct a bug, so there may be side effects. Also, Principia does not benefit from this fix at this time, unfortunately. Those users may try "MakingLessHistory" mod, the old workaround.

4.) When using the ultra/atlas shader, ocean effect customization (color etc) is unreliable. Please use only high shader level (shader level 2) or lower if working with stock ocean effects. This does not effect scatterer or other ocean rendering mods.

Edited by R-T-B
Link to comment
Share on other sites

8 minutes ago, Kerbal Productions said:

Oh wow new update again what's new this time...

If you had no bugs in the last one, not much.  It's for users who were suffering from the shadow-fix last update not working right on older cards.

That release is really just a hotfix until I can work on the scatters some more.  I am determined to anchor those floating rocks permanently. ;)

  

5 hours ago, SuppaTenko said:

My GPU works on 100% load for minute or two after I load quicksave

Yeah, that sounds like the shadow-fix introduced bug in its more minor form (some users fell way worse in performance), basically your GPU driver / video card does not like my first fix attempt by just raising the shadow map size.

Try the new release and see if that goes away. :)

Edited by R-T-B
Link to comment
Share on other sites

7 minutes ago, R-T-B said:

until I can work on the scatters some more. 

good luck!

7 minutes ago, R-T-B said:

Yeah, that sounds like the shadow-fix introduced bug in its more minor form (some users fell way worse in performance), basically your GPU driver / video card does not like my first fix attempt by just raising the shadow map size.

Is it similar to some lag stuff?

 

Cuz I'm having some

Link to comment
Share on other sites

1 hour ago, Kerbal Productions said:

Is it similar to some lag stuff?

 

Cuz I'm having some

It did manifest itself as some lag, yes.  You could try the new release if you haven't.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...