e-dog

[1.2] Procedural Fairings 3.20 (November 8)

Recommended Posts

Hi all. I'm running the RO pre-release with only a couple of necessary mods and procedural parts and procedural fairings. I have a big problem with these fairings though.

Whenever I go to launch pad from VAB and the spacecraft loads or whenever I take off with the fairings on, my screen shakes as if it is going through a lot of g-force and then the fairings fall apart. There is no reason at all they should fall off unless I want them too. Also this has happened with multiple rockets. Anyway, has anyone else experienced something similar? Do I need to post screenshots?

Thanks.

Fire

Share this post


Link to post
Share on other sites
5 hours ago, Phineas Freak said:

@Firemetal There is a small bug with the PF autostruts and KJR. We have implemented a fix but it is not a part of the RO preview release. Download the "RO_PFairings.cfg" file from the repo and replace your local one.

Alright thanks!

Alright, I couldn't find a download button anywhere so I copy and pasted the entire thing into my current file. Will that work or is there a way to download it, it was probably right in front of me, and I'm missing it?

Fire

Edited by Firemetal

Share this post


Link to post
Share on other sites
52 minutes ago, Firemetal said:

Alright thanks!

Alright, I couldn't find a download button anywhere so I copy and pasted the entire thing into my current file. Will that work or is there a way to download it, it was probably right in front of me, and I'm missing it?

Fire

That should work.

Easiest way for a single file is to hit the 'RAW' button, and then use 'Save Page' in your browser.

Share this post


Link to post
Share on other sites
On 1/28/2017 at 3:43 PM, KortexM said:

If all is well i am going to make a next official release soon. Any other big issues left that need fixing?

@KortexM any update on making an official release?  Do you have a github page where we could track what you're doing?  I tried opening up an issue on @e-dog's repo, but he pointed me to you.

Edit: I also found out that technically it's against the rules of this forum to post mods (or updates to mods in this case), without making the source available.  Because of this, I think it's best if you make a fork on github of the OP's mod with your changes there, and I would also suggest submitting a PR to his codebase.  I'd be happy to help with that if you need it! 

 

Edited by rsparkyc

Share this post


Link to post
Share on other sites

Hi ! :) 

first I want to thanks the dev(s) for this mods, i've been using it in every ksp version i had :) 

I got an issue with the textures in my 1.2.2 install, i don't know if i'm in the right place to ask for that but..

I have blackheart textures and mainsailor i think, and the fairings turns black on the launchpad, sometimes the side where the sun is, is black and the other side which should be in the shadow is bright.. are these textures pack the problem ? 

 

thanks a lot ! 

Share this post


Link to post
Share on other sites

Help.

http://steamcommunity.com/sharedfiles/filedetails/?id=898101274

I'm trying to do an interstage with an upper stage of 4 aerospikes on the 4-way adapter. I think I built it the intended way (I put the fairing base upside-down?) but the engines fall off inside the fairing as soon as it loads. Weird thing is, if I leave off the fairing sides, it works as I imagined it:

http://steamcommunity.com/sharedfiles/filedetails/?id=898101360

Craft files if anybody cares:

Share this post


Link to post
Share on other sites

Are you guys familiar with Procedural parts? I just thought it would be awesome to have a option menu when you right click on the fairing to change the fairing textures to match the procedural parts textures. IS there a mod that would allow me to do that? Or is there plans to add this function?

Share this post


Link to post
Share on other sites
31 minutes ago, Dermeister said:

Are you guys familiar with Procedural parts? I just thought it would be awesome to have a option menu when you right click on the fairing to change the fairing textures to match the procedural parts textures. IS there a mod that would allow me to do that? Or is there plans to add this function?

 

The creator of this mod has been inactive since 2016, the mod in current state has some issues unfixed. I do not think this feature will be implemented soon. Sorry:(

Still, feel free to look for some textures online. Better still, implement it yourself if you know how to code!

Share this post


Link to post
Share on other sites
4 hours ago, Dermeister said:

IS there a mod that would allow me to do that?

Check if this suits your needs:

 

Share this post


Link to post
Share on other sites

 

How to increase the maximum size of the fairing? 50 meters a little
 

I'm playing with RO

Share this post


Link to post
Share on other sites

So I read a couple of pages and search inside this thread for "thrust plates" but no avail, it's bugged.

Engines fall apart from the center node, no cross-feed (turned on in VAB) ...

Darn.

I would also like to see that the plate is not becoming so thick when scaled up - and it could need some textures.

Share this post


Link to post
Share on other sites

Another something:

It seems that dV of stages below an interstage fairing are not calculated individually anymore, instead the sum of all dV of stages below the fairing will either be shown in an upper stage with engine - or just more weird, in the decouple-the-interstage-fairing stage  ...

Edit:

This also applies to payload fairings...

Some pictures to show the weirdness:

Spoiler

 

 

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

btw I fiddled so much to get the procedural interstages to work, but they neither decouple nor detach the fairings...

When I'm lucky the interstage fairing base gets too hot and just explodes, then the staging is done :D

Edit:

Yeah, I got it. It was a mismatch of the downloaded .dll from the last two pages of this thread.
There was a .dll from 2016-12-02 and a .dll from 2017-01-28 - of course I had the older one because it was linked to twice (one time inside a .zip with the according file date, one time as .dll with the timestamp of download...).

Edited by Gordon Dry

Share this post


Link to post
Share on other sites

How do I apply bump maps to FStextureSwitch2 ?

I merged several texture packs into one folder to avoid double buttons for texture switching in the GUI context menu of the faring sides.
I can switch the texture nicely but the bump maps are not applied.

Actually it looks like this:
https://www.dropbox.com/s/lnmihjgty9orzjq/ProceduralFairingsRetext.zip?dl=1

Share this post


Link to post
Share on other sites

Ah damn the interstages issue is back - like I never changed the .dll

Edit:

I have to

  1. use payload fairings for interstages
  2. disable decoupling at the interstage fairing base
  3. use an additional decoupler
  4. manually stage

But why - oh why - is it now an issue for ages that MechJeb can not recognize the Procedural Fairings at all?
It already was like that one year ago. I don't know how long is was before that - I started with KSP last year, had a nearly-one-year-break of frustration and hope and here we are.
What inside the code of PF is avoiding this?

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
8 hours ago, Gordon Dry said:

Ah damn the interstages issue is back - like I never changed the .dll

Edit:

I have to

  1. use payload fairings for interstages
  2. disable decoupling at the interstage fairing base
  3. use an additional decoupler
  4. manually stage

But why - oh why - is it now an issue for ages that MechJeb can not recognize the Procedural Fairings at all?
It already was like that one year ago. I don't know how long is was before that - I started with KSP last year, had a nearly-one-year-break of frustration and hope and here we are.
What inside the code of PF is avoiding this?

I don't really understand exactly what the problem you are having is....

BUT I can tell you that if you want your fairings shells to jettison you have to use the "payload" fairings. If you use the other fairings (I think they are called structural fairings) they do not have a decoupler and will not jettison, they are meant to create permanent hollow shells. I usually set up an action group that jettisons the shells and decouples the top node and I have never had any issues with the interstage fairing part.

Also in regards to your earlier questions regarding dV readouts if whatever tool you are using there behaves anything like KER then anything that has to be decoupled manually will do that, basically if staging doesn't detach the parts then your dV utility won't know that those parts will be detached and it will calculate your dV as if those parts are still attached. I know that I have this issue with the SSTU interstage decouplers since they use a custom decouple module that jettisons the bottom node and then a few seconds after the ullage motors burn out it jettisons the top node.

 

@yobeeb That is not the correct way to do that. what you want is multi adapter attached to upper fuel tank, engines attached to that, then the interstage adapter attached to the middle attach node on the multi adapter, and then the big orange tank attached to that. You may need to use the offset tool to get the adapter and everything sunk down into the fairing but it should work just fine.

Share this post


Link to post
Share on other sites

The main problem is that I use the interstage fairing for "real" interstages with engines in them.

I set nothing to strut or rigid at all, but the interstage base will not decouple.

I really need this mod, because the amount of preset interstages is very low and mostly very restrictive in use with other parts than envisaged by the creator.

Now I just have enough mods, I try to lower the amount of mods, I don't want to just add more part packs...

Share this post


Link to post
Share on other sites

I have encountered a problem running this mod with FAR (and I am aware that the OP states it is FAR-compatible.)

One of my probe designs has a shrouded midsection which contains solars, radiators and scientific instruments and is meant to be exposed after leaving the atmosphere. Jettisoning the fairing works perfectly fine, but the probe's solars and radiators refuse to deploy, reporting they are in a stowed state. This does not occur without FAR.

I would like to know possible causes of and, if available, solutions to this problem.

 

This message has also been posted to the FAR thread.

Edited by Angstinator

Share this post


Link to post
Share on other sites

I had tried reaching out to @KortexM regarding getting the sources for his 3.20b4 release, but never got a reply.  With the help of @sarbian, we decompiled the binary he put out there, generate a diff, and from that I was able to put together the following PR: https://github.com/e-dog/ProceduralFairings/pull/28

I've done a little testing and haven't noticed any issues, but if anyone else wants to do some, that would be awesome. 

Share this post


Link to post
Share on other sites
On 5/26/2017 at 11:28 AM, rsparkyc said:

I've done a little testing and haven't noticed any issues, but if anyone else wants to do some, that would be awesome. 

I actually did just find an issue.  In RO, i attach a decoupler, than a procedural tank, and then an interstage, and on reloading that craft, the interstage becomes separated from the tank.  Going to see if i can track that down

Share this post


Link to post
Share on other sites

@rsparkyc if you place a proc interstage with its floating node attached to a proc tank, both the tank and the interstage will attempt to adjust position on load of the craft file, leading to offset positions. Right-clicking on the interstage will snap things back into position. This has been an issue at least since KSP 0.90, and probably since Proc Parts came out and PF got its floating-node interstage.

Share this post


Link to post
Share on other sites

@NathanKell Jeez, is that what causes that? Always drove me crazy.

Would putting a strut between them and offsetting it into the parent part so it's visually the same prevent the issue?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.