Starwaster

[1.6.1] Deadly Reentry v7.7.2, May somethingth, 2019 (The Rachel Edition)

Recommended Posts

Oh that's absolutely given. Otherwise my 1.25m tanks would melt on ascent (I tried. Hence why I wanted this patch in the first place).  This failure happened on reentry.  What I don't understand is why two different parts with the same temperature tolerance (according to the editor readout) has one melt on reentry while the other survives MUCH heavier punishment.

Share this post


Link to post
Share on other sites
57 minutes ago, Atlessa said:

Oh that's absolutely given. Otherwise my 1.25m tanks would melt on ascent (I tried. Hence why I wanted this patch in the first place).  This failure happened on reentry.  What I don't understand is why two different parts with the same temperature tolerance (according to the editor readout) has one melt on reentry while the other survives MUCH heavier punishment.

 

You can always open up your modulemanager.configcache and do a search for the parts you’re curious about. That should show you any differences in base stats and their upgrades. 

Share this post


Link to post
Share on other sites
1 hour ago, Jognt said:

 

You can always open up your modulemanager.configcache and do a search for the parts you’re curious about. That should show you any differences in base stats and their upgrades. 

Looks fine as far as I can tell

For what reason should those be different than what is shown in the game?

Share this post


Link to post
Share on other sites

Will DRE affect nuclear engines like the NERVA? I've seen the NERVA and my radiators get red hot with a full heat progress bar, but nothing happened. No damage, explosion or otherwise.

Share this post


Link to post
Share on other sites
5 hours ago, KingMonkeyNuts said:

Will DRE affect nuclear engines like the NERVA? I've seen the NERVA and my radiators get red hot with a full heat progress bar, but nothing happened. No damage, explosion or otherwise.

Everything has its max temp balanced to something more sensible than stock where needed including the Nerv. A full heat bar with no damage or explosions means either something is broken somewhere or it wasn't really full or the temperature cheat was turned on.

Share this post


Link to post
Share on other sites

Is it correct that the service bays from Universal Storage 2 have only 1000 K max temp? I thought they would somewhat protect their contents, but they burn up very quickly. I'm playing KSP 1.7.3 with JNSQ and latest DRE.

Share this post


Link to post
Share on other sites
8 hours ago, Atlessa said:

Looks fine as far as I can tell

For what reason should those be different than what is shown in the game?

They shouldn’t. It’s just a completer ‘picture’ than in-game. 

Share this post


Link to post
Share on other sites
8 hours ago, garwel said:

Is it correct that the service bays from Universal Storage 2 have only 1000 K max temp? I thought they would somewhat protect their contents, but they burn up very quickly. I'm playing KSP 1.7.3 with JNSQ and latest DRE.

Sounds correct to me. It's basically just a service module right? If it were really meant to be protected against reentry then they would have done more than just given it a high max temp. Shielding or thermal properties adjusted to actually protect it. What's the outer hull supposed to be made out of? Aluminum? (if aluminum then 1000 K is really a little high

Share this post


Link to post
Share on other sites
1 hour ago, dlrk said:

Perhaps remove the version cap?

It's just a warning. Read it, consider yourself warned and close it.

Share this post


Link to post
Share on other sites

Hey @Starwaster!

Speaking of versions, AVC reports the latest version as 7.7.2, but the version file in the 7.7.2 download reports itself as 7.7.1. Minor issue, doesn't affect anything (as you know), but I thought I would post here in case someone else sees it and gets confused.

Hope the kitties are well!

Share this post


Link to post
Share on other sites
4 hours ago, eightiesboi said:

Hey @Starwaster!

Speaking of versions, AVC reports the latest version as 7.7.2, but the version file in the 7.7.2 download reports itself as 7.7.1. Minor issue, doesn't affect anything (as you know), but I thought I would post here in case someone else sees it and gets confused.

Hope the kitties are well!

Thanks for telling me!

Yeah they're doing well for the most part. We just lost our oldest one who was in her twenties. Half blind, half deaf, vocal as hell when she wanted something :). She had a good life though.

 

Share this post


Link to post
Share on other sites

Deadly Reentry version 7.7.3 for KSP 1.6.0 - 1.6.1

https://github.com/Starwaster/DeadlyReentry/releases/tag/v7.7.3

change log

  • Fixed versioning
  • Forced ModuleAeroReentry to Awake when added at runtime.
  • Added DR reentry heat override in DR menu (up to 200% by default. Can be patched to support any arbitrary integer. 1 = 100%, 2 = 200%, 3 = 300% etc etc)
    WARNING: If the stock reentry slider is used to scale heat it will revert to the stock cap of 150%. I can't actually override the stock slider which is why I added one to the Deadly Reentry menu.

// example scale patch: @REENTRY_EFFECTS
{
    maxHeatScale = 3 // this caps the reentry heat scale override menu slider at %300
}

Once this update has been indexed by CKAN it will be re-released for KSP 1.7.3 (but it should be safe to use as is for the latest KSP)

Share this post


Link to post
Share on other sites

Using SMURFF and RSS, I found the 1.875m heat shield burns ablator like it's going out of fashion. Looks like it's not supported yet?

Anyway, I made the following quick & dirty hack to the DeadlyReentry config file, which seemed to fix the problem. (This definitely won't be the right way to do it as I don't know what I'm doing :) But it works so far...)

I changed:

@PART[HeatShield1|HeatShield2|HeatShield3]:FOR[DeadlyReentry]

To:

@PART[HeatShield1|HeatShield1p5|HeatShield2|HeatShield3]:FOR[DeadlyReentry]

As you can see, I'm a skilled and subtle modder...

Share this post


Link to post
Share on other sites
2 hours ago, KincaidFrankMF said:

Using SMURFF and RSS, I found the 1.875m heat shield burns ablator like it's going out of fashion. Looks like it's not supported yet?

Anyway, I made the following quick & dirty hack to the DeadlyReentry config file, which seemed to fix the problem. (This definitely won't be the right way to do it as I don't know what I'm doing :) But it works so far...)

I changed:

@PART[HeatShield1|HeatShield2|HeatShield3]:FOR[DeadlyReentry]

To:

@PART[HeatShield1|HeatShield1p5|HeatShield2|HeatShield3]:FOR[DeadlyReentry]

As you can see, I'm a skilled and subtle modder...

That's interesting because there's supposed to be fallback patches to catch unhandled heatshields in any oversized star system (which RSS qualifies as)

I haven't used that shield in my RSS install but looking at it in the cache I can see it has normal stats.

I'll have to dig deeper but what I think is happening is that my patches are assuming that the shield is already being handled by something else and then it isn't.

You say you're using SMURFF so can I assume you are NOT using Realism Overhaul?  The only way I can see this happening is if Realism Overhaul is installed but is not handling the heat shield. (which it would not be since none of the Making History parts are currently supported by RO...)

No... actually Realism Overhaul currently HIDES that shield. If you see it then you can't have it installed.... so the shield should be getting patched.... what is going on here? 

I'll try to look into it tonight sometime.

Share this post


Link to post
Share on other sites

A very quick question: is the Mk1-3 pod supposed to have 10 units of Ablative Shielding? I thought it strange that it wasn't higher (like the 100 of the Mk1 pod) or non-existent.

@PART[Mark1-2Pod|mk1-3pod]:NEEDS[!Kopernicus]
{
	@maxTemp = 1000 // 1700
	MODULE
	{
		name = ModuleHeatShield
		ablativeResource = AblativeShielding
		lossExp = -7500
		lossConst = 1.6
		pyrolysisLossFactor = 6000
		reentryConductivity = 0.001
		ablationTempThresh = 500
		depletedMaxTemp = 1200
		charMin = 1
		charMax = 1
		charAlpha = 1
		useNode = true
		nodeName = bottom
	}
	RESOURCE
	{
		name = AblativeShielding
		amount = 10
		maxAmount = 10
	}
}

As always, thank you for making this!

Share this post


Link to post
Share on other sites
1 hour ago, eightiesboi said:

A very quick question: is the Mk1-3 pod supposed to have 10 units of Ablative Shielding? I thought it strange that it wasn't higher (like the 100 of the Mk1 pod) or non-existent.


@PART[Mark1-2Pod|mk1-3pod]:NEEDS[!Kopernicus]
{
	@maxTemp = 1000 // 1700
	MODULE
	{
		name = ModuleHeatShield
		ablativeResource = AblativeShielding
		lossExp = -7500
		lossConst = 1.6
		pyrolysisLossFactor = 6000
		reentryConductivity = 0.001
		ablationTempThresh = 500
		depletedMaxTemp = 1200
		charMin = 1
		charMax = 1
		charAlpha = 1
		useNode = true
		nodeName = bottom
	}
	RESOURCE
	{
		name = AblativeShielding
		amount = 10
		maxAmount = 10
	}
}

As always, thank you for making this!

Yes, it imitates the thin backshell protecting Apollo. In stock KSP it probably won't matter too much; you'll likely be doing ballistic reentries and with stock heating and aero you won't see heating on the pod itself when protected by a shield.

For lifting reentries and/or situations where FAR and/or Real Heat are installed then you'll see heating of the pod. So it gets just enough to protect it when a full shield is attached. Probably not so much on its own.

Share this post


Link to post
Share on other sites

I'm playing RSS (Not RO, just RSS with real fuels) and reentry is very easy! I lower my periapsis to -100km on Earth, and lost about 20 units of ablator (out of 1800). I believe there's some other mod conflicting with DR, but can't say for sure.

Share this post


Link to post
Share on other sites
1 hour ago, mateusviccari said:

I'm playing RSS (Not RO, just RSS with real fuels) and reentry is very easy! I lower my periapsis to -100km on Earth, and lost about 20 units of ablator (out of 1800). I believe there's some other mod conflicting with DR, but can't say for sure.

Uh, ok.  Am I supposed to do something with this information? It's kind of sparse. I know one parameter of your orbit and that's it. Are we talking a reentry from LEO or Lunar? What was its apoapsis?

1800 ablator would be the 3.75m shield... but what was attached to it? How much mass did the entire reentry vessel have? If it was a very light part (or set of parts) attached to the shield then the it has a low ballistic coefficent and will get lot more deceleration from drag so would naturally lose less ablator.

All in all there's not a lot of information about your post.

Share this post


Link to post
Share on other sites
8 hours ago, Starwaster said:

Uh, ok.  Am I supposed to do something with this information? It's kind of sparse. I know one parameter of your orbit and that's it. Are we talking a reentry from LEO or Lunar? What was its apoapsis?

1800 ablator would be the 3.75m shield... but what was attached to it? How much mass did the entire reentry vessel have? If it was a very light part (or set of parts) attached to the shield then the it has a low ballistic coefficent and will get lot more deceleration from drag so would naturally lose less ablator.

All in all there's not a lot of information about your post.

Sorry for the lack of useful information. It was an MK3 command module with an empty fuel adapter below it to make it 3.75m, reentring from LEO at about 7500m/s. Forgot to mention, i also using FAR. Reentry was always pointing retrograde. 

Share this post


Link to post
Share on other sites
13 hours ago, mateusviccari said:

Sorry for the lack of useful information. It was an MK3 command module with an empty fuel adapter below it to make it 3.75m, reentring from LEO at about 7500m/s. Forgot to mention, i also using FAR. Reentry was always pointing retrograde. 

You mean Mk 1-3?

Sounds like what I was saying; you're basically cutting its ballistic coefficient almost in  half. Maybe by more than half depending on the mass of that adapter.

This does't sound very unusual to me. It's basically the math behind inflatable decelerators (inflatable heat shields) which drastically increase the drag area. They decelerate much sooner before the craft would otherwise reach its peak heating.

Share this post


Link to post
Share on other sites
1 minute ago, Starwaster said:

You mean Mk 1-3?

Sounds like what I was saying; you're basically cutting its ballistic coefficient almost in  half. Maybe by more than half depending on the mass of that adapter.

This does't sound very unusual to me. It's basically the math behind inflatable decelerators (inflatable heat shields) which drastically increase the drag area. They decelerate much sooner before the craft would otherwise reach its peak heating.

Oh so that's how it works... I thought it might be something wrong because I heard other people saying they were always exploding on reentry using RSS, and i am barely losing ablator. ANyway, i cranked reentry heating to 200% because I like to feel the "heat of the moment" hahah...

Share this post


Link to post
Share on other sites
5 minutes ago, mateusviccari said:

Oh so that's how it works... I thought it might be something wrong because I heard other people saying they were always exploding on reentry using RSS, and i am barely losing ablator. ANyway, i cranked reentry heating to 200% because I like to feel the "heat of the moment" hahah...

You can even set it above 200% but you'd have to change the limit by editing the setting config

Share this post


Link to post
Share on other sites
Posted (edited)

Im playing RSS With DeadlyReentry, Some command pods and parts that would be rated for 2000K in stock blow up when exposed to the slightest amount of heating. I tried to edit the .cfg's in the parts to something like 2700K and it showed up in the VAB to be 1300K. 

Is there a .cfg that halves the heat tolerence?

 

Edited by IronKerbal

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.