stupid_chris

[1.7] RealChute Parachute Systems v1.4.7.4 | 13/04/19

Recommended Posts

10 hours ago, Bob810 said:

Hi i have no parachute in my game.I installed the latest version.

I have ksp 1.4.5 with rss Ro and dependencies.

Firstly, please read and follow the guidance in this post How To Get Support (READ FIRST) - Technical Support (PC, modded installs) - Kerbal Space Program Forums.  It helps more often than not.

Secondly, it sounds as if you have an installation problem since even the stock game has parachutes.  Did you have them before installing Real Chutes?

Share this post


Link to post
Share on other sites
10 hours ago, Bob810 said:

my log

Without real chute i have stock parachute, no problem.

(Sorry for my bad english)

Your English is good enough :), so no problems there.  However, your link isn't.  I get a blank page.  I suggest you use Dropbox, Google Drive or OneDrive and try again.  What versions of RSS/RO and RC are you using?

Es-tu francais?

Share this post


Link to post
Share on other sites

i think your are french Brigadier...

me too, and i have the same probleme my real chute doesn't apear in VAB part list, it might be a category problem...

Share this post


Link to post
Share on other sites

Yes French, I use version 1.4.5 of RSS For RO it is a version 1.3 but that seems to work well in 1.4 according to the forum RO, I did not find any problem.
My log

Share this post


Link to post
Share on other sites
1 minute ago, Bob810 said:

 


Yes French, I use version 1.4.5 of RSS For RO it is a version 1.3 but that seems to work well in 1.4 according to the forum RO, I did not find any problem.
My log

The parachutes will be found in a seperate tab with a parachute icon.

Please uses the correct version for the game, crossing 1.4 and 1.3 versions of mod and game will screw things over.

Share this post


Link to post
Share on other sites
14 hours ago, Bob810 said:

Yes French, I use version 1.4.5 of RSS For RO it is a version 1.3 but that seems to work well in 1.4 according to the forum RO, I did not find any problem.
My log

I agree with @Xd the great, RO v12.1.0 is not compatible with KSP 1.4.5 so your combination is probably not supported.  Also, you don't have ClickThroughBlocker installed which is a dependency for a couple of mods you do have.  I suggest you install it.

If you're still adamant to use RO in KSP 1.4.5, I would recommend you start with a clean, separate install of KSP 1.4.5, add Real Chutes and check to see if the parachutes are visible.  Then add RO and check again.  Let us know what you find.

Share this post


Link to post
Share on other sites
1 hour ago, Bob810 said:

I have clean all mods and unzip real chute , i still have no parachute.

Clarify what you did please; not sure what 'clean all mods' means or if that complies with previous instructions given.

Share this post


Link to post
Share on other sites

i deleted all mods and unzip real chute , i have no icon for parachute, i have no prarachute.

 

 

Edited by Bob810

Share this post


Link to post
Share on other sites
51 minutes ago, Bob810 said:

i deleted all mods and unzip real chute , i have no icon for parachute, i have no prarachute.

 

 

I see what the problem is, assuming you installed it the same way as you did before.

Download Real Chute directly from HERE: https://github.com/StupidChris/RealChute/releases/latest or if you need an earlier version: https://github.com/StupidChris/RealChute/releases/

(the link you apparently used is only meant for copying the repository files and you don't have RC installed correctly. So before you reinstall, look in GameData and delete RealChute-master if it is there. Do not try to rename it or otherwise salvage it. Just delete that folder outright. Then install using only the file downloaded from the link I gave you above)

Edited by Starwaster

Share this post


Link to post
Share on other sites
16 hours ago, Bob810 said:

Same problem.

I have icon at space center not at building assembly

https://ibb.co/nBtVpU

https://ibb.co/kqTYb9

 

As Starwaster pointed out earlier, you had downloaded the source of RealChute, not the mod.

Can you confirm that you have downloaded the mod correctly by giving us logs again and a screenshot of your GameData folder?

Share this post


Link to post
Share on other sites
7 hours ago, stupid_chris said:

Something something, partcategorizer. Probably.

Yeah, that's it exactly. Looks like a fix for the localizer stopped working in 1.4.5

Probably choking on AddCustomSubcategoryFilter on line 44 because of filterByFunction coming up null on 42.

https://github.com/StupidChris/RealChute/blob/5b360b37f549c6047d489aa4b4d214860eca44e3/RealChute/RCToolbarManager.cs#L42-L44

Should have a fix for it sometime today depending on finding time to poke at it some more.

@Bob810 two workarounds possible until this is fixed. The obvious one being switch to english. OR... click on the arrow in the upper left in the editor (Activer le mode avancé) then look for Filtrer par Module (looks like a jigsaw puzzle piece) and look for Procedural Chute or Real Chute in the column of purple buttons. Its icon will be a question mark and the name of the module appears when you mouse over them. (they're in alphabetical order so it's not TOO hard to find)

Share this post


Link to post
Share on other sites

So, right in the middle of testing my fix ... in my actual main KSP installation and suddenly it updates to KSP 1.5

Well, I think I have it fixed and as soon as I can actually verify that I'll get something pushed out for 1.4.5 ... with 1.5 probably tomorrow.

Share this post


Link to post
Share on other sites

Updated to fix the missing chutes when using non-english localizations in KSP 1.4.5

https://github.com/StupidChris/RealChute/releases/tag/v1.4.7

Problem is that looking up the button's by their localized names doesn't work anymore. However, just passing in the localized text name does. (i.e. just "#autoLOC_453705" as the lookup key instead of running it through the Localizer formatter first)

IF YOU ARE USING ENGLISH AS YOUR CONFIGURED KSP LANGUAGE YOU DO NOT NEED THIS UPDATE

Share this post


Link to post
Share on other sites

Game updated to 1.5 and realchute is no longer compatible. Chute tab is gone, and I can't even find the stock parachutes now. A craft I had built previously has a realchute stack in it but it's not configurable any longer. I'm getting a bunch of warnings/incompatibilty entries at startup. Looks like I'm going to have to wait a bit for some mod catch ups.

Share this post


Link to post
Share on other sites
17 minutes ago, MikeO89 said:

Game updated to 1.5 and realchute is no longer compatible. Chute tab is gone, and I can't even find the stock parachutes now. A craft I had built previously has a realchute stack in it but it's not configurable any longer. I'm getting a bunch of warnings/incompatibilty entries at startup. Looks like I'm going to have to wait a bit for some mod catch ups.

And that will always be the case anytime there is a major/minor version number change or Unity version change. Real Chute will automagically disable itself if any of those checks fail. This is hard coded into the plugin and it will not function.

As soon as I get chance to reset and recompile against the new KSP binaries and successfully run it through its paces there will be an official update. (unless of course Stupid_Chris gets to it first)

Edited by Starwaster

Share this post


Link to post
Share on other sites
6 minutes ago, Starwaster said:

And that will always be the case anytime there is a major/minor version number change or Unity version change. Real Chute will automagically disable itself if any of those checks fail.

As soon as I get chance to reset and recompile against the new KSP binaries and successfully run it through its paces there will be an official update. (unless of course Stupid_Chris gets to it first)

Is there any way to manually override this function for the time being? Or is it hard-coded into the .dll?

Share this post


Link to post
Share on other sites
12 minutes ago, MaverickSawyer said:

Is there any way to manually override this function for the time being? Or is it hard-coded into the .dll?

Hard coded.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.