RoverDude

[1.3] Karbonite Plus (K+) - A Karbonite Expansion!

Recommended Posts

Hi, the last release of this mod is for KSP 1.41. It's KSP 1.6 now, are you planning to contine support?

Thank you.

Share this post


Link to post
Share on other sites

How do i power the karborundrum engine?? I dont see a fuel tank for it.

Share this post


Link to post
Share on other sites

I want to convert Karbonite into LFO. Which part should I use for that? Tried the BSP-250 Karbonite Converter, but it offers no additional info, and has no options at all (except the default like Change Name Tag, Autostruts etc.)

Share this post


Link to post
Share on other sites

I think I am having a similar problem to what infinite_monkey is describing above me. Although I am having it with the advanced particle collector instead of the karbonite converters. I'm not getting any of the special buttons needed to open karbonite/karborundum collection on the APC. I've checked the config files for the part itself, but I didn't see anything that was obviously out of place.

I've been flying out to the karborundum band, save editing, and then flying back. So I'm not really hurting for Karborundum, but I reckon it might be a bug since it seems to be in the same vein as what infinite_monkey described.

And lastly, your mod-suite is nothing short of amazing. I can't imagine playing KSP without the MKS mods these days. Thanks for allowing me to live out my Elon Musk e-cosplaying fetish. Duna will be mine!

Share this post


Link to post
Share on other sites
23 hours ago, infinite_monkey said:

I want to convert Karbonite into LFO. Which part should I use for that? Tried the BSP-250 Karbonite Converter, but it offers no additional info, and has no options at all (except the default like Change Name Tag, Autostruts etc.)

@infinite_monkey and @Jvj, I see the same problem with some of the resource harvesters and converters not working with Karbonite.  I poked around in the error logs and found errors showing modules ModuleResourceConverter_USI and ModuleResourceHarvester_USI not found.  After looking at MKS, it looks like they were renamed to be USI_Converter and USI_Harvester.  I did some editing on the .cfg files to test this and that appears to be the problem.  I'm going to report this issue over on GitHub but leaving this here if others have this problem.

  • Like 3

Share this post


Link to post
Share on other sites

I'll have a patch release tomorrow, new PC and have to load a few things

  • Like 3

Share this post


Link to post
Share on other sites
On 2/10/2019 at 4:30 PM, atomicfury said:

@infinite_monkey and @Jvj, I see the same problem with some of the resource harvesters and converters not working with Karbonite.  I poked around in the error logs and found errors showing modules ModuleResourceConverter_USI and ModuleResourceHarvester_USI not found.  After looking at MKS, it looks like they were renamed to be USI_Converter and USI_Harvester.  I did some editing on the .cfg files to test this and that appears to be the problem.  I'm going to report this issue over on GitHub but leaving this here if others have this problem.

i actually posted about that issue over in the asteroid recycling thread, i made patches for all the usi mods and have just been playing like that. i was debating posting those here, but i suppose if theres a patch being released tomorrow there wouldn't be much point.

Share this post


Link to post
Share on other sites

@RoverDudeOk thanks and 

CKan says that mks is not in 1.6 is it updated to 1.6 for ckan

Edited by kbar12
Autocorrect change to something

Share this post


Link to post
Share on other sites
1 hour ago, kbar12 said:

how do I fix it

Do you have 1.6.1 installed? Is compatibility setting in CKAN for 1.6 enabled? (Settings -> Compatible KSP Versions)

On 2/11/2019 at 11:13 AM, RoverDude said:

I'll have a patch release tomorrow, new PC and have to load a few things

Is there still something missing in the develop branch or could I just use that one?

Share this post


Link to post
Share on other sites
1 hour ago, kbar12 said:

@infinite_monkey how do I get 1.6 and I do not see 1.6 in the CKAN settings

I mean KSP 1.6.1. Usually, CKAN should autodetect the current KSP version. If there is an update, it asks you to check the compatible versions you want to look for.

If I remember correctly, you can't see 1.6 if your KSP installation is still 1.5. Maybe you need to get the newest version of CKAN (1.25.4) as well? If it doesn't help, please make a screenshot of what you get - Title bar, Karbonite version in the main window, plus the settings window. Should look like this:

C3i6qno.png

Share this post


Link to post
Share on other sites

Ok ya my CKAN dose not have that option so I will try and get the new one but do I need to delete the CKAN files and uninstall the mods before I get the new version

Share this post


Link to post
Share on other sites
On 2/11/2019 at 5:13 AM, RoverDude said:

I'll have a patch release tomorrow, new PC and have to load a few things

Has the configs been patched? CKAN hasn't had a update for me yet this week...  I am also having a converter issue Been trying to go through all the cfg files to fix myself and every time i get back into the game its still not giving me convert options anywhere even trying to do as mentioned above..

 

Edited by BruteMan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now