pjf

[1.2.2] Realistic Progression Zero (RP-0) - Lightweight RealismOverhaul career v0.53 June 12

Recommended Posts

6 hours ago, Maxsimal said:

I assume you mean 'have plans' and not 'got planes'

Thanks! My English is worse, but i'm practice. Thank you for correction. 

Share this post


Link to post
Share on other sites
2 hours ago, KOCTROTTAJI said:

Thanks! My English is worse, but i'm practice. Thank you for correction. 

No worries.  A bunch of us are waiting eagerly for it all to work again in 1.1 :)

Share this post


Link to post
Share on other sites

 

I am running the 1.0.5 version on my 1.1.2 KPS install. But its pretty much a mess. It is playable, but overall the ballance is out of the window and bugs here and there... I consider it just as a training for myself in RSS/RO untill the real RP-0 career starts again with an official 1.1 update from the devs. :)

 

Edited by TrooperCooper

Share this post


Link to post
Share on other sites

v0.48 for KSP 1.1.2

Note: This update is, as far as I am aware, save-compatible with careers in RP-0 0.47 / KSP 1.0.5. It is intentionally so, and therefore does not include the save-braking major changes we would like to do; please stay tuned.

Thanks to our contributors Raidernick, awang, stratochief, SirKeplan, chrisl, Zarbizaure, pjf, Ravenchant, Agathorn, and Veskenapper!

  • Improve support for Raidernick parts.
  • Sanify body science multipliers and altitude thresholds.
  • Allow Mercury Flyby contract to occur earlier.
  • Change KCT starting points in sandbox since our points are linear.
  • Fix some Station contract issues.
  • Support Tantares Venera parts, further Tantares fixes.
  • Tweak stock satellite part-requirement chances, fix a typo.
  • Update engine costs a bit (more to come).
  • Tweak proc part costs upward a bit to better represent stage costs.
  • Support Forgotten Real Engines Viking and Vega and RD-843 parts.
  • Moved all LEO-rated heat shields to survivability node.
  • Sanify FASA<->stock LR79 stats.
  • Fix an issue with the Lunar Landing Repeat contract.
  • Place RD-57 and M-1
  • Fix funny or duplicate placement of Soyuz PAO parts.
  • Add more science reports!
  • Update Custom Barn Kit syntax to latest version
  • Use Tier 3 Runway model for all tiers to avoid pothole runways.
  • Support RO v11's new Titan GLV upper stage.
  • Update to KSP 1.1.2!
  • Include a version file.

Share this post


Link to post
Share on other sites

Now it's 1.2.2? Darn, I envy all those time travelling modders!

Share this post


Link to post
Share on other sites

For real tho, thanks for the update, you - and also all other modders keeping this humongous project together - are doing  awesome work! <3

Edited by Temeter

Share this post


Link to post
Share on other sites
2 minutes ago, liveseaandsky said:

v0.48 is on CKAN but it says it is only compatible up to KSP 1.0.5.

Wait for the bot run - assuming it's set up properly. Give it a few hours. :)

Share this post


Link to post
Share on other sites

How are you updating your mods so fast? HOW??  I wasnt expecting to start new RO-RSS-RP-0 campaing till fall, and its out now!! 

 

Thank you so much!!!

Share this post


Link to post
Share on other sites
3 hours ago, NathanKell said:

Use Tier 3 Runway model for all tiers to avoid pothole runways.

You sir, are a god.

Share this post


Link to post
Share on other sites

Or just don't use the runway at all like me, because I am too stupid to build planes in FAR and lack the will to really dig into it.

Share this post


Link to post
Share on other sites

First time playing RP-0 and I got parts of the very first tech node together to make this:

zQhhZSh.png

You can't imagine how proud I am right now. :D

Share this post


Link to post
Share on other sites
6 hours ago, coco146 said:

Can someone please explain to me why I can't remove this quote and am unable to type inside anything other than said quote???? no matter how much I refresh or go to a different web page or navigate around the site, I am left only able to type inside this quote which refuses to disappear....

^That right there was incredible weird and annoying, I think I'll have to report that as a forum glitch...^

anyway, on to the post I was trying to make! 

For some reason since installing this and its dependencies to my Realism Overhaul game I am unable to launch vessels, they just spin around from crazy phantom forces and the debug log looks like this: 

tumblr_o6yizewHyA1r0o48lo1_1280.png

 

The output log is here:

https://www.dropbox.com/s/v8m7daj17p64r8d/output_log.txt?dl=0

It looks like Ferram and RealHeat (Mostly RealHeat) are throwing a lot of exceptions... I have no idea what is going on though I've never had this before, the ships just zip around from phantom forces and the Kraken noise is made.

 

EDIT: Ok removing Ferram completely fixed the problem, I am now going to try to redownload and add Ferram to see if it breaks again or just works fine.

Edited by Squiggsy

Share this post


Link to post
Share on other sites
48 minutes ago, Squiggsy said:

For some reason since installing this and its dependencies to my Realism Overhaul game I am unable to launch vessels, they just spin around from crazy phantom forces and the debug log looks like this: 

I have no idea whats going on but this value tA is equal to Pi. Interesting

I had a similar bug with FAR recently where my capsule just got no aerodynamic forces applied on reentry. FAR flight data just said 0 for all forces. That caused the capsule to hit the water at orbital speeds. I had the 2m lunar rated heatshiel attached. I feel like I have heard of this bug before but can't find it. But 1.1 might fix it anyway. Does anyone know what can be done about it?

By the way how do you get images into the post?

And finally thank you all so much for your hard work and Update for 1.1!

Edited by Warp11

Share this post


Link to post
Share on other sites

Just a small issue - on the 1st page asteroid day is stated as a requirement, wasn't it incorporated into 1.1? Awesome work, now we'll have to wait just for RVE :) Do you even sleep @NathanKell?

Share this post


Link to post
Share on other sites
2 hours ago, quarrion said:

now we'll have to wait just for RVE

You could install SVE, just change the names from the Kerbin/Mun/Duna folders to Earth/Moon/Mars and go into the clouds file and do the same here. You should be able to get your planets looking beautiful, even without RVE. I did this and I'm very happy with the result.

Share this post


Link to post
Share on other sites
2 hours ago, quarrion said:

Just a small issue - on the 1st page asteroid day is stated as a requirement, wasn't it incorporated into 1.1? Awesome work, now we'll have to wait just for RVE :) Do you even sleep @NathanKell?

Don't quote me on it, but I think the antenna and probe core were included into stock in release 1.1. I am sure RP-0 doesn't need the only part which wasn't included, the telescope.

Share this post


Link to post
Share on other sites

@SpaceEnthusiast... What will basilcally come down to porting RVE port to stock system back to RSS :wink: Did you have any problems with cloud  heights/city textures?
PS I ported RVE to 1.12 by using @Rhavoreth solution, but i get lots of Nullrereference from citylights

@Three_Pounds Yeah, Rp-0 is working correctly without this. Still, asteroid day hasn't updated for 1.1, and probably won't be:

 

Share this post


Link to post
Share on other sites

Final piece of the puzzle! (others being RSS and RO)

Now aggressively updating CKAN...

Share this post


Link to post
Share on other sites

Whatever works :P I always delete the city light, personally I don't think they look so good. I also increased the height of the clouds, other than that, works perfectly.

http://imgur.com/0MkT93q

This is what it looks like (all highest res packs).

Edited by SpaceEnthusiast

Share this post


Link to post
Share on other sites
6 hours ago, liveseaandsky said:

v0.48 is on CKAN but it says it is only compatible up to KSP 1.0.5.

Which is why I installed it. It works with 1.0.5 but some things are brocken, e.g. there is no control limit on probe cores anymore. I hope I can downgrade without trouble,

Awesome. So RP-0 is now "up to date" so to speak, but not all requirements, suggestions and recommendation are - right?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.