Jump to content

KSP 2 and Proton

Recommended Posts

Ubuntu 22.10


AMD Ryzen 5 1600 12 core

NVIDIA GeForce RTX 3060

I got the game running, but not out of the box.

Ran directly the KSP2_x64.exe from the steam install directory,  using Wine. It skips the useless launcher.

Also tried your suggestions with steam and PROTON_USE_WINED3D=1 . It also ran, can´t see a difference from using Wine directly.

I can't use the runway as it appears underground. Videos don't show. I have no clouds. Quite frequently the Kraken shows up, had to make some restarts.

Nevertheless, I already managed to land on the Mun and get back to Kerbin!

It runs on Linux from day 1, I feel happy !

Link to comment
Share on other sites

I have also been able to get it to run on steam deck.

Using proton experimental, and the PROTON_USE_WINED3D environment variable. I've been able to launch with the eval launch option that lets you skip the launcher. It kept crashing when loading a campaign until I increased the swap file size to 8gb and that's what finally allowed it to run decently.


Hopefully performance will improve with updates!

Link to comment
Share on other sites

I only tried with proton-ge 7.49 and it worked. I'm always using the following commands though:

mangohud RADV_PERFTEST=aco DXVK_ASYNC=1 gamemoderun %command%

Later I changed the launched option for the following in order to remove the PD Launcher:

eval $( echo "mangohud RADV_PERFTEST=aco DXVK_ASYNC=1 gamemoderun %command%" | sed "s/PDLauncher\/LauncherPatcher.exe'.*/KSP2_x64.exe'/" )

Worked as well.

                   -`                    thomot512@amdBuild 
                  .o+`                   ------------------ 
                 `ooo/                   OS: Arch Linux x86_64 
                `+oooo:                  Kernel: 6.1.12-arch1-1 
               `+oooooo:                 Uptime: 9 hours, 9 mins 
               -+oooooo+:                Packages: 959 (pacman) 
             `/:-:++oooo+:               Shell: zsh 5.9 
            `/++++/+++++++:              Resolution: 5120x1440 
           `/++++++++++++++:             DE: Plasma 5.27.1 
          `/+++ooooooooooooo/`           WM: kwin 
         ./ooosssso++osssssso+`          Theme: [Plasma], Adwaita [GTK3] 
        .oossssso-````/ossssss+`         Icons: [Plasma], Adwaita [GTK3] 
       -osssssso.      :ssssssso.        Terminal: konsole 
      :osssssss/        osssso+++.       CPU: AMD Ryzen 5 7600X (12) @ 4.700GHz 
     /ossssssss/        +ssssooo/-       GPU: AMD ATI Radeon RX 7900 XT/7900 XTX 
   `/ossssso+/:-        -:/+osssso+-     GPU: AMD ATI 6c:00.0 Raphael 
  `+sso+:-`                 `.-/+oso:    Memory: 8286MiB / 31234MiB 
 `++:.                           `-/+/
 .`                                 `/                           

I'm using a Wayland session.

Link to comment
Share on other sites

It's probably not worth posting this, but the game is almost playable on my Dell XPS 13 (9360).

I'm launching it with a shell script:



export W="/home/$USER/snap/steam/common/.local/share/Steam/steamapps/common/Proton - Experimental/files"
export PATH=$W/bin:$PATH
export WINESERVER=$W/bin/wineserver
export WINELOADER=$W/bin/wine
export WINEDLLPATH=$W/lib/wine/fakedlls
export WINEPREFIX=/media/$USER/death_star_plans/SteamLibrary/steamapps/compatdata/954850/pfx


cd "/media/$USER/death_star_plans/SteamLibrary/steamapps/common/Kerbal Space Program 2"

wine64 KSP2_x64.exe

My steam library is, as you can see, on an SD card, so you'll have to adjust it if you want to use the script.

As you can see, I'm running the snap package in Ubuntu. The graphics card is a Intel UHD Graphics 620 Mobile.

I've managed to get a stock ship into orbit, but the control response is a little too realistic in that there's a second or two of delay between input and some kind of response by the craft. The UI on the other hand is pretty responsive, so go figure.

Oh, and of course I turned down all of the graphics effects as far as they will go.

Link to comment
Share on other sites

4 hours ago, Khesperus said:

I've managed to get a stock ship into orbit, but the control response is a little too realistic in that there's a second or two of delay between input and some kind of response by the craft. The UI on the other hand is pretty responsive, so go figure.

What I noticed is that when I push a control key for a long time it fills up some cache, and until that cache runs out, any keypresses are ignored. Due to the 10-12 fps this results overcorrections very quickly. I'll try to make a video so i can report it as a bug.

Link to comment
Share on other sites

Super Potato
Ubuntu 22.04
16 Gb DDR3
GTX1650 (so below minimum game spec)
Proton experimental

The game runs but only at 2 fps on the launchpad with the Stock Kerbal K-1 and all graphics settings on low.
Dual boot to Windows 10 on the same PC, same conditions and I am getting 12-15 fps so barely playable on this hardware anyway.

I am encouraged by the fact that it already runs (even though unplayable) under Linux at all

Link to comment
Share on other sites

I got KSP2 running including its Launcher out-of-box with Proton - Experimental under Fedora 37. While I had 220 fps on main menu, I got only 6-9 fps on launchpad.

But I somehow was able to snap something inside KSP2 after switching off/on v-sync or changing Fullscreen to Borderless window. Then fps got raised to 20 fps at launch pad and kept performing well till next crash. Which happened during re-entry after attempt to eject from pod around 10000 m above ground after my only chute was torn by aero-forces.

Snapping into reasonable performance probably occurred after turning on v-sync. Unfortunately, I have not been able to replicate that ever since.

PROTON_USER_WINED3D="1" Does not make any difference for me.
I am running KSP2 just with command: "PROTON_LOG=1 %command%"
Fedora 37 (wayland), Proton experimental, Ryzen 5600G, 16 GB RAM, Geforce 3060 GTX

Link to comment
Share on other sites

| NVIDIA-SMI 525.89.02    Driver Version: 525.89.02    CUDA Version: 12.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| 30%   55C    P0    60W / 170W |   7610MiB /  8192MiB |    100%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      2258      G   /usr/bin/gnome-shell              159MiB |
|    0   N/A  N/A      3683      G   /usr/bin/Xwayland                  13MiB |
|    0   N/A  N/A      3728      G   ...gl=desktop --shared-files       58MiB |
|    0   N/A  N/A      4529      G   /usr/lib64/firefox/firefox        167MiB |
|    0   N/A  N/A     10066      G   ...e/Steam/ubuntu12_32/steam        9MiB |
|    0   N/A  N/A     10984    C+G   ...ce Program 2\KSP2_x64.exe     7130MiB |

Guess what! 9 fps or not, its not being dragged down by graphics! Geforce utilization is merely 30%!!! Why! Its not fuel system either, I got that with only Kerbal swimming at sea!

Link to comment
Share on other sites

Okay, I have to admit I have been wrong. Either DXVK_HUD=full and nvidia-smi dmon shows that bottleneck is indeed graphics:
nvidia-smi dmon shows SM utilization to 100% (main menu was giving about 30% load):

    0     51     55      -    19      8      0      0   7500   1560 
    0     41     54      -    15      7      0      0   7500   1807 
    0     35     53      -     0      0      0      0   7500   1807 
    0     32     54      -   100     28      0      0   7500   1777 
    0     51     54      -     3      2      0      0   7500   1935 
    0     42     53      -    41      1      0      0   7500   1935 
    0     62     57      -   100     11      0      0   7500   1935 
    0     66     57      -   100      9      0      0   7500   1935 
    0     71     57      -   100      7      0      0   7500   1935 
    0     72     57      -   100      9      0      0   7500   1935 
    0     71     57      -   100      9      0      0   7500   1935 
# gpu   pwr gtemp mtemp    sm   mem   enc   dec  mclk  pclk
# Idx     W     C     C     %     %     %     %   MHz   MHz
    0     70     57      -   100      7      0      0   7500   1935 
    0     70     58      -   100      7      0      0   7500   1935 


Link to comment
Share on other sites

For me PROTON_USE_WINED3D=1 does make a huge difference.

However it causes almost all the terrain except the ocean and the KSC area disappear. So at least for me this not really a fix but simply triggers a bug in wined3d and since no ground is rendered the FPS are better.

I am on AMD, so maybe this only makes a difference on AMD cards.


Furthermore I have noticed that my FPS differ wildly in the exact same situations. In an empty VAB i sometimes get around 10 FPS. But sometimes also 20 or 25. And this doesn't really change if there is a vehicle or not. At least for the stock planes and rockets. I tried to reproduce it by changing back and forth between different game screens but could not really find a reason why I sometimes get 10 FPS in an empty VAB and sometimes 25.

Edited by running_bird
Link to comment
Share on other sites

I got something! When my FPS dramatically drops, the KSP2 keeps doing excessive PCIE transfers! Does that 7% memory numbers look as bad as I imagine?

$nvidia-smi dmon -s tu
# gpu rxpci txpci    sm   mem   enc   dec
# Idx  MB/s  MB/s     %     %     %     %
    0  11075   8424    100      6      0      0 
    0  10799   8688    100      7      0      0 
    0  10230   8493    100      6      0      0 
    0   9352   6909    100      7      0      0 
Link to comment
Share on other sites

I finished my first Mun landing. And the FPS did completely change after reloading a save where I was in a low Mun orbit.

I easily get around 50 FPS. If i have the same ship on the KSC launchpad I get around 7-15 FPS. However I did a restart of the game due to some bugs. Before the restart the FPS around the Mun was also quite bad.

I think there is something funky going on around KSC or Kerbin or planets with atmosphere. If I go to the Mun, save, restart the game and load the save the FPS are MUCH better.

But I have to load the save directly from the Mun. If I go to KSC and back to the Mun the FPS are bad again.

Edited by running_bird
Link to comment
Share on other sites

The FPS drop is likely related to amount of Video RAM. A guy with 3060 12 GB is running just fine, but I with 3060 8 GB am running only ~9 fps on kerbin. Are clouds causing the behaviour? It was reported the problem does not manifest if you load a save in space until you get back to kerbin...
As a matter of fact, we found that the difference with my computer running ~9 fps and the other guy's computer running >20fps may be actually PCIe 3.0 vs PCIe 4.0 capable CPU!
Can anyone confirm something similar from AMD graphics, please?


Edited by tuzok
Link to comment
Share on other sites

Given That I've apparently made a personal specialty of making every conceivable mistake, I thought I would help others spare some time

For context, I got KSP2 running (extremely poorly) on my steamdeck, And given that I'm on a metered connection, I tried transferring the game to my Laptop + eGPU (Arch Linux) setup, without success.

  • First of all, if the game doesn't load *at all* after the splashscreens, and simply displays a grey screen, verify the integrity of your files. The game doesn't even find the appropriate files to load and eventually crash.
  • Second, The game kept crashing at "Pumping Sim Once" when creating a new campaign, a recurring error on forums. After reducing the game resolution and more importantly increase my swap size* to 12G to compensate for my 8G of RAM, I was able to play. It's quite obvious when the game starts loading stuff into swap, given that the loading dramatically slows down.

I believe that contrary to what a lot of people say about VRAM, right now the biggest hurdle is actually RAM


  • Model: Thinkpad x380 yoga
  • CPU: i5-8250U
  • RAM: 8G
  • GPU: RX 6600XT as a eGPU with ADT-link
  • OS: ArchLinux

* https://www.protondb.com/app/954850#IK8EWgLSbJ

sudo swapoff -a #disable current swap
fallocate -l 12G ~/swapfile # create a 12G file on home directory
chmod 600 ~/swapfile # change file permissions
mkswap ~/swapfile # make it swappy (create swap)
sudo swapon ~/swapfile # enable swap


Link to comment
Share on other sites

After bypassing the PD launcher and adding the wine3d argument, It worked similar to what I've seen on windows. Only problems were performance issues in KSC, VAB, and in flight, where I got ~10fps on a 1650 mobile at 900p (fedora 37). In the map view, everything seemed like 60+ fps! After the performance issues are sorted out, I'm hoping for up to 45fps in orbit and 35fps at KSC/VAB/launchpad. I will use KSP1 until a performance patch comes out though.


EDIT: Specs:  GTX 1650 mobile gddr6, i5 11400h, 16gb 2x8 ddr4 3200mhz, Proton GE. 7.42

Edited by 737
Link to comment
Share on other sites

  • 2 weeks later...

New PC 
KSP2 made me finally do it.

Ryzen 5 5600
32 GB DDR4-3600
AMD RX6700 10Gb
Kubuntu 22.04

Proton Experimental
Launch Options:  none

18-25 FPS around the launchpad and up to 60 FPS in space.

 For some reason Mods / BepInEx / SpaceWarp etc., are not loading when using Proton



Edited by Kaa253
Link to solution
Link to comment
Share on other sites

i run on a new-ish high end system, fedora 37, steam, proton, no changes made by me

worked out of the box, of course with tons of bugs.

with a simple rocket 4k highest settings seems well playable, once you get away from ksp it is perfect.

16gb vram amd and amd threadripper, 3 digits of ddr4 ram, quad channel

however large complex rockets make the game unplayable fps wise. i'm not an engineer, but the game does seem to use a fraction of what the hardware could provide. that was before the patch. a little better after the patch, not very much yet.


the worst of the worst is a bug that persisted from before the patch and got 1000 times worse with the new patch, rendering the game entirely unplayable: long press inputs such as steering a rocket completely messes up the input queue of the game engine. 5 seconds pressing left translates to 15-25 seconds of pressing left, ignoring all inputs until that now way too long steering input is completed. after that it executes all key presses one after another, from map on off on off on off to esc menu on off on off on off to time ,.,.,. but if you press right to counteract the over steer that was induced, the problem compounds and the game gets worse and worse and worse.

at some time you just watch the game seemingly played by somebody else, of course since esc is not even elevated over other key inputs in ksp2, pressing that does nothing during that time.

the very first time starting with the new patch no steering input was accepted at all. then i updated everything (os, steam, those vulkan shaders steam sometimes updates, restarting for the new kernel, opening and then closing ksp2, then finally reopening ksp2 and start testing) and now i am left with this mess i described above that makes ksp2 unusable.


i hope this gets better, it could be such a great game. btw i only do rockets. i am not interested in the planes at this time.

Link to comment
Share on other sites

I've just spent £45 on KSP2 and to say I'm majorly p****d off is understatement of the century as it flat out doesn't work!  Once purchased, I went to download it and couldn't find the link for the Linux version.  I went back to the KSP1 download just to check I wasn't going mad and discovered that where with KSP1 Windows, Linux and Mac versions are clearly listed, it KSP2 there is only a link for Windows!

The native Linux support is what initially drew me into KSP and I know that applies to a lot of people.  There was however no warning that KSP2 was missing this support, just a friendly checkout ready to take my money!

Digging around I've not found any information on when Linux support will be added.  All I've stumbled on people using "proton" to get round this and play KSP2 in Linux.  I have no idea what that is yet, how much it will cost, what setup is required etc.  I note though that this is not an out of the box solution and that with a certain amount of fiddling with proton settings, it "might" work.  One of the boxes you have to tick when purchasing the game is that you can't get a refund once you've downloaded the game.  So if I download the windows version I lose the ability to claim a refund and there is absolutely no guarantee it will work with proton.  Obviously as yet, I haven't downloaded it.

I have 2 questions.

Firstly without "proton" or any other emulator, virtual machine, or extra device, will KSP2 work with Linux?  I know Linux development can lag behind Windows development (though not that I've previously noticed with KSP) but I can't find anything to say KSP2 will be Linux compatible.  I know this is a pre-release and that may be the reason there is no current Linux download, but unless there is a definite plan to release a linux download that works natively, I'll be getting a refund and saying goodbye to KSP2.

Secondly I understand the first version of KSP2 had so many bugs that customers were refunded.  At least those customers could use it if, they discovered bugs!  What are the developers planning to do for KSP fans like me who have bought V2 only to find it is completely useless and uninstallable?

Link to comment
Share on other sites

After playing for a few days with the new patch (KSP2 v0.1.1.0), I managed to get the game going with a pretty decent performance. As far as I can read on multiple posts, the game seems to run quite like most Windows players.

With settings all at max, I'm getting around 35 fps in KSC, around 25 at the launchpad with a small rocket, 35 fps in orbit and map views. Much smoother than before.

I'm using Steam on Ubuntu 22.10, 16 GB RAM, CPU AMD Ryzen 5 1600 12 core, NVIDIA GeForce RTX 3060

Forcing Proton 7.0-6

  • I always get an error in proton Experimental stating it can't find DX11 if not using WINE3D
  • If running Proton Experimental must add PROTON_USE_WINED3D=1 in launch options to run, causing lots of terrain bugs and much slower performance.

Launch options: 

eval $( echo "LC_ALL=C PROTON_LOG=1 %command%" | sed "s/PDLauncher\/LauncherPatcher.exe'.*/KSP2_x64.exe'/" )
  • Skips the annoying launcher
  • Not using WINE3D: much better performance, clouds present, much less terrain glitches


Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...