Jump to content

Why485

Members
  • Posts

    54
  • Joined

  • Last visited

Reputation

148 Excellent

Profile Information

  • About me
    Rocketeer

Recent Profile Visitors

1,951 profile views
  1. I look at IVAs once to go "wow, they actually modeled this, that's cool" and then never look at them again. It's cool they exist, but I wouldn't miss them if parts were released without them.
  2. @Shadowmage Any word on getting this pull request merged to fix the gamma not being loaded correctly? https://github.com/shadowmage45/TUFX/pull/25
  3. I had no plumes either after updating with CKAN, but I fixed it by uninstalling Waterfall and Waterfall Restock, then re-installing it.
  4. There is an optional patch you can install from the Extras folder (it's also in CKAN if you use that) which converts all the engines to use liquid fuel instead of cryogenic fuels.
  5. TUFX already allows for some pretty spectacular shots, even with the current version of Waterfall. I'm curious how much better it can even get.
  6. Thanks for the reply! I don't think it's so much my resolution as it is that at the time I had so few things on the toolbar. Now that I have more mods installed, I can comfortably read it. It's an edge case (literally!), but maybe if the pop ups could be aligned by their right edge, it could prevent the issue from happening. The temperature readout that showed a range where the operator works nominally was really nice to have. I think this mechanic is still in place, but I didn't test in detail, so maybe it's not. Either way it's not really apparent unless you are very closely watching the power generated value on the new panel. Having a quick way to dial in reactor power was useful because you could more carefully manage a reactor to stay within the appropriate heat levels. You can still do this, but now you need to click on the reactor itself, check manual control, and then do it with that little slider instead. I also really liked being able to run the reactor at lower power levels, because it extended the life of it, though that mechanic seems to have been removed. The auto setting doesn't work as well as I'd like (e.g. not automatically going to full power when something super power hungry like an engine starts running) so I manually set the power to max myself. I really liked having that slider so easily accessible. While not needed per se, it was nice having quick options for the auto-shutdown and when auto-hibernation kicks in. A minor thing that I didn't notice until I took these screenshots: it was more intuitive that how much power the reactor was generating in the old popup since it outright said EC/s instead of kW. I kept on clicking on the reactor to see the power output that way instead. It seems that the two panels overlapping was similarly caused by having so few buttons on my toolbar. Now that I have more mods and stuff cluttering it up, they are spaced out such that I can see both at the same time. I'm not really sure how you handle that kind of edge case, but yeah. That seemed to have been the cause.
  7. I've been using it just fine. I use CKAN and made sure to not install the Scatterer Sunflare and instead use one of the Kabrams ones. I'm running KSP version 1.11.1.3066, which as far as I know is the latest.
  8. Hello, I've noticed a few UI issues appearing after installing System Heat. In addition to System Heat, I'm also using Near Future Electronics, and Near Future propulsions. After installing System Heat, I also added the Nuclear Reactor Configuration and Nuclear Engine Configuration. Here's a screenshot of my CKAN configuration so you can see what mods are installed. I'm running KSP 1.11.1.3066. When looking at the Systems Manager, the nuclear reactor doesn't seem to contribute power for these calculations. I'm not sure if there's an option I missed, but no matter what I do to the reactor I can't seem to get it to show anything more than zero. This tool is very useful for figuring out the high power-consumption engines, so this no longer working makes building require a lot more cross-checking. Worth mentioning is that during flight, this does work correctly. I run the game in 1920x1200, and when I click on the toolbar button for heat, it the values get clipped off the edge of the screen. I can click and drag the toolbar to the left to momentarily see what's on there, but as soon as I let go, it snaps back and can no longer be read. I think I'd prefer if this was a standalone window. After installing System Heat, the Reactor Control Panel that I was used to seeing from Near Future Electrics doesn't seem accessible. Instead, it's been replaced by the nuclear button on the toolbar. This one doesn't have many options or information as I recall the old toolbar having, but the biggest issue is that I cannot view the System Heat and reactor control bar at the same time. These two things are pretty heavily related, so seeing both at once is very valuable.
  9. Posting this here in case it was missed on the GitHub: https://github.com/shadowmage45/TUFX/pull/25 There is a bug where the gamma doesn't load correctly from the configs. A pull request is up to fix it. Seems it was only a missed line. I love using TUFX for taking screenshots and all-around looking awesome, and tweaking gamma is one of the most powerful settings for color correciton. This fix would be greatly appreciated!
  10. [quote name='sashan']Wow, awesome. Short question - does it work in 1.0.4? I'm holding up my update untill I'm sure all the mods in both installs would work.[/QUOTE] I don't know what happens if you try to run a mod built with the 1.0.5 dlls in an earlier version. I want to say it probably would, but I honestly don't know. [COLOR="silver"][SIZE=1]- - - Updated - - -[/SIZE][/COLOR] [quote name='Kartoffelkuchen']That's pretty cool! You can even use it for spacecrafts! [url]http://cdn.rsvlts.com/wp-content/uploads/2014/07/%E2%80%9CDragon-starting-its-journey-home.%E2%80%9D-Swanny-This-image-of-the-SpaceX-Dragon-was-taken-from-the-International-Space-Station-just-after-it-was-released-by-the-robotic-arm-on-May-18-2014.--630x630.jpg[/url][/QUOTE] I think they look really cool on space ships. In fact if you put a single white light on ships and set it to be visible from below, your ship will appear as a white dot from a distance. It works really well and I love the way it looks. Here's a ship with a white light on it. (It's on the other side of the capsule) [img]http://i.imgur.com/FiEOmwF.jpg[/img] Here it is from a distance. You can still see it as a white dot. [img]http://i.imgur.com/0NWmLXC.jpg[/img] I'm looking forward to seeing what this looks like when you put it on stations.
  11. I added a bunch of usability features to the nav lights. You can now toggle whether or not the lights are visible from below, as well as if they should have a limited viewing angle. If they do, then you can set by how much. Click the image for a gfy video. [url=http://gfycat.com/GrizzledForsakenBudgie][img]http://i.imgur.com/9Z1OakA.png[/img][/url] The basics of strobes are now in place. There's some bugs I've found related to strobes + persistence, and I've also found some weird bugs that happen with more than one craft in the scene that I need to track down. I'm not sure if switching between craft is what causes the billboards to break or if it's the simple fact that there's more than one. It's not completely consistent when they break. [img]http://i.imgur.com/yZmpLpO.gif[/img]
  12. [quote name='jlcarneiro']These nav lights look great in the demo, but they don't show up in my installation. Am I doing something wrong or are they in a different file?[/QUOTE] They're not released yet. I'm still working on them. I fixed a bunch of bugs, added a lot of UI usability improvements, and got strobe functionality working, but there's some bugs I've noticed with persistence and changing crafts. They're getting pretty close to release. I [url=http://forum.kerbalspaceprogram.com/threads/139602-WIP-1-0-5-Surface-Nav-Lights]opened another thread in the Add On Developments forum[/url] so I can post updates there rather than spamming it here. It's kind of grown into its own mod at this point. [quote name='ObsessedWithKSP']Curse updated to 1.2.2, waiting for approval.[/QUOTE] Thanks again for keeping it up to date!
  13. This started as an extension of my Surface Lights mod, but it's starting to grow into its own thing. I've never been too happy with the nav light mods that are out there, so I started working on my own. The big difference between these and all others is that the lights actually glow (using a custom billboard). This means that I can scale them with distance so that you can still see nav lights from afar like you should be able to. The current ones are just lights, which doesn't do you any good when you barely see the plane anyway. There's still a bunch of functionality left to add like blinking and bunch of usability stuff, but I'm really happy that the core of it is working great. Here's a video of it in action. http://gfycat.com/ScaryClearBobwhite Here's a fancy Imgur album, but you'll need to look at the album on Imgur to be able to really see it. Today I fixed some bugs related to the external camera and got the limited angles working correctly. I've added values so that nav lights (and in the future, strobes) can have limited angles. I'm surprised that no flight sims seem to model this, but depending on the angle of the plane, there are certain lights you shouldn't see. For example, from the front you should see only the red and green, but no rear white. If they are flying right to left, you should see red. If they are flying left to right, you should see green. If they are head on, you should see both colors. Here's a video http://gfycat.com/ElatedIllegalKestrel It's a bit hard to see in a small webm due to compression. It's much more visible ingame and in screenshots.
  14. Update on the nav lights. I've added values so that nav lights (and in the future strobes) can have limited angles. I'm surprised that no flight sims seem to model this, but depending on the angle of the plane, there are certain lights you shouldn't see. For example, from the front you should see only the red and green, but no rear white. If they are flying right to left, you should see red. If they are flying left to right, you should see green. If they are head on, you should see both colors. Here's a video http://gfycat.com/ElatedIllegalKestrel It's a bit hard to see in a small webm due to compression. It's much more visible ingame and in screenshots.
  15. FYI, there's a bug where if you load a saved vessel in the editor, it won't load the saved color of the surface lights. I'm working on a fix for that right now. - - - Updated - - - That bug has now been fixed and the download on Kerbal Stuff is now updated to 1.2.2.
×
×
  • Create New...