Jump to content

[1.9+] ModularFlightIntegrator 1.2.7 (19 October 2019)


Recommended Posts

Having an issue using MFI with FAR for a realism overhaul game in 1.8. I launch a vessel, and after a few seconds or around 150m/s i lose control. The F3 log shows that the root part has been ripped off due to airflow. Weird as the root part remains connected and its right-click menu remains accessible. However, physics just kinda stops. My altiude is locked, my speed is 0, the apoapsis increases rapidly. There is a repeated log spam of:

Spoiler

[ERR 21:32:20.805] TimingFI threw during Update: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
  at System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) [0x00029] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at System.ThrowHelper.ThrowArgumentOutOfRangeException () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at FlightIntegrator.UpdateOcclusionSolar () [0x00220] in <9d71e4043e394d78a6cf9193ad011698>:0
  at FlightIntegrator.UpdateOcclusion (System.Boolean all) [0x00069] in <9d71e4043e394d78a6cf9193ad011698>:0
  at ModularFI.ModularFlightIntegrator.UpdateOcclusion (System.Boolean all) [0x00007] in <1a5eb41924ae4dfca6d5042557592b79>:0
  at FlightIntegrator.Update () [0x0007a] in <9d71e4043e394d78a6cf9193ad011698>:0
  at ModularFI.ModularFlightIntegrator.TimedUpdate () [0x0000e] in <1a5eb41924ae4dfca6d5042557592b79>:0
  at (wrapper delegate-invoke) <Module>.invoke_void()
  at TimingFI.Update () [0x00023] in <9d71e4043e394d78a6cf9193ad011698>:0

Any help would be amazing. I will add, this kinda started ever since I edditted a physics config file in RealismOverhaul. It was setting kerbal crew mass to 0.1 and was responsible for lots of parts in my save having negative mass if they were attached to the root part. Somehow feels relevant in this issue.

Here's my game log

Q

Link to post
Share on other sites
1 hour ago, Qwarkk said:

Having an issue using MFI with FAR

MFI by itself does nothing. If something breaks then it is a mod that uses MFI. The code that generate the error in your game is even stock KSP code. 

I am really unsure how I could help here

Link to post
Share on other sites
1 hour ago, sarbian said:

MFI by itself does nothing. If something breaks then it is a mod that uses MFI. The code that generate the error in your game is even stock KSP code. 

I am really unsure how I could help here

Ok, you have helped by narrowing my issue down. I think either FAR or RO are potential causes, I’ll post there. Thank you!

Q

Link to post
Share on other sites
  • 2 months later...
  • 3 months later...
  • 3 weeks later...
  • 3 weeks later...

anyone help me i get a bug after i install Kopernicus and ModularFlightIntegrator ,it said i can't get EVA because i didn't upgrade Astronaut Complex yet but my game is science mode . i thing issuse with because when i uninstall MFI everything normal

sorry for my bad english 

Link to post
Share on other sites
  • 1 month later...

Dear Sarbian, I've got a guy who got AtmosphereAutopilot broken by MFI 1.2.8 (I reproduced myself as well), apparently by this commit
I do not understand the exact reason why the control is borked, but I have a pretty strong gut feeling that the stock update order is broken by it. Control/model artifacts I see suggest that the old schedule of physics update:
Control input taken from input devices and written to vessel's control state -> onPreAutopilot/onAutopilot/onPost.../onFlyByWire -> control surface module applies the actuation -> aerodynamics forces are applied -> Unity PhysX Update
is violated by new MFI.

Edited by Boris-Barboris
removed log
Link to post
Share on other sites
1 hour ago, Boris-Barboris said:

Dear Sarbian, I've got a guy who got AtmosphereAutopilot broken by MFI 1.2.8, apparently by this commit
I do not understand the exact reason why the control is borked, but I have a pretty strong gut feeling that the stock update order is broken by it. Control/model artifacts I see suggest that the old schedule of physics update:
Control input taken from input devices and written to vessel's control state -> onPreAutopilot/onAutopilot/onPost.../onFlyByWire -> control surface module applies the actuation -> aerodynamics forces are applied -> Unity PhysX Update
is violated by new MFI.

Log (I see nothing susspicious):  KSP.log

Strange. I tested the change and using DefaultExecutionOrder did execute the call at the right timing. I will test again...

Link to post
Share on other sites
1 minute ago, sarbian said:

Strange. I tested the change and using DefaultExecutionOrder did execute the call at the right timing. I will test again...

It may execute in time but change something in the stock module/gameobject ordering. Could the number "8" be occupied by something?

Link to post
Share on other sites
Just now, Boris-Barboris said:

works on my machine

Great, sorry for the stupid mistake. That freaking COVID killed my brain...

Link to post
Share on other sites

Good morning. I seem to have a version of this mod all over my installations - looks like due to Kopernicus. Do you recommend updating bundled installations with this latest build? 

58 minutes ago, sarbian said:

That freaking COVID killed my brain...

We're all in the same boat, so everyone understands. Thank you for hanging in there and working on this.

Link to post
Share on other sites
1 minute ago, OrbitalManeuvers said:

Good morning. I seem to have a version of this mod all over my installations - looks like due to Kopernicus. Do you recommend updating bundled installations with this latest build? 

Yes, I do. Kopernicus bundled a modified version to fix a problem they thought was in MFI, but they reverted that. You can use my version

Link to post
Share on other sites
7 minutes ago, sarbian said:

Yes, I do. Kopernicus bundled a modified version to fix a problem they thought was in MFI, but they reverted that. You can use my version

OK, will do. I have 11 installs that have (had) version 1.2.7 or 1.2.7.1.  :)  

Link to post
Share on other sites

Just FYI, Kopernicus is updating the bundles in latest releases, but you can always update manually.  Sarbian's mainline is all we use now.

Edited by R-T-B
Link to post
Share on other sites
  • 2 weeks later...

Reposting my comment on BDB to here since this mainly concerns MFI Sarbian. 
 

Quote

I semi take it back :(. It's mostly resolved, at least on BDBs end of the woods. 

Long time lurker and veteran KSP user here that hasn't bothered posting in a long long time :P

A fascinating issue really, one that I believe combines the previously recorded mass bug and how FAR & Modular Flight Integrator handle drag. 

Public service announcement! Latest BDB Github master works fine with 1.11.1 providing you stay BELOW version 1.2.8.0 of MFI (KSP ver 1.10), assuming of course you are running it. 

Using a recent version of MFI reintroduces our funky mass issue BUT only in atmosphere where there is appreciable aerodynamic drag. 

Launching an LV-3 Atlas with MFI 1.2.9.0 and 1.2.8.0 I observed that calculated surface TWR would proceed as expected, however upon a velocity of greater then 60ms-1 things start getting weird.  Upon a 3.3 TWR which is usually where the skirt will jettison with the given payload, the vessel is only under 1.6gs of thrust. Testing in vacuum however shows all expected values. Also an interesting issue is a pseudo dynamic pressure spike at around 7,700m, almost as if the expected mach 1.0 speed hump is twice as large as its supposed to be, this is despite calculated Q being at a mere 8000 kPA. I personally run Atlas on a max q of 25k and don't come anywhere close to that with this bug. 

The exact same craft and scenario using MFI 1.2.7.0 yielded consistent TWR with respect to g force across the board. All expected q values were met on timeline. 

I should also add I conducted this testing across various versions of Kopernicus and established that the latest build as of this post (v1.11.1-34) works fine with BDB providing MFI is 1.2.7.0.

I'll double post this to the MFI thread. I hope this helps lads!

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...