Galileo

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]

Recommended Posts

Posted (edited)

Anyone else have some viewing troubles with SVE and newes SCatterer v0.0540? Black sky with white clouds from terrain and clunky clouds in the orbit.Module Manger is 4.0.2

(I know I need logs and screens for help - I'm not asking for help, just wondering if I'm the only one and  so the problem is elsewhere

Edited by releansol

Share this post


Link to post
Share on other sites
25 minutes ago, releansol said:

Anyone else have some viewing troubles with SVE and newes SCatterer v0.0540? Black sky with white clouds from terrain and clunky clouds in the orbit.Module Manger is 4.0.2

(I know I need logs and screens for help - I'm not asking for help, just wondering if I'm the only one and  so the problem is elsewhere

SVE has not been updated. Do not use the latest Scatterer until SVE officially updates. Thanks.

Share this post


Link to post
Share on other sites

Thanks @Galileo that last post saved me a couple hours of researching my black sky (although it does look kinda cool for a minute).

Share this post


Link to post
Share on other sites
6 minutes ago, Rich T said:

Thanks @Galileo that last post saved me a couple hours of researching my black sky (although it does look kinda cool for a minute).

I should have an update out either tonight or tomorrow at the latest. I’m trying out a few new things to mix it up a bit

Share this post


Link to post
Share on other sites

Update will happen tonight. Just have to do one last once over and I'll be done

Share this post


Link to post
Share on other sites
2 hours ago, Galileo said:

Update will happen tonight. Just have to do one last once over and I'll be done

Woot

Share this post


Link to post
Share on other sites
Posted (edited)

UPDATE

SVE v1.4.1
Change Log 

  • Update to work with latest Scatterer
  • New Jool textures
  • No more cloud rim in scaled space

ZEmW4uo.png
iAj3taJ.png
oL90J3E.png

TO INSTALL:

  1. Drop the StockVisualEnhancements Folder into your GameData Folder

  2. Download and install SVE Textures
    https://github.com/Galileo88/StockVisualEnhancements/releases/tag/1.0.8

  3. Download and install EnvironmentalVisualEnhancements (Not the Configs)
    https://github.com/WazWaz/EnvironmentalVisualEnhancements/releases

  4. Download and install the latest Module Manager
    http://forum.kerbalspaceprogram.com/index.php?/topic/50533-130-module-manager-280-may-26th-2017-better-late-than-never/

Optional(recommended) mods:

 

 

Enjoy, and please report any issues here, or on the github repo HERE

 

 

I found a small bug with the latest scatterer upon my  last test, where the clouds are black while a vessel is on the surface.

 

EDIT: And I immediately found a fix

Edited by Galileo

Share this post


Link to post
Share on other sites

I'm so excited about this update, have to try it as soon as possible!

Thank you very much Galileo :):)

Share this post


Link to post
Share on other sites

Thank you @Galileo for the swift update, and for the SVT one as well.

Feels good to get new stuff from you, glad you're still at it.

Share this post


Link to post
Share on other sites

Thanks @Galileo for this and your other mods. You're work is very much appreciated.

That said, I subscribe to the theory that Kerbals are a subterranean species. So, how would I go about removing city lights? Everything else about SVE is great, I just want to make this one little tweak, if possible.

Would it be as simple as removing the following files:

StockVisualEnhancements\SVE_Configs\SVE_CityLights.cfg
StockVisualEnhancements\Textures\detaildark.dds
StockVisualEnhancements\Textures\detaillight.dds
StockVisualEnhancements\Textures\main.dds

Or would I have to remove CityLights.dll from EVE, in addition? Or just one or the other?

Like I said, SVE is awesome, I just want to remove city lights. As long as doing so doesn't break anything else.

TIA o7

Share this post


Link to post
Share on other sites
6 minutes ago, MisfitMarius said:

Thanks @Galileo for this and your other mods. You're work is very much appreciated.

That said, I subscribe to the theory that Kerbals are a subterranean species. So, how would I go about removing city lights? Everything else about SVE is great, I just want to make this one little tweak, if possible.

Would it be as simple as removing the following files:


StockVisualEnhancements\SVE_Configs\SVE_CityLights.cfg
StockVisualEnhancements\Textures\detaildark.dds
StockVisualEnhancements\Textures\detaillight.dds
StockVisualEnhancements\Textures\main.dds

Or would I have to remove CityLights.dll from EVE, in addition? Or just one or the other?

Like I said, SVE is awesome, I just want to remove city lights. As long as doing so doesn't break anything else.

TIA o7

You can just remove the city lights dll, and thanks for the kind words!

Share this post


Link to post
Share on other sites
1 hour ago, Galileo said:

You can just remove the city lights dll, and thanks for the kind words!

Thanks for the help, and you are welcome o7

Share this post


Link to post
Share on other sites
19 hours ago, Galileo said:
  • No more cloud rim in scaled space

It is amazing how subtle this change is, yet it makes a big difference in overall appearance! :D

 

Share this post


Link to post
Share on other sites
9 minutes ago, Newtie said:

It is amazing how subtle this change is, yet it makes a big difference in overall appearance! :D

 

Thanks for noticing. I figured this would be a feature that went unappreciated :D

Share this post


Link to post
Share on other sites
Posted (edited)

Hey there, I went and installed this, though I seem to be having an issue where Kerbin and Laythe seem to be working just fine, but Eve, Duna, and Jool seem to not be looking the way they should be. I've checked and double checked how and what I installed, and even removed all my other mods, yet the problem persists. I'm at a complete loss as to what to do. I greatly appreciate anything you might be able to point out to me to help resolve this issue!

 

How the planets look for me:

https://imgur.com/a/htm4wrg

My Game Data Folder:

https://imgur.com/a/Jt4BFSp

My KSP Log:

https://drive.google.com/file/d/1tMhH_CMbepWJFFX2RSM9bW_VGwHCvY2-/view?usp=sharing

 

EDIT: So after reinstalling it four times or so, I managed to get it working finally. Don't know if I was doing something wrong while manually installing or if EVE screwed something up, but it all seems good now. At least I can go enjoy this wonderful mod you've got here now!

Edited by CluelessBlackKnight

Share this post


Link to post
Share on other sites
10 hours ago, CluelessBlackKnight said:

-snip- 

I’m glad you got it up and running. I have no idea why it was only partially loading up for you. 

Share this post


Link to post
Share on other sites
Posted (edited)

Missed this, installed SVT soon as I saw it up, will test SVE in this new update soon. Been busy in career mode the past few months without good visuals, been tough enjoying missions without good visuals

Edited by The-Doctor

Share this post


Link to post
Share on other sites
Posted (edited)

@GalileoI think you are missing a few lines in the file "Scatterer_EVEShadows.cfg" for OPM integration;

 

	OBJECT
	{
		body = Plock
		caster = Karen
	}
	OBJECT
	{
		body = Karen
		caster = Plock
	}

I've added them and tested it my game, seems to work as expected, with sigma binary installed too!

EDIT: Also, out of curiosity, why is the duna dust storms stuff commented out in the clouds cfg?

Edited by Errol

Share this post


Link to post
Share on other sites
On 3/24/2019 at 2:29 AM, Errol said:

I think you are missing a few lines in the file "Scatterer_EVEShadows.cfg" for OPM integration;

 


	OBJECT
	{
		body = Plock
		caster = Karen
	}
	OBJECT
	{
		body = Karen
		caster = Plock
	}

I've added them and tested it my game, seems to work as expected, with sigma binary installed too!

I did the same on my side for all of the OPM bodies, with exception of atmospheric ones.

Also in Gamedata/StockVisualEnhancements/SVE_Scatterer/planetsList.cfg, I added Slate as eclipse caster to Tekto and set Urlum cloud integration to True instead of false. It turned out quite similar in appearance to Neidon, but it looks nice to watch; however it is by no mean a change/update suggestion. Here are the results :

Spoiler

uEjsTXZ.png

XAXQQqW.png

ecDTHIo.png

On another point, I like a lot the new and very wild appearance of Tekto as well as the "Coffee Thatmo" (not shown to not spoil).  Now I guess I will move from GPP to Stock+OPM as main modded setup.

eoWZgHf.jpg

l4v6tEU.jpg

3Z4U5FF.jpg

@Galileo, Thank you for this nice update :) 

Share this post


Link to post
Share on other sites

Hmmm...

 

Unable to install via CKAN...

 

Says: "SVH Module has not been found.  This may be because it is incompatible with the current game version"

 

Running 1.6.9

 

Any ideas?

Share this post


Link to post
Share on other sites
On 4/5/2019 at 12:13 PM, Kilo60 said:

Hmmm...

 

Unable to install via CKAN...

 

Any ideas?

I was able to install via CKAN just now

It took some fighting, I had to add 1.4.9 as a compatible version so it would install the right EVE dependency.

Share this post


Link to post
Share on other sites
On ‎4‎/‎6‎/‎2019 at 6:04 PM, gulegule said:

I was able to install via CKAN just now

It took some fighting, I had to add 1.4.9 as a compatible version so it would install the right EVE dependency.

Hmmmm

 

How did you do this specifically?

 

Thanks!

Share this post


Link to post
Share on other sites
On 4/9/2019 at 11:39 AM, Kilo60 said:

Hmmmm

 

How did you do this specifically?

 

Thanks!

In CKAN, in the Settings Menu, there's an entry 'Compatible KSP versions'.  That brings up a dialog of versions for CKAN to consider 'compatible' with your installed KSP version.  I manually added the version '1.4.9' to the list and checked the box for it in the list.  After that EVE showed as installable, which let me install SVE.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.