RoverDude

[1.8.x] - Modular Kolonization System (MKS)

Recommended Posts

2 hours ago, Choc113 said:

The "bases getting all twisted up" over time bug or whatever it is has been happening to me for years :(

My experience also so,

  • (a) use the logistics to build a village of small disconnected bases (as designed)
  • and/or (b) use the welding docking ports to construct a single base without any KIS/KAS  (You want the Konstruction! mod for this)

Share this post


Link to post
Share on other sites
1 hour ago, Kaa253 said:

My experience also so,

  • (a) use the logistics to build a village of small disconnected bases (as designed)
  • and/or (b) use the welding docking ports to construct a single base without any KIS/KAS  (You want the Konstruction! mod for this)

thanks for the docking port tip, I will give it a try:)

Share this post


Link to post
Share on other sites

Am I being particularly dense here or is the Scout Landing Module https://github.com/UmbraSpaceIndustries/MKS/wiki/Parts-%28Ranger-Series%29#scout-landing-module not working properly? It says (in the VAB) that it is a workshop as well as a lander but when I went to the Mun with it as part of the ship I could not get it to construct my kit as it said there was "no crew in workshop", but it has no space for a crew in it.

 I assumed that the command pod on top of my ship would work for the crew as they where both part of the same ship but it seems to need guys actually in it which is impossible:(.

  Is it just a "booster" to your proper workshop and adds to its efficiency or something? If so why does it show in the select workshop window? (big spanner and cog icon) and its description in the VAB does not mention it does that but for the inflatable workshop it does and that CAN be manned. 

Am I doing something wrong?   

Share this post


Link to post
Share on other sites

I've got a problem with the Survey Scanner,

I'm in polar orbit, I right click on it to do a scan, I then show the overlay map.

There's a button in the context menu called "Resource" which I assume switches the map overlay between resource types, however it doesn't say *which* resource.

I'm assuming that this button is added by MKS, I'm unsure I've never gotten this far in stock. (stock only had Ore right?)

 

I've a vague recollection of this button showing a type of resource earlier in the game, at that point I wasn't in a position to start exploiting the resources so I didn't look too closely at it, I'm wondering if another mod has conflicted?

 

Edit:

Nevermind I've just installed SCANSat, that has better tools.

Edited by se5a

Share this post


Link to post
Share on other sites
32 minutes ago, CaveJohnson376 said:

I noticed lack of screenshots on first post. @RoverDude, will you add some more screenshots? Or maybe you want me to send them?

Always happy to have screenshots - imgur links are best!

Share this post


Link to post
Share on other sites

I installed this because it looked cool, but now all my EPL bases aren't working! Is there a way I can keep the mod installed (and have the sweet-looking parts) but not the special EPL gameplay mechanic? Please help!

Share this post


Link to post
Share on other sites
4 hours ago, TeslaPenguin1 said:

I installed this because it looked cool, but now all my EPL bases aren't working! Is there a way I can keep the mod installed (and have the sweet-looking parts) but not the special EPL gameplay mechanic? Please help!

remove the epl config files from MKS.  I am not near my home computer so I don't have the exact name but its not difficult to figure out.

Share this post


Link to post
Share on other sites

Hi, I'm running KSP 1.4.5.2243 (Steam) with making history 1.4.0

The mods im running are all USI mods, KIS/KAS, SCANSat, Mechjeb2, KSP-AVC and SVE

Start T-Credits buttons are not appearing on either the Duna or Tundra logistics modules

as far as i can tell i have the latest versions of all my mods, AVC shows no issues with any mks or usi mods

Everything else works, just no start T-Credits.

I've got a fully established base on the Mun, using Planetary Warehouses to automatically distribute all the resources from remote drilling rigs back to the fully staffed main base for processing. i have plenty of everything there. just no button to start making T-Credits so i can sent stuff from the surface to orbiting ships.

I've even tried making a small ship with a power plant, Logistics center (Tried Both), an antenna and stocked with Material Kits, Liquid fuel and oxidizer.

No mater what i do, no button to make t-credits

Test Center Screenshot Below

https://imgur.com/a/8xWB0AO

Share this post


Link to post
Share on other sites
9 hours ago, TeslaPenguin1 said:

I installed this because it looked cool, but now all my EPL bases aren't working! Is there a way I can keep the mod installed (and have the sweet-looking parts) but not the special EPL gameplay mechanic? Please help!

Another option besides removing the files manually is to use PatchManager - all the configs for this are set up to be easily accessible via that as well.

There are actually four patches - one that adds EL productivity to appropriate MKS classes, one that adds EL build compatibility to MKS parts, one that *removes* the standard EL parts (disabled by default) and one that changes the EL recipes to use MKS-style resources.

At the moment the patch that adds EL build compatibility to MKS parts is out of date, and doesn't do anything useful.  Off the top of my head, I'm not sure about the one that adds EL productivity to MKS classes.  (It won't be causing you issues, but I'm not sure if it's useful either.)  The patch that is likely causing you issues is the one that changes the EL recipes - that the one here:

GameData/UmbraSpaceIndustries/MKS/Patches/PatchManager/ActiveMMPatches/MKS_EL_Resources.cfg

Share this post


Link to post
Share on other sites

I've started a new career, it's been a long time since I last played KSP.

I had MKS/OKS last time, and so have installed it again.

 

However, I've noticed that the habitation time 'per seat' seems to have changed a lot. It now only provides 0.25 of a month per seat.

 

This pretty much rules out low-tech excursions to Minmus (i.e. One MK1 pod, including orbit, landing & return).

Is this an intended outcome? Is this because the balancing has large end-game bases in mind? Or am I missing an obvious low-tech habitation modifier improvement?

Share this post


Link to post
Share on other sites
5 hours ago, Cooper42 said:

I've started a new career, it's been a long time since I last played KSP.

I had MKS/OKS last time, and so have installed it again.

 

However, I've noticed that the habitation time 'per seat' seems to have changed a lot. It now only provides 0.25 of a month per seat.

 

This pretty much rules out low-tech excursions to Minmus (i.e. One MK1 pod, including orbit, landing & return).

Is this an intended outcome? Is this because the balancing has large end-game bases in mind? Or am I missing an obvious low-tech habitation modifier improvement?

Yes, it is intended and I don't think you're missing anything.  You'll need to add more hab time, and supplies and/or recyclers to your craft to support those early Minmus missions.

Share this post


Link to post
Share on other sites
11 hours ago, Brigadier said:

Yes, it is intended and I don't think you're missing anything.  You'll need to add more hab time, and supplies and/or recyclers to your craft to support those early Minmus missions.

Supplies aren't really an issue at all, as the small packs unlock in survivability, and there is the 14 day 'starving' period for Kerbals. Unless I'm mistaken, there's no similar grace period for habitation.

Which means that there's no low tech option for Minmus if you have habitation active. You have to wait until Hitchiker is unlocked, as even a MK1 Command Pod + a MK1 Lander, with one Kerbal, is still cutting it a little close at 15 days.

 

It means MKS & USI-LS provides a situation where you can supply a ship to go for months away a before you can actually build anything that is habitable for more than 7/15 days. Which makes career games with 60% or less science multipliers extra grindy for how much you need to milk the Mun.

 

In anycase, I'm not complaining, as it is configurable. I'm just gonna double what it's been set to and make it a half-month. Not as high as it used to be with one full month (which is what much of the info on the wiki is still based on), but not as super restrictive at low-tech levels as a quarter-month.

I just wanted to check that the changes haven't been made with space stations & bases in mind and I'll just me making it all super-trivial down the line with this setting?

Share this post


Link to post
Share on other sites
1 hour ago, Cooper42 said:

In anycase, I'm not complaining, as it is configurable. I'm just gonna double what it's been set to and make it a half-month. Not as high as it used to be with one full month (which is what much of the info on the wiki is still based on), but not as super restrictive at low-tech levels as a quarter-month.

I just wanted to check that the changes haven't been made with space stations & bases in mind and I'll just me making it all super-trivial down the line with this setting?

That shouldn't throw things off too badly compared to the dedicated hab parts. Most have at least 5 months of bonus hab time per crew capacity, unless they have a significant multiplier, or the Karibou's 0.24t "emergency shelter" at 1.2 months and 2 crew. For highest-tech bases, the Tundra Hab ring has 10 crew and almost 500 months bonus hab time.

I haven't played with a lower science multiplier, but I haven't had too much trouble with the default time either. Have you considered letting hab time expire on the way home from Minmus? If not that might make the default settings manageable.

If the hab penalty is on the default "grouchy" then fairly low technology is enough to safely return a grouchy "Tourist". Either any probe core to take over when it's close enough to Kerbin for the internal antenna to work, or just leave Minmus on a direct reentry trajectory (may require a heat shield, and don't forget to arm the chutes before the crew goes on "vacation"). If you build a separate lander and return capsule then the default setting give you 15 days of hab time, which should be plenty to arrive and science, though I'm not sure that saves mass unless you will be landing several times and have unlocked enough to refuel in orbit. Arriving in under 7 days takes a bit more ΔV than the cheapest Hohmann transfer but it shouldn't be too bad . I think a good Mun assist can get you to Minmus periapsis before 5 days with only a little more dV than needed to reach a low Mun flyby in the first place.

Share this post


Link to post
Share on other sites
On 8/9/2018 at 6:43 AM, infinite_monkey said:

Do resource lodes need to be docked to the base where the sifter is attached to, or is it enough to be near the base?

Resource loads need to be connected to the sifter.  I generally used a klaw on a rover with a small sifter.  Once the lode was small enough I would carry it back to base to finish up.

(planned but never really built a rover that would be good at carrying large lodes back to base)

Share this post


Link to post
Share on other sites
On 8/7/2018 at 5:36 PM, DStaal said:

Another option besides removing the files manually is to use PatchManager - all the configs for this are set up to be easily accessible via that as well.

There are actually four patches - one that adds EL productivity to appropriate MKS classes, one that adds EL build compatibility to MKS parts, one that *removes* the standard EL parts (disabled by default) and one that changes the EL recipes to use MKS-style resources.

At the moment the patch that adds EL build compatibility to MKS parts is out of date, and doesn't do anything useful.  Off the top of my head, I'm not sure about the one that adds EL productivity to MKS classes.  (It won't be causing you issues, but I'm not sure if it's useful either.)  The patch that is likely causing you issues is the one that changes the EL recipes - that the one here:

GameData/UmbraSpaceIndustries/MKS/Patches/PatchManager/ActiveMMPatches/MKS_EL_Resources.cfg

Finally got back to my computer and it works! :D 

Thx for the help!

Share this post


Link to post
Share on other sites
3 hours ago, Terwin said:

Resource loads need to be connected to the sifter.  I generally used a klaw on a rover with a small sifter.  Once the lode was small enough I would carry it back to base to finish up.

(planned but never really built a rover that would be good at carrying large lodes back to base)

Thanks, I'm now able to mine it, but I'm not quite sure what it does - the "lode" resource is getting reduced, but what happens with it? I'm within 250 m from my base, so I guess ressources are transferred directly to it? But what resources specifically?

Share this post


Link to post
Share on other sites
4 minutes ago, infinite_monkey said:

Thanks, I'm now able to mine it, but I'm not quite sure what it does - the "lode" resource is getting reduced, but what happens with it? I'm within 250 m from my base, so I guess ressources are transferred directly to it? But what resources specifically?

Like Dirt, the Sifter will process it into all the resources present on the planet, with the output proportions corresponding to the planetary average concentrations of the resources. I'm not sure about the exact I:O ratio.

Share this post


Link to post
Share on other sites
Just now, infinite_monkey said:

OK thanks. So everything I don't have a container for is lost?

Yes. Stuff that doesn't have anywhere to go will be discarded so it doesn't gum it up for other resources.

Share this post


Link to post
Share on other sites

I don't understand the drills.

What's the difference between the MEU-100 and the MEU-100-A

Contrary to the descriptions, once out of the VAB you can't change either of these even EVA that I can see.

Also the separator function is confusing, and the description doesn't seem to match up with the options given.

"Swappable drillheads and internal separator configurations allow the drill to focus on specific resources, or pull in all resources for later separation"

I don't see the option for the "pull in all resources" and in my little runway test I didd't see anything other than what the drill was configured for going into the tanks, but maybe I didn't leave it running long enough.

 

Share this post


Link to post
Share on other sites
1 minute ago, se5a said:

I don't understand the drills.

What's the difference between the MEU-100 and the MEU-100-A

Contrary to the descriptions, once out of the VAB you can't change either of these even EVA that I can see.

Also the separator function is confusing, and the description doesn't seem to match up with the options given.

"Swappable drillheads and internal separator configurations allow the drill to focus on specific resources, or pull in all resources for later separation"

I don't see the option for the "pull in all resources" and in my little runway test I didd't see anything other than what the drill was configured for going into the tanks, but maybe I didn't leave it running long enough.

 

The MEU-100A doesn't need any crew to run at 100% load, while the MEU-100 depends on the level of the best Engineer or Miner on the vessel - just one can boost all drills. The MEU-100 only runs at 5% without any appropriate crew, 25% if the highest level is zero, and another +20% for each star afterward. However fast or slow they are running, either drill uses the same amount of EC per unit of resource harvested. These numbers are before from Kolonization bonuses or thermal limits, which affect both parts identically.

The MEU-100A's "100%" is only about 65% as fast as "100%" on the MEU-100, so a 3-star Kerbal in the crew is enough for each MEU-100 drill to product just as much as a MEU-100A. The MEU-100A is also 40% heavier, so by productivity per ton of drills a 2-star Kerbal is almost enough for the MEU-100 to catch up (within 5%).

To change the settings from EVA you need an Engineer or Mechanic (these two jobs are also the only ones that can use KAS tools to attach parts), plus it costs the amount of specialized parts, material kits, and EC listed in the VAB. This, plus the whole UI for setting up the separators in the VAB is shared any MKS part that lets you configure the function. It's a bit confusing but at least it applies to everything once you learn it. (the button with the "=>" arrow change the configuration of the part - this is when you pay the resource cost. The "Next" and "Prev" buttons change the selection to the right of the arrow without actually changing the part. In the VAB it's free to just cycle with the first button, but "Next" and "Prev" are worthwhile when changing the setup in the field). I haven't switched drills much, but now I see it only costs 20kgs of consumables to reconfigure a MEU-100 (1% of the drill mass), so maybe it is the most efficient option sometimes.

"pull in all resources" is an oblique reference to harvesting Dirt and then running it through a sifter. The sifter part will do exactly what you expected to see from the drill, pushing a little bit of every resource into available tanks (and just dumping the rest). The amounts are proportional to overall planetary abundance.

Share this post


Link to post
Share on other sites

Ok that makes a little more sense,

I'm still a bit confused on the separator bit of the drill though.

From what I understand you can change what the drill digs up, but it can also separate what it digs up... or something.

I'm confused.

Share this post


Link to post
Share on other sites

"Separator" is just what the drills call the slots where you can change what it digs up. The larger drills have more than one, then you can have one drill digging up several different resources at once, or set multiple separators to the same resource to get more of that resource. Other switchable things call the slots "Bay" or "Converter" or just "Config".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.