Jump to content

[KSP 1.11.0] Physics Range Extender v1.20.0 (20 Jan 2021)


jrodriguez
 Share

Recommended Posts

5 hours ago, yeetbot4000 said:

Having a similar issue to the guy on October 6th, except i'm flying  a ship over the mun and it switches to a flag that i had planted while saying "extending terrain: focusing landed vessels".

I will need to add some logic to avoid switching to flags. The switch is expected for normal vessels. Basically it is a way to do a "physics ease" for those vessels that are landed and entering into Physics zone.

Link to comment
Share on other sites

9 minutes ago, jrodriguez said:

I will need to add some logic to avoid switching to flags. The switch is expected for normal vessels. Basically it is a way to do a "physics ease" for those vessels that are landed and entering into Physics zone.

brilliant, thanks! any idea when the patch will come out if you don't mind me asking?

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Saludos! I have a slightly unusual question for you. Another mod called HullCamVDS has a problem on my system, and other people have it too. It's a problem where the screen appears to flash when the cams are active while the sun is out and the altitude of the camera is something less than 2k. Anyway, another user reported in that thread that your mod has a camera fix option that also fixes the HullCam flashing problem. This seemed like an odd connection, so I came to investigate.

I noticed your method UpdateNearClipPlane() mentions a flickering fix. When you have a free moment, would you mind commenting on what you were addressing with that fix? Do you think the problem I mentioned above has anything to do with things you addressed in your mod, too? LGG was able to confirm the flashing, so I was hoping there might be a clue here.

Thanks for your time!

Link to comment
Share on other sites

  • 2 weeks later...

I'm not sure if anyone is still encountering this, but even at a relatively low distance (50km), I'm still getting landed vessels phasing into the ground and exploding upon being loaded.  I'm doing this with BDA for Runway Project (v1.4.4.4 IIRC) and it makes the mod pretty much pointless for me.  Sometimes when the camera switches to a vessel being loaded, I might be able to save it by using VesselMover, but that sometimes just causes it to explode instantly.

Also, when loading vessels in weird places (i.e. underground), they become just far enough away that the vessels which flew close enough to load them in unload themselves!  I'm not using RSS/RSO, so I have no need for 2000+km distances, but not working at small distances is still getting on my nerves over time.  I have a recording I made with OBS that demonstrates the issue that I should have a link for soon.

Video demo link: 

 

Edited by GKSP
video link
Link to comment
Share on other sites

Posted (edited)
5 hours ago, GKSP said:

I'm not sure if anyone is still encountering this, but even at a relatively low distance (50km), I'm still getting landed vessels phasing into the ground and exploding upon being loaded.  I'm doing this with BDA for Runway Project (v1.4.4.4 IIRC) and it makes the mod pretty much pointless for me.  Sometimes when the camera switches to a vessel being loaded, I might be able to save it by using VesselMover, but that sometimes just causes it to explode instantly.

Also, when loading vessels in weird places (i.e. underground), they become just far enough away that the vessels which flew close enough to load them in unload themselves!  I'm not using RSS/RSO, so I have no need for 2000+km distances, but not working at small distances is still getting on my nerves over time.  I have a recording I made with OBS that demonstrates the issue that I should have a link for soon.

Video demo link: 

 

Not sure if this is the case, but there is known issue in PRE in which if a Vessel X is entering the Physics Range but there is a Vessel Y that is within the physics range of X  but is not in the range of your active vessel then...BOOM!

There is no fix for this and my suggestion is to increase the physics range until all the vessels that you want to interact with are within physics radius

Edited by jrodriguez
Link to comment
Share on other sites

  • 2 weeks later...

The mod is awesome, its perfect in combination with KOS and the suicide burn scripts i wrote. But there are 1,5 Problems.

The first one is that Orbits randomly change, sometimes after a Maneuver Node, sometimes other crafts Orbit( like my Space Station, RIP Bob ) .
I saw that from other users as well. I haven't realized a pattern, when the orbits are changing, but its unluckly often :/.
Sometimes the Vessel im controlling is falling to the ground while warping, although im in orbit. Wasn't quite sure if this is PRE or just KSP Time Warping.
But when i couldn't find my Space Station and a Satellite, which were both in LEO, and that reminded me of the Post i mentioned before. 

The Post i mentioned: https://www.reddit.com/r/KerbalSpaceProgram/comments/6rthqk/what_is_going_on_here/

The half problem is heavy flickering and slight shaking in Orbit. Its not Gamebreaking,  but still a little bit disturbing while performing Burns.

Link to comment
Share on other sites

Posted (edited)
On 5/4/2021 at 10:14 AM, Unilif said:

The mod is awesome, its perfect in combination with KOS and the suicide burn scripts i wrote. But there are 1,5 Problems.

The first one is that Orbits randomly change, sometimes after a Maneuver Node, sometimes other crafts Orbit( like my Space Station, RIP Bob ) .
I saw that from other users as well. I haven't realized a pattern, when the orbits are changing, but its unluckly often :/.
Sometimes the Vessel im controlling is falling to the ground while warping, although im in orbit. Wasn't quite sure if this is PRE or just KSP Time Warping.
But when i couldn't find my Space Station and a Satellite, which were both in LEO, and that reminded me of the Post i mentioned before. 

The Post i mentioned: https://www.reddit.com/r/KerbalSpaceProgram/comments/6rthqk/what_is_going_on_here/

The half problem is heavy flickering and slight shaking in Orbit. Its not Gamebreaking,  but still a little bit disturbing while performing Burns.

PRE has a lot of issues and most part of them are due to the fact that it is trying to hack the stock ranges, during these years I have tried to prevent or minimize these side effects but as you have described there are several remaining issues.

I will invest some time soon  to prevent these scenarios but I can't do any promise to be honest.

Finally, I can give some tips to minimize your issues:

- PRE is not meant to be used as your daily driver mod, but as a mod that you use for specific scenarios like:

  • Watching a launch to orbit from the ground
  • Landing boosters while the 2nd stage goes to orbit
  • Having two planes flying at 100 km.

- There are some specific scenarios that can trigger physics issues and that are not recommended:

  • Active vessel landed and  a satellite enters physics range or goes out of range. This could end up deorbiting the satellite.
  • Active vessel suborbital  and a landed vessel enters physics range.
  • High speed (> 1000 m/s)  and great distance ( > 100km) difference with a vessel that is about to enter physics range
  • Active vessel ascending suborbital about to change inertial plane and a vessel still landed on the ground when the inertial plane changes.
  • PRE range to something greater than > 500 km and vessel distance is close to that number: things will get bad once the distance starts to go beyond 500 km, from flickering up to RUD.

- My recommendation is to low the PRE range as much as possible (50km) when you don't really need it. And if you need 500 km or 1000 km for something specific then do it but ensure first that all your vessels are loaded from the very beginning. 

Edited by jrodriguez
Link to comment
Share on other sites

  • 2 weeks later...

BDArmory Mod is awesome I play on KSP 1.8.1, but I've noticed on physics range extender seems to not be working properly. When I fly my vessel for around 50-100 meters the other vessels seem to disappear, I have downloaded latest version of Bda mod compatible with 1.8.1 and physics range extender. Do I need to be more specific? Or is it a simple fix? Thank you.  

Link to comment
Share on other sites

4 hours ago, SleepyDude21 said:

BDArmory Mod is awesome I play on KSP 1.8.1, but I've noticed on physics range extender seems to not be working properly. When I fly my vessel for around 50-100 meters the other vessels seem to disappear, I have downloaded latest version of Bda mod compatible with 1.8.1 and physics range extender. Do I need to be more specific? Or is it a simple fix? Thank you.  

Which version of PRE are you using, if the vessel is disappearing then your PRE is not working. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...