Tidal Stream

[1.3.1, 1.4.1] Procedural Parts - Tidal Stream Branch

Recommended Posts

On 4/29/2018 at 1:01 PM, PariahDog119 said:

So the new update has broken the procedural boosters:

N2vkbDp.png

Any suggestions?

Having same issue, but mine is placed correctly. Any Ideas for a quick fix?

KSP 1.4.3.2152
Procedural Parts v.1.3.14-1

Thanks
// Reknot

Share this post


Link to post
Share on other sites

@Tidal Stream Its not supposed to have a massive Red Bell Nozzle ,I guess? xD 
Besides, I'd like to see the issue fixed for others So, used his post. =) 

Share this post


Link to post
Share on other sites

oh no, it's supposed to be massive, I did that on purpose because I needed ALL THE THRUST

 

I have no idea why it's red, though

Share this post


Link to post
Share on other sites
Posted (edited)

The nozzle gets red when its temperature rises. For some reason this animation is bugged and is always red. I am not a graphic designer so I am not sure how it works exactly. Also the SRB bells IRL are usually white. Try replacing SRBBell.mu and StretchySRBBell.dds. I don't know why the bell placement gets broken. While we are on the topic, can you test the 1.2.15 Beta with the SRB thrust fix? I will release it as stable and merge it in the KSP 1.4 branch if I get one more positive feedback for it (I try to be conservative with releases to not break stuff).

Update: Released the SRB thrust fix for 1.3 and 1.4.3 today. They are both indexed on CKAN (had to delete and recreate the beta version for CKAN to index it). It makes it easy to create fully solid ICBMs as I found out during testing today. Unfortunately most of them ended on solar escape trajectories even with 4000 kg ore payloads. Have fun with them and fly safe. O7

Edited by Tidal Stream

Share this post


Link to post
Share on other sites

Is there any more texture packs kicking around for these? Freedomtrex seems to mess up staging when I use them.

Share this post


Link to post
Share on other sites

I can't find the procedural SRBs in the new tech tree in RP-0. The upgrades are there. I looked in all the early nodes and I looked in all the tabs in the VAB. But no SRBs. Any idea what's going on?

Share this post


Link to post
Share on other sites

What is going on is that no one so far has figured out how to balance and cost them for RP-0, placing them in the correct nodes and them costing sensible amount of funds. If you want to do that, feel free to submit a patch (pull request) to the RP-0 GitHub repository.

Share this post


Link to post
Share on other sites

I'm having a problem where there are no textures for the tops of tanks when attached to other parts. ie when there's a fairing adapter that can be seen through the texture for the top of the proc fuel tanks is not there. Is there a way to turn this off so that the top texture can be seen through parts that are not solid?

Share this post


Link to post
Share on other sites
On 7/17/2018 at 11:26 AM, Tidal Stream said:

The texture of the tankbutts is Parts/ends.dds. 

Yes, this file is there. The problem is not that it's not there, the problem is as I put in my first post.

Share this post


Link to post
Share on other sites

Can you provide a screenshot? Optionally create a github issue with this description and screenshot because things can be hard to find in a long thread in the future when someone tries fixing these bugs.

Share this post


Link to post
Share on other sites
On 7/19/2018 at 1:17 AM, Tidal Stream said:

Can you provide a screenshot?

Jr1QCUy23Bt3_screenshot2.png

Sorry for late reply

Share this post


Link to post
Share on other sites

I'm considering adding some different fuselage shapes to Procedural parts, oval cross-section instead of circular. Is this possible and is there any information on how it can be done?

Share this post


Link to post
Share on other sites

I have some problems with the SRB which it dosent appear in the part list.

If it helps here are the files:

ksp log https://www.dropbox.com/s/i3txszizujq0fni/KSP.rar?dl=0

output_log  https://www.dropbox.com/s/v1a3pw4p2fqolog/output_log.rar?dl=0

PS: I play with RSS/RO and real fuels, hope that information helps.(I use ksp 1.3.1 and the version that CKAN shows of PP is 1.2.15)

Edited by JPGSP

Share this post


Link to post
Share on other sites
3 hours ago, Citizen247 said:

I'm considering adding some different fuselage shapes to Procedural parts, oval cross-section instead of circular. Is this possible and is there any information on how it can be done?

I think you'd inherit from ProceduralAbstractShape and then override all of its abstract functions to generate the shapes you want:

https://github.com/Tidal-Stream/ProceduralParts/blob/master/Source/ProceduralAbstractShape.cs

Share this post


Link to post
Share on other sites
7 hours ago, HebaruSan said:

I think you'd inherit from ProceduralAbstractShape and then override all of its abstract functions to generate the shapes you want:

https://github.com/Tidal-Stream/ProceduralParts/blob/master/Source/ProceduralAbstractShape.cs

I've looked at the code, it seems the way you add shapes is by varying the diameter of the circle across the length of the part. So it still has a circular cross section but with diameter of the circle varies. I want to change the shape of the cross section. The code to change that is in the part generation code, so I'd need to override that, and I'm not entirely sure how that will work.

Doing what I want seems to be a much bigger job than adding new shapes.

Edited by Citizen247

Share this post


Link to post
Share on other sites

Hello and i am sorry for mi english. I am using USI Life Support and your mod for create tank with mulch, fertilizer, etc. Now, my problem: if i save mulch in a tank, Dry and Wet not changed in "cost", but yes changed in "Craft Stats".

First example without mulch (mantillo in spanish) Dry 866 — Wet  866

Spoiler

5899120476BBCAB24A57F7C95DAE4C5A26EC3E5F (1280Ã720)


Now, with mulch Dry and Wet not change in "cost":
 

Spoiler

42FF498742AB20A0C05EF723DE614189DF7530CD (1280Ã720)

Logs: https://drive.google.com/open?id=1D6dXoj7vsbhViwg2_NJQ6MFFcuc4Vrqt

https://drive.google.com/file/d/1lyy-ookpcJUDfYx-tWmTZtauCxFwDtth/view?usp=sharing

I not have problems with "fertilizer" and "supplies" and both are in spanish (fertilizante; suministros). it can't be a lenguage problem.

 

Edited by Owari
my english is so bad

Share this post


Link to post
Share on other sites

I just downloaded the latest 1.31 from github (1.2.15). I'm running RP-1 install but this is the only mod I updated. Everything is now +100kg. So, tiny tanks are 102kg. A 5kg antenna is 105kg. Since this was the only change I made, any chance it is from this mod??

Share this post


Link to post
Share on other sites

@AntstarNo, this is a common RealismOverhaul KER issue. Remove the crew and you will not see the mass increase. This is just VAB/SPH problem, in-flight the mass is correct.

@OwariThis is USI problem, not ProceduralParts one.

@Citizen247You have to figure out the formula of the oval cross-section, then instead of the loop going around the circle, you will have a loop that picks the next point in the oval. For regular polygons you could choose n points, then every iteration of the loop you go along the sides and corners of it.

  • Like 1

Share this post


Link to post
Share on other sites
On 9/14/2018 at 3:04 PM, Owari said:

Hello and i am sorry for mi english. I am using USI Life Support and your mod for create tank with mulch, fertilizer, etc. Now, my problem: if i save mulch in a tank, Dry and Wet not changed in "cost", but yes changed in "Craft Stats".

First example without mulch (mantillo in spanish) Dry 866 — Wet  866

  Hide contents

5899120476BBCAB24A57F7C95DAE4C5A26EC3E5F (1280Ã720)


Now, with mulch Dry and Wet not change in "cost":
 

  Reveal hidden contents

42FF498742AB20A0C05EF723DE614189DF7530CD (1280Ã720)

Logs: https://drive.google.com/open?id=1D6dXoj7vsbhViwg2_NJQ6MFFcuc4Vrqt

https://drive.google.com/file/d/1lyy-ookpcJUDfYx-tWmTZtauCxFwDtth/view?usp=sharing

I not have problems with "fertilizer" and "supplies" and both are in spanish (fertilizante; suministros). it can't be a lenguage problem.

 

Owri, yo fui el que escribio la parte del mod para darle support a USI-LS. La contestacion de Tidal Stream es correcta. El costo es function de USI-LS.  Aun asi le dare un vistazo al file a ver si se me quedo algo. honestamente como normalmente juego en sand box no me fijo en el costo. -Rafael

Translation for English speakers. Owari, I wrote the CFG file for USI-LS compatibility. The answer given by tidal Stream is correct. Cost is a USI-LS function. I will however take a look at the file to check if I missed anything. Honestly haven't paid attention to cost, since I play sandbox mostly.-Rafael 

  • Like 1

Share this post


Link to post
Share on other sites
17 hours ago, Rafael acevedo said:

Owri, yo fui el que escribio la parte del mod para darle support a USI-LS. La contestacion de Tidal Stream es correcta. El costo es function de USI-LS.  Aun asi le dare un vistazo al file a ver si se me quedo algo. honestamente como normalmente juego en sand box no me fijo en el costo. -Rafael

Translation for English speakers. Owari, I wrote the CFG file for USI-LS compatibility. The answer given by tidal Stream is correct. Cost is a USI-LS function. I will however take a look at the file to check if I missed anything. Honestly haven't paid attention to cost, since I play sandbox mostly.-Rafael 

Español: Sé que poca gente ha reportado esto, así que no te preocupes demasiado y no gastes tiempo en mí. El precio del mulch es irrelevante y puedo usar la consola para quitarme dinero. 

English: I know that not many users have reported this. Do not worry and do not spend time for me. In fact, the price of the mulch is irrelevant and I can use alt + f12 to remove money.

Share this post


Link to post
Share on other sites
2 hours ago, Owari said:

Español: Sé que poca gente ha reportado esto, así que no te preocupes demasiado y no gastes tiempo en mí. El precio del mulch es irrelevante y puedo usar la consola para quitarme dinero. 

English: I know that not many users have reported this. Do not worry and do not spend time for me. In fact, the price of the mulch is irrelevant and I can use alt + f12 to remove money.

Recuerda que el mulch es un byproduct the los Kerbonautas, asi que si ellos estan abordo el costo es zero.

Remember mulch is a kerbonaut byproduct so if they are onboard mulch cost is zero. 

  • Like 1

Share this post


Link to post
Share on other sites

I am getting a error when me launch a ship with procedural parts (xenon tanks, liquid tank, etc). The number of errors depend of the number of parts.
 

Spoiler

42529449_686250408422541_156959575537352704_n.png?_nc_cat=105&oh=9b2f9a70b6623bffeef0e632f3e173ea&oe=5C24F8C042458275_437031796824548_8135603442371526656_n.png?_nc_cat=101&oh=b04837fdf6659b8a6791c95f1fefeded&oe=5C2C699B

For some reason i only can get KSP.log and i cant find output.log. Edit: don't worry, was finded.

https://drive.google.com/open?id=15Ux3T4UXs23Ppd9RcIPTPIrzQeWj3TLa
https://drive.google.com/open?id=1pAHANU6QODjyokIpEW8qX6OxBOBb6ycD

Edited by Owari
output_log

Share this post


Link to post
Share on other sites
1 hour ago, Owari said:

For some reason i only can get KSP.log and i cant find output.log.

If you're on a Windows (recent version) computer, in recent KSP versions it's in your user profile directory, normally located here:

C:\Users\<username>\AppData\LocalLow\Squad\Kerbal Space Program\

More details in the troubleshooting post linked in my signature.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now