Jump to content

Parts demo – Blender, GIMP, and Unity files [Dec 7, 2019]


Recommended Posts

Just now found this thread! This is awesome! Iv'e been messing around with modding here and there for about a year now. And now that I'm stuck in the house for who knows how long, this is all i been doing. So far Iv'e made a fuel tank, nosecone, cargo bay, stack adapter and a wing. Nothing to brag about but I got them into the game and they worked so I was happy! I also made a command pod and am also struggling to get the lights to work. Iv'e been trying for 2 days strait, literally! I can not do it! I've tried everything and now I'm starting to wonder if my unity install is messed up or my part tools is wrong. I'm using unity 2019.2.2 and the latest Part Tools.

Link to post
Share on other sites

@Tomtomdb83 Thanks! Hope it's helpful - if you find any mistakes please let me know. As far as lights on a command pod - I haven't done a command pod yet but understand the window glow is an emissive animation. If you have questions about color animations there's a link and some notes (notes.txt) in the WIP Lights project.

Unity 2019.2.2f1 is the Unity KSP 1.8.X and 1.9.X use - important if you're writing plugin's but not so important for parts (though I don't know what would happen if you used, say parttools version 1.9.0 with Unity version 5.2.4). Happy modding!

Link to post
Share on other sites
  • 1 month later...
  • 1 month later...

Appreciate the work you've put in this! What's the deal with setting up emissives on lights?  I've got this sweet light I created that has made me age a year in the last two days from frustration. I checked the Mod Development Links Compilation thread that actually has a link to setting up lights with emissives, but the link is dead. 90% of those links are dead. I'm losing my mind!

Link to post
Share on other sites

I've been unable to get the light to work - either the light works or emissive works but never both. Changing "useAnimationDim" in the config file from true to false toggles which works. I've tried everything I can think of including things that I didn't think would work (they didn't) and unless I find some new information or think of something new to try I'm stuck. If you do manage to figure this out I'd be very interested in hearing what you did to get it to work. Good luck!

Link to post
Share on other sites
  • 4 months later...
2 hours ago, wasml said:

@hemeac Your welcome, glad you found them useful. If you spot anything that doesn't make sense or is just wrong/confusing please let me know.

PS. Saw your Aerobee page - looks nice!

Thanks!.  Was able to get my SRB together without much hassle as well.  Really saving me a lot of hours of frustration.  For the emissive, I used a couple of different modules that I took out of TantaresLV part configs that seems to be used in some newer engines (guessing they are new?).  That seemed to work well and didn't require the use of the color animation tool, but need to play around with the settings a bit more.

Spoiler
MODULE
    {
        name = FXModuleThrottleEffects
        fxModuleNames = heatColor
        responseSpeed = 0.1
        dependOnEngineState = True
        dependOnThrottle = True
    }
    MODULE
    {
        name = ModuleColorChanger
        moduleID = heatColor
        animRate = 1.0
        shaderProperty = _EmissiveColor
        //excludedRenderer = EngineCore
        toggleInEditor = false
        toggleInFlight = false
        redCurve
        {
            key = 0 0 1 1
            key = 1 1 1 1
        }
        greenCurve
        {
            key = 0 0 1 1
            key = 1 1 1 1
        }
        blueCurve
        {
            key = 0 0 1 1
            key = 1 1 1 1
        }
        alphaCurve
        {
            key = 0 0 1 1
            key = 1 1 1 1
        }
    }

 

By any chance, do you have a good resource that documents the different shaders?

Link to post
Share on other sites
1 hour ago, hemeac said:

I used a couple of different modules that I took out of TantaresLV part configs

Thank you for pointing these out - I'll have to take a look at them.

1 hour ago, hemeac said:

By any chance, do you have a good resource that documents the different shaders?

Unfortunately no - and I haven't seen anything either. One thing I have seen is the when I use the Bumped Specular (Mapped) the part is invisible in the VAB when dropped

Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...