Jump to content

[1.9.x] DMagic's Evolved Mods - Tracking Station Evolved 6.0 [5-4-2018]


DMagic
 Share

Recommended Posts

Was it always needed to DOUBLE click to focus a vessel? I don't think so. Does it behave the same for everybody?
1. Single click just selects the vessel in the list/tree, but does not focus it.
2. Double click selects and focuses.
3. Another double click, when already focused, jumps into the ship.

Win10 18xx 64bit, fresh reinstall of everything (new SSD).

Link to comment
Share on other sites

On 5/25/2018 at 10:34 AM, klesh said:

Puts the stock Tracking Station to shame.

The stock tracking station puts itself to shame.

Come on 1.4.  I know you can do it.  I believe in you!  I need this mod...

Edited by klgraham1013
Link to comment
Share on other sites

On 6/22/2018 at 12:56 PM, firda said:

Was it always needed to DOUBLE click to focus a vessel? I don't think so. Does it behave the same for everybody?

I just noticed that too, and thought it was weird.  I'm pretty sure it wasn't like that before.  Maybe something changed in KSP 1.4.4?

Link to comment
Share on other sites

Yes, it looks like they made a slight change to how clicking on the tracking station vessel list works (I have no idea why). Since this mod relies on the stock vessel buttons as a sort of backstop to how it functions this change affects how the mod works. 

I'll need to update to make it so that the first single click focuses on the vessel, though I'll probably wait for the inevitable 1.4.5.

Link to comment
Share on other sites

Tracking Station Evolved has been updated to version 4.0 for KSP 1.4.4; get it on Space Dock.

It fixes the KSP 1.4 related bug that was preventing vessels from being focused on when clicking on their tracking station button.

Note that neither Space Dock nor Curse have been updated with the KSP 1.4.4 release tag, so despite what they say about supporting KSP 1.4.3 this version only supports KSP 1.4.4. If you want to use the mod with KSP 1.4.3 or earlier use version 3.0. I'm not sure what version CKAN will support, the .version file included in the release specifies KSP 1.4.4 as the minimum supported version.

 

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
On 7/13/2018 at 10:20 AM, klgraham1013 said:

This has been my motto for about two years now.

My counter-offer for desires to "make things stock" is to point out how slow the development and maintenance for those components would become. Would you want a favorite mod getting updated once every few months (or longer) with the main game updates? ;) 

Link to comment
Share on other sites

17 minutes ago, Beetlecat said:

My counter-offer for desires to "make things stock" is to point out how slow the development and maintenance for those components would become. Would you want a favorite mod getting updated once every few months (or longer) with the main game updates? ;) 

I'd want the product to not need to be updated.  I prefer finished products.

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...
On 8/29/2018 at 5:39 AM, eberkain said:

Loving the tracking station changes.  I would suggest adding some sort of highlight for vessels that have crew members aboard. 

Or maybe a little Kerbal icon with a number next to it?  Not sure how difficult this would be.  As I'm still on 1.3.1, I'm actually still waiting to play this mod.  Finger's crossed for 1.5.4.

Link to comment
Share on other sites

Could it be that this mod does not like RSS?

I don't see the remains of my first launched sounding rocket to be recovered - but they're recognized by other mods as existing like Kerbalism. And also the icons on top of the Tracking Station show me there is something.

Link to comment
Share on other sites

40 minutes ago, eberkain said:

Another suggestion, I would love to be able to see some orbital information about vessels without actually loading them, like orbital period would be handy to make sure satellite groups were in sync. 

If I'm not mistaken, KER has this information available in the Tracking Station.

Link to comment
Share on other sites

Now without RSS, I see a low-fps-in-Tracking-Station issue - and the selected debris (on ground) has no available buttons below the Tracked Objects list:
yiLK444.png

I see this in the log:

Exception handling event onVesselWasModified in class VesselStatsManager:System.ArgumentNullException: Argument cannot be null.
Parameter name: key
  at System.Collections.Generic.Dictionary`2[Vessel,TrackResource.ResourceStats].ContainsKey (.Vessel key) [0x00000] in <filename unknown>:0 
  at TrackResource.VesselStatsManager.Remove (.Vessel v) [0x00000] in <filename unknown>:0 
  at TrackResource.VesselStatsManager.Reload (.Vessel v) [0x00000] in <filename unknown>:0 
  at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0 
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

ArgumentNullException: Argument cannot be null.
Parameter name: key
  at System.Collections.Generic.Dictionary`2[Vessel,TrackResource.ResourceStats].ContainsKey (.Vessel key) [0x00000] in <filename unknown>:0 
  at TrackResource.VesselStatsManager.Remove (.Vessel v) [0x00000] in <filename unknown>:0 
  at TrackResource.VesselStatsManager.Reload (.Vessel v) [0x00000] in <filename unknown>:0 
  at EventData`1[Vessel].Fire (.Vessel data) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
EventData`1:Fire(Vessel)
RemoteTech.Modules.ModuleRTAntenna:AddTransmitter()
RemoteTech.Modules.ModuleRTAntenna:SetState(Boolean)
RemoteTech.Modules.ModuleRTAntenna:OnStart(StartState)
Part:ModulesOnStart()
<Start>c__Iterator0:MoveNext()
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
 
(Filename:  Line: -1)

Full log and stuff:
https://www.dropbox.com/s/uxuvpnd80uvlo54/2018-09-17_1 KSP.log and stuff.7z?dl=1

Link to comment
Share on other sites

@Gordon Dry Those exceptions are from Remote Tech and they seem to happen in the editor, so I don't know why they would have anything to do with the tracking station.

I don't know why the list isn't showing all of the available vessels. There are way too many mods in there to sort it out, so you'll have to try getting rid of mods to figure out where the problem is coming from (and make sure the stock tracking station list works correctly).

Any mod that makes any kind of changes to the tracking station or the tracking list is the first thing I would look at.

@eberkain Adding extra information is fine, but everyone has their own opinion about what is valuable enough to show in the limited amount of space available for each vessel. So aside from being more trouble than it's worth for me, it would mean trying to figure out the 1 or 2 most valuable things to add, or making some type of list of available info that players can choose from, which is never going to happen.

Edited by DMagic
Link to comment
Share on other sites

Does the tracking station mod change anything about how focused objects are positioned on the screen? In the screenshots in the beginning of the thread, it looks like focused celestial bodies are positioned on the right side of the screen for some reason, but in later screen shots it looks like the objects are centered.

I ask because of a particular annoyance I have with the stock tracking station that I don't think many other users are likely to talk about. A focused object is focused exactly in the center of the screen. And, for me, this is less than ideal. You see, I don't have a widescreen monitor. This 1280×1024 LCD monitor is, at 5:4, even more square than traditional TVs and monitors. The portion of the UI listing tracked / focusable objects occupies about ¼ of the horizontal screen real estate, and is nearly opaque. As a result, a focused object is considerably closer to the left edge of the usable display area than to the right. It would be really great if I could have focused objects centered within the region of the screen which is to the right of the list of tracked / focusable objects.

Link to comment
Share on other sites

@DMagic

So, about my Tracking Station problem - first I tried the most obvious and removed TrackingStationEvolved (two days ago already) - didn't work. Now, I removed everything but Squad folder and ModuleManager, created a new Sandbox and built a stock vessel, let it be on the launch pad. All okay. Exit, add TrackingStationEvolved - problem is there ... This gives me the conclusion that this mod IS one culprit, but not the only one ... damn it.

Then I removed TrackingStationEvolved again and moved back all the other mods, loaded the game and ... now the issue is gone.

So - at least I was able to pinpoint the issue: TrackingStationEvolved is the culprit.
But sometimes after removing it, the issue just persists...

And nothing in the log, no NRE, no error messages after switching to the Tracking Station.

F12 unlocking didn't help, btw.

Edited by Gordon Dry
Link to comment
Share on other sites

@Gordon Dry If the issue happens without Tracking Station Evolved installed, then it is not due to Tracking Station Evolved.

I've never seen a problem where an existing vessel either doesn't show up in the list, or doesn't have any functional buttons when selected. There was a problem with the vessel not registering as being selected after one of the 1.4.x updates, which could cause the buttons to not work, but that is fixed in the latest version.

There are a few rough edges that might cause weird behavior when there are no active vessels, or when you select one of the vessel categories with no active vessels in it (from the icons at the top of the screen), but that doesn't sound like the issues you are having.

All TSE does is take the vessel list from stock, move them off of the UI layer, then copy the data from that list of vessels to populate the new version of the vessel list. All of the vessel data and functionality of the vessel list runs through the stock vessel list (clicking on a vessel button in the TSE list simply passes on that mouse click to the stock vessel button). If a vessel doesn't appear in the TSE list, then it is likely because it doesn't appear in the stock list, also, for whatever reason.

Your log file shows that TSE seems to be initializing and loading properly, so I'm not sure where the problem is coming from.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...