maja

[KSP 1.8] Bon Voyage (1.0.0) - 2019-10-20

Recommended Posts

4 minutes ago, jaunco325 said:

These are the mods I have:

https://prnt.sc/oulzhu

if it seems good to you, I pass the file

No problem, pass it :)

Share this post


Link to post
Share on other sites
Posted (edited)

HI, i'm stuck with my rover on Duna

I used Kopernicus, and remove because drop FPS 60 to 6... 
But now,  BonVoyage always say it's not enough power, rover production is too low"
But i have 2K of energy, or if i pass in consol infinit electrical energy 

2x solar panels give 0.65 of= 1.3 of Generated power in Bon Voyage panel 

Why ?

I'm on BonVoyage 0.5.0, and only this mod in my gameData folder.

Edited by Yohaskan

Share this post


Link to post
Share on other sites

@jaunco325 It's what I thought. One of the wheels clipped to the terrain. BV tries to move a rover up during scene load to get clearance, but it can miss some bumps, if the terrain is uneven. There is probably nothing, I can do with it programatically. But the remedy is easy. Open the save file and edit the altitude of the rover. I added only a few meters and it was enough to get out of that terrain.

VESSEL
        {
            pid = 3b20fc5cb7a0433ab600e88a28f31ace
            persistentId = 2039132760
            name = Mini Rover lunar
            ...
            landedAt = Mun
            ...
            alt = 3400.440856645233

Share this post


Link to post
Share on other sites
19 hours ago, aluc24 said:

Thank you very much!!! Deleting these two dll's fixed it. Damn. I always update my mods manually (I read that's the better way as opposed to CKAN), and I always overwrite on top of the old versions of the mods so I get to save the configs. Never occurred to me that a situation like this could ever happen. How do I make sure this never happens again when updating mods?

Backup just the config, delete the folder, install the New one, make sure that the New config file has the same lay-out and variables as the old one. 

Or remember your settings, delete the old mod, install the new, and set it up again. 

 

Share this post


Link to post
Share on other sites
1 hour ago, maja said:

@jaunco325 It's what I thought. One of the wheels clipped to the terrain. BV tries to move a rover up during scene load to get clearance, but it can miss some bumps, if the terrain is uneven. There is probably nothing, I can do with it programatically. But the remedy is easy. Open the save file and edit the altitude of the rover. I added only a few meters and it was enough to get out of that terrain.

VESSEL
        {
            pid = 3b20fc5cb7a0433ab600e88a28f31ace
            persistentId = 2039132760
            name = Mini Rover lunar
            ...
            landedAt = Mun
            ...
            alt = 3400.440856645233

thank you

Share this post


Link to post
Share on other sites
Posted (edited)
8 hours ago, Yohaskan said:

HI, i'm stuck with my rover on Duna

I used Kopernicus, and remove because drop FPS 60 to 6... 
But now,  BonVoyage always say it's not enough power, rover production is too low"
But i have 2K of energy, or if i pass in consol infinit electrical energy 

2x solar panels give 0.65 of= 1.3 of Generated power in Bon Voyage panel 

Why ?

I'm on BonVoyage 0.5.0, and only this mod in my gameData folder.

The panels get changed by Kopernicus, so there’s nothing this mod can do about that. 

There’s a patch in the Kopernicus thread to work around the FPS problem though so I suggest you use that. 

Edit: I assumed the rover worked fine before and that the amount of generated power should be sufficient, but somehow wasn’t generated anymore. As Maja suggested, if the problem is just that there’s more power needed than available, just turn off some wheels. :P 

Edited by Jognt

Share this post


Link to post
Share on other sites

@Yohaskan you can try to turn off motors on some wheels. You need only two motorized wheels. It will lower rover's speed, but it will lower power demands too.

Share this post


Link to post
Share on other sites
Posted (edited)

Hmm... that's odd. I also reluctantly had to uninstall Kopernicus (as a dependency for SVT). What I did see is that every solar panel reverted to stock (as expected), and every solar panel was retracted and its action group assignment was gone. The amount of EC generated though was unchanged. I'm still using BV 0.14.9, don't know if that makes any difference (why would it)?

Edited by VoidSquid

Share this post


Link to post
Share on other sites

@Maja, too bad for this rover, I preferred to put an end to his mission. which is strange because the same model on Earth or Mimnus continues to work (even if the solar yield is stronger in these places).
@VoidSquid In fact I had a chain of problems that triggered with the last DLC and I had to test, desinstaler one or the other mods, and reinstal other version them. Now i have a big mess in my active save game. They continue to want Copernicus Solar panel but i do not want. And some vessel seem to work badly.
I do not know how to reset and keep all my save.
May be parsing and cleaning any code mentions added in .sfs files by mods.

Share this post


Link to post
Share on other sites

I still don't get it: how is it possible that your stock, non-Kopernicus, solar panels give you that significant less EC/s ?
Very odd, to say the least.

Share this post


Link to post
Share on other sites
2 hours ago, Yohaskan said:

@Maja, too bad for this rover, I preferred to put an end to his mission. which is strange because the same model on Earth or Mimnus continues to work (even if the solar yield is stronger in these places).
@VoidSquid In fact I had a chain of problems that triggered with the last DLC and I had to test, desinstaler one or the other mods, and reinstal other version them. Now i have a big mess in my active save game. They continue to want Copernicus Solar panel but i do not want. And some vessel seem to work badly.
I do not know how to reset and keep all my save.
May be parsing and cleaning any code mentions added in .sfs files by mods.

Check to make sure the Kopernicus folder is gone. Sometimes parts linger and cause problems. 

Share this post


Link to post
Share on other sites

@jognt ?
Where? in my gameData i have only Bon voyage, Squad and Squad extention (with ModuleManager.4.0.2.dll)

 

Share this post


Link to post
Share on other sites
Posted (edited)

Is there any way of hiding the biome from being displayed when you are picking a location on the map? I want to use satscan for locating biomes.

Edited by Spagoose

Share this post


Link to post
Share on other sites
1 hour ago, Spagoose said:

Is there any way of hiding the biome from being displayed when you are picking a location on the map? I want to use satscan for locating biomes.

No. If you mean SCANsat mod, then remedy is easy. Don't use BV before you scan planet/moon for biomes.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, it's me again (the rover who appeared buried). It happened to me again, but besides being buried I was also lying back. In the file you showed me the other day, how did the rotation change?

Edited by jaunco325

Share this post


Link to post
Share on other sites

reading that I think I saw the problem: "Rotation of a rover or a vessel depends on the orientation of the root part."
I thought it was based on the command module.
Thank you.

Share this post


Link to post
Share on other sites
Posted (edited)

New version

0.5.1

Changes

  • Suport of servo rotors from the Breaking Ground DLC for ship controller

 

If you have Breaking Ground DLC, then you can use EM line of rotors and turboshaft engines (you can find them in the Robotics tab). Setting up a test ship with two rotors, each with four propeller blades, was a pain, but it worked surprisingly well. I recommend to bind RPM to throttle, set torque to some sensible value (25% is enough) and use control group to toggle deployment of propellers. If you use two rotors, then you can easily turn your craft by toggling deployment of propellers on each rotor. And you need one rotor to turn clockwise and second counter clockwise if you do not want to turn your craft upside down :D

Edited by maja

Share this post


Link to post
Share on other sites
5 minutes ago, zer0Kerbal said:

Just when KAS dumped its anchors...

??

Share this post


Link to post
Share on other sites
5 minutes ago, zer0Kerbal said:

Just when KAS dumped its anchors...

Tbf.. that’s kind of what anchors are for. ;) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.