Theysen

[1.4.5] Real Solar System v13.1 [03 Sep 2018]

Recommended Posts

41 minutes ago, chriscarp_14 said:

Update for 1.5.0? Pls

Welcome to the forums :)  two things:

  1. RSS has been working fine for many peeps in 1.5.x and also appears to work just great in 1.6, so go ahead and play.
  2. it's against community rules to bug modders about updating, I know it's common on Steam and other places for people to keep asking for updates, but it's not something that's done on KSP Forums. Modders are working for free and at their own pace. 
  • Like 3

Share this post


Link to post
Share on other sites
On 1/7/2019 at 5:52 PM, Tyko said:

Welcome to the forums :)  two things:

  1. RSS has been working fine for many peeps in 1.5.x and also appears to work just great in 1.6, so go ahead and play.
  2. it's against community rules to bug modders about updating, I know it's common on Steam and other places for people to keep asking for updates, but it's not something that's done on KSP Forums. Modders are working for free and at their own pace

Ok thank you very much, I thought it was only for one version, so I'm going to install it to see if it works, thank you very much :)

  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)
51 minutes ago, chriscarp_14 said:

Ok thank you very much, I thought it was only for one version, so I'm going to install it to see if it works, thank you very much :)

sure thing. The limiting factor is usually Kopernicus. That's the mod that enables all the planet packs. Kopernicus is locked to a specific KSP version, so if that's not updated no planet pack will work. As long as Kopernicus is updated though most planet packs will work even if they haven't been updated.

Edited by Tyko

Share this post


Link to post
Share on other sites

So, unfortunately, I have not seen an answer to my question and I would like to try and ask it again. My question; is it normal for the sun to come up at around 12:30 (KSP day using the RSS Date Time Format mod) or could I have done something wrong during the process of installing the mod? My family and I were stationed in Florida for several years and I can attest that the sun never came up at almost 13:00 hours. I have read, during my lengthy searches, that this is a limitation of the implementation of system inclination within KSP; however, I would like to find out if that is the fact; or, being new to KSP maybe I made a mistake during installation.

Thank you in advance.

Share this post


Link to post
Share on other sites
2 hours ago, Phineas Freak said:

@DKShang The game clock is outputing the time in UTC.

Ah, that would make sense. As obvious as that may seem I honestly had not considered it. So, it's not that I installed something incorrectly, it's a matter of my inexperience with the game overall. Well, thank you for putting my mind at ease. 

Share this post


Link to post
Share on other sites
23 hours ago, Tyko said:

sure thing. The limiting factor is usually Kopernicus. That's the mod that enables all the planet packs. Kopernicus is locked to a specific KSP version, so if that's not updated no planet pack will work. As long as Kopernicus is updated though most planet packs will work even if they haven't been updated.

The mod worked perfectly but the problem is that now I need rockets of many stages and bigger to make them reach a maneuver and that is almost perfect, this makes it difficult for the missions, I wanted to know if it is normal or if I I have skipped some mod to download

Share this post


Link to post
Share on other sites
1 hour ago, chriscarp_14 said:

The mod worked perfectly but the problem is that now I need rockets of many stages and bigger to make them reach a maneuver and that is almost perfect, this makes it difficult for the missions, I wanted to know if it is normal or if I I have skipped some mod to download

RSS is 10x scaled over Stock. So it takes over 3 times as much fuel to perform a maneuver. I'm not sure RSS is really playable with stock parts. Like you said, you'd need much bigger stages and many more of them. I'd read the initial post for this thread. It suggests other mods to use with it.

Share this post


Link to post
Share on other sites
9 hours ago, Tyko said:

RSS is 10x scaled over Stock. So it takes over 3 times as much fuel to perform a maneuver. I'm not sure RSS is really playable with stock parts. Like you said, you'd need much bigger stages and many more of them. I'd read the initial post for this thread. It suggests other mods to use with it.

It actually is possible with stock parts.... you've got 3.75m parts so you could do Falcon Heavy type launches (but with standard propellant loads since we don't have super chilled propellants, though it's technically possible for RF to handle that)

Manned lunar would be harder; no all-up Saturn V launches.

So yeah, it's definitely possible but you're not going to want to.

  • Like 1

Share this post


Link to post
Share on other sites
On 4/3/2018 at 4:26 AM, Theysen said:
Manual installation:
1. Download Kerbal Space Program 1.3.1 and create a fresh install on your hard drive.

Should be 1.4.5

Share this post


Link to post
Share on other sites
11 hours ago, chriscarp_14 said:

now I need rockets of many stages and bigger to make them reach a maneuver and that is almost perfect, this makes it difficult for the missions, I wanted to know if it is normal or if I I have skipped some mod to download

Stock parts were deliberately gimped by Squad, because parts with realistic masses and performance characteristics would make the toy-sized stock solar system so trivially easy that the game wouldn't be fun.  Any craft built using stock parts (or mod parts balanced with stock parts) will have the same unrealistically poor performance.

In a realistic, full-sized solar system like RSS, you can either use the Realism Overhaul mod to give the parts accurate real-world masses and performance, or use something like the SMURFF mod to rebalance the stock parts to have more realistic characteristics. 

Edited by RoboRay

Share this post


Link to post
Share on other sites
1 hour ago, Duck1998 said:

Should be 1.4.5

But 1.3.1 will never leave my heart.

 

Will change, thanks! :P

Share this post


Link to post
Share on other sites

I am still happily playing RSS on KSP 1.3.1 and would like to take the opportunity here to express my gratitude to all involved parties, RSS crew all the way back, the RSSVE people, just all involved individuals. It is a great set of mods and it still gives me tons and tons of entertainment.

Share this post


Link to post
Share on other sites

How was Omelek Island added?

This is how it appears in-game:

1l6ObWF.png

but according to the land + water textures layered together, the texture resolution (even at 8192 x 4096) is not fine enough to account for the shape of the island (which seems to be bigger than its real life counterpart).

d86Sm2y.png

So how was it added? Was it hard-coded? I need to know because I want to make an custom imaginary island in the Pacific, if that's even possible.

edit: the heightmap doesn't seem to correspond to the shape of the island either

PCDKS4L.png

 

Edited by Pipcard

Share this post


Link to post
Share on other sites
7 hours ago, Pipcard said:

How was Omelek Island added?

Omelek only appears because you selected it as a launch site with KSCSwitcher, if you traveled there from another launch site you would see nothing but open ocean. 

I don't understand your second an third images, what are you trying to show?

If you want to build your own island you will need to use custom height maps. It is possible to do so with Kopernicus, but the method is very awkward and documentation is poor. My main problem is that it uses x,y,z coordinates rather than Lat/Lon/Elevation and KittopiaTech seems to crash a lot (at least when working on Earth).

I've had more success modifying terrain using Kerbal Konstructs (see the ??? link in my sig for a couple examples of real places I've brought into the game). Get or create a heightmap then you can edit it's appearance in game. If you want to use a real place you can get decent heightmaps from a website unfortunately titled terrain.party , otherwise you may need to use a GIS for higher resolution heightmaps. 

Share this post


Link to post
Share on other sites

Dose it have real physic or is that a different mod?

Share this post


Link to post
Share on other sites
13 minutes ago, MSA said:

Dose it have real physic or is that a different mod?

I believe you are looking for Principia

 

Share this post


Link to post
Share on other sites

[snip]  Can you please give the reigns of this mod to someone else who has more free time? I've been waiting so long for it to be updated and last time it was, someone else had done it. Maybe give it to them since they are willing? I absolutely love this mod but the wait is killing me. 

Edited by Snark
Redacted by moderator

Share this post


Link to post
Share on other sites
1 hour ago, Blyet Nye the Soviet Guy said:

Can you please give the reigns of this mod to someone else who has more free time? I've been waiting so long for it to be updated and last time it was, someone else had done it. Maybe give it to them since they are willing? I absolutely love this mod but the wait is killing me. 

A few things:

  • Modders pour a lot of effort into their creations, asking nothing in return.  About the only reward they get for their efforts is "pride of ownership", so I'd suggest not pushing in that direction.  It's great that you love the mod; but on the "tact scale", asking this kind of thing is kind of like asking a young parent "beautiful child you've got there, can I have it?"  ;)  It's entirely up to the modder if they feel like no longer supporting a mod, and not our place to needle them about it.
  • If you look at the license for the mod, you'll note that it's CC-BY-NC-SA, meaning that "giving ownership" isn't even a thing:  the author has explicitly declared that anyone who wants to can produce derivative works (such as updated versions).  That's not to say that I'm encouraging people to do this without at least checking with the original author... proliferation of "forks" of one's mods can be a nightmare for the author.  But it does mean that you're asking the wrong question.  A better thing to ask would be something like, "I'd love to produce an updated version myself, which it looks like the license allows; would you mind?"
  • Is it even necessaryYou're complaining about "waiting so long for it to be updated".  Do you have a reason to think that it needs updating?  Is it not usable in its current state?  I only ask because I've just now read the last page or so of comments here-- recent ones, from just a couple of weeks ago-- and it sure looks as though people are talking about this mod in the present tense.  Also, there's the fact that it's a Kopernicus-based mod, and such mods generally tend not to be KSP-version-dependent.  Unless KSP undergoes a major engine change (which it hasn't done since 1.1), such mods generally go on working forever, as long as Kopernicus itself gets updated (which it has been, there's currently a Kopernicus version that works in 1.6.1).

In short:  You may already have the thing you want-- have you verified that you don't?  ;)

  • Like 7

Share this post


Link to post
Share on other sites
3 hours ago, Blyet Nye the Soviet Guy said:

[snip]  Can you please give the reigns of this mod to someone else who has more free time? I've been waiting so long for it to be updated and last time it was, someone else had done it. Maybe give it to them since they are willing? I absolutely love this mod but the wait is killing me. 

If you want to use this mod then you should downgrade KSP to version 1.3.1 or 1.4.5. In case you also care about making the game pretty, then I would recommend 1.3.1  because RSSVE does not currently work on any higher versions.

Even though the current release of RSS might also partially work on newer KSP versions, part of it's functionality will definitely be locked down by version checks. Getting a fully working copy for KSP 1.5 or 1.6 requires some knowledge of Git/GitHub + editing and recompiling C# code.

  • Like 2

Share this post


Link to post
Share on other sites
6 hours ago, siimav said:

If you want to use this mod then you should downgrade KSP to version 1.3.1 or 1.4.5. In case you also care about making the game pretty, then I would recommend 1.3.1  because RSSVE does not currently work on any higher versions.

Agreed. I was able to get RSS working fine (for me) in KSP 1.6. However, what is RSS without Earth clouds and pretty water? For that, I had to go back to KSP 1.3. There is no current way around it.

I do miss some of the game improvements that have been made since KSP 1.3 and various mod improvements that have been made and which are not backward compatible with 1.3.

At the end of the day (for now), if you want to play with Real Solar System at its best, run it in KSP 1.3x with RSSVE (visual enhancements).

Edited by Observe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now