Paul Kingtiger

Universal Storage II [1.3.1 and 1.4.5 - 1.7.0]

Recommended Posts

1 hour ago, StevieC said:

@Paul KingtigerI'm currently watching @TheReadPanda's KSP stream and he mentioned wondering about the possibility of a retractable solar panel in a Universal Storage II wedge form-factor. He also mentioned it'd be nice to have a comms antenna in wedge form-factor (I thought, perhaps two each for direct and relay, with the more powerful ones needing to be deployed but the less powerful ones not needing deployment to work?) I also imagined that some wedge-form-factor radiators (retractable or otherwise) might also be a useful thing to have. Just suggesting, is all.

We've been playing around with having radiators on the inside of the fairing doors, like the Space Shuttle used.  We don't have models for it, but the code is complete and working.  The code could be adapted for solar panels as well, but I don't know if we would get the models updated to include the panels.  We'll add solar wedges to the request list (I believe communication gear is already on the list).

Share this post


Link to post
Share on other sites

Hello everyone, 
I'm going to try a different approach to the next release.  Rather than put it straight up on SpaceDock I'm going to offer it here as a 'release candidate'.

The files are ready to go but have only been tested by me, so there's a lack of robust QA. Having said that: 1.5.1.8 and 1.3.1.8 are ready to go and can be downloaded from:
https://1drv.ms/f/s!AvmqbLkW8UIH2PsfIYBmSwhNfYG-pw

Change log:

  • Fixed KIS compatibility for wedges, they should now correctly mount on a Kerbal's back as they did before 1.5
  • New resource amounts based on balancing with each life support mod.  New values can be found in the spreadsheet (in the link above) as shown in green.  These changes should make the UvSii parts less OP/UP than the Life Support mod you use.

 

Coming next: New balance pass on processors, we're waiting on new models for that so not sure when it'll be.

If you find any issues please let me know.  If it all looks good I'll push this release out to Spacedock in a week or so.

 

Edited by Paul Kingtiger

Share this post


Link to post
Share on other sites

Love this mod, unfortunately, most contracts dont except these parts. My only complaint. I would have to say that other part mods are the same way though. I guess the problem with that is having mod parts in balance with other parts. An ongoing problem it seems given the diverse amount of ways KSP can be played. Must be tough on mod makers to try and cope with all of that.

Share this post


Link to post
Share on other sites
18 hours ago, Kevin Kyle said:

Love this mod, unfortunately, most contracts dont except these parts. My only complaint. I would have to say that other part mods are the same way though. I guess the problem with that is having mod parts in balance with other parts. An ongoing problem it seems given the diverse amount of ways KSP can be played. Must be tough on mod makers to try and cope with all of that.

Do you mean part testing contracts? We can always try implement that if people want it :)

Share this post


Link to post
Share on other sites

No, other contracts, sat contracts I believe were some of them. I should be writing down the ones that wont let me but I didnt. But, to be honest, Im not positive my much modded build is working exactly as it should. I have doubts about it. I have had contracts that I get warnings about it not having a agency name or something like that. I can find them in the tracking station and sure enough, there is no name on the orbit but I can match that up with a contract in the list by matching the orbit parameters. Things like that I have going on. I dont know why. I will try and keep an eye out for a contract like I am talking about. There are other parts from other mods not allowed in contracts as well. Maybe its on purpose or it hasnt been implemented.

Share this post


Link to post
Share on other sites
On 12/2/2018 at 6:19 AM, Kevin Kyle said:

No, other contracts, sat contracts I believe were some of them. I should be writing down the ones that wont let me but I didnt. But, to be honest, Im not positive my much modded build is working exactly as it should. I have doubts about it. I have had contracts that I get warnings about it not having a agency name or something like that. I can find them in the tracking station and sure enough, there is no name on the orbit but I can match that up with a contract in the list by matching the orbit parameters. Things like that I have going on. I dont know why. I will try and keep an eye out for a contract like I am talking about. There are other parts from other mods not allowed in contracts as well. Maybe its on purpose or it hasnt been implemented.

Are you in 1.5?

It sims contract-configurator is not working correctly in 1.5

 

 

Share this post


Link to post
Share on other sites
1 minute ago, danielboro said:

Are you in 1.5?

It sims contract-configurator is not working correctly in 1.5

 

 

Ya. 1.5.1.1. That might be my problem then. I knew I was pushing boundaries when I started this build and career. Too many mods on a new version of KSP was bound to have some issues. Considering all, its actually working pretty well.

Share this post


Link to post
Share on other sites
On 11/21/2018 at 10:07 PM, bobvodka said:

I've hit upon an interesting little problem with US2.0 and Connected Living Spaces and I figure this is a good place to start with the whole 'trying to track down what is going on'.

 

OK, so it took me a bit longer than I wanted to get back to this but I've managed to reproduce it with only the following mods installed; 

  • Module Manager : 3.1.2
  • Connected Living Spaces : 1.2.6.2 (latest on CKan anyway, only compatible to 1.4.99)
  • Universal Storage 2 : 1.5.1.7
  • Community Resource Pack : 1.0.0.0

KSP version 1.5.1.2335

Lashed together a quick 'station core' (docking port, 2.5 meter command pod, science lab, 8 core double height US2 wedge, 2.5 double height fairing, 2.5 meter command pod, docking port) which CLS was happy with being one 'space'. Saved it. Made it a sub-assembly. 

Left, VAB, reentered, built a quick command module + engine + decouple setup, shoved a docking port on the bottom; dragged the sub-assembly in and bam! Disconnected at the same place. 

Looking at the two files the problem is the same as before; 

// Working
link = USCylindricalShroud250_4294427370
attN = StackNodeUpper,Large.Crewed.Lab_4294507316_0|0.612|0
attN = StackNodeCentral,USCylindricalShroud250_4294427370_0|-0.2040291|0

// Not working
link = USCylindricalShroud250_4294427370
attN = StackNodeUpper,Large.Crewed.Lab_4294507316_0|0.612|0

The two craft files in question can be found here; https://gist.github.com/bobvodka/acba0753f82f0f12634d13ca27d259bb

With the 'Lifter Start.craft' being the broken one, with the 'Station Core.craft' having been merged in to it.

Hope that is all some help :)

Edited by bobvodka

Share this post


Link to post
Share on other sites
On 11/16/2018 at 4:09 PM, Paul Kingtiger said:

Universal Storage 1 was balanced vs the Apollo and Shuttle fuel cells.  Universal Storage 2 is balanced against the stock fuel cells.

I'm currently working on a big balance update so these values may change.  I've already updated the capacity of resource tanks ready for the next release and am working on the processors.

I'd suggest not nerfing the US II fuel cells anymore than you already have.  I'll agree that US I FC balance was a bit OPed, but I'd think that it should still be better than Stock as pure H2 reactions should be more efficient than a complex hydrocarbon (LF) that needs steam reformation and other nastiness filters to separate the H2 from the less useful molecules.

A couple of suggestions I have, aside from revisiting the balancing:

1) The fuel cells should ideally automatically turn off when there's an alternate power supply available, specifically solar.  The USI/MKS fuel cells have a feature where they only engage when overall energy drops below 95%.  This eliminates the need to constantly have to manually switch the FC on and off when going in and out of shadows during orbit.  Right now the US II FCs seem to sputter along at relatively low consumption when solar is available.

2) This probably was brought up at some point a long time ago, but it would be nice to have an alternate reactant mode for Liquid Hydrogen (as used in NFT Cryogenic Engines and various NTRs) and Oxidizer.  Lacking that, maybe a converter for LH2 to H2 and Ox to O2.

Also, if it hasn't already been brought to your attention, USI Life Support is supposed to have a pre-release out in the Constellation that includes a part-breaking overhaul of life support/converter modules.  The MKS and USI-LS threads talk to it, and some users are assisting by either writing band-aid search-and-replace patches or offering support to work PRs.

Share this post


Link to post
Share on other sites
On 12/3/2018 at 6:19 PM, bobvodka said:

OK, so it took me a bit longer than I wanted to get back to this but I've managed to reproduce it with only the following mods installed; ...

That's a first class bug report, thank you for the detailed feedback!

Share this post


Link to post
Share on other sites

I finally got to start playing around with US II a few weeks ago, and I have to say that the revamp is truly top-notch. You guys really outdid yourselves (and just about everyone else) and made a great mod truly legendary. Thanks for all the hard work!

Looking forward to seeing those radiator parts!

Share this post


Link to post
Share on other sites
On ‎12‎/‎2‎/‎2018 at 11:36 PM, danielboro said:

Are you in 1.5?

It sims contract-configurator is not working correctly in 1.5

 

 

Contract Configurator just updated to 1.5.1, be sure to go to the thread and thank the author Nightingale, who has been kept away by events.

Share this post


Link to post
Share on other sites

Hello out there,

after some attempts I would like to ask here, how I use EVA-X.
In several videos about KAS and US I saw that I can apply EVA-X via context menu. However, this menu item does not exist with me. See picture.

2018-12-11-195613_1920x1200_sc.jpg

KAS otherwise works normally, I can remove and mount everything (including EVA-X), stow it in my backpack, etc. But I don't know how to apply and use EVA-X.

Have I overlooked anything?

KSP 1.5.1

US II 1.5.1.7 for 1.5.1

KAS 1.1 for 1.5.1

 

Thanks

Alex
***

 

 

Edited by AlexO

Share this post


Link to post
Share on other sites
1 hour ago, AlexO said:

KAS otherwise works normally, I can remove and mount everything (including EVA-X), stow it in my backpack, etc. But I don't know how to apply and use EVA-X.

Im hoping one of the devs will comment, but I know the new KAS has changed the way KAS works and broke many mods that supported the older version.
US 2 may not have been updated to reflect the new changes yet... vOv

Share this post


Link to post
Share on other sites

Is there a special place for wedge requests?  Cause I never stop having ideas for wedges.

You guys are doing outstanding work, and these are by no means "OMG I wants" but just some ideas I've had, sorry if they've been requested before.  If I had any modding ability whatsoever, I'd be making wedge packs!

  • Deployable solar panels.
  • Deployable high gain / relay antennas.
  • Short deployable sticks with RCS thrusters.
  • Very small decouplers to make the wedges eject-able.
  • Eject-able fairings (look/feel of what you have now, but eject-able)
  • Deployable landing legs!
  • Crew cabins in addition to the crew tubes.
  • Deployable ladders.

Basically I want to make USII-only ships.

 

 

 

 

 

Share this post


Link to post
Share on other sites
15 hours ago, AlexO said:

Hello out there,

after some attempts I would like to ask here, how I use EVA-X.
In several videos about KAS and US I saw that I can apply EVA-X via context menu. However, this menu item does not exist with me. See picture.

2018-12-11-195613_1920x1200_sc.jpg

KAS otherwise works normally, I can remove and mount everything (including EVA-X), stow it in my backpack, etc. But I don't know how to apply and use EVA-X.

Have I overlooked anything?

KSP 1.5.1

US II 1.5.1.7 for 1.5.1

KAS 1.1 for 1.5.1

Thanks

Alex

A few posts above you had a small hotfix release to solve that problem, KAS did indeed change the way they dealt with part attachment, so we had to update all the code and stuff to match. USII 1.5.1.8 should fix that problem :D

13 hours ago, Stone Blue said:

Im hoping one of the devs will comment, but I know the new KAS has changed the way KAS works and broke many mods that supported the older version.
US 2 may not have been updated to reflect the new changes yet... vOv

:prograde::D:prograde:

8 hours ago, Geonovast said:

Is there a special place for wedge requests?  Cause I never stop having ideas for wedges.

You guys are doing outstanding work, and these are by no means "OMG I wants" but just some ideas I've had, sorry if they've been requested before.  If I had any modding ability whatsoever, I'd be making wedge packs!

  • Deployable solar panels.
  • Deployable high gain / relay antennas.
  • Short deployable sticks with RCS thrusters.
  • Very small decouplers to make the wedges eject-able.
  • Eject-able fairings (look/feel of what you have now, but eject-able)
  • Deployable landing legs!
  • Crew cabins in addition to the crew tubes.
  • Deployable ladders.

Basically I want to make USII-only ships.

Thanks for the praise, we aim to please! :P

So we have a rough roadmap going forward...
* Solar panels are planned
* Radiator systems are planned
* Antennas are planned
* Stock science parts are coming 
* Radial wedge mounting trusses are coming
* Control (probe) brains are coming
* Jettisonable doors of certain shrouds are being looked at
* Bulk tanks (one day, urgh!) 

..but I think starting on crewed parts would be such a massive undertaking i'd rather not even think about it. Not sure about RCS systems but if i were to make them, they'd be 'built in' to the doors so the structure existed under the shroud, and the nozzles stuck out from the surface. It's how i'll be approaching the low gain scimitar antenna like the Apollo CSM used - you'll have the immobile blade structure on the outside of the craft, and a bit of machinery in the bay underneath it. I dunno. 

Share this post


Link to post
Share on other sites

Thanks again for this great mod :)

Small problem: when using US2 fuell cell with TAC life support I get "run out of electricity" warning for unloaded vessels at high time- warp. I guess this is due to the way the TAC deals with resource processing during time- warp - and maybe should be posted in TAC life support forum?

 

 

Edited by Walker

Share this post


Link to post
Share on other sites
2 hours ago, Daishi said:

A few posts above you had a small hotfix release to solve that problem, KAS did indeed change the way they dealt with part attachment, so we had to update all the code and stuff to match. USII 1.5.1.8 should fix that problem :D

Oh thank you I've overlooked that. I'll check this out. 

 

Edit: Nope, sorry. Same problem with 1.5.1.8. No entry in context menu of EVA-X.

Edited by AlexO

Share this post


Link to post
Share on other sites
7 hours ago, Daishi said:

..but I think starting on crewed parts would be such a massive undertaking i'd rather not even think about it

I wasn't thinking of its own part, but  just another switch on the hex and octo cores. 

Crew Tube/Monopropellant/LFO/Xenon/CrewCabin so we could actually store kerbals inside the core.  Is that doable?

Share this post


Link to post
Share on other sites
On 12/13/2018 at 2:24 AM, AlexO said:

Oh thank you I've overlooked that. I'll check this out. 

 

Edit: Nope, sorry. Same problem with 1.5.1.8. No entry in context menu of EVA-X.

Can you at least attach it to the kerbal? Hold g and drag it into their inventory (or whatever key it was?)

On 12/13/2018 at 7:16 AM, Geonovast said:

I wasn't thinking of its own part, but  just another switch on the hex and octo cores. 

Crew Tube/Monopropellant/LFO/Xenon/CrewCabin so we could actually store kerbals inside the core.  Is that doable?

I'd rather get some fancy new parts done first, to be honest, but maybe in the future.

On 12/13/2018 at 1:46 AM, Walker said:

Thanks again for this great mod :)

Small problem: when using US2 fuell cell with TAC life support I get "run out of electricity" warning for unloaded vessels at high time- warp. I guess this is due to the way the TAC deals with resource processing during time- warp - and maybe should be posted in TAC life support forum?

I think it is TAC, i remember having the same problem ages ago with the stock system. Might just be a limitation of their processing? Not sure.

Share this post


Link to post
Share on other sites

Bug: Oxidizer runs out before LiguidFuel. (The 9-to-11 ratio is configured backward.)

The "Universal Storage: Radial Tank" part seems to have the stock 9 to 11 ratio for LiquidFuel to Oxidizer backward.  It should be 9 parts Liquidfuel per 11 parts Oxidizer, or so I thought.  When I tried making a service module with lots of these little tanks in it, it ran out of Oxidizer when there was plenty of Liquidfuel left.

I think the culprit is this config in GameData/UniversalStorage2/Parts/Radial/RadialTanks.cfg :

                name = USFuelSwitch
                SwitchID = 0
                resourceNames = Oxygen;Hydrogen;MonoPropellant;LiquidFuel,Oxidizer
                resourceAmounts = 3600;3600;3.5;3.7,3
                initialResourceAmounts = 3600;3600;3.5;3.7,3

Notice the way it is set up, it's assigning the "3.7" value to the LIquidFuel, and the "3.0" value to the Oxidizer. Notice that the ratio of "3.7" to "3.0" is almost exactly 11 to 9.  So I think it *is* the right ratio, just swapped around so you have more liquid than oxidizer instead of the other way around like it should be for stock fuel.

I haven't looked at any of the other part configs to see if they have the same problem.  For all I know they might.  I just happened to encounter the problem with this one.

Edited by Steven Mading

Share this post


Link to post
Share on other sites
17 hours ago, Steven Mading said:

Bug: Oxidizer runs out before LiguidFuel. (The 9-to-11 ratio is configured backward.)

The "Universal Storage: Radial Tank" part seems to have the stock 9 to 11 ratio for LiquidFuel to Oxidizer backward.  It should be 9 parts Liquidfuel per 11 parts Oxidizer, or so I thought.  When I tried making a service module with lots of these little tanks in it, it ran out of Oxidizer when there was plenty of Liquidfuel left.

I think the culprit is this config in GameData/UniversalStorage2/Parts/Radial/RadialTanks.cfg :


                name = USFuelSwitch
                SwitchID = 0
                resourceNames = Oxygen;Hydrogen;MonoPropellant;LiquidFuel,Oxidizer
                resourceAmounts = 3600;3600;3.5;3.7,3
                initialResourceAmounts = 3600;3600;3.5;3.7,3

Notice the way it is set up, it's assigning the "3.7" value to the LIquidFuel, and the "3.0" value to the Oxidizer. Notice that the ratio of "3.7" to "3.0" is almost exactly 11 to 9.  So I think it *is* the right ratio, just swapped around so you have more liquid than oxidizer instead of the other way around like it should be for stock fuel.

I haven't looked at any of the other part configs to see if they have the same problem.  For all I know they might.  I just happened to encounter the problem with this one.

Thanks, I'll get that updated.

Share this post


Link to post
Share on other sites

New Update Released

Universal Storage II 

1.5.1.8 released (1.3.1.8 for KSP 1.3.1)

  • This update completely re-balances the resource capacity for wedges to be more balanced against 3rd party mods.  This means that capacity of the Oxygen wedge with TAC Life Support installed is completely different to having Kerbalism installed.  Details on the new values (highlighted green) are available here: https://1drv.ms/x/s!AvmqbLkW8UIH2OwefpQDu5RRUqEvDg
  • The mod has also been updated to match changes in KIS, so you should be able to carry wedges and the EVAx again.

Note this release is identical to the 1.5.1.8 beta release so if you already have that installed there is no need to update.

 

Download from SpaceDock

Make sure you download the correct version. 

  • 1.5.1.8 for KSP 1.5.1
  • 1.3.1.8 for KSP 1.3.1

https://spacedock.info/mod/1933/Universal Storage II/download/1.5.1.8

https://spacedock.info/mod/1933/Universal Storage II/download/1.3.1.8

 

Edited by Paul Kingtiger

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.