Ender1618

Unity Version for Mod dev for KSP 1.6.1

Recommended Posts

I am interested in writing a mod for KSP  1.6.1, first time modder.

What version of Unity should i install?

There are versions mentioned on the wiki, but the post are old, and i wondered if they are still correct.

 

Thanks,

-Ryan

Share this post


Link to post
Share on other sites

Hi welcome to the forums...

The best way to do a search on the forum, even better than the built-in forum search box, is to Google the word kerbal, followed by your search term.
Also using the Tools-> Any Time function to narrow down recent results (using past month), would net you as the first result, this thread addressing this same exact question from two days ago:
 

I mention the Google instructions, because you will find it very helpful on your next questions: where to begin to find results on how to start learning how to mod for KSP specifically. ;)

Edited by Stone Blue

Share this post


Link to post
Share on other sites
On 3/18/2019 at 5:36 PM, Stone Blue said:

Hi welcome to the forums...

The best way to do a search on the forum, even better than the built-in forum search box, is to Google the word kerbal, followed by your search term.
Also using the Tools-> Any Time function to narrow down recent results (using past month), would net you as the first result, this thread addressing this same exact question from two days ago:
 

I mention the Google instructions, because you will find it very helpful on your next questions: where to begin to find results on how to start learning how to mod for KSP specifically. ;)

Well I have been searching around both using Google and on the forums for at least more than 15 minutes now and havent been able to find this information.

[snip]

If you search Google(as you suggested) "Kerbal Unity Version for Mod dev for KSP 1.6.1" this thread is the first search result.  There is no definitve answer to this question on any of the links in the first page of Google results.  Only clue is for "Unity Part Tools" which is NOT the same as Kerbal unity version which gives a version number of :

Unity 2017.3.1p1

KSP 1.6.1- > Unity 2017.1.3p1 download: ( https://beta.unity3d.com/download/02d73f71d3bd/UnityDownloadAssistant-2017.1.3p1.exe ) page : ( https://unity3d.com/unity/qa/patch-releases?version=2017.1 ), unity version now confirmed working

I have no idea if this is right or not.

[snip]

Gavin786

Edited by Deddly

Share this post


Link to post
Share on other sites

[snip]
As to the *exact* version of Unity needed, KSP seems to have been upgraded to 2017.1.3p1 ... As stated by an actual Squad developer in a post which I directly linked to in my response on the other thread.

the "...p1, .p2, p3, ...etc" suffix is a patch number only... the base version is still 2017.1.3... patch releases offer bug fixes and possibly minor feature additions to the base version.
If you dont feel confident in taking someone's word that a minor version update will be sufficient to work with current version of KSP, thats fine... Just use the *exact* version stated by the OP in the PartTools thread. [snip]

Edited by Deddly

Share this post


Link to post
Share on other sites
14 minutes ago, matthewjd24 said:

Hi, do you know if this is still accurate? I've been searching everywhere to find what version 1.7 uses but no luck :(

Should be...
this post is from an actual, official Squad/KSP dev. He's been excellent in keeping it updated any time theres a Unity upgrade for KSP:

 

Share this post


Link to post
Share on other sites

So he says

Quote

PartTools has been updated to align with KSP 1.7.0.

Link in the opening post above.
This includes the new part shader.

NB: PartTools still requires Unity 2017.1.3p1.

This means I should use Unity 2017.1.3p1? Sorry, brand new to all of this :O speaking of which, do you know of any good resources to get started on modding?

Share this post


Link to post
Share on other sites

yea... KSP most likely will never have another Unity update, so likely that version will be the same for all future KSP upfdates...
If it *does* get a Unity update at some point, I'm sure JPL will update that thread.
@matthewjd24

Also Google will most likely be your best bet... the forum search function succs... theres *tons* of decent KSP modding tutes and threads out there...
Just depends on what aspects of modding you're looking to get into. just use google to get started... most threads/tutes will have links and terminology which you can use to better specify google searches... Its all out there, tho ;)

Edited by Stone Blue

Share this post


Link to post
Share on other sites

Well actually KSP 1.8 is being upgraded to Unity 2019.2.2f1 (this was announced yesterday) and a new parttools will be released for it. Part tools works with the Unity version the game runs on. So currently KSP 1.7.3 is unity 2017.1.3p1 and so to use parttools you must use that version.

Share this post


Link to post
Share on other sites
21 minutes ago, JPLRepo said:

Well actually KSP 1.8 is being upgraded to Unity 2019.2.2f1 (this was announced yesterday) and a new parttools will be released for it. Part tools works with the Unity version the game runs on. So currently KSP 1.7.3 is unity 2017.1.3p1 and so to use parttools you must use that version.

OwO ... noice... one of my biggest hopes for KSP :P

*...runs off to find this announcement thread...*

Edited by Stone Blue

Share this post


Link to post
Share on other sites
26 minutes ago, JPLRepo said:

actually KSP 1.8 is being upgraded to Unity 2019.2.2f1

good news.

2017.1 to 2019.2 is a lot of stuff.

physx 3.4, garbage collector update, ecs, lots of other neat stuff.

i will be interested to see what difference it makes for performance.

maybe not much at first until they decide to re-architect to ecs.

that would be a non-trivial task.

what are u most looking forward to?

Share this post


Link to post
Share on other sites

All other differences aside, just dumping Dx9 and moving to Dx11 should be a pretty significant performance gain... I've seen the difference for a few years.

Share this post


Link to post
Share on other sites
59 minutes ago, zer0Kerbal said:

wonder if this means .NET upgrade as well (from .NET 3.5)?

By Kraken's sake, say yes. :)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.