Jump to content
  • 0

Minmus base rotating on the ground - why?


Question

I feel I need help with this. For some reason my Minmus mining base is rotating since I upgraded to KSP 1.8. It used to be stable while deployed on Minmus. Ever since I landed it, it stood rock solid with the solar panels facing north and south to collect all the sunlight. Now it rotates. After I expanded the base by an additional module, it rotates by one degree every 4 seconds!

I tried fiddling with the landing struts damper settings, resetting them to auto, hibernating the probe core, removing the engineer from the lander can, activating RCS, nothing worked. The base rotates. Was coriolis force added to the game or what????

UPDATE: I did additional tests on 1.9 yesterday. See last answer.

ADDITIONAL INFO: I am running KSP on a Mac, unmodded but with Breaking Ground DLC installed. 

Edited by Shmauck
Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0

I don't know if it's related, but I had an issue with a vessel in orbit of Eve recently, which when not under control (i.e. no kerbal onboard) started to rotate along it's longitudinal axis. The rotation was much faster, picking up to several revolutions per second in about 15 seconds after scene reloading, but then it was in a situation with no friction involved.

I've not seen this behaviour before 1.8, but this was the only vehicle I've seen it on so far.

Link to post
Share on other sites
  • 0
12 hours ago, Ratwerke_Actual said:

Wheels were sliding like they weren't there, brakes were on, engines off, no trim or reaction wheels active.

This happens to me all the time on all bodies including kerbin with or without mods. And, the ground is jittery on kerbin like there is a magnitude 7 or higher earthquake(kerbinquake?) at all times. The problem showed up in 1.8.0. I stopped playing until 1.8.1 released. That did not fix it. I haven't played since. I was hoping for a 1.8.2 but that seems unlikely. Maybe 1.9.0 will address it.

Link to post
Share on other sites
  • 0
On 12/17/2019 at 11:40 PM, purpleivan said:

I've not seen this behavior before 1.8, but this was the only vehicle I've seen it on so far.

I have seen it before 1.8 on for example my "Little Duna Lander" video on my YouTube channel that was running on 1.7.3, but I have noticed more of the problems that @Waseemq1235 pointed out and it's totally obvious in my "The Mun Arch Lander" video where it shakes noticeably when it touches down or when I bring the time-warp back to 1x. I do want to see images/videos of your shaking base though.

Link to post
Share on other sites
  • 0

So, I haven't played the game properly in a long time but I have just encountered something similar. I decided I wanted to try and make a SSTO plane capable of lifting a reasonable amount of tonnage. The plane works fine until I add some docking ports and the intended cargo in to the cargo bay, then, it just spins when loaded to the runway. It's a very slow rotation, no reaction wheels enabled (I disable them on all plane type craft and rely on ailerons). I fiddled with spring, damper and friction values and that seems to have "fixed" it, though I'm not convinced there isn't something weird going on underneath that this simply hides. Mostly, it was increasing the friction that prevented it, I just adjusted spring and damper to make sure it wasn't on the verge of doing the old kangaroo thing when they bottom / top out.

I also suspect the MK3 cargo bays are not shielding correctly but that's another story.

Edited by Manwith Noname
Link to post
Share on other sites
  • 0

Yesterday I fired up KSP for the first time since December. I had gotten very frustrated about the rotating base thing but I wanted to give the 1.9 version another try. The result is that my base is still rotating. I may be able to provide visual reference later today.

I tried the following in version 1.9 yesterday: 

I reloaded a save in which my Minmus ISRU is standing still on Minmus surface. I have described the construction and deployment of the ISRU vehicle in depth in this post.

I can see a bit of a motion in the vehicle after the usual loading jumps but the craft is not rotating. It has not rotated ever since I deployed it at timecode Y2 D306. It seems to be quivering or shaking very slightly though.

The save I reloaded was taken at timecode Y3 D116 01:10, immediately after I landed the ISRU expansion module on the surface of Minmus, some few hundred meters away from the inital ISRU vehicle. 

Then I loaded another save from timecode Y3 D116 01:18. This was taken immediately after I had maneuvered the expansion module to a position where the docking ports attached between the initial ISRU vehicle and the expansion module. Here, the resulting combination superstructure of both subassemblies rotates at a speed of roughly 1 degree every 5-10 seconds. 

I reloaded that last save again and immediately undocked the maneuvering lander vehicle from the expansion module because I suspected that the probecore or the reactions wheels would be causing the problem. But the rotation went on. 

So I reloaded again and tried undocking the lander AND pulling all reaction wheel sliders to zero as well as resetting the damper settings on all landing struts back to auto. I succeeded on the first try. The base did not rotate. 

Then I tried to reproduce the same procedure with reloading the same savegame again. This time, the same steps did not solve the problem. I am not 100% sure if I really took the same steps in the same order and this is what I will retry tonight. 

Could it be that reaction wheel counter-movements or spring/damper settings are contributing to the rotation effect?

Link to post
Share on other sites
  • 0

1.9.0 had some issues with friction, from the 1.9.1 patch notes:

* Reverted Wheel Friction and Brake changes to 1.8.1 behaviors.

Have you tried this with 1.9.1?

 

Link to post
Share on other sites
  • 0

That sounds more like the age-old issue with landing legs and wheels, @Anth12, thankfully there's a mod that helps with this issue:

I don't know if this mod works with 1.9.x, you might want to ask the author of the mod.

Link to post
Share on other sites
  • 0

I was just trying to add what I had experienced to the discussion.

The crafts that have done a little spin aren't bases that need the solar panels to be facing a certain way.

They are land mine... lift off

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...