Jump to content

[1.9.1+] OPT Spaceplane Continued 3.1.1 [Mar 06, 2021]


Recommended Posts

@O YEAAAAAAH Mr Crabs Another round of work is done. RP-0 tech tree placement is done, all parts fully covered by DRE, OPT's stockalike/non-RO upgrade items are disabled (and the heat upgrades with them, but the VIsp stuff for the Warpjets and EggDog engines are still enabled, parts that had the option for Ablator will have Ablator always-on).

You'll have to download all the OPT folders again and make another clean copy-paste of everything. (Delete from GameData first).

I'd especially like your feedback on the following. Let me know if to provide these:

  • If you believe the heat limit upgrades should stay (in spite of DRE which kinda makes them pointless). In which case I'll also remove the always-on Ablator.
  • I've made a SMURFF-alike mechanism to easily scale only OPT's masses. It's in OPT_Reconfig/OPT_RO.cfg. Let me know if they should have different defaults (currently just "1" for all).
  • Other RCS fuel options (their mixes and what their Isp's should be). Current options are MMH + NTO, MMH + NTO + EC, IntakeAtm + EC, LH2 + LOx
  • Fuel cell options for the "Tidal Force" (LFO) power spheres. They currently use just LFO and are useless.
Link to post
Share on other sites

@JadeOfMaar  In my opinion youy should set mass to 1.5-2.0

As for heat limit upgrades and power spheres I cant comment as I dont know how to use them or in the case of upgrades where to find em.

You could add the fuels that other rcs uses in ro but I dont know how effiecient it would be since ISP is lower but you can give it a try

Here is the fuels other rcs use:

https://imgur.com/a/Ml6Ajii

 

Link to post
Share on other sites

@JadeOfMaar Just followed the traces of handovers to this thread, as I am trying to gather some information on the spawning in 1km bug. Out of others users and the first post in this thread I found, that this mod was/is suffering from that as well? Is that correct and do you know anything about this bug?

I am searching for information about this, as it also plagues the habtech2 mod.

Link to post
Share on other sites

@chris-kerbal From what I remember, the bug is caused by bad practice with (usually animated) meshes. I recently made a part that doesn't animate and it had the bug. I can't get at all why that would happen. What I assume is that the origin of an animated mesh is far from the center of its geometry, so when KSP calculates the bounding box of the part, it somehow ends up underground and KSP spawns the part in the air to somehow cover for that. The WorldStabilizer mod (linked in this thread's OP) suppresses the bug. I don't have it in me to deal with OPT's parts (mainly the issue of re-unwrapping and re-atlasing these parts if/when needed) so I can't fix them myself.

Link to post
Share on other sites
4 minutes ago, JadeOfMaar said:

@chris-kerbal From what I remember, the bug is caused by bad practice with (usually animated) meshes. I recently made a part that doesn't animate and it had the bug. I can't get at all why that would happen. What I assume is that the origin of an animated mesh is far from the center of its geometry, so when KSP calculates the bounding box of the part, it somehow ends up underground and KSP spawns the part in the air to somehow cover for that. The WorldStabilizer mod (linked in this thread's OP) suppresses the bug. I don't have it in me to deal with OPT's parts (mainly the issue of re-unwrapping and re-atlasing these parts if/when needed) so I can't fix them myself.

Thanks for the quick reply. I thought, that it is some correction mechanism of KSP, however as I am no modder, I have no clue what is happening. I asked over at the world stabilizer thread, on what it does, that prevents the bug. It at least must change calculating the bounding box.

I try to gather all of the bits of information over in an dev thread and will mention your input as well.

Link to post
Share on other sites
  • 4 weeks later...

@Incarnation of Chaos I believe SMURFF on its own will affect OPT. For that not to happen, I believe there is a blacklist system that parts can be opted-into, and I haven't done that. However, there is a SMURFF-ish setup in OPT's RO configs for users to mess with because I don't know how much the parts should be made heavier or not for RO.

@Ebo_ You must have CryoEngines installed without CryoTanks. Do one of the following to fix your issue:

  • Uninstall CryoEngines. This will restore engines' need for LFO.
  • Delete OPT_Reconfig/CRP/OPT_CryoEngine.cfg This will restore engines' need for LFO.
  • Install CryoTanks. This will activate the LH2, LH2O tank options.
Edited by JadeOfMaar
Link to post
Share on other sites
2 hours ago, JadeOfMaar said:

@Incarnation of Chaos I believe SMURFF on its own will affect OPT. For that not to happen, I believe there is a blacklist system that parts can be opted-into, and I haven't done that. However, there is a SMURFF-ish setup in OPT's RO configs for users to mess with because I don't know how much the parts should be made heavier or not for RO.

@Ebo_ You must have CryoEngines installed without CryoTanks. Do one of the following to fix your issue:

  • Uninstall CryoEngines. This will restore engines' need for LFO.
  • Delete OPT_Reconfig/CRP/OPT_CryoEngine.cfg This will restore engines' need for LFO.
  • Install CryoTanks. This will activate the LH2, LH2O tank options.

So as of right now it would double patch any OPT tanks if SMURFF is installed? Trying to track down a error with my new install ATM. 

Link to post
Share on other sites
14 hours ago, Incarnation of Chaos said:

So as of right now it would double patch any OPT tanks if SMURFF is installed? Trying to track down a error with my new install ATM. 

It would, yes. Rather, it would give extra, unwanted maths to the mass changes. The default values of OPT's own mass-rebalancer are all 1 (so no effect) and it's only available if you have RO installed (which I don't know yet if you do).

The mass balancers conflicting or overlapping would (I hope) be error-free. (I've never had to install SMURFF).

If your error is one that shows up in the in-game console, share your KSP.log/Player.log and perhaps I can help you to identify the cause by the error info.

If your error is indeed directly related to SMURFF, then try this patch and let me know. If this works out I'll make OPT's mass re-balancer available without the need for RO.

@PART:HAS[#manufacturer[OPT*Division]]:BEFORE[OPT_Reconfig]:NEEDS[SMURFF]
{
	%SMURFFExclude = true
}

 

Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

It would, yes. Rather, it would give extra, unwanted maths to the mass changes. The default values of OPT's own mass-rebalancer are all 1 (so no effect) and it's only available if you have RO installed (which I don't know yet if you do).

The mass balancers conflicting or overlapping would (I hope) be error-free. (I've never had to install SMURFF).

If your error is one that shows up in the in-game console, share your KSP.log/Player.log and perhaps I can help you to identify the cause by the error info.

If your error is indeed directly related to SMURFF, then try this patch and let me know. If this works out I'll make OPT's mass re-balancer available without the need for RO.

@PART:HAS[#manufacturer[OPT*Division]]:BEFORE[OPT_Reconfig]:NEEDS[SMURFF]
{
	%SMURFFExclude = true
}

 

I'm not running RO, so i shouldn't need to worry. Thanks for the assist.

Link to post
Share on other sites

Had an issue recently where the game hard crashed, when the KWT mod was clicked on: 

Mods Loaded...

Quote

KSP: 1.10.1 (Win64) - Unity: 2019.2.2f1 - OS: Windows 10  (10.0.0) 64bit
ClickThroughBlocker - 0.1.10.14
ToolbarControl - 0.1.9.4
Astrogator - 0.10.2
B9 Part Switch - 2.17
Community Resource Pack - 1.4.1
Environmental Visual Enhancements - 1.10.1.3
GravityTurn - 1.8.1.2
RasterPropMonitor - 0.31.4
Kerbal Engineer Redux - 1.1.7.2
AdvancedFlyByWire - 1.8.3.2
KSP-AVC Plugin - 1.4.1.5
LoadingTipsPlus - 1.9
OPT Legacy Spaceplane Parts - 2.1.1
OPT Reconfig - 2.2
Precise Node - 1.2.11.1
RCS Build Aid - 1.0.3
RealPlume - Stock - 4.0.1
Trajectories - 2.3.4
Kerbal Alarm Clock - 3.13
Kerbal Actuators - 1.8.3.1
ZeroMiniAVC - 1.1.0.1

Error Log...

https://drive.google.com/file/d/1XrgIV6UBY3qY08chOZXbmuKqtZiQAoCv/view?usp=sharing

Link to post
Share on other sites
4 hours ago, Redacted said:

Had an issue recently where the game hard crashed, when the KWT mod was clicked on:

Quick look through your log doesnt show anything definitive for me, other than a big exception at the begininng, thrown by something that has code for  "_BuildManager". I do not now what mod that would be from, certainly not OPT.

Also, about 1/4 of that unusually long log, seems to consist of exceptions from Parallax.

Since your issue seems to be primarily with KWT, I suggest creating a fresh, non-Steam install of KSP, and only installing KWT and any required dependencies... Test, then add any plugin-only mods that are in your current, failing install... only do mebbe half-a dozen at a time... less if there arent that many to begin with... Test after each group of mod installs.

With the nature of KWT, I have no idea how it would play with any planet pack mods. Also, Kopernicus could possibly be an incompatability? vOv
A note on Kopernicus: mae SURE you have the correct fork of Kopernicus for the version of KSP you are on. There are currently THREE branches: original (for KSP 1.8.1), prestja's one for 1.9.1, and R-T-B's for 1.10.1

Also,  i dont know if FAR could be causing an issue with KWT, I would install FAR as your first plugin after installing KWT.
 

Link to post
Share on other sites
22 hours ago, Stone Blue said:

Quick look through your log doesnt show anything definitive for me, other than a big exception at the begininng, thrown by something that has code for  "_BuildManager". I do not now what mod that would be from, certainly not OPT.

Also, about 1/4 of that unusually long log, seems to consist of exceptions from Parallax.

Since your issue seems to be primarily with KWT, I suggest creating a fresh, non-Steam install of KSP, and only installing KWT and any required dependencies... Test, then add any plugin-only mods that are in your current, failing install... only do mebbe half-a dozen at a time... less if there arent that many to begin with... Test after each group of mod installs.

With the nature of KWT, I have no idea how it would play with any planet pack mods. Also, Kopernicus could possibly be an incompatability? vOv
A note on Kopernicus: mae SURE you have the correct fork of Kopernicus for the version of KSP you are on. There are currently THREE branches: original (for KSP 1.8.1), prestja's one for 1.9.1, and R-T-B's for 1.10.1

Also,  i dont know if FAR could be causing an issue with KWT, I would install FAR as your first plugin after installing KWT.
 

Thing to keep in mind though is most of these mods have been around for quite a while, except for OPT. Prior to installing OPT, everything was running smooth and happy.

Link to post
Share on other sites
  • 1 month later...
Posted (edited)

Warning. WorldStabilizer no longer suppresses the 1km spawn bug as of KSP 1.11, and seems to actually evolve it into a new and vicious kraken.

Take extreme care when spawning crafts containing the following parts, or just don't use them anymore:

  • J Deployment Bay
  • J Inline Large Docking Port
  • Avatar Cargo Ramp
  • Humpback Cargo Ramp
  • Stail Cargo Bay (Mk1, not Mk2)

OPT Sapceplane 3.0

  • Added KerbalChangelog support.
  • Added Localization support.
  • Added missing SAS module to all drone cores.
  • Fixed bulkheadprofile in Nebula engine. (Spotted by @ Lisias.)
  • Fixed bulkheadprofile in some I and J parts.
  • Fixed K Drone Core's SAS module still missing.
  • Fixed K and KH cargo bays and hollow fuselages appearing in Fuel Tank category (moved to Payload).
  • Fixed missing bulkheadprofile in RCS ports.
  • Increased thrust in these engines:
    • Valkyrie tilt & WarpJet MARGE.
    • VTOL wrapper engines.
  • Moved the following in from OPT Legacy:
    • 2.5m Nebula Shock Intake.
    • VTOL Wrapper engines.
    • Avatar tilt and WarpJet MARGE engine.
    • DepthMask assets.
    • K cockpits (custom, TAV). All 3 K cockpits are now here.
    • K cabin and lab.
    • K and KH Inline SAS.
  • Removed obolste parts: some RCS thrusters, some Avatar fuselage parts. Craft files that have these will break.
  • Reduced node size on H parts.
  • Updated DepthMask patch to detect standalone DepthMask plugin.

OPT Reconfig 3.0

  • Added heat limit upgrades for H noses. (Bundled with Mk2 nose upgrades.)
  • Added KSP 1.11 stock inventory to crewed parts.
  • Added Localization support.
  • Added Realism Overhaul support.
  • Fixes to IntakeAtm and CryoEngines patches.
  • Removed GPOSpeed fuel patch. Unknown if it supports WBI Omnistorage.
  • Rewrote WBI integration and phased out Pathfinder legacy templates. It's all OmniConverters and OmniStorage. Always has been.
  • OPT in ClassicStock play mode uses "PropLox" fuel mix (Propellium + Oxidizer, equivalent to Hydrolox).

DOWNLOAD CONTINUED :: SPACEDOCK :: GITHUB

DOWNLOAD RECONFIG :: SPACEDOCK :: GITHUB

Edited by JadeOfMaar
Link to post
Share on other sites
  • 2 weeks later...

1.10 and 1.11

Can't seem to land any of my spaceplanes on the water as I did in old 1.9.

Is there something that changed n the update that ruined the water collision model or a specific add-on that messes this up?

All my spaceplanes collide with the ocean surface at 6m height and bounce on top of the water 6 meters above the surface.   Capsules are fine so far!

Thanks!

 

Edited by Kilo60
Link to post
Share on other sites
16 minutes ago, Kilo60 said:

Can't seem to land any of my spaceplanes on the water as I did in old 1.9.

Sorry. I can't help you at all with that.

It's likely that aero physics may have changed in that interval as side-effects of changes to the DLC prop blades and you may have to adjust your tactics to keep up with that. Also, as a general rule, try not to land a plane with over 6m/s vertical speed or high angle of attack (regardless of horizontal speed). if you have to land with either of these, you built your plane badly.

If you happen to have 100+ mods in your install, some new bug must be coming out of that mix and it would be a good idea to trim down your install or create a new one with just OPT and its dependencies and try your water landings again.

Link to post
Share on other sites
21 minutes ago, JadeOfMaar said:

Sorry. I can't help you at all with that.

It's likely that aero physics may have changed in that interval as side-effects of changes to the DLC prop blades and you may have to adjust your tactics to keep up with that. Also, as a general rule, try not to land a plane with over 6m/s vertical speed or high angle of attack (regardless of horizontal speed). if you have to land with either of these, you built your plane badly.

If you happen to have 100+ mods in your install, some new bug must be coming out of that mix and it would be a good idea to trim down your install or create a new one with just OPT and its dependencies and try your water landings again.

Thanks!

 

Seems like its the new big waves.

 

Not sure if its a mod or the stock game but the new beautiful rough waves are not letting me land or take off in the water anymore with any space plane even stock...

Link to post
Share on other sites

Remember this? "Make sure your seatbacks and tray tables are in their fully upright and locked positions." (I never thought I'd miss those words until now)...

In 1.11, you can add this. "Make sure your landing gear is stowed and the SAS is OFF."  

Landing gear and water don't mix apparently.  Must be the spring and dampener logic trying to bounce the craft on water.  And keep them stowed.

SAS is trying to keep the craft level but the water is bouncing it around.  Eventually, SAS will over-compensate enough to bounce your craft off the water high enough that it breaks into pieces when it lands/crashes back on the water.

So... "Make sure your landing gear is stowed and the SAS is OFF."

Edited by bcqJC
typo
Link to post
Share on other sites
2 hours ago, Kilo60 said:

Seems like its the new big waves.

Scatterer's ocean/wave physics? Ah, I had a small feeling it might be that, but didn't completely realize it to suggest to you. Yeah....good luck landing planes on those.

@bcqJC This ^

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...