sarbian

[1.8.x] SmokeScreen 2.8.7 - Extended FX plugin (19 October 2019)

Recommended Posts

I tried the update, on my heavily modded install, and it seems better. Before I had more slow framerate on rocket liftoff, now it's more smoother.

Share this post


Link to post
Share on other sites

It's raining SmokeScreen version ! SmokeScreen-2.6.9.0.zip

Include Felger patch to add 3 parameters

Global SmokeScreen Parameter:

atmDensityExp - SmokeScreen.cfg variable, adjusts input atmospheric pressure by an exponent, to give similar plume scaling between RSS and Stock.

ModelMultiParticlePersistFX Parameters:

vRandPosOffset - Random positive position offset to spread fast particles out. Additive.

vPosOffset - nonrandom positive ffset to adjust starting particle position. Additive.

Share this post


Link to post
Share on other sites
It's raining SmokeScreen version ! SmokeScreen-2.6.9.0.zip

Include Felger patch to add 3 parameters

Global SmokeScreen Parameter:

atmDensityExp - SmokeScreen.cfg variable, adjusts input atmospheric pressure by an exponent, to give similar plume scaling between RSS and Stock.

ModelMultiParticlePersistFX Parameters:

vRandPosOffset - Random positive position offset to spread fast particles out. Additive.

vPosOffset - nonrandom positive ffset to adjust starting particle position. Additive.

Link appears to be dead?

Share this post


Link to post
Share on other sites

Of course my server had to crash while I am away...

It is back. Kvm & Ssh on a phone is not fun..

Share this post


Link to post
Share on other sites

Look at your GameData/SmokeScreen/SmokeScreen.cfg

Something may prevent the game to save the value...

Share this post


Link to post
Share on other sites
Look at your GameData/SmokeScreen/SmokeScreen.cfg

Something may prevent the game to save the value...

There is no smokescreen.cfg file in my smokescreen dir, nor was there one in the zip file I installed it from, or the CKAN version.

Is the CFG file something additional that has to be downloaded?

I need to adjust the amount of smoke, im getting 3fps on liftoff if I have multiple boosters.

Share this post


Link to post
Share on other sites

Oops. There was an error in the build script. Get that version of the zip. I ll bump the version up so I can update it in CKAN.

Share this post


Link to post
Share on other sites

Thank you for your continued support! Smokescreen really allows KSP to become a lot more immersive. :D

Share this post


Link to post
Share on other sites

When I use the GUI smokescreen tool to change the flames and smoke parameters, my setting do not get saved and the engine always reverts back to original. Isnt the purpose of the Import/Rebuild Tool to make the changes permanent?

Share this post


Link to post
Share on other sites
When I use the GUI smokescreen tool to change the flames and smoke parameters, my setting do not get saved and the engine always reverts back to original. Isnt the purpose of the Import/Rebuild Tool to make the changes permanent?

Actually no."Import" will import settings which engine already uses,"rebuild" will add all setting,which is useful for engines that don't already have any settings.

If you want to save the progress you made,the best way is to select all stuff that you change(orange color),then Ctrl+c and you can paste it to your .cfg

Share this post


Link to post
Share on other sites
Actually no."Import" will import settings which engine already uses,"rebuild" will add all setting,which is useful for engines that don't already have any settings.

If you want to save the progress you made,the best way is to select all stuff that you change(orange color),then Ctrl+c and you can paste it to your .cfg

sounds like a lot of work , but at least smoke screen gives us a great tool to let us visualize our config changes in real-time ! :D

Share this post


Link to post
Share on other sites

what is the difference runningEffectName vs powerEffectName vs directThrottleEffectName? I think this is giving me a problem as to why some engines are not getting saved AND engines losing their effects all together.

Edited by lextacy

Share this post


Link to post
Share on other sites
CKAN version is still missing the CFG file.

I fixed this problem on CKAN, it will now download the config file. :D

Share this post


Link to post
Share on other sites

Not sure if this has been requested before, if so excuse the repetition. Would you be able to add a debug toggle that can be set per engine to allow particles in the editor? I would like this to be able to adjust plume with the Real Plume mod without having to go through so many scene changes. Don't know if that's even possible so if you know better say so. Thanks!

Share this post


Link to post
Share on other sites

Looks like there may be an incompatibility between this and KSP Interstellar Extended.  I installed this plugin because it's a requirement for B9 - previously I did not have this installed.  Now, however, I get no exhaust plumes at all from any of the engines in the KSPIE mod - I still get plumes from stock engines and others, just not from KSPIE.  I'm going to try manually disabling this .dll out from under B9 (which will probably break THOSE engines' effects) but it'll be interesting to see if it solves it or not for the KSPIE engines.

Share this post


Link to post
Share on other sites

2.6.10 is a rebuild for 1.0.5 since some things were not working properly (???)

Share this post


Link to post
Share on other sites
4 hours ago, sarbian said:

2.6.10 is a rebuild for 1.0.5 since some things were not working properly (???)

Sarbian, The link doesn't appear to be working.

Share this post


Link to post
Share on other sites

It is working fine for me. Make sure you have a recent navigator because my site won't have much love for old Internet explorer.

Share this post


Link to post
Share on other sites
On ‎12‎/‎23‎/‎2015 at 2:10 AM, sarbian said:

It is working fine for me. Make sure you have a recent navigator because my site won't have much love for old Internet explorer.

Still not working for me. I'm on win 10 Edge or IE 11

ok I got it by "copying the link' and then deleting everything after "smokescreen"

https://ksp.sarbian.com/jenkins/job/SmokeScreen/

Edited by V8jester

Share this post


Link to post
Share on other sites

I'm running 2.6.10 and the Interstellar engines still have no drive trails until I disable this mod :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.