magico13

[1.4.1] Kerbal Construction Time 1.4.0.69 (2018-03-24) - Unrapid Planned Assembly

Recommended Posts

2 hours ago, linuxgurugamer said:

Ok, I just tried this, new career, built a pod, launched it, hit recover, and it worked.

Please send me the save file which replicates this issue.

Thanks

Oh, I also need the MagiCore version

Interesting. I'll see into it more when I get home from work and I'll get you a log and compile as much information together as I can. When I build my test rocket I use a pod, a booster, and parachute and yes I do it on career mode.

Share this post


Link to post
Share on other sites
Posted (edited)

Oh, I just realized that you were using the Recover Active Vessel in the KCT window.  I tried that and got the error.

Sorry for not realizing what you were doing, I can only claim unfamiliarity with the mod (I'm intending to start using it in my next career)

So I can now recreate the problem.

I saw something very interesting while doing a recovery;  the rocket was displayed a 2nd time at right angles to the one on the pad; did you see that? 

 

Edit:  I won't know until tomorrow, but I think I know what's going on.  Details to follow

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
Posted (edited)
21 minutes ago, linuxgurugamer said:

Oh, I just realized that you were using the Recover Active Vessel in the KCT window.  I tried that and got the error.

Sorry for not realizing what you were doing, I can only claim unfamiliarity with the mod (I'm intending to start using it in my next career)

So I can now recreate the problem.

I saw something very interesting while doing a recovery;  the rocket was displayed a 2nd time at right angles to the one on the pad; did you see that? 

 

Edit:  I won't know until tomorrow, but I think I know what's going on.  Details to follow

Yes, the rocket shows at a right angle and the engine particle effects show as well. It's pretty common with KCT and has been for a very long time or at least as long as I've been playing with the mod the last couple years. 

Edited by FuriousSquirrel

Share this post


Link to post
Share on other sites
1 minute ago, FuriousSquirrel said:

Yes, the rocket shows at a right angle and the engine particle effects show as well. It's pretty common with KCT and has been for a very long time or at least as long as I've been playing with the mod the last couple years. 

That is KCT making sure it can reload the vessel (I did some more digging)

The issue is that ScienceAlert adds a module to the root part of the active vessel.  Since it is added at runtime, KCT is having a problem with it.

Now that I know the problem, I should be able to fix it in the next few days

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

That is KCT making sure it can reload the vessel (I did some more digging)

The issue is that ScienceAlert adds a module to the root part of the active vessel.  Since it is added at runtime, KCT is having a problem with it.

Now that I know the problem, I should be able to fix it in the next few days

Sweet. Glad you were able to find the issue. Doing Kerbalkind a huge service!

Share this post


Link to post
Share on other sites

I suspect that KCT has this problem with any mod which adds partmodules at runtime.  

Share this post


Link to post
Share on other sites

Replicated, found and fixed!!!!

This is a pre-release, i am aware of a small issue related to localization, but functionally this is working for me:

PreRelease 1.4.5.5

  • Restored missing presets:
    • 7 Days - A strict 7 Kerbin day limit between launches. No other time restrictions or use of upgrades.
    • Default - The Default KCT Settings
    • Upgrade Free - Relies entirely on the Stock building upgrades rather than the KCT upgrade system
    • Rodhern Low-tech - Faster low-tech career values
  • Fixed inability of mod to recover vessels when other mods have added partmodules to the vessel or it's parts,
    • tested with ScienceAlert, EVAParachutes&EjectionSeat

https://github.com/linuxgurugamer/KCT/releases/tag/1.4.5.5

Share this post


Link to post
Share on other sites

There are no interface in Career 1.6.1! How to fix this?

Share this post


Link to post
Share on other sites
35 minutes ago, MXMS said:

There are no interface in Career 1.6.1! How to fix this?

There certainly is. I'm using it right now as I type this on the forum. Maybe if you were more descriptive and added links to your uploaded logs, someone could help you. There are a lot of people on the boards that are happy to help, but we need information. 

If you don't know how to upload logs, a very quick perusal of the forums--especially any mod from linuxgurugamer--will tell you how to get support. 

But this mod is working, with a few already noted issues, in 1.6.1.

Share this post


Link to post
Share on other sites
5 hours ago, MXMS said:

There are no interface in Career 1.6.1! How to fix this?

MagiCore is what you need. I was confused why it didn't work for me as well.  MagiCore is available on Spacedock. But this is made known on the OP now.  Checking there first might be a good idea.

Peace.

Share this post


Link to post
Share on other sites
11 hours ago, eightiesboi said:

But this mod is working, with a few already noted issues, in 1.6.1.

As of now, with the Prerelease, I don't have any reports of any issues.  The localization issue I saw must be local, since I can't replicate it in anything other than one install.

If I don't get any feedback by tomorrow (Sunday) afternoon, I'll be releasing the current version as a full release, and not a beta

Share this post


Link to post
Share on other sites
13 hours ago, theJesuit said:

MagiCore is what you need. I was confused why it didn't work for me as well.  MagiCore is available on Spacedock. But this is made known on the OP now.  Checking there first might be a good idea.

Peace.

Thx, man! MagiCore helped

Share this post


Link to post
Share on other sites
Posted (edited)

A final beta before release.  

1.4.5.6

  • Added #if/#endif around the AssemblyVersion lines
  • Replaced KCT_TechItemIlist Ilist with an ObservableList, thanks @MikeOnTea for the suggestion
  • Moved initialization of the TechList into a method, which is called when the list needs to be initted or cleared
  • Changed hard-coded #if false in KST_UpdateChecker with an #if !KSP1_4
  • Removed old code per RO requests

https://github.com/linuxgurugamer/KCT/releases/tag/1.4.5.6

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
6 hours ago, linuxgurugamer said:

A final beta before release

Safe to say you're going to be starting a new thread once it's released?

Share this post


Link to post
Share on other sites
On 3/8/2019 at 8:48 AM, linuxgurugamer said:

Replicated, found and fixed!!!!

This is a pre-release, i am aware of a small issue related to localization, but functionally this is working for me:

PreRelease 1.4.5.5

  • Fixed inability of mod to recover vessels when other mods have added partmodules to the vessel or it's parts,
    • tested with ScienceAlert, EVAParachutes&EjectionSeat

https://github.com/linuxgurugamer/KCT/releases/tag/1.4.5.5

Can you also apply this fix to the old version KCT 1.4.0.69 (for 1.5.1) so players still using KSP1.5.1 can get this fix?

(I dont know if its was a simple correction, or if it was linked with other functions/etc so that you dont want to get involved with applying this fix to the old version)

Share this post


Link to post
Share on other sites
2 hours ago, BlackHat said:

Can you also apply this fix to the old version KCT 1.4.0.69 (for 1.5.1) so players still using KSP1.5.1 can get this fix?

(I dont know if its was a simple correction, or if it was linked with other functions/etc so that you dont want to get involved with applying this fix to the old version)

 It's not trivial to back port, but I could probably recompile this version for  1.5.1

Share this post


Link to post
Share on other sites

New release, 1.4.5.6

  • Added #if/#endif around the AssemblyVersion lines
  • Replaced KCT_TechItemIlist Ilist with an ObservableList, thanks @MikeOnTea for the suggestion
  • Moved initialization of the TechList into a method, which is called when the list needs to be initted or cleared
  • Changed hard-coded #if false in KST_UpdateChecker with an #if !KSP1_4
  • Removed old code per RO requests

There is a build for KSP 1.5.1 available here.  Note that MagiCore is not included, you need to get it as well:

Share this post


Link to post
Share on other sites

  This Mod looks very interesting in career. Does it also work in Science mode?

Share this post


Link to post
Share on other sites
13 hours ago, Verthel said:

  This Mod looks very interesting in career. Does it also work in Science mode?

It should work in all 3 modes. (Some presets may not be available in all modes.)

Share this post


Link to post
Share on other sites
17 minutes ago, Kerballing (Got Dunked On) said:

@linuxgurugamer, is this mod compatible with 1.6.x yet?

Yes, its been compatible for a while now

Share this post


Link to post
Share on other sites

Please note:  I've started a new thread for my versions moving forward, please move all discussion to it:

 

Share this post


Link to post
Share on other sites

Locked as requested by OP. 

Thanks for picking it up, LGG.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.