Nertea

[1.6.x] Mark IV Spaceplane System (January 21, 2019)

Recommended Posts

2 hours ago, StahnAileron said:

FYI The BDAnimationsModule.dll supplied with the mod is significantly outdated (v5.x; current version is v6.2). I didn't realize it and it was wreaking havoc with test plane I made beforehand.

I normally install overlapping mods by telling my system to overwrite all older files, but the timestamp on this DLL was is Sept (the latest 6.2 version is dated from mid-May). Inadvertently overwrote the plugin. (I actually wasn't paying attention and didn't even notice the BahaSP folder.

Just a heads up just in case anyone else uses other BD mods that use his animations (like the landing gears).

Nertea, hopefully you'll update (or correct?) that dependency-distro on your next release, whenever that is. (It's a pseudo-minor thing, so not urgent, maybe... Though it did technically "break" my designs.)

I had the same problem, as I love using Adjustable Landing Gear. The DLL in MKIV is 15KB and the one supplied with Adjustable Landing Gear is 80KB. Putting the original file in resolved any issues I had. The other thing I noticed was the MKIV Crew Cabin not calculating FAR lift correctly. This is down to two files:

  1. In the MKIV FAR Module Manager file, you need to ensure the crew cabin is there with the other parts
  2. In the MKIV Crew Cabin config file there is two MODULE {} LiftingSurface code snippets, the lower one is missing a parameter and seems to cause some issues. Removing the second snippet gets everything working on this part for FAR

Keep up the good work @Nertea!

Edited by Jebman82
Typo

Share this post


Link to post
Share on other sites

2.1.1 deployed:

  • Fix to thermal values for most parts
  • Fixed incorrect BDAnimationModules version
  • Fixed FAR patch for crew cabin
  • Fixed duplicate lift module in crew cabin
9 hours ago, StahnAileron said:

FYI The BDAnimationsModule.dll supplied with the mod is significantly outdated (v5.x; current version is v6.2). I didn't realize it and it was wreaking havoc with test plane I made beforehand.

I normally install overlapping mods by telling my system to overwrite all older files, but the timestamp on this DLL was is Sept (the latest 6.2 version is dated from mid-May). Inadvertently overwrote the plugin. (I actually wasn't paying attention and didn't even notice the BahaSP folder.

Just a heads up just in case anyone else uses other BD mods that use his animations (like the landing gears).

Nertea, hopefully you'll update (or correct?) that dependency-distro on your next release, whenever that is. (It's a pseudo-minor thing, so not urgent, maybe... Though it did technically "break" my designs.)

It looks like the D/L location I've been pulling the latest version of BDAnimationModules is out of date (but newer??). I got the latest ALG just now and pulled it from there.

17 hours ago, Captain Sierra said:

Jet engines can pull from all parts evenly but now respect no-crossfeed parts. This was something that was an artifact of using monopropellant flow rules on them in 1.0.4 and myself and others fought tooth and nail to have the lack of respect for crossfeed recognized as a bug. In the end we evidently succeeded.

 

@Nertea TY very much!  And lol at album pic 4. I think that one quite nicely summarizes why we regularly ask for larger wing parts.

 

EDIT: Am I the only one who thinks the CUTLASS just screams Interstellar? I'm getting that kind of vibe strongly off it.
EDIT 2: It appears the deploy limits on the cargo bays is backwards. Very minor issue that warrants nothing more than an afterthought until next update. Just a quick FYI.

EDIT 3: A more significant reporting of functionality as I got an SSTO run in. Efficiency of scale translates to SSTO spaceplanes better than it should because it was too damn easy. Now onto the issues I noticed.
Vulture Hypersonic Cockpit: Both Control From Here buttons switch it to the docking port's orientation. Neither one reverts it to its default. Will dig into .cfg to investigate potential fixes.
BROADSWORD: Not an issue that you can necessarily fix, likely a deficiency in the animation plugin you use as a dependency. The bypass doors do not animate to correctly reflect the mode if the mode is switched while the engine is off. It did not seem to update when the engine was reactivated.
All Parts: Max temps are way too low across the board. I nearly blew up on a standard reentry (15km periaps, 100km starting orbit) at 60% reentry heating. Note that increasing max temps is more of a stopgap measure to fix the fact that vanilla reentry is handled in a terrible way that means with a heat shield it is trivial but without one (read: all spaceplanes ever) it is beyond merciless.

I fixed some of those, not sure I can fix the control issue. I had some success in reverting the orientation by going to IVA mode though.

  • Like 1

Share this post


Link to post
Share on other sites

Seeing this update named the "Go Faster" update, I got ʜʏᴘᴇ for some red parts. Still not disappointed, though, that hypersonic cockpit is awesome!

Share this post


Link to post
Share on other sites

Nice update :D just a few issues I found:

There seem to be some oddities with the Arcadia's reverse thrust.  The stock engines just have two thrust transforms which rotate with the animation (see the Wheezley on the left side of the image).  But the Arcadia has two thrust modes and a separate animation.  And in reverse mode, the thrust appears to only point down (at least according to RCS build aid).  Is this intentional?

Spoiler

nyfZOWJ.png

EDIT: And the MarkIV-Mk3 adapter seems to have its Mk3 node ever so slightly offset from where it should be

Spoiler

AaMNA6C.png

EDIT2: Many of the parts seem to have their nodes slightly offset from where they should be.

Also, some of the adapters have holes in the mesh near the shoulder nodes:

Spoiler

cveHp0E.png

EDIT3: The precooler's surface attach node appears to be reversed.

EDIT4: The Arcadia's issues might just be an issue in the editor (seems to do what it's supposed to in flight), but I'd still recommend using the stock method as it's more robust.

Edited by blowfish

Share this post


Link to post
Share on other sites

Thanks for the notes, I'll put them in the to-fix list

13 hours ago, blowfish said:

EDIT4: The Arcadia's issues might just be an issue in the editor (seems to do what it's supposed to in flight), but I'd still recommend using the stock method as it's more robust.

The stock method doesn't let me do a lot of the things I want, like having gimbal restricted to only forward thrust, and having reduced reverse thrust with different FX. It's probably just a mispositioned thrust transform. It may be inside the collider in certain cases, I'll have to take a look. 

13 hours ago, blowfish said:

EDIT2: Many of the parts seem to have their nodes slightly offset from where they should be.

 

It's not the nodes, it's the meshes... At some point a deformation snuck into the endcap mesh and a lot of the parts suffer for this, particularly the adapters. As I am seriously considering redoing the adapter meshes soon, I don't particularly want to sink the effort of fixing the deformation that much.

 

Share this post


Link to post
Share on other sites
On 1/2/2016 at 5:26 PM, Nertea said:

 

2.1.0 update:

  •  KSP 1.05
  •  Added MiniAVC versioning
  •  Converted cargo ramp to use stock module (deprecated old one)
  •  All jet engines now use the correct 1.05 fuel flow mode
  •  All cargo bays can now use the tweakable opening module
  •  All engines now use the delayed animation module for heat animations
  •  Adjusted intake effectiveness to match 1.05 intakes
  •  Respecced and remodeled Arcadia turbojet as a medium-performance jet with thrust reversers
  •  Added Mk4 Vulture cockpit - pointy cockpit with integrated docking port
  •  Added CUTLASS: 2.5m high-efficiency RAPIER-style engine
  •  Added Valkyrie turboramjet: high performance high altitude 2.5m engine 
  •  Added Kerboshov D27 Propfan engine (efficient heavy propeller engine)
  •  Added APR-4000 Buzzsaw Turboprop engine (powerful heavy propeller engine)
  •  Added 3 lengths of basic 2.5m liquid fuel tanks (LF, LF/O, structural)
  •  Increased occlusion detection radius for all cargo bays
  •  Fixed facing of SCIMITAR's rear attach node
  •  Fixed RCS blister's surface attach node
  •  Reduced the spooling time on the Yellowjacket engine

Probably a few bugs, but hopefully mostly good. New engines might need some balance tweaking too. 

(KS is being slow, give it a few minutes)

Woohoo!

Thunderbird 2 under construction

Share this post


Link to post
Share on other sites

Please note:

I find I'm losing track of bugs that I've fixed and bugs for most of my mods (too many mods and not enough time), so I'm moving all bug reporting to GitHub.  It would be really helpful if anyone reporting an issue logged it on the Mark IV GitHub page, and possibly checked the list to see if it's already been reported. I have moved the ones I've seen here so far to there, but any new ones... well, it helps!

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Nertea said:

It's not the nodes, it's the meshes... At some point a deformation snuck into the endcap mesh...

and then you don't notice until you've made thirty parts with that endcap and now you have dig around to see how much you have to re-do. I hate it when that happens:huh:

Share this post


Link to post
Share on other sites

I realy like the new cockpit. Sadly the "control form here" will only align control to the docking port orientation. Is there a way to chose between docking port and cockpit alignement ?

Share this post


Link to post
Share on other sites

I'll look into that some more, but I don't know if it's possible. I had some success with quickly toggling IVA mode to reset the transform.

Share this post


Link to post
Share on other sites
8 minutes ago, Nertea said:

I'll look into that some more, but I don't know if it's possible. I had some success with quickly toggling IVA mode to reset the transform.

OPT mod had similar cockpit with exact same problem and, unless i'm missing something, K.Yeon haven't found way to fix it. Perhaps making docking shaft a separate part would be easiest solution.

 

Oh and many-many-many thanks for your efforts! NFTech and Mk4 are some top-notch stuff.
 

Share this post


Link to post
Share on other sites

Just started playing with this with 2.0, and omg these parts are SO FUN!

Share this post


Link to post
Share on other sites
38 minutes ago, Rho-Mu 34 said:

OPT mod had similar cockpit with exact same problem and, unless i'm missing something, K.Yeon haven't found way to fix it. Perhaps making docking shaft a separate part would be easiest solution.

 

Oh and many-many-many thanks for your efforts! NFTech and Mk4 are some top-notch stuff.
 

Yeah I remember that. I wonder if it would not be possible to animate the docking port orientation so that when its closed it match the cockpit. Might be nasty enough to work.

 

Share this post


Link to post
Share on other sites
1 hour ago, RedParadize said:

Yeah I remember that. I wonder if it would not be possible to animate the docking port orientation so that when its closed it match the cockpit. Might be nasty enough to work.

 

that wouldnt change the docking port transform though, which is what the problem is tied to.

Share this post


Link to post
Share on other sites
2 hours ago, Captain Sierra said:

that wouldnt change the docking port transform though, which is what the problem is tied to.

I know, can the transform be animated ? 

Jeb certify that explosion is acceptable outcome to retracting while being docked.

Share this post


Link to post
Share on other sites

Gotta say that new cockpit looks super dope.

Share this post


Link to post
Share on other sites
On 1/5/2016 at 9:11 PM, RedParadize said:

I know, can the transform be animated ? 

Jeb certify that explosion is acceptable outcome to retracting while being docked.

A little hacky, put probably. Not hard to test, at any rate.

Share this post


Link to post
Share on other sites

im having a lot of fun with this pack - it looks great and very useful. Thanks! :)

 

edit: I saw somewhere you had a nosecone ramp in mind - that would be awesome.

Edited by CorBlimey

Share this post


Link to post
Share on other sites

Hi

All the rear parts of the pack presents backside and when set them front side,  I attach them correctly.

if i set a B9 all part moving as stabilizer, it moves the wrong side, up for down and down for up. No problem if i set a wing then an aileron, but i think the fact that it is presenting backside make this happen

Share this post


Link to post
Share on other sites
27 minutes ago, gilflo said:

Hi

All the rear parts of the pack presents backside and when set them front side,  I attach them correctly.

if i set a B9 all part moving as stabilizer, it moves the wrong side, up for down and down for up. No problem if i set a wing then an aileron, but i think the fact that it is presenting backside make this happen

Well, the player should check all controls for proper movement, and if backwards it is easy to change.

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

Well, the player should check all controls for proper movement, and if backwards it is easy to change.

Easy to changes, yes, but reverse the controls does not work at all.

Share this post


Link to post
Share on other sites
40 minutes ago, gilflo said:

Easy to changes, yes, but reverse the controls does not work at all.

Are you saying that when you edit the motion of the part (ie:  throw range, etc (not sure if I'm saying it right)) that it just doesn't work?

Share this post


Link to post
Share on other sites

I am just saying that, due to rear presentation of the Mark IV back parts(rear at the front and front a the rear), once you've turned the back part to present it correctly,  if you use B9 Aerospace procedural wings all moving parts to set up a stabilizer moving full up and down, your pitch command is reversed even if you set the deploy cell on "inverted". The only way to get your pitch working the right way is to set up procedural wing parts on your back part and then to attach  a moving part to it.

Share this post


Link to post
Share on other sites

We really need an example craft thread :)

I love the turboprop transport in the 2.1.0 update but after about 50 attempts I can't get my version to stay in the air :( 

  • Like 1

Share this post


Link to post
Share on other sites

I am sorry, I deleted the aircraft, but here is another example of what happens

Pitch up on stab while pitch down on wings!

631966screenshot95.png

 

Edited by gilflo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now