Phineas Freak

[1.2.2] Real Solar System Visual Enhancements v1.2.2-RC3 [2017-02-26]

327 posts in this topic

5 minutes ago, Theysen said:

If you are on the latest scatterer v.0.3 downgrade to the version before that. It is already reported and answered in this thread here as well. 

thanks for the prompt response, and so sorry I missed the mention in this thread!

Share this post


Link to post
Share on other sites

@hypervelocity As @Theysen said, the Release Candidate 2 of RSSVE is compatible only with Scatterer v0.0256. You can download a WIP v0.0300 - compatible version from the GitHub repository (unofficial).

1 person likes this

Share this post


Link to post
Share on other sites

thanks a million @Phineas Freak - sorry for overlooking what was already stated in the thread. I am already enjoying RC2 with the previous scatterer version - must say you did a hell of a job, the pack is looking gorgeous.

I am very grateful for the mod you released, many many thanks! RSS/RO is not the same without it!

1 person likes this

Share this post


Link to post
Share on other sites

Hi everyone!

I am hoping one of you, or some of you might be able to help me out. I want to use this great modpack to create visuals for my Half Size and Quarter Size RSS games that I created. That being said, I have no idea where to get started. I have messed around with some of the values on these files, but I cannot get the visuals to look nearly as good as @Phineas Freak for RSS or @Galileo for Stock, SSRSS and his planet pack.

Would someone be willing to create the proper configs for me? Or would someone be able to tell me a little about the values I need to change and what effects that have on the visuals.

Thank you in advance!

Share this post


Link to post
Share on other sites
1 minute ago, pap1723 said:

Hi everyone!

I am hoping one of you, or some of you might be able to help me out. I want to use this great modpack to create visuals for my Half Size and Quarter Size RSS games that I created. That being said, I have no idea where to get started. I have messed around with some of the values on these files, but I cannot get the visuals to look nearly as good as @Phineas Freak for RSS or @Galileo for Stock, SSRSS and his planet pack.

Would someone be willing to create the proper configs for me? Or would someone be able to tell me a little about the values I need to change and what effects that have on the visuals.

Thank you in advance!

Did you attempt to just start it up with RSSVE? IIRC the configs should 'scale' with the radius of the planets, from there it might need just little tweaking for a good look.

Share this post


Link to post
Share on other sites
22 hours ago, Theysen said:

Did you attempt to just start it up with RSSVE? IIRC the configs should 'scale' with the radius of the planets, from there it might need just little tweaking for a good look.

This did not work. I went in and edited the values that I thought I needed to edit to make it work, but I could not get anything to look right and despite change the sun values, I couldn't get the light to work correctly there either.

Share this post


Link to post
Share on other sites

@pap1723 The EVE configs definitely need to be adjusted for the smaller scale. For the Scatterer configs i am not so sure but when i tried the opposite of what you are attempting (using SSRSS for RSS) none of them worked. I had to remake them from scratch. You may be SOL if that's the case.

I would suggest to start from the EVE clouds. They are fairly straitforward to make/adjust using the GUI.

 

Share this post


Link to post
Share on other sites

BTW RVE is a double abbreviation of RSS visual enhancements, just saying :P

Share this post


Link to post
Share on other sites

Hey all,

New RSSVE user here. I am having issues with only Earth's atmosphere rendering. Earth looks gorgeous, but none of the other rocky planets have atmospheric effects and the gas giants just appear black (assuming there is no terrain map for them).

Ideas?

Mods: EVE 1.2.2, Scatterer 0.0256, RSSVE RC2

Thanks! KSP is so much better due to all of the time and effort put in by the awesome modding community.

Edit: using KSP 1.2 on Linux

Edited by wvjmaff

Share this post


Link to post
Share on other sites

Just have a small problem , why my clouds are black instead of white from orbital view?

Share this post


Link to post
Share on other sites

Can anybody provide a link to the version of scatterer that works with this mod?

Share this post


Link to post
Share on other sites
On 2/22/2017 at 2:25 PM, Slye37 said:

Can anybody provide a link to the version of scatterer that works with this mod?

https://spacedock.info/mod/141/scatterer - Version history, it is the previous one (.0256)

Edited by Krazy_Kerbal
Clarification

Share this post


Link to post
Share on other sites

New release candidate: RSSVE v1.2.2-RC3

Change Log

  • Compatibility update for the Scatterer v0.300 release.
  • Many small tweaks to the atmospheric scatter effects of all bodies.
  • Increased the apparent brightness of the Moon (might still need some tweaking).
  • Titan will now appear less bright and saturated than before.
  • Remade and simplified the Earth aurora main and detail textures.
  • The Earth aurora is now less visible in the daylight.
  • Removed an old and unused Earth cloud main texture.
  • Removed the Earth PQS texture (was a performance hog and did not look good anyway).
  • Re-factored the file and folder structure to ease management and development.
  • New binary assemblies for KSP 1.1.3 users (for use with EVE 1.1-3 and Scatterer v0.255). Download and replace the .dll assembly (dated: 2017/02/03).

Bug Fixes

  • None so far.

Known Issues

  • The city lights may appear to fade-in/out or flicker near to the PQS/SS transition. This probably is a bug with the EVE/Scatterer interoperability.
  • The new Scatterer cloud integration and Kopernicus ring shader features are currently disabled.
5 people like this

Share this post


Link to post
Share on other sites
4 hours ago, Phineas Freak said:

New release candidate: RSSVE v1.2.2-RC3

Change Log

  • Compatibility update for the Scatterer v0.300 release.
  • Many small tweaks to the atmospheric scatter effects of all bodies.
  • Increased the apparent brightness of the Moon (might still need some tweaking).
  • Titan will now appear less bright and saturated than before.
  • Remade and simplified the Earth aurora main and detail textures.
  • The Earth aurora is now less visible in the daylight.
  • Removed an old and unused Earth cloud main texture.
  • Removed the Earth PQS texture (was a performance hog and did not look good anyway).
  • Re-factored the file and folder structure to ease management and development.
  • New binary assemblies for KSP 1.1.3 users (for use with EVE 1.1-3 and Scatterer v0.255). Download and replace the .dll assembly (dated: 2017/02/03).

Bug Fixes

  • None so far.

Known Issues

  • The city lights may appear to fade-in/out or flicker near to the PQS/SS transition. This probably is a bug with the EVE/Scatterer interoperability.
  • The new Scatterer cloud integration and Kopernicus ring shader features are currently disabled.

Will this lower the lag in previous version?

Share this post


Link to post
Share on other sites
1 hour ago, dennislee said:

Will this lower the lag in previous version?

if you mean the PQS lag then yes, if you mean the overall lag then no.

Share this post


Link to post
Share on other sites

Hi everyone,

I've read some of the first pages but apparently, I'm the only one to get this issue.. I'm on ksp 1.2.2, RSS and RO (the pre-release for 1.2.2) and I've just installed RSSVE, EVE and scatterer in the correct version (the previous one 0.2.... that works with RSS)

However, when i'm in orbit, the earth is just a (beautiful) full ocean planet, there are no continents, or city lights.. I got the clouds and stuff but no lands..

Any ideas on this issue ? 

 

Thanks for this mod by the way, it is absolutely gorgeous ! :) 

Edited by Alex38

Share this post


Link to post
Share on other sites

Upgraded to RC3 and scatterer 0.300 - works like charm :) no special issues on Earth and Mars so far. ReentryParticleEffect and KAX are working too.

A19DFAC2E6D23065CFC6BA9CD8A110DE1A002638

649AFE8342AC472B540D6111D8F220300D7A1A7B

 

Share this post


Link to post
Share on other sites
2 minutes ago, Heady978 said:

Upgraded to RC3 and scatterer 0.300 - works like charm :) no special issues on Earth and Mars so far. ReentryParticleEffect and KAX are working too.

A19DFAC2E6D23065CFC6BA9CD8A110DE1A002638

649AFE8342AC472B540D6111D8F220300D7A1A7B

 

What's RC3 ? 

yeah i tried but my framerate was terrible.. and i've read on the RO discussion thread that the .2... version of scatterer works better with RO  than the .300 

that so gorgeous ! 

Share this post


Link to post
Share on other sites

@Alex38 RC3 is the brand new release of this RSSVE mod here, as Phineas Freak just said some posts before. RSSVE RC2 worked with scatterer 0.256, but not with 0.300. Following the install instructions from first page lead to the result shown in the pictures. As i've not intalled RO, my first wild guess would be, you have got a problem with the combination of RSS, RO, RSSVE an Scatterer, or one of them is not properly installed. As the Earth map comes with RSS-Textures, this might be the first place to check. Next would be the right EVE package - should be "AnyCPU-EVE-Release.zip" (2.35MB) and nothing else.

Edited by Heady978

Share this post


Link to post
Share on other sites
15 minutes ago, Heady978 said:

@Alex38 RC3 is the brand new release of this RSSVE mod here, as Phineas Freak just said some posts before. RSSVE RC2 worked with scatterer 0.256, but not with 0.300. Following the install instructions from first page lead to the result shown in the pictures. As i've not intalled RO, my first wild guess would be, you have got a problem with the combination of RSS, RO, RSSVE an Scatterer, or one of them is not properly installed. As the Earth map comes with RSS-Textures, this might be the first place to check. Next would be the right EVE package - should be "AnyCPU-EVE-Release.zip" (2.35MB) and nothing else.

thanks for the help, i'm gonna re do the install, but i've done it carefully the first time i tried :) 

 

Share this post


Link to post
Share on other sites

Okaaay so, I just broke my install I think, the probes body don't show up in the vab anymore..

and i've re-done the install of RSSVE and i got the same bug, i have the good files because RSS and scatterer work fine on my other install:

http://imgur.com/uyzYEZu

Share this post


Link to post
Share on other sites

@Alex38 Please make sure that your base RSS install is working correctly and then proceed to install any other mods. I have never seen that before so i cannot comment what the actual problem is. Besides, as i note in the OP, i will not provide support if the user does not provide any game logs.

@ufindbatman Currently, it is a GameData file/folder validator and version checker. I am also thinking about adding an extra check for x86 installations, since it is not possible to run RSSVE with the RAM limitations that it imposes.

Edited by Phineas Freak

Share this post


Link to post
Share on other sites
1 hour ago, Phineas Freak said:

@Alex38 Please make sure that your base RSS install is working correctly and then proceed to install any other mods. I have never seen that before so i cannot comment what the actual problem is. Besides, as i note in the OP, i will not provide support if the user does not provide any game logs.

RSS is running fine, i just tested it last night.. I think that could be a EVE/RSS conflict, or a EVE scatterer conflict.. I don't have the log so thanks for the help anyway :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now