blackrack

[WIP][1.6.1] Scatterer-atmospheric scattering (v0.0540 - 17/03/2019) FIXED TSUNAMI BUG !!!1!1!

Recommended Posts

15 hours ago, blackrack said:

Alright, that's pretty accurate, I'll look at it.

Edited:

@Theysen  @stratochief66 Grab this https://mega.nz/#!yc4yABLR!CpbBgK_9BVFyabsBZX1OkjwkvQwy-KYEJjQmsQbSBtw or revert to the previous .dll (the one with the memory savings), this time change both entries in the planetsList file to Earth


scattererCelestialBodies
{
	Item
	{
		celestialBodyName = Earth
		transformName = Earth
		loadDistance = 5E+07
		unloadDistance = 1E+08
		hasOcean = True
		eclipseCasters
		{
			Item = Moon
		}
	}
}

It seems with either the newest version of RSS or Kopernicus the differing transformName is no longer required, maybe @NathanKell could confirm this.

Edited:

I've updated the downloads with the memory-improved version

I used the most recently released version with those suggested settings, and everything worked well for Earth. Mapmode, launch, everything looks good. I increased the sun flare size by a factor of 5 instead of 10 because the big sun just hurts my yes <then don't look into it, stupid!>

I play with the ocean for Earth set to false (in case that might be important) and around the PQS/SS transition, the scattering post processing appears to apply over the land, but not over the ocean. I'm not sure if that is unique to me, or something other people are experiencing with RSS Earth as well.

Share this post


Link to post
Share on other sites

Hey @blackrack I want to do a little more investigating before I complain like a big fat baby. But a heavily modded instal on win 10 x64. I have blue engine exhaust and a blue Tron looking KSC. The last dll (not the memory saver) worked without a hitch. I am not at my box ATM. But I'll post some pics and an output log. Looked pretty cool though I think you'll have a good laugh :)

 

edit

Here is what I saw

Spoiler

screenshot28_zpstpbcavmv.png~original

 

screenshot29_zpsnnqrcefv.png~original

 

Edited by V8jester

Share this post


Link to post
Share on other sites
2 hours ago, V8jester said:

Hey @blackrack I want to do a little more investigating before I complain like a big fat baby. But a heavily modded instal on win 10 x64. I have blue engine exhaust and a blue Tron looking KSC. The last dll (not the memory saver) worked without a hitch. I am not at my box ATM. But I'll post some pics and an output log. Looked pretty cool though I think you'll have a good laugh :)

 

edit

Here is what I saw

  Reveal hidden contents

screenshot28_zpstpbcavmv.png~original

 

screenshot29_zpsnnqrcefv.png~original

 

Yes! I got this as well. On my version all the planets went blue in scaledspace.

Share this post


Link to post
Share on other sites
2 hours ago, daniel l. said:

Yes! I got this as well. On my version all the planets went blue in scaledspace.

4 hours ago, V8jester said:

Hey @blackrack I want to do a little more investigating before I complain like a big fat baby. But a heavily modded instal on win 10 x64. I have blue engine exhaust and a blue Tron looking KSC. The last dll (not the memory saver) worked without a hitch. I am not at my box ATM. But I'll post some pics and an output log. Looked pretty cool though I think you'll have a good laugh :)

edit

Here is what I saw

  Reveal hidden contents

screenshot28_zpstpbcavmv.png~original

 

screenshot29_zpsnnqrcefv.png~original

 

Is this with the newest release from yesterday? I thought I fixed this like a week ago.

Share this post


Link to post
Share on other sites
21 minutes ago, blackrack said:

Is this with the newest release from yesterday? I thought I fixed this like a week ago.

 

22 minutes ago, blackrack said:

Is this with the newest release from yesterday? I thought I fixed this like a week ago.

It was the newest, I tried the previous release and the bug went away.

Share this post


Link to post
Share on other sites
2 minutes ago, daniel l. said:

It was the newest, I tried the previous release and the bug went away.

Alright well, what else do you have? Anything in the debug log? Any other symptoms? And post your platform and renderer.

Share this post


Link to post
Share on other sites
3 minutes ago, blackrack said:

Alright well, what else do you have? Anything in the debug log? Any other symptoms? And post your platform and renderer.

I'll see what i can do but aside from the bug i told you about, Scatterer does horrible things to my old gaming pc. Maybe you could release a lite version that has just the sun flare and basic scattering.

 

And something i personally would love wouldbe if you released independantly whatever plugin you used for the sun flare and give it a config file so users can add a flare to any star? :)

Share this post


Link to post
Share on other sites
Just now, daniel l. said:

I'll see what i can do but aside from the bug i told you about, Scatterer does horrible things to my old gaming pc. Maybe you could release a lite version that has just the sun flare and basic scattering.

And something i personally would love wouldbe if you released independantly whatever plugin you used for the sun flare and give it a config file so users can add a flare to any star? :)

You can just disable the ocean, the godrays and the shadows and you'll have the "lite" version, really there wouldn't be a point in releasing a separate version for that.

So are you asking for a standalone lens flare shader or just multiple star support? In the case of a standalone shader, keep in mind you won't have the lens flare change color during sunsets/sunrises.

Share this post


Link to post
Share on other sites
7 minutes ago, blackrack said:

So are you asking for a standalone lens flare shader or just multiple star support? In the case of a standalone shader, keep in mind you won't have the lens flare change color during sunsets/sunrises.

I am asking for standalone and multiple please :) The lens flare is great on its own and would be even greater with multistar support, Making kopernicus packs would be great because a modder could choose his/her own flare for the custom star. And not to bug but maybe add layer support like EVE clouds so that a modder could add a space engine like corona, And put the flare over it.

And while i of course dont mind if i wont be able to have it change color during sunsets and sunrises it would be worth it anyway, Maybe you could eventually add that.

But yes the sun flare is too good to be a mere part of a greater mod, It should be independant so players will be able to enjoy beautiful custom flares without having scatterer. (A great mod but burdensome on computer resources when you got it for the flare like i did ;) )

Share this post


Link to post
Share on other sites
8 minutes ago, daniel l. said:

I am asking for standalone and multiple please :) The lens flare is great on its own and would be even greater with multistar support, Making kopernicus packs would be great because a modder could choose his/her own flare for the custom star. And not to bug but maybe add layer support like EVE clouds so that a modder could add a space engine like corona, And put the flare over it.

And while i of course dont mind if i wont be able to have it change color during sunsets and sunrises it would be worth it anyway, Maybe you could eventually add that.

But yes the sun flare is too good to be a mere part of a greater mod, It should be independant so players will be able to enjoy beautiful custom flares without having scatterer. (A great mod but burdensome on computer resources when you got it for the flare like i did ;) )

Alright, fair enough, I will do it but not right now.

Share this post


Link to post
Share on other sites
Just now, blackrack said:

Alright, fair enough, I will do it but not right now.

Thanks :) 

Share this post


Link to post
Share on other sites
7 hours ago, blackrack said:

Is this with the newest release from yesterday? I thought I fixed this like a week ago.

Yes, this was from the newest release on space dock. I also for the first time have a.... I guess "digital camo" pattern on the moon. I'm afraid to give you my log though, I'm over 100 mods at this point. But since it worked on the pre memory optimization. I figured I'd at the very least mention it.

Share this post


Link to post
Share on other sites
6 hours ago, blackrack said:

Alright, fair enough, I will do it but not right now.

Well, you do already have tone mapper as a stand alone.... And if Scatterer is broken up into multiple seperate mods. It may confuse a lot of people.

also @daniel l. the lens flare is fairly easy to modify. I ripped the textures from an asset file for AVP I2 and was able to modify it to work with scatterer. And modders can use a similar approache as texture replacer. Just make there own textures and you would over right existing scatterer textures. Then you would have a new flare with fewer mod folders to keep track of.

Share this post


Link to post
Share on other sites

I was just too stoked about this, I have to share. So I put GEM FX on top of everything (Scatterer EVE AVP) and this was the end result :)

 

Share this post


Link to post
Share on other sites

@blackrack I have to commend you on the new lens flare system. It works so much better than the systems we previously had. The color fading and lightening as your angle to the sun changes looks fantastic! I converted the asset file lens flares Astronomer made for AVP. As he has been absent for some time. Here is a link to those lens flares. If he has any objections I'll be happy to take it down.

 

Scatterer Lens Flares

Share this post


Link to post
Share on other sites
1 hour ago, V8jester said:

o I put GEM FX on top of everything (Scatterer EVE AVP) and this was the end result

Your video seriously needs Real Pume :P

 

Share this post


Link to post
Share on other sites
Just now, sashan said:

Your video seriously needs Real Pume :P

 

You know.... Your at absolutely right :) I'll remember that for next time. I really haven't played with RP yet but I've seen it before.

Share this post


Link to post
Share on other sites
Just now, V8jester said:

You know.... Your at absolutely right :) I'll remember that for next time. I really haven't played with RP yet but I've seen it before.

It's simply awesome.
q4baF1L.png


On-topic: Would it be possible to make water splash horizontal particles to be drawn on top of water again? They are completely invisible now.

Share this post


Link to post
Share on other sites
10 hours ago, V8jester said:

@blackrack I have to commend you on the new lens flare system. It works so much better than the systems we previously had. The color fading and lightening as your angle to the sun changes looks fantastic! I converted the asset file lens flares Astronomer made for AVP. As he has been absent for some time. Here is a link to those lens flares. If he has any objections I'll be happy to take it down.

Scatterer Lens Flares

Thanks, I wasn't satisfied with the existing lens flare system, it was too simplistic and I thought that some small changes could make it a lot better. I also tried implementing another feature where additional spikes would rotate and grow around the sun as it moves around, to make it seem less static, but it didn't look good, I'll probably give it another try later on.

10 hours ago, sashan said:

On-topic: Would it be possible to make water splash horizontal particles to be drawn on top of water again? They are completely invisible now.

I didn't actually remove them (though I didn't like them either) so not sure what's going on, could be because of the new method to disable the ocean, if that's the case it's safe to say they aren't coming back unless you want the performance hit back.

Share this post


Link to post
Share on other sites

FYI, I've reported a possible anomaly with the TST mod and Scatterer in the TST thread at this post.  When I open a telescope window from his mod, I'm getting some sort of additional layer that looks suspiciously like one of yours.  Example here.

Edited by Brigadier

Share this post


Link to post
Share on other sites
16 minutes ago, Brigadier said:

FYI, I've reported a possible anomaly with the TST mod and Scatterer in the TST thread at this post.  When I open a telescope window from his mod, I'm getting some sort of additional layer that looks suspiciously like one of yours.  Example here.

Yes, this was reported on my github repository a long time ago, I haven't fixed it yet.

Share this post


Link to post
Share on other sites
3 hours ago, blackrack said:

I didn't actually remove them (though I didn't like them either) so not sure what's going on, could be because of the new method to disable the ocean, if that's the case it's safe to say they aren't coming back unless you want the performance hit back.

What happened is that you've changed draw order of ocean in relation to particles - they are in the same layer now. This made smoke and others look much better near the ocean but splash FX is almost always a bit lower than actual ocean surface - so it's invisible.

Share this post


Link to post
Share on other sites

Does anybody else feel the stock re-entry/mach effects are big performance hogs?

22 minutes ago, sashan said:

What happened is that you've changed draw order of ocean in relation to particles - they are in the same layer now. This made smoke and others look much better near the ocean but splash FX is almost always a bit lower than actual ocean surface - so it's invisible.

Right, try the oceanRenderQueue field in the UI.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.