blackheart612

[1.4.x-1.8.x] Airplane Plus - R26.4 (Fixed issues/Github is up to date) (Dec 21, 2019)

Recommended Posts

7 hours ago, AntiMatter001 said:

So! I'm having issues with the prop engines you get at the very early stages of the tech tree (spud, baron). the issue is that i'm getting up to a certain speed and they're then losing their thrust. it goes from a steady 17KN to almost 3KN.

Loss of thrust is normal for propellers in real life. Propeller blades begin to stall at a certain airspeed, producing less thrust and more drag. Don't expect to go supersonic with early piston engines, even mighty turboprops can't do it.

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/5/2020 at 7:17 PM, moguy16 said:

hello,

i am still encountering the landing gear problems, they are really frustrating,

is there a way to fix them?

i am tired of my plane jeering off course or not being stable

thanks

 

 

do you have the config for the rest of the engines?

1. Reduce braking on the front wheel(s) by 25-50%

2. Increase Spring strength (advanced tweakable) or double up on wheels if it’s bouncing/veering. 

3. attach wheels to a heavy fuselage part, then offset them to the correct place. Helps with stability.

This applies to the stock wheels. I have not (yet) tried the kspwheel CFG. 

On 5/17/2020 at 9:38 AM, kcs123 said:

I'm already using something similar, folder with name "ZX_Tweaks" for my own custom patches to ensure it is executed after anything else. I didn't know that MM behave like that even if you don't have folder with "Z" name. That is good trick to know for some future patches.

Without specifying a pass (FOR/AFTER/BEFORE/LAST/FINAL) and relying purely on the folder name means your patch will run at the end of the Legacy pass. Which means it’s still one of the first patches loaded, since that pass happens before the others. 

Current MM recommendation is to specific a pass. Like “FOR[zzzzmytweaks]” though that still isn’t as foolproof as just giving them passes as appropriate. 
sometimes you want FIRST or BEFORE. sometimes you want LAST or AFTER. And the rest of the time you’re probably fine with FOR[mystuff]

Edited by Jognt

Share this post


Link to post
Share on other sites
6 hours ago, Manul said:

Loss of thrust is normal for propellers in real life. Propeller blades begin to stall at a certain airspeed, producing less thrust and more drag. Don't expect to go supersonic with early piston engines, even mighty turboprops can't do it.

so essentially I'm just being a big dum dum. I drew the same conclusion yesterday after doing some tests with different propellers. kinda sad i can't get my prop SSTO to even lift off anymore. are their any other mods that add more propellers?

apart from KAX, Firespitter.

Share this post


Link to post
Share on other sites
17 hours ago, AntiMatter001 said:

Hi!

Right off the bat I'm going to say I'm running 1.9.1 so this may very well be my issue and why I'm having problems but carrying on!

So! I'm having issues with the prop engines you get at the very early stages of the tech tree (spud, baron). the issue is that i'm getting up to a certain speed and they're then losing their thrust. it goes from a steady 17KN to almost 3KN.

is this a bug or am i just missing something to do with effective running speed? or something?

They're designed that way. Spud is based on the Spad WW1 biplane, for instance, whose top speed was around 120mph, around 53m/s, which is where the Spud tops out. The Spud is meant for old and slow biplanes, so it can't go fast.

2 hours ago, AntiMatter001 said:

so essentially I'm just being a big dum dum. I drew the same conclusion yesterday after doing some tests with different propellers. kinda sad i can't get my prop SSTO to even lift off anymore. are their any other mods that add more propellers?

apart from KAX, Firespitter.

SXT adds a fair few prop engines.

Share this post


Link to post
Share on other sites

Probably a stupid question, but this works fine with 1.9, right? Or is there any issues that I should know?

Share this post


Link to post
Share on other sites
12 minutes ago, Misguided_Kerbal said:

Probably a stupid question, but this works fine with 1.9, right? Or is there any issues that I should know?

Works fine. No issues.

Share this post


Link to post
Share on other sites

@Citizen247 hey, the patches sadly don't work, i was using the slant landing gear and have ksp wheel installed

Share this post


Link to post
Share on other sites

I'm having some problems with 1.9.1

1st of all, some parts don't have proper collision. Namely the landing skid. When launched, the skid will sink into the runway, and helicopter will fall untill it hits the runway with its belly.

Also I can't make a working helicopter. It always seem to weer to left or right, never increase altitude straight up. When enabling SAS it put maximum yaw in direction opposite to my control rotor, like if it was counteracting some massive phantom force. But there's no phantom force, so it ends up spinningu around like a real life helicopter with broken rear rotor.

Is there any tutorial for marking helicopters with APP? Or am I doing something wrong? Maybe it has something to do with FAR? I am using it 

Share this post


Link to post
Share on other sites

Is this mod still actively being managed? If not we need someone to seriously upgrade this mod.

Share this post


Link to post
Share on other sites
11 hours ago, KIMCHI said:

Is this mod still actively being managed? If not we need someone to seriously upgrade this mod.

If I see issues and pulls on github, I take a look at them/fix them, so it should be up to date, hopefully if people have issues, they report there.

Share this post


Link to post
Share on other sites
Posted (edited)

Version 1.9.1

Beginner-level piston props (not sure about the other ones) has no sound at launch, the helix is not rotating too, though there is a traction.

Where is problem here?

Edited by Evanse

Share this post


Link to post
Share on other sites
On 6/29/2020 at 7:31 AM, KIMCHI said:

Is this mod still actively being managed? If not we need someone to seriously upgrade this mod.

What "serious upgrad[ing]" do you believe it needs?

The only issue I've had with it was a DXT texture not updated.  Blackheart just provided that.

(P.S. I suggest everyone just download and overwrite the skidtex.dds. This really should not require Blackheart push an update.)

Share this post


Link to post
Share on other sites

Not everything needs constant updates.  The mod is in a good place.  Anything else Blackheart decides to give us for free is appreciated, but shouldn't be expected.

Share this post


Link to post
Share on other sites
19 hours ago, Evanse said:

Version 1.9.1

Beginner-level piston props (not sure about the other ones) has no sound at launch, the helix is not rotating too, though there is a traction.

Where is problem here?

Have you checked everything in the FAQ?

Share this post


Link to post
Share on other sites

I have Magpie Mods installed and the parts in this mod used to be shiny but aren't anymore. Not a huge issue but it's kinda annoying. Is there something missing?

Share this post


Link to post
Share on other sites

Hi,

There are several problems with this mod. Here are the messages from KSP.log. Pls fix these errors ASAP. Thanks!

[ERR 21:20:30.104] Texture 'AirplanePlus/Parts/Command/b29cockpit/placeholder' not found!

[ERR 21:20:30.506] Texture 'AirplanePlus/Parts/Engine/Rotorwing/powerprop/default' not found!

[ERR 21:20:31.511] Texture 'AirplanePlus/Parts/Utility/Skid/skidtex' not found!

Share this post


Link to post
Share on other sites
22 hours ago, LittleRed said:

Hi,

There are several problems with this mod. Here are the messages from KSP.log. Pls fix these errors ASAP. Thanks!

[ERR 21:20:30.104] Texture 'AirplanePlus/Parts/Command/b29cockpit/placeholder' not found!

[ERR 21:20:30.506] Texture 'AirplanePlus/Parts/Engine/Rotorwing/powerprop/default' not found!

[ERR 21:20:31.511] Texture 'AirplanePlus/Parts/Utility/Skid/skidtex' not found!

If you go to the GitHub repository you can download  the new skidtex.dds

As for the other two, they are baked-in the .my files.  They are there to stay.

(Helpful hint, never use "ASAP" when seeking assistance with a voluntary project.)

Share this post


Link to post
Share on other sites

are the engines of example ww2 piston planes and ac-130's expected to have very low thrust so that the planes have a TWR of always 0.10-0.14? the jet engines work, and strangely the 0.625m prop with 5 blades works as well

Share this post


Link to post
Share on other sites
On 7/28/2020 at 11:30 PM, I likeOxidizerrfuel said:

Does this mod work with 1.10? 

The mod will always work unless there's a fundamental change in the way parts work in game like the sad sad landing gears ;.; But yeah, there's only one dependency, which is firespitter, and if FS doesn't work on the most recent version, you'll experience some weirdness around the propellers, that might not work properly

6 hours ago, Starhelperdude said:

are the engines of example ww2 piston planes and ac-130's expected to have very low thrust so that the planes have a TWR of always 0.10-0.14? the jet engines work, and strangely the 0.625m prop with 5 blades works as well

The TWR depends a lot on the speed and altitude of the aircraft, the curves behave differently to turboprops and turbofans. If you're checking out the game sheet's data, try it in practice if you haven't yet.

Share this post


Link to post
Share on other sites

Hi, love your mod, it's really one of my favorites of all time.
But is there any other mod, or plan to make IVA's for your cockpits? With the RPM, ASET and other interactive tools for IVA-only flight?
If there isn't would you give permission to a second party to make them?

Thank you very much for your mod and your support!

Share this post


Link to post
Share on other sites
54 minutes ago, pdrZoox said:

If there isn't would you give permission to a second party to make them?

The license in the OP allows for someone else to add IVAs if they want, as long as they follow the other terms. Here's another link: https://creativecommons.org/licenses/by-nc-sa/4.0/

Share this post


Link to post
Share on other sites
On 8/3/2020 at 12:54 PM, pdrZoox said:

Hi, love your mod, it's really one of my favorites of all time.
But is there any other mod, or plan to make IVA's for your cockpits? With the RPM, ASET and other interactive tools for IVA-only flight?
If there isn't would you give permission to a second party to make them?

Thank you very much for your mod and your support!

 

On 8/3/2020 at 1:51 PM, sturmhauke said:

The license in the OP allows for someone else to add IVAs if they want, as long as they follow the other terms. Here's another link: https://creativecommons.org/licenses/by-nc-sa/4.0/

Go ahead! If you want I can link it here in the OP if you've done one

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.