Galileo

[KSP 1.6.1] Stock Visual Enhancements [v1.4.1] [20 March 2019]

Recommended Posts

8 minutes ago, Majorjim! said:

Hi @Galileo I did some FPS tests and using my high part count Atlas V on the pad with scatterer and SVE I get 28FPS. On Duna I get 50-54 FPS. Using the Low resolution version nets no more FPS on the pad but 4-5 more FPS on Duna.

 Using scatterer only and using the same craft on the pad I get 38-40 FPS. And 60 FPS on Duna.

 Does this sound normal? Loosing 10 FPS just for the clouds?

Yeah that's about right but it really depends on your GPU and CPU. Of course,  with a bunch of mods and part packs comes lower performance.  Also,  I'm sure you know,  but part count also plays a big role.  If you can get 28 fps.  with a high part count that's pretty good I'd say. 

If you were to disable the volumetric clouds or disable Scatterer's ocean shaders you would see a boost in performance.  The ocean shaders are the most performance hungry part of SVE

Edited by Galileo

Share this post


Link to post
Share on other sites
Just now, Galileo said:

Yeah that's about right but it really depends on your GPU and CPU. Of course,  with a bunch of mods and part packs comes lower performance.  Also,  I'm sure you know,  but part count also plays a big role.  If you can get 28 fps.  with a high part count that's pretty good I'd say. 

OK thanks mate. I'm running an intel i7 4790k @4.40GHZ and a GTX 970. Craft was over 650 parts.

Share this post


Link to post
Share on other sites
6 minutes ago, Majorjim! said:

Does this sound normal? Loosing 10 FPS just for the clouds?

Sounds normal to me. Vanilla KSP does not support clouds, otherwise they would be in by stock, so EVE & scatterer, which SVE is based on, trick the usage of voluminous clouds by using many many particle effects which need a lot of GPU power. The more voluminous clouds you have the higher the impact on the framerate.

It's an either or thing: either you want a high framerate, then remove the (voluminous) clouds or you want nice graphics, then you must get used to the FPS drop.

 

Share this post


Link to post
Share on other sites
1 minute ago, Tekener said:

It's an either or thing: either you want a high framerate, then remove the (voluminous) clouds or you want nice graphics, then you must get used to the FPS drop.

You could also just disable Scatterer's ocean shaders for a pretty substantial performance gain. 

2 minutes ago, Majorjim! said:

OK thanks mate. I'm running an intel i7 4790k @4.40GHZ and a GTX 970. Craft was over 650 parts.

Yeah 28fps is great for that many parts.  

Share this post


Link to post
Share on other sites
Just now, Galileo said:

You could also just disable Scatterer's ocean shaders for a pretty substantial performance gain. 

Yup, I disable that anyway. That and eclipses, terrain shadows and god-rays.

 

Just now, Galileo said:

Yeah 28fps is great for that many parts.

Cool, thanks for the confirmation. Keep up the excellent work!

Share this post


Link to post
Share on other sites

Have an odd one.

Installing QuickStart is breaking my SVE install.

Link to post in QuickStart thread. My Post

Maybe just something I am doing wrong.....  Pastebin logs included if you want to look.

Share this post


Link to post
Share on other sites
1 minute ago, FizzerUK said:

Have an odd one.

Installing QuickStart is breaking my SVE install.

Link to post in QuickStart thread. My Post

Maybe just something I am doing wrong.....  Pastebin logs included if you want to look.

EVE doesn't work with Quickstart 

Edited by Galileo

Share this post


Link to post
Share on other sites

There ya go..  me being Daft. Did not know that. BUT oddly my v1.1.3 install does have eve working and QuickStart., I think!!

OK thanks, will stop being lazy and pres the load game button.

:D

Share this post


Link to post
Share on other sites
1 minute ago, FizzerUK said:

There ya go..  me being Daft. Did not know that. BUT oddly my v1.1.3 install does have eve working and QuickStart., I think!!

OK thanks, will stop being lazy and pres the load game button.

:D

EVE in 1.2 takes a couple of moments to load at the main menu.  Quickstart is so fast that it loads the game before eve gets loaded and basically skips it

Share this post


Link to post
Share on other sites

Sounds like it could be an easy fix then.  Strange I mentioned pretty much the same thing as a stab in the dark in the other thread.

Thanks. 

Share this post


Link to post
Share on other sites
1 minute ago, FizzerUK said:

There is a setting in the config fileI can adjust.

Will experiment later.

Let me know because I'd like to use that mod as well

Edited by Galileo

Share this post


Link to post
Share on other sites

Are the Joolian rings intended to be at a different inclination relative to Jool's axis of rotation or does this have something to do with Kopernicus?

DQMjAyY.png

Edited by drZuko

Share this post


Link to post
Share on other sites
3 hours ago, drZuko said:

Are the Joolian rings intended to be at a different inclination relative to Jool's axis of rotation or does this have something to do with Kopernicus?

DQMjAyY.png

It is intentionally set like that.  For aesthetics 

Share this post


Link to post
Share on other sites
11 hours ago, Galileo said:

Let me know because I'd like to use that mod as well

It's here.

Need to run  once for the config file to be created.

 

Share this post


Link to post
Share on other sites

Seems to be working in 1.2.1 if anyone is wondering. If you find any bugs related to the new update, let me or @Waz know on the EVE thread

Share this post


Link to post
Share on other sites

56c3a24bd0a4.png

1.2.1 or it from terrain?

i have folders: Kopernicus, StockVisualEnhancements, SVEKopernicus 

updated... or it scatterer...

Edited by *MajorTom*

Share this post


Link to post
Share on other sites
4 hours ago, *MajorTom* said:

56c3a24bd0a4.png

1.2.1 or it from terrain?

i have folders: Kopernicus, StockVisualEnhancements, SVEKopernicus 

updated... or it scatterer...

That is scatterer. Turn off terrain shadows in the main menu scatterer options to fix.   SVEkopernicus won't work in 1.2.1.  Kopernicus needs to be updated 

Edited by Galileo

Share this post


Link to post
Share on other sites

So, when you say that snow was an optional thing for kerbin, does it just add a snow texture to the terrain? And what the heck are the gysers? I tried looking up videos for these but came up with nothing!

Share this post


Link to post
Share on other sites
35 minutes ago, RYU AZUKU99 said:

So, when you say that snow was an optional thing for kerbin, does it just add a snow texture to the terrain? And what the heck are the gysers? I tried looking up videos for these but came up with nothing!

No, it add, snow fall on the poles of Kerbin

and you couldn't find a video or a picture of geysers? i found a ton. here is a pic

pluto3sd.jpg

Edited by Galileo

Share this post


Link to post
Share on other sites
17 hours ago, drZuko said:

Are the Joolian rings intended to be at a different inclination relative to Jool's axis of rotation or does this have something to do with Kopernicus?

You can set the inclination in the config file for the rings if you want a more realistic equatorial plane matching up with the inner moons.

Edited by RoboRay

Share this post


Link to post
Share on other sites
23 minutes ago, RoboRay said:

You can set the inclination in the config file for the rings if you want a more realistic equatorial plane matching up with the inner moons.

You can,  but locking the rings to the inclination of the inner moons can't happen as locking the inclination doesn't work in kopernicus anymore. Until that is fixed we are going to have rings that don't match the inclination of inner planets. If you want to see for yourself,  try to lock the rings and then timewarp in game. You will notice the rings and moons are no longer in alignment . 

Share this post


Link to post
Share on other sites

Hello, for this issue on Laythe with KSP 64bit DX11:0EF71AB976C32E43E69A6B4E1D0CBA59743523AA

You can change this in Laythe-CloudsHigh (EVE config):

_DetailScale = 4
_DetailDist = 1E-07
_Color = 255,255,255,240

By this:

_DetailScale = 1
_DetailDist = 1E-06
_Color = 255,255,255,140

And you will get this:CCEC22A2CFED1DF11EAB8E9C0356A0A7B9200489

I hope it will help somebody who get the same.

Edited by Vandest

Share this post


Link to post
Share on other sites
36 minutes ago, Galileo said:

You can,  but locking the rings to the inclination of the inner moons can't happen as locking the inclination doesn't work in kopernicus anymore. Until that is fixed we are going to have rings that don't match the inclination of inner planets. If you want to see for yourself,  try to lock the rings and then timewarp in game. You will notice the rings and moons are no longer in alignment .

Ok, I'm confused (and not at home to play with it in-game)... why would the inclination need to be variable over time?  Laythe and Vall have zero inclination and Tylo's approaches zero.  If the rings are set to zero or near zero inclination, why should they get out of alignment with the moons?

Edited by RoboRay

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.