Jump to content

[1.12.x] Konstruction! Weldable ports, servos, cranes, and magnets!


RoverDude
 Share

Recommended Posts

1 hour ago, se5a said:

Ah yeah I was looking at that and just installed it, it works with the Konstruction ports out of the box? I read the whole thread and people were saying it'd be nice if it did, but I didn't see anywhere that defiantly said it did work with them.

I can say definitely (and defiantly! :P) that yes, it works.  I recently built a space station that way, using 2.5m konstruction ports and DockRotate to align the modules before compressing the ports away.

Link to comment
Share on other sites

OK so I have been using Konstruction a lot... design a base, make it into a DIY kit, land that kit somewhere, take a construction spaceplane there which contains a workshop and materialkits, unpack the box, build, etc.  I do this often.

Until today.  I noticed that the latest update to the mod lets me constrain the DIY kits by one of the three dimensions, ostensibly so it can fit into places, and that's cool.  I thought nothing of it until I tried to build something on the Mun just now.  I brought the construction craft in range, and pushed DEPLOY on the workshop window, as usual.  The kit started expanding, again as usual.  But it only expands along 2 of the 3 dimensions now, whereas it used to expand evenly.  That'd be ok if it ever STOPPED expanding.  It just keeps growing and growing and growing, to a size far larger than the footprint of the base I'm trying to build... and then it starts sliding, and then it explodes.  This is obviously .. not good.  Anything else I should be trying or is this a known bug?

Link to comment
Share on other sites

So .. @goldenpsp this may be an MKS issue after all; the problem only happens when the craft/base to be built contains MKS drills - pulse 500s or industrial strip miners (those are the ones I tested with) - remove those parts and the behavior is normal.  I posted on the ground construction forum as well, but... I'm super confused here as to why the drills would do this?

Link to comment
Share on other sites

11 hours ago, ss8913 said:

So .. @goldenpsp this may be an MKS issue after all; the problem only happens when the craft/base to be built contains MKS drills - pulse 500s or industrial strip miners (those are the ones I tested with) - remove those parts and the behavior is normal.  I posted on the ground construction forum as well, but... I'm super confused here as to why the drills would do this?

Ok. But this still isn't the mks thread either...:D

Link to comment
Share on other sites

  • 2 weeks later...

@RoverDude Does size matter? I'm asking for a friend. 

This is about docking ports. Since the ports are going to disappear when compressed, besides aesthetics, does it matter which size is used for the joint?  I know both sides of a connection need the same size, but is there any reason not to just use Jr. ports everywhere? I have a friend that just started using Konstruction and the question came up when talking about using KIS/KAS to replace a bunch of conventional docking port joints on his space station. It's more convenient to just use Jr.  ports everywhere, since more fit will fit in a KIS Inventory for shipment to the station.

Link to comment
Share on other sites

1 hour ago, Tonka Crash said:

@RoverDude Does size matter? I'm asking for a friend. 

This is about docking ports. Since the ports are going to disappear when compressed, besides aesthetics, does it matter which size is used for the joint?  I know both sides of a connection need the same size, but is there any reason not to just use Jr. ports everywhere? I have a friend that just started using Konstruction and the question came up when talking about using KIS/KAS to replace a bunch of conventional docking port joints on his space station. It's more convenient to just use Jr.  ports everywhere, since more fit will fit in a KIS Inventory for shipment to the station.

Why not just try with a quick sandbox save?

Link to comment
Share on other sites

18 minutes ago, goldenpsp said:

Why not just try with a quick sandbox save?

I'd fully expect using Jr. ports instead of Sr ports on  2.5m diameter parts would work without trying it a sandbox. What I don't know and hope @RoverDude can answer is if there are any hidden gotchas to this approach that may not be obvious. Like is the resulting connection strength a function of the docking port size?  Doing this in a sandbox may not show some of this.

Link to comment
Share on other sites

2 hours ago, Tonka Crash said:

I'd fully expect using Jr. ports instead of Sr ports on  2.5m diameter parts would work without trying it a sandbox. What I don't know and hope @RoverDude can answer is if there are any hidden gotchas to this approach that may not be obvious. Like is the resulting connection strength a function of the docking port size?  Doing this in a sandbox may not show some of this.

It *should* work but let us know :D

Link to comment
Share on other sites

Hmm @RoverDude I'm just wondering, being a potential writer of a KSP mod (I'm an experienced software dev, but have never written C# or modded KSP) ... how hard would it be to write a mod to just re-root a vessel in flight? There's multiple mods, including this one, that really need that functionality sometimes (here for being unable to collapse ports because one is a root, KAS for being unable to destroy parts on vessels because they've become the root part too, RemoteTech too, IIRC.)

BTW, to answer @Tonka Crash yes you can use Jr ports to collapse larger diameter parts together.

Edited by r1chardj0n3s
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...
3 minutes ago, Kernel Kraken said:

Would this work for 1.3.1 if I changed the version file? 

EDIT: triple posted, oops.

works fine for me on 1.3.1.

IIRC i just use the version CKAN gave me on one of my old 1.3.1 installs. Kept copying it over to my ever evolving 1.3.1 installs.

 

edit: oops sorry, did not realize you were talking about the current version. Please ignore.

Edited by Dafni
Link to comment
Share on other sites

1 minute ago, RoverDude said:

Nope.  It's compiled for 1.4.x

Aww...

Just now, Dafni said:

works fine for me on 1.3.1.

IIRC i just use the version CKAN gave me on one of my old 1.3.1 installs. Kept copying it over to my ever evolving 1.3.1 installs.

...?

I'll try it and see if it works.

Link to comment
Share on other sites

Just now, Kernel Kraken said:

Aww...

...?

I'll try it and see if it works.

Sorry, I did not realize you guys were discussing the current iteration of the mod.

Should be easy to find the 1.3.1 one, right?

At least it looks like my 1.3.1 CKAN here still has access to it.

Link to comment
Share on other sites

Just now, Dafni said:

Sorry, I did not realize you guys were discussing the current iteration of the mod.

Should be easy to find the 1.3.1 one, right?

At least it looks like my 1.3.1 CKAN here still has access to it.

I was wondering because I checked the spacedock and it only listed the 1.1.3 version. I think I can mess with something and make it work, though.

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...