Thomas P.

[1.7.3-2 + Backports] Kopernicus & KittopiaTech

Recommended Posts

11 hours ago, Just Jim said:

WOOOOOHOOOOO!!!! This just made my whole weekend!!! 

Thank you!!!  :D

Oh, yeah, forgot you used OPM-Galileo.

Share this post


Link to post
Share on other sites

 

I'm so happy - Jool has rings again (I use SVE). :) 

KWiAK2d.png

19cqiaC.png

Edited by LameLefty

Share this post


Link to post
Share on other sites

@sarbian has said Module Flight Integrator works with KSP 1.3 and 1.3.1 here.  @Thomas P. said above it also appears to work with KSP 1.4.x as well.

 

 

Share this post


Link to post
Share on other sites

I have been playing gamelinx and opm planet packs, on 1.4.2, since Kopernicus was updated.  There seemed to be some issues with contracts bugging out.  Which does not surprise me since 1.4.x had so many problems with contracts anyway.     I then tried science only and have not seen any errors pop up yet on screen (debug mode on).    

This report is for anyone wanting to start playing the planet packs on 1.4.2.

Edited by Red Thought
Clarification

Share this post


Link to post
Share on other sites

Hey guys,

Has anyone heard of an issue where Kopernicus is causing solar panels not to work?  My solar panels are getting zero exposure when in direct sunlight, and I just installed Kopernicus yesterday.  I googled the problem and there was a link to a forum page talking about some kind of fix, but that link is dead.  I'm happy to provide logs, etc, but I'm just trying to find out if this is a known issue or not first.

Edited by MerlinsMaster

Share this post


Link to post
Share on other sites
23 minutes ago, MerlinsMaster said:

Has anyone heard of an issue where Kopernicus is causing solar panels not to work?

They work for me.

Share this post


Link to post
Share on other sites
Just now, OhioBob said:

They work for me.

Unfortunately, I have isolated it to Kopernicus for me, as after removing the mod, the solar panel was working normally again.  But I would like to find a fix so I don't have to stop using it.

Share this post


Link to post
Share on other sites
7 minutes ago, MerlinsMaster said:

Unfortunately, I have isolated it to Kopernicus for me, as after removing the mod, the solar panel was working normally again.  But I would like to find a fix so I don't have to stop using it.

Are you sure the problem isn't with something else that uses Kopernicus?  What happens when you remove everything but Kopernicus?

Share this post


Link to post
Share on other sites
9 minutes ago, OhioBob said:

Are you sure the problem isn't with something else that uses Kopernicus?  What happens when you remove everything but Kopernicus?

I can confirm Kopernicus is the issue. It was the only mod I’ve ever installed, and uninstalling fixed the panels.

Share this post


Link to post
Share on other sites

Kopernicus has to implement its own behavior for solar panels to account for multiple stars. If you are installing kopernicus mid career, there may be some issues as the solar panels you have on your current vessels didn’t have the necessary changes. Try a fresh game and see if the issue persists.

Also, there is no reason to JUST have kopernicus installed. It does nothing on its own.

Edited by Galileo

Share this post


Link to post
Share on other sites
29 minutes ago, Galileo said:

Kopernicus has to implement its own behavior for solar panels to account for multiple stars. If you are installing kopernicus mid career, there may be some issues as the solar panels you have on your current vessels didn’t have the necessary changes. Try a fresh game and see if the issue persists.

Also, there is no reason to JUST have kopernicus installed. It does nothing on its own.

I tried it on a fresh game, and the solar panels did work.  In my normal install, I do have other mods besides Kopernicus, but at the suggestion of OhioBob, I tried a fresh install with just that to see what would happen.

Share this post


Link to post
Share on other sites
1 hour ago, MerlinsMaster said:

I tried it on a fresh game, and the solar panels did work.  In my normal install, I do have other mods besides Kopernicus, but at the suggestion of OhioBob, I tried a fresh install with just that to see what would happen.

If you added it mid game, you can go to /GameData/Kopernicus/Configs and rename SolarPanel.cfg to SolarPanel.cfgDISABLED.

Share this post


Link to post
Share on other sites
10 minutes ago, leatherneck6017 said:

If you added it mid game, you can go to /GameData/Kopernicus/Configs and rename SolarPanel.cfg to SolarPanel.cfgDISABLED.

What does that do, force KSP to generate a new SolarPanel.cfg?

Share this post


Link to post
Share on other sites
Just now, MerlinsMaster said:

What does that do, force KSP to generate a new SolarPanel.cfg?

No just forces KSP to use stock behavior. This can screw up your game if you are using a planet pack with more than one star.

Share this post


Link to post
Share on other sites
Just now, Galileo said:

No just forces KSP to use stock behavior. This can screw up your game if you are using a planet pack with more than one star.

Oh, really.  I'm not currently using one of those planet packs, but if I decide to use one in the future, do I need to start a new game?

Share this post


Link to post
Share on other sites
1 hour ago, MerlinsMaster said:

Oh, really.  I'm not currently using one of those planet packs, but if I decide to use one in the future, do I need to start a new game?

Most of the time, yes. 

Share this post


Link to post
Share on other sites

Are we now able to place new launch sites using Kopernicus? if not, are there plans to incorporate that into Kopernicus?

If so, can someone post an example config showing how.

It would be cool if we could use kopernicus to make a solar system with 2 or more inhabited planets, and the ability to launch from those inhabited planets.

If nothing else, would it be possible to move the woomerang launch site to laythe?

Share this post


Link to post
Share on other sites
38 minutes ago, KerikBalm said:

Are we now able to place new launch sites using Kopernicus? if not, are there plans to incorporate that into Kopernicus?

If so, can someone post an example config showing how.

It would be cool if we could use kopernicus to make a solar system with 2 or more inhabited planets, and the ability to launch from those inhabited planets.

If nothing else, would it be possible to move the woomerang launch site to laythe?

You can do all of that with kerbal konstructs

Share this post


Link to post
Share on other sites

But that mod doesn't add the "stock" making history launch pads, no? I thought those might be defined in the planet data like PQScity which is used to place the main spaceport.

If it is, then wouldn't modification of that sort of thing fall under the scope of this mod?

After all, I know I can use Kopernicus to move the main KSC structures. I haven't seen updated config dumps for MH, otherwise I'd just try and figure it out myself

Share this post


Link to post
Share on other sites

I just tested once again, I thought it maybe MM3.0.6 but it is not. It is certainly Kopernicus. SVT requires it as a dependency, and I really like SVT. But Kopernicus makes it so solar panels won't charge my batteries. So needless to say everything I put into space becomes useless. Anyone else having this issue with Kopernicus? or is it just me. Either way here are the MODS I have installed if someone cares to test it on there KSP build.

 

kOS

EVE

Planetshine

scatterer SciFiVE

SVT

Kopernicus

Realplume

Realchute

Smokescreen

Share this post


Link to post
Share on other sites

Hi there,

I am in the process of upgrading to 1.4.2. I installed the latest Kopernicus, along with OPM and Sigma Dimensions. I am getting a message stating that Kopernicus was unable to load the planet pack due to an exception.

Anybody got an idea, how to narrow down the likely cause? Screenshot, list of gamedata folder and ksp.log are enclosed in the following file:

https://www.dropbox.com/s/jcndb4jkeyr67sv/KSP_1.4.2.zip?dl=0

Thanks in advance,

Sebastian

Edited by StarStreak2109
Imanoob

Share this post


Link to post
Share on other sites

Update: This also happens with "only" Kopernicus + OPM installed...

Turns out I'm a noob and can't install mods by hand...

Runs away and hides in shame... :/

Edited by StarStreak2109
Imanoob

Share this post


Link to post
Share on other sites

Hello, i have fps problem when installing this mod. Actually if i install just this mod without any other mod, on Mun (and in other cases too) i have much lower fps. Without this mod and other graphical mods it is around 60-77 on surface of mun, but when this mod installed it drops to 35-50 without anything else. If use it with mods like SVT + EVE + SVE + Scatterer, then i have ~20 and in some cases even 15, and removing Kopernicus with SVT (as its dependency on it) i have 30-50 fps again (so EVE + SVE + Scatterer eat around 10-20 fps). Why is this happens? What can i do with that to improve my fps? I don't want lost mods what require kopernicus as dependency (basically i'm using it because of SVT).

Here is all logs required if this can help: http://www.mediafire.com/file/i2njbhlrs3lynvl/logs.zip
All configs are default, and as i mention - this happens even if install kopernicus without anything else.

Here is also my FPS test table:
note: 77 is equal to HZ of my monitor, and that's right, i have 77hz instead of 60hz

without graphical mods - 60-77
only with kopernicus - 35-50
EVE/SVE/Scatterer/DistantObject without kopernicus - 30-55
EVE/SVE/Scatterer/DistantObject with kopernicus - 20-26
EVE/SVE/Scatterer/DistantObject with kopernicus + SVT - 20-26 (so SVT doesn't affect fps at all)

If you need anything else from my side - just tell me, i'll provide it. Thank you.

ps i'm still on KSP 1.3.1 (x64) with kopernicus 1.3.1-7, tested on both dx9 and dx11 (result is same)

Edited by AlexALX

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.