Jump to content

[1.7.3/1.8.1] Extrasolar v1.9.2 [24/01/2020]


Recommended Posts

On 5/16/2020 at 2:57 PM, kspnerd122 said:

how to make it AK compatible

Lots and lots of hackery, or patience and a polite request. I have this running with AVP and Extrasolar, but I had to go in to the files and rip out a bunch of things. I imagine AK is similar.

Link to post
Share on other sites
  • 2 weeks later...

Finally reached Maol

Jeb is ecstatic. He was frozen for a long, long time.

MAde it there with KSPI, DeepFreeze and a bunch of other mods.

AIOukW4.jpg

Link to post
Share on other sites
  • 2 weeks later...

I've had mixed results with planet packs. Some like Outer Planets pack, load properly but I use.an earlier version of KSP 1.2 for that because I don't want to start over from scratch. . .  .  .  The only mods that I use are Kopernicus, MechJeb, and very importantly HyperEdit (except that doesn't run on 1.8 so I have to edit config files instead)  Can someone tell me what my GameData folder should look like if I were to do the following:

These are in KSP 1.8.1 fresh install then add ->

ModularFlightIntegrator file dated 2020-02-04, size 23K (in its own folder).  

Module Manager 4.1.3 dated 2019-11-30 size 142 K (in it's own folder).

and the 5 other files that are a part of ModuleManager in the GameData directory itself. This individual ModuleManager file has a version 2.7.2. dll and is located in the GameData directory itself. One of the important files here is ModuleManager.ConfigCache

Then: 

1. download Extrasolar and put into GameData

2. copy a version (important, which file date?) Kopernicus to GameData <- - which file date?

3. maybe include HyperEdit? (Right now I'm editing the config files themselves on 1.8 to change orbit inclinations - - I Like Eclipses and Transits)

4. include MechJeb which seems to just run fine no matter which version of KSP.

That's all the mods, really!

- -> What should my GameData folder look like starting with just a fresh install copy of KSP 1.8.1 then adding the above?

Thanks in advance for any help.

Link to post
Share on other sites

Great news!  I was not only able to download and get this planet pack running on 1.8.1 with the right version of Kopernicus but also got my standard MechJeb with my favorite craft from another instance of KSP plus Hyperedit.  I had to put that into a "saves" folder then under "SPH".  You probably all know this stuff.  I'm just learning.  

Did run into one slight problem with the details.  One of the planets (whitish surface, 1.02 gravity and a high re-entry limit of 120km) with atmosphere has a blocky surface with larger rectangles like not all of the detail files are getting loaded or maybe it's ?.  It loads the larger blocks as I fly over the surface..  I'm guessing that will be fixed eventually in a new release, unless I need to know something else to fix it.

 

Link to post
Share on other sites

Finally got Extrasolar working.  I had two copies of Module Manager one in GameData and one in Modular Flight Integrator folder. Since nobody answered the question or has posted anything, it looks like this thread has died so it is moot.

 

Link to post
Share on other sites

Hi again,

I'm still running into issues with Extrasolar, I have SVE in and planets are still not showing up.

If a planet did show up then there's no atmosphere for them, I'm beginning to become discouraged because I really do want to explore Valentine, but with these constant bugs I can't enjoy Extrasolar.

 

My version is 1.7.3, I don't know if it's because of Kopernicus, but even the version of Kopernicus I have is 1.7.3. I honestly don't know what else to do. My module manager is 4.0.3.dcf4c5e8b521822806fbe538ae97f0b1.png

Should I reinstall Extrasolar? I don't know what to do.

Link to post
Share on other sites

It looks like the number of people looking at this thread has dropped.  I posted a long message on July 1 and a follow up on July 2 which didn't get any replies.  Then on July 6, a shorter two line message.   Not sure if developers have stopped or ?  

I had success with version 1.8.1, of KSP which you might want to download.

Make a duplicate of the virgin install of KSP without anything installed and work from a second copy.  Find the correct version of Kopernicus that works with 1.8.1.  Then, download and install Extrasolar.

Next step is important.  Make a duplicate of the folder with KSP 1.8.1 and again work from the duplicate copy. That way you can always step backwards to see what went wrong and work from a copy of KSP with Kopernicus and Extrasolar that does work.

A lot of my problems came from not having the correct versions of things like Kopernicus installed.

Hope this helps. It looks like you might not get any help from the few others, if any, who might yet see these posts.  Drop a reply and I'll try to help, but my experience with mods is not great.  I had to learn from little tidbits dropped my way.  Never knew about F-5 and F9 and F12 for quite some time into the early versions of the game.  There's no good database of what to do with mods, and I had to keep asking how to install mods, so for a long time I was scared of installing any at all.  Finally, someone said to put things into the GameData folder.  I'd get installs that didn't work because I had the wrong versions of things like Kopernicus which for planet packs its required, but there are different versions and sometimes an additional Kopernicus folder added.

When you are doing mods make sure the system works first before you add mods one at a time. Make duplicates of working KSP installs when you add things.

 

Link to post
Share on other sites

I'm sorry I have not been attentive to this mod (or Real Exoplanets for that matter). Real life sucks, and I also have a Skyrim mod I've been putting a lot of time into. I was in the middle of working on an update for Extrasolar a few months ago, so I'll try to complete that. As for people who are maybe having issues with Extrasolar, you need to provide me with a screenshot of your gamedata folder, and your KSP.log file in order for me to even begin to be of any help.

Link to post
Share on other sites
On 7/2/2020 at 3:07 AM, etoanrish said:

Great news!  I was not only able to download and get this planet pack running on 1.8.1 with the right version of Kopernicus but also got my standard MechJeb with my favorite craft from another instance of KSP plus Hyperedit.  I had to put that into a "saves" folder then under "SPH".  You probably all know this stuff.  I'm just learning.  

Did run into one slight problem with the details.  One of the planets (whitish surface, 1.02 gravity and a high re-entry limit of 120km) with atmosphere has a blocky surface with larger rectangles like not all of the detail files are getting loaded or maybe it's ?.  It loads the larger blocks as I fly over the surface..  I'm guessing that will be fixed eventually in a new release, unless I need to know something else to fix it.

 

You hyperedited to the planet without quickloading

Link to post
Share on other sites
21 hours ago, Hpl said:

You hyperedited to the planet without quickloading

That worked!  quickloaded at Space Center, then went to Tracking Station.  Great mod.  Need to get a bigger computer.  16GB isn't enough these days.  Maybe 64GB MacBook Pro would be better. :)    Swapping is my enemy.

 

Link to post
Share on other sites
  • 3 weeks later...
On 6/2/2020 at 4:10 PM, Bej Kerman said:
On 10/8/2019 at 8:56 PM, AndrewDraws said:

DO NOT INSTALL THIS FROM CKAN!

Why?

I mean, I installed this from CKAN and it works perfectly fine. The expected contents of GameData from a manual install match what CKAN installs for me. ¯\_(ツ)_/¯

Link to post
Share on other sites
  • 1 month later...
8 hours ago, Cap Arcona said:

I'm looking for another star system to visit, but I can't find any mods compatible with 1.10.1 :( Is this going to get updated? It's on of the most famous extrasolar systems and I am want!

This is working on 1.10.1 for me.

Edited by Merlin1809
Link to post
Share on other sites

Hello, hate to bother you however I have encountered a minor problem. Valentine does not have any sun flares its just a ball I have AVP. Its not like a major problem however it is kind of annoying, if I could get some help. that would be great, Thanks 

Link to post
Share on other sites
4 hours ago, Bob’sCousin said:

Hello, hate to bother you however I have encountered a minor problem. Valentine does not have any sun flares its just a ball I have AVP. Its not like a major problem however it is kind of annoying, if I could get some help. that would be great, Thanks 

I use AVP and don't have that problem on 1.10.1. So I think it might be a mod conflict or something.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...