Jump to content

[1.8-1.10] Extraplanetary Launchpads v6.8.3


Recommended Posts

@schlosrat I know the window can be moved off-screen manually, but not completely, though I suppose it can be hard to find (especially if you don't notice moving it). I will, however, look at getting window movement limits into EL's UI.

On a separate note, I have found that click-through blocker doesn't really work all that well, and can negatively impact user experience (in particular, blocking vessel controls just because the cursor is over a window). However, EL's new UI (when I get it done) removes the need for click-through blocker :) (with the new UI, the only time input locks are needed is when entering text into an input field).

Link to post
Share on other sites
Just now, Souptime said:

I have it installed and mini avc says its not compatible so i thought it needed an update

MiniAVC literally just reads a text file that specifies what version the mod was made for.  It doesn't have any way to actually "check" compatibility.

Link to post
Share on other sites
11 minutes ago, goldenpsp said:

MiniAVC literally just reads a text file that specifies what version the mod was made for.  It doesn't have any way to actually "check" compatibility.

oh

Link to post
Share on other sites
  • 2 weeks later...

How is the amount of time a vessel requires to be constructed calculated? Is there any way to change it? I use Kerbal Construction Time and whilst it's not a hard conflict it feels a little off when the VAB and SPH take longer to build a vessel than an orbital shipyard.

Link to post
Share on other sites

The VAB and SPH are run by Boeing, your orbital shipyard by SpaceX ;)

On a more useful note, there's EL_ResourceRates, which is not set by default, but you can do something like

EL_ResourceRates {
    default = 10
}

In a config file to double the kerbalhours/ton (it can be set per resource)

Link to post
Share on other sites

Mostly just a matter of curiosity. Wondering about the rather drastic improvement in fuel cell productivity compared to stock. Searching for "fuel cell" in the manual got no hits. Searching for it in the forums gets impractically many. I didn't notice a way to restrict a forum search to this particular 240-page thread :-(. I recently started a new career - my first using EL. I had formerly used SimpleConstruction instead, but decided to try EL this time. Got to where I was ready to add some fuel cell power to one of my bases. Glanced at my old notes on what I had needed, but then when I started to build it... wow, that's a big change! A fuel cell array puts out 108 EC/sec from LF+LOX input of 15+18/hr. Compared to stock 18 EC/sec from .02/sec (=72/hr) of LF+LOX. That's somewhere around a factor of 25 or 30 better productivity. Fiddled around quite a bit before discovering it was from EL. Sure makes it a lot simpler to set up a self-sufficient base when farther out than Duna/Ike.

On 1/15/2021 at 4:07 AM, taniwha said:

That's a bug in the CKAN metadata, so take it up with the CKAN people. KIS (and KAS) should be recommended or suggested, not required.

And "recommends" is indeed exactly how CKAN shows it. I suppose that might have changed in the 2 weeks between when the above was posted and when I'm looking right now. I installed EL using CKAN and without KIS. Working fine for me (and I find launchpad 2 more convenient than survey stakes anyway... after using the disposable micropad to attach a launchpad 2 to my base).

Link to post
Share on other sites
4 hours ago, rmaine said:

A fuel cell array puts out 108 EC/sec from LF+LOX input of 15+18/hr. Compared to stock 18 EC/sec from .02/sec (=72/hr) of LF+LOX. That's somewhere around a factor of 25 or 30 better productivity. Fiddled around quite a bit before discovering it was from EL. Sure makes it a lot simpler to set up a self-sufficient base when farther out than Duna/Ike.

Yes, this is by careful design, actually, but as a side effect of designing the LFO smelters. Once I worked out the minimum J/kg available in LFO (which is in the manual, btw), I took a look at how the stock fuel cells compared with the assumption of 1u EC = 1kJ and found them to be horribly nerfed compared to realistic fuel cells: 40% efficiency is realistic, stock fuel cells were getting a tiny fraction of this, thus the factor of 30 improvement.

Link to post
Share on other sites
On 1/26/2021 at 3:58 AM, taniwha said:

The VAB and SPH are run by Boeing, your orbital shipyard by SpaceX ;)

On a more useful note, there's EL_ResourceRates, which is not set by default, but you can do something like

EL_ResourceRates {
    default = 10
}

In a config file to double the kerbalhours/ton (it can be set per resource)

:D I guess I could headcanon that but EL_ResourceRates worked a treat. Thanks!

Link to post
Share on other sites
1 hour ago, Interstellar-farmer said:

Alright so I am using Extraplanetary Launch Pads in 1.11 and the orbital construction dock  shows that I have no productivity, I am using a workshop and I am just testing something, any help is great!

IIRC, you need an engineer onboard, level 3 minimum.

Link to post
Share on other sites
2 minutes ago, ktosiu said:

IIRC, you need an engineer onboard, level 3 minimum.

I was playing in sandbox to test a surface base and I had Bill onboard :huh:

2 minutes ago, ktosiu said:

IIRC, you need an engineer onboard, level 3 minimum.

I had bill (level 5) on board so I don't know what to do

Edited by Interstellar-farmer
Link to post
Share on other sites
7 hours ago, ktosiu said:

IIRC, you need an engineer onboard, level 3 minimum.

Just level 1 (for workshops that aren't fully equipped, 0 for fully equipped).

8 hours ago, Interstellar-farmer said:

Alright so I am using Extraplanetary Launch Pads in 1.11 and the orbital construction dock  shows that I have no productivity, I am using a workshop and I am just testing something, any help is great!

Right click on the part with your engineer(s) and check its productivity (note, there will be two productivities listed: part and vessel). If you don't get any productivity listed at all, then the part is not capable of providing productivity (not a workshop, or something went wrong configuring the part). If you do get productivity listed but it's 0 even with Bill Kerman in sandbox mode (note: Bill's base productivity is 0, but at level 3+ it should be 0.5), then something went wrong configuring the kerbals to have construction skill.

The obvious question: did you install ModuleManager, and is there only one version installed?

Link to post
Share on other sites
2 minutes ago, taniwha said:

Just level 1 (for workshops that aren't fully equipped, 0 for fully equipped).

Right click on the part with your engineer(s) and check its productivity (note, there will be two productivities listed: part and vessel). If you don't get any productivity listed at all, then the part is not capable of providing productivity (not a workshop, or something went wrong configuring the part). If you do get productivity listed but it's 0 even with Bill Kerman in sandbox mode (note: Bill's base productivity is 0, but at level 3+ it should be 0.5), then something went wrong configuring the kerbals to have construction skill.

The obvious question: did you install ModuleManager, and is there only one version installed?

Thank you for the help although I just had to re-install Extraplanetary-Launch-Pads via CKAN

Link to post
Share on other sites
  • 2 weeks later...

I'm trying to use this with 1.11 .. in combination with MKS, if that matters;  I have a station with the normal pad on it and the automated constructor.. tried to build a very simple ship in orbit.. everything worked fine until it came time to launch it after completion - instantly destroys the built craft, all but one part of the station, and after pushing F9 to reload the last save, a 'return to space center' caused the entire game to crash (i haven 't had a CTD in a long time, and I've managed to reproduce this twice with two different craft builds) ... wish the logs had something useful to say, but just a 'dewarp' message from when the build finished and then.. 'part XXX exploded! blast awesomeness <xxx>' all over..  are there deprecated parts?  known issues with EL + MKS currently?  installed everything from CKAN, if that makes a difference.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...