Athlonic

[1.7.x] Chatterer v.0.9.96 - Just keep talking to me [18 Oct 2018]

Recommended Posts

I'm posting solely to draw attention to this post since I feel it has been ignored, and I am also having crashes on scene changes (Flight to whatever) where the crash log is ONLY listing Chatterer, and indeed in the normal flow of the log the last thing to show up is Chatterer:

On 6/28/2019 at 12:43 AM, Babalas said:

Weird crash on scene change. Any clues. Looks like a unhappy combo between scatterer and chatterer.

  Reveal hidden contents

Unhandled Exception: System.NullReferenceException: 
  at (wrapper managed-to-native) UnityEngine.GameObject:get_transform ()
  at scatterer.AtmosphereProjector.Finalize () [0x00000] in <filename unknown>:0 
Stacktrace:

  at (wrapper managed-to-native) UnityEngine.Object.FindObjectsOfType (System.Type) <0x00062>
  at (wrapper managed-to-native) UnityEngine.Object.FindObjectsOfType (System.Type) <0x00062>
  at Chatterer.chatterer.destroy_all_beep_players () <0x0003c>
  at Chatterer.chatterer.load_shared_settings (ConfigNode) <0x0007f>
  at Chatterer.chatterer.load_plugin_settings () <0x00589>
  at Chatterer.chatterer.Awake () <0x01059>
 

 

In my instances I do not have any reference to Scatterer being an issue (though I do have it installed). I've been using Chatterer since at least 2013-14 so I'm very sad that I've had to pull it out of my normal install.

I'm on KSP v 1.7.3, running 109 mods or so (95% installed using CKAN), and kept getting these crashes on scene change from flight to where ever until I narrowed it down to Chatterer, and then pulled it temporarily. Crashes stopped. Now ever since I once in a while try to put it back in, and the crashes start again. Every time the crash log lists Chatterer and nothing else and is very similar to the one above except no mention of Scatterer.

I would post/link one, but this issue started more than a month ago and I've pulled Chatterer from my install that long ago as well (crashes stopped), and when I saw someone had already brought up a similar issue I just waited for them to get a substantial response, and that never happened.

Ultimately, I'm hoping to get some attention drawn to this potential (though I think evident) issue, and hopefully inspire anyone else with the same issue to come forward as well.

Thanks.

Share this post


Link to post
Share on other sites

Hey @longbaugh01,

Although I haven't had any problems with Chatterer in my 144 mod install, that doesn't mean there couldn't be one. If there is, helping the mod authors find it could potentially help others. If you are serious about trying to get this fixed, then I'd like to suggest you reinstall Chatterer, wait for the crash, and post your logs to this and the Scatterer forums so that the mod authors have something to work with other than one report that contains a snippet with an NRE. Neither you nor Babalas posted your logs, and it seems unreasonable to expect a mod author, who generously shares their work with the community for free and the occasional donated cup of coffee, should have to try to figure out what may have gone wrong in a 100+ mod install with a 10-line error message from someone else's game. Help them help you. :)

 

 

Share this post


Link to post
Share on other sites

Yep,

This Chatterer/Scatterer issue wasn't unnoticed, it is just that I wasn't able to reproduce it here so unable to trace and investigate this further.

Here is a quick/dirty recompile devBuild for KSP v1.7.3 :

https://github.com/Athlonic/Chatterer/releases/tag/v0.9.97_devBuild

Feel free to test this one if you have any issue and please report back ;)

Hope this helps.

PS: @eightiesboi thanks again for the cup of coffee :D

 

 

Share this post


Link to post
Share on other sites
On 9/15/2019 at 4:33 AM, Athlonic said:

Here is a quick/dirty recompile devBuild for KSP v1.7.3 :

https://github.com/Athlonic/Chatterer/releases/tag/v0.9.97_devBuild

Feel free to test this one if you have any issue and please report back ;)

Hope this helps.

So far so good, with no Chatterer-related crashes/issues, so I thank you very much for providing this recompile. I'll continue to keep an eye on it, but I'm hopeful it'll no longer be an issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.