K.Yeon

[1.3.0] OPT Space Plane v2.0.1 - updated 29/07/2017

Recommended Posts

2 hours ago, maalof said:

why can´t i find the bug fixes in the links part of the post

The bugfixes were eventually included in the main downloads. No need to be concerned. If you have the problems described there, it's time to get the main downloads.

Share this post


Link to post
Share on other sites

Hi. 
Running Kerbal 1.3.0 (the one revertable on steam). Plus a bunch of mods installed by CKAN
Including this one, how ever. I can not for the life of me get a stock Orange Tank(Rockomax jumbo-64 fuel tank) to be shielded and not produce any drag inside 2 OPT J Cargo Bays. 
I have alot of experience doing spaceplanes, I know how it works with cliping. Stock MK2\MK3 parts shields propperly. 
Something must be wrong.
Used Collide-o-Scope to ensure nothing is clipping, nor does the tank collide with any of the OPT parts...
Using 2 Rockomax x200-32 Fuel tanks does NOT produce any drag. Just the Orange tank. Is that part broken by any chance?

 

Edited by Reknot
Added some info

Share this post


Link to post
Share on other sites

@Reknot Unfortunately, OPT (especially OPT Legacy, controlled by me and @stali79) has a long history of cargo bay issues. The only thing I can suggest is that you ensure that your two cargo bay pieces are attached by their outer nodes, not their inner nodes, which I've repeatedly found for myself.

As part of the next release of OPT Legacy I've revised or at least inspected and confirmed the attach nodes on all of its cargo bays which will unfortunately break some craft but at least fixes the Stail and Stail Freight body cargo bays. I'm in need of someone who's willing and able to take my revised editions of these parts and invest the time to wrestle with the cargo bay coding to hopefully, truly, finally fix them...or confirm that they have model issues and are utterly unfixable. :/ 

Share this post


Link to post
Share on other sites

@JadeOfMaar 
I see. Well, as I edited in. Two Rockomax x200-32 Fuel tanks works, does kerb use the mesh no adays as a collider? or does the cargobay occlusion itself use the Mesh? Because the only thing i can see is the small "fuel tubes" going along the side of the Orange tank that's poking at the models? Just a thought. 
However, it's some awesome parts you have on this mod and I will still use them. Thanks for keeping it alive. <3 

 

Share this post


Link to post
Share on other sites
On 11/30/2017 at 8:07 PM, stali79 said:

SAGE and SURGE use non stock resources. You need the Community Resource Pack installed

I know this was pointed out a few pages back, but is it mentioned anywhere as a dependency? If it is, sorry, I must have just missed it.

Edited by TheKurgan

Share this post


Link to post
Share on other sites

@TheKurgan It's not mentioned anywhere; I should change that.

 @Reknot Cargo bay occlusion uses an imaginary cylinder with a given radius and which uses the inner attachment nodes of the bay as its height and its caps. Anything that intersects this cylinder should be shielded but OPT's cargo bays have been broken for a very long time (especially the legacy ones), and I'm in need of a helper or a fanboy/fangirl who has the time and interest, and who can take my work with the legacy parts (I've revised the nodes and bay modules somewhat) and finish it.

I love modding and tweaking things but tbh I don't casually play enough so for me the answer is to pack extra dV and either brute force an ascent or do much longer deorbit burns.

To prevent this, right here......

Your appreciation ( <3 ) is very welcome. :) 

VsaALUv.jpg 6iCmZWX.jpg

Share this post


Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

@TheKurgan It's not mentioned anywhere; I should change that.

 @Reknot Cargo bay occlusion uses an imaginary cylinder with a given radius and which uses the inner attachment nodes of the bay as its height and its caps. Anything that intersects this cylinder should be shielded but OPT's cargo bays have been broken for a very long time (especially the legacy ones), and I'm in need of a helper or a fanboy/fangirl who has the time and interest, and who can take my work with the legacy parts (I've revised the nodes and bay modules somewhat) and finish it.

I love modding and tweaking things but tbh I don't casually play enough so for me the answer is to pack extra dV and either brute force an ascent or do much longer deorbit burns.

To prevent this, right here......

Your appreciation ( <3 ) is very welcome. :) 

VsaALUv.jpg 6iCmZWX.jpg

I am in a similar boat as I barely play anymore.

 

Btw @JadeOfMaar have we released a version with the new OMS pods yet?

Share this post


Link to post
Share on other sites

@stali79 Lol. No I haven't made such a release yet. I'm waiting on a few big projects to finish, and I need to clear my KSP modding task list so i can actively develop Legacy some more. I intend for the next release to be very large.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, JadeOfMaar said:

@stali79 Lol. No I haven't made such a release yet. I'm waiting on a few big projects to finish, and I need to clear my KSP modding task list so i can actively develop Legacy some more. I intend for the next release to be very large.

Thats cool. Just wasnt sure if a release was done yet that included the new pods

 

  • Like 1

Share this post


Link to post
Share on other sites

I am looking over this mod before I download it and I like all the parts that it adds especially the Phoenix cockpit but I can't seem to find any examples online on what the interior looks like. Is there an interior and if not when can we expect to get one? Thanks!

Share this post


Link to post
Share on other sites
On 1/21/2018 at 4:02 PM, RocketRaccoon said:

I am looking over this mod before I download it and I like all the parts that it adds especially the Phoenix cockpit but I can't seem to find any examples online on what the interior looks like. Is there an interior and if not when can we expect to get one? Thanks!

All of OPT's parts have IVAs now, except maybe the Stail class parts. You have to install the mod(s) for yourself to see them all, as screenshots of IVAs are few and far-between. And some IVAs are more complete than others, of course.

In other news, I've just released this addon for OPT.

1QXG3oI.jpg

  • Like 3

Share this post


Link to post
Share on other sites

@williamhall531@gmail.com OPT Legacy's development is at a bit of a stand-still. Help is needed to fight another fight against the broken cargo bay modules. But there is something good. I released something big for OPT (see my previous comment).

Something is wrong with your game if OPT doesn't work. OPT is a parts mod with no plugins of its own. The usual problems are:

  • You're missing Firespitter (for fuel switching)
  • You're missing Community Resource Pack (the WarpJet engines will throw exceptions as they use non-stock resources)
  • A module that shouldn't be present in the not-hollow K or KH Inline SAS will somehow cause physics to break and you can't accelerate past 320m/s. :/ 
  • Like 1

Share this post


Link to post
Share on other sites

@stali79 I have another Firespitter replacing config coming (B9 Part Switch). Night Mode can be adapted to run on that too. This will be available firstly/only within OPT Legacy. :) The WBI config is a stepping stone towards it.

  • Like 1

Share this post


Link to post
Share on other sites
On 1/23/2018 at 9:17 PM, williamhall531@gmail.com said:

hi whats up?

i've been wondering, it appears that this version of OPT isn't working with KSP 1.3.1, 

You should unzip the mod folder in a separate location and copy the entire contents into the root of the Kerbal space program directory, the zip file has GameData and Ships folders that you want to merge with the existing game folders, if you just unzip the file into the GameData folder it's probably not going to work, the mod includes Mod manager but you should always look for the latest one and Mod Manager must be in the GameData folder. As JadeOf Maar said the mod also requires Firespitter for fuel switching, and Community Resource Pack for Warp Jet functionality. For IVAs you will need ASET Prop Pack and ASET Avionics as many of the cockpit layouts use these, as well as RasterPropMonitor for full instrument functionality. All of this should work with 1.3.1, especially parts, if not either the mods were not installed correctly or there may be a conflict with another mod.

  • Like 1

Share this post


Link to post
Share on other sites

I am not getting any cockpits when installing on 1.3.1.

 

Share this post


Link to post
Share on other sites
6 hours ago, Zyme said:

I am not getting any cockpits when installing on 1.3.1.

 

I've got all the cockpits, so it must be install error.

  • Like 1

Share this post


Link to post
Share on other sites

Suggestion - Add battery and ore container variants for all parts. Ore for submarines (and transporting ore) and batteries for muh space lazors!

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, Fireheart318 said:

Suggestion - Add battery and ore container variants for all parts. Ore for submarines (and transporting ore) and batteries for muh space lazors!

Configurable Kontainers does just that

  • Like 2

Share this post


Link to post
Share on other sites

Hi, 

I'm having a weird problem with some of the parts in this mod that I haven't been able to pin down. Yaw. Lots of unintended yaw, and always in the same direction. 

At first I thought I'd applied some parts off-centre, or asymmetrically, but nope. After rebuilding different sizes of J-type craft I always have the same problem - it yaws to the right. The faster it gets, the worse the problem is. 

Any idea what might be causing it? I've tried all sorts of things, and I'm convinced that the centre line of the J parts (possibly others) must be ever so slightly off

  • Like 1

Share this post


Link to post
Share on other sites

So I was curious about a few things here.  I used this back a  year ago, and am recently coming back to kerbal.

1.)  Is this the thread to download OPT for for the current version 1.3.1

2.)  I saw your WBI addon.  What is WBI? I've googled and I can't really find a description.  I found the page that has all the different mods I guess.  I'm all for immersion, but I'm not really interested in dealing with life support.  

3.)  It sounds like OPT legacy no longer works in 1.3.1?  If it does, where do I download it?

 

Thanks for your help and answers.  I loved these parts when I used them last, so really want to be able to toy with them again.

Edited by flyguybc

Share this post


Link to post
Share on other sites
30 minutes ago, flyguybc said:

So I was curious about a few things here.  I used this back a  year ago, and am recently coming back to kerbal.

1.)  Is this the thread to download OPT for for the current version 1.3.1

2.)  I saw your WBI addon.  What is WBI? I've googled and I can't really find a description.  I found the page that has all the different mods I guess.  I'm all for immersion, but I'm not really interested in dealing with life support.  

3.)  It sounds like OPT legacy no longer works in 1.3.1?  If it does, where do I download it?

 

Thanks for your help and answers.  I loved these parts when I used them last, so really want to be able to toy with them again.

1) spacedock for download.

2) its to make opt more compatible with the Wild Blue Industries mods (life support etc)

3) spacedock for download

  • Like 1

Share this post


Link to post
Share on other sites

OK I just can NOT get this to work with 1.3.1

I have all the dependencies, I've installed everything in the right place, and I can get to the KSP main menu, but when trying to actually start or load a game, it'll go to the load screen and crash after 5 seconds >_< I really don't want to revert to 1.3.0 because that would require re-downloading previous versions of all the OTHER mods I use, this is the only one causing an issue. Halp?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now