CaptRobau

[1.2.1] Outer Planets Mod (2.1) - Active development has moved, see first post for new thread

Recommended Posts

26 minutes ago, Sigma88 said:

you should try to reproduce the bug without GN, I don't do anything that affects atmospheres so if you see the bug there you should see it without GN as well

Update: it suddenly started working? Even though i had restarted the game before and the issue persisted, it was only on the second restart that drag occurred. Whats weird is that i did not modify the game files at all??-Wait... i just reloaded a quicksave and its broken again. This is weird

Edited by Xblackmamba

Share this post


Link to post
Share on other sites

So, CaptRobau, maybe you could make an asteroid belt mod? Like if you agree

Sorry about the random quote, I don't know how to delete them.

Edited by Edlu Kerman
GOT RID OF RANDOM QUOTE

Share this post


Link to post
Share on other sites
17 hours ago, Edlu Kerman said:

 

So, CaptRobau, maybe you could make an asteroid belt mod? Like if you agree

Sorry about the random quote, I don't know how to delete them.

Click the quote and press 'delete' works if I remember correctly.

Share this post


Link to post
Share on other sites
1 hour ago, The White Guardian said:

Click the quote and press 'delete' works if I remember correctly.

Thanks!

Share this post


Link to post
Share on other sites

the 2.0 update is absolutely splendid and i love it in every way but one. just my personal taste but i find eeloo's new craters to be rather disfiguring. is there any way to remove them? (my attempts so far have either failed, or caused eeloo to vanish altogether).

Share this post


Link to post
Share on other sites

You can easily remove it from the terrain, but not from the texture you see from far off/map view as it's baked in there. To remove from the terrain, open up the cfg and remove the section that sort of looks like this:

				VoronoiCraters
				{
					colorOpacity = 0.7
					DebugColorMapping = False
					deformation = 200
					jitter = 0.1
					jitterHeight = 2
					rFactor = 1
					rOffset = 1.1
					simplexFrequency = 300
					simplexOctaves = 3
					simplexPersistence = 0.5
					simplexSeed = 123123
					voronoiDisplacement = 0
					voronoiFrequency = 50
					voronoiSeed = 462
					order = 100
					enabled = True
					name = _HeightNoise
					index = 1
					CraterCurve
					{
						key = -0.9963056 -0.7950293 -0.1902251 -0.1902251
						key = -0.9520697 -0.8223228 -0.6806358 -0.6806358
						key = -0.7445966 -0.8581167 0.4436148 0.4436148
						key = -0.4499771 -0.1392395 5.289535 5.289535
						key = -0.4015177 0.2551735 9.069458 -2.149609
						key = -0.2297457 0.08363447 -0.4453675 -0.4453675
						key = 0.2817185 0.01192154 0.01421198 0.01421198
						key = 1.000876 0.001117015 0.01397126 0.01397126
					}
					JitterCurve
					{
						key = -1.000701 0.4278412 0.1577609 0.1577609
						key = -0.7884969 0.09487452 -0.7739663 -0.7739663
						key = -0.6091803 0.072019 0.123537 0.123537
						key = -0.3930514 0.3903495 3.300831 3.300831
						key = -0.3141366 0.9276265 0 0
						key = -0.2586833 0.002564805 -0.01814346 -0.01814346
						key = 0.9970253 0.003401639 0 0
					}
				}

 

Share this post


Link to post
Share on other sites
On ‎6‎/‎8‎/‎2016 at 9:28 PM, CommanderSmith said:

I'm glad you've got that working, and I hope you're having lots of fun sending probes off everywhere. :)

Update: Sending New Korizons probe to Plock!

Share this post


Link to post
Share on other sites

How did you create your planets? I've been trying so hard for so long to successfully make planets, all guides i've found always refer to guides from 2015, before the update and thus irrelevant or horrendously incomplete. Is there any guide you can refer me too? I wanted to give Kerbol a binary companion. And is there a way to control what ids Kopernicus gives planets? I wanted to give my planet packs a hierarchy order for id assignment

Edited by BashGordon33

Share this post


Link to post
Share on other sites

I would love to see this mod working.

But of course (as most cool mods) this does not work on my computer. (The mod is just ignored... even if I do a reinstall of the game and start a fresh "sandbox" game)

Is there any sign that a mod is "accepted" by the game or can I see the reasons why a mod is not accepted?

 

Share this post


Link to post
Share on other sites
1 hour ago, Idinyphe said:

Is there any sign that a mod is "accepted" by the game or can I see the reasons why a mod is not accepted?

The thread below gives all sorts of information about how you can troubleshoot your modded game including details on where to find the log files that indicate what mods are being loaded and what they are doing...

 

Share this post


Link to post
Share on other sites

@Padishar

Thank you but I did those steps already (I reinstalled the game, reduced the mods to the dependencys the installertool recommended etc....) except for the logfile... I will check the log but I doubt that I will find anything useful.

 

Share this post


Link to post
Share on other sites
43 minutes ago, Idinyphe said:

@Padishar

Thank you but I did those steps already (I reinstalled the game, reduced the mods to the dependencys the installertool recommended etc....) except for the logfile... I will check the log but I doubt that I will find anything useful.

 

if you upload these things we can take a look for you:

- output_log.txt (found either in KSP/KSP_x64_Data or in KSP/KSP_Data depending if you run 64bit or 32bit ksp)
- Logs (the whole "Logs" folder, found it in the KSP install folder)
- ModuleManager.ConfigCache (found in KSP/GameData)

 

it would help if you generated these logs while having installed only the minimum:

KSP 1.1.2
OPM 2.0
Kopernicus 1.0.5
MM 2.6.24 or 25

Edited by Sigma88

Share this post


Link to post
Share on other sites

@Sigma88

Thank you. The mod is working now.

What worked for me was the following:

Don't start the game from "Steam" after a clean install but start it _once_ from the exe in the folder. After that, it works, even if started from Steam...

Why? I don't know... I had the problem that everytime I asked steam to check the files _one_ file was "wrong" and reloaded from steam. Maybe those issues are related?

 

I LOVE this mod! Great work!

Share this post


Link to post
Share on other sites

So for my Slate mission I decided to take a wee drive up Mount Nehellenia. Took ages in the rover but I got some great views of the crater (and my landing site), Sarnus, some of its moons and the Slatean Supercontinent from the summit!

PS - Here's where the Kerbals were (roughly) in relation to the volcano;

screenshot773.jpg

 

screenshot770.png

 

screenshot771.png

 

screenshot772.png

Edited by Diddly Feelerino

Share this post


Link to post
Share on other sites
4 hours ago, Diddly Feelerino said:

So for my Slate mission I decided to take a wee drive up Mount Nehellenia. Took ages in the rover but I got some great views of the crater (and my landing site), Sarnus, some of its moons and the Slatean Supercontinent from the summit!

PS - Here's where the Kerbals were (roughly) in relation to the volcano;
 

  Hide contents

screenshot773.jpg

 

  Hide contents

screenshot770.png

  Hide contents

screenshot771.png

  Hide contents

screenshot772.png

Very pretty! Which skybox are you using?

Share this post


Link to post
Share on other sites

Does Outer Planets Mod break Stock Visual Enhancements? I noticed that when I installed Outer Planets, suddenly Kerbin looked naked w/o any clouds. Are these two mods incompatible?

[edit]

Strangely, when I uninstalled OPM and then reinstalled it, SVE still worked. Can't explain that. :/

Edited by Recon777

Share this post


Link to post
Share on other sites
On 2/13/2015 at 8:01 AM, Eudae55 said:

KSPRC Compatibility

Here's a config for the people asking for compatibility with KSPRC

Includes Tekto and Gas Giant cloud layers

Javascript is disabled. View full album

Important:

These configs will not work if:

 

  • The EVE mod .dlls are out of date
  • The RSS .dll is out of date
  • The Texture Replacer mod is below version 2.2.5 (this breaks the OPM mod if its an old version)
  • Planetshine is out of date

 

Does this config still work or does it require updating to 1.1.x?

Share this post


Link to post
Share on other sites

Er, pardon me, but this:

9KKeWKf.png

Is not one of the finest views in the Kerbol system. Btw that's Eeloo, one of three moons I got with this mod. Everything is textured like this. I have a fresh install with Kopernicus 1.0.5 and the latest version of this mod. Um... Any suggestions...? This is my first experiment with planet packs and I'd hate to have to give up and go back to the stock system. I've kind of outgrown it at this point...

EDIT: after experimenting with some other planet packs and Galactic Neighborhood, I have found that some but not all of them have this problem as well. Strangely the New Horizons mod has some planets with textures and some without. I think it must be a problem with some other thing than OPL then, although if anyone here has any idea how to fix it, I'm excited to hear it.

Edited by ruiluth

Share this post


Link to post
Share on other sites

Hello. I am sorry if I am causing trouble, but I have a question.
I would like to play with this mod and the KScale64 mod. Did anyone make the config file? I looked for it but if it exists I must be blind.
Thanks!

Share this post


Link to post
Share on other sites

Can you add Verbalized versions of 6 or more dwarf planets? Can you possibly kerbilze Eris Makemake, Haumea, Orcus Vauruna and Ixion?

 

I love the mod by the way.

 

Share this post


Link to post
Share on other sites

I have same issue with planets yellow-black textured as ruiluth. Any sollution has been found or should I post log etc. for help you fix it?

Share this post


Link to post
Share on other sites

Excuse me @CaptRobau I really need to know how to make the textures lower in this mod, my computer has been having a ton of issues running planet packs with all of 2.0's high res textures. I know there is a setting to reduce texture, but that also reduces the stock texture, but that results in a terrible textures for stock planets

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.