Jump to content

[WIP][1.9.x-1.12.x] Scatterer-atmospheric scattering (0.0838 - 14/08/2022) Scattering improvements, in-game atmo generation and multi-sun support


blackrack
 Share

Recommended Posts

Apologies if there is a better place to ask this or I'm just missing something, but is there a way to turn off the surface saturation on Kerbin? I'm messing with visual packs and something I've done has made it rather bright, and I would prefer it to be off. 

EDIT: Nvm, figured it out!

Edited by xXIndestructibleEVAXx
Link to comment
Share on other sites

I'm contemplating a boat trip around Laythe, and so when I saw Scatterer gives actual waves, I installed it. Hooray, this should add a bit of interest to boat trips.

However, now I have to ask - anyone got any tips for boat design if you are using Scatterer to give actual waves? Bolting together rocket spares any old way isn't cutting it anymore.

Link to comment
Share on other sites

On 4/6/2022 at 4:53 PM, damerell said:

I'm contemplating a boat trip around Laythe, and so when I saw Scatterer gives actual waves, I installed it. Hooray, this should add a bit of interest to boat trips.

However, now I have to ask - anyone got any tips for boat design if you are using Scatterer to give actual waves? Bolting together rocket spares any old way isn't cutting it anymore.

I don't have any building tips, but the thing I remember from this post is that real world stability rules apply (ship designs that are more stable irl are more stable in-game): https://www.reddit.com/r/KerbalSpaceProgram/comments/khzqcy/testing_out_the_new_scatterer_waves_with_my_125/

 

Link to comment
Share on other sites

New build is up, mostly fixing TAA and enabling it by default.

Full changelog:

- Fix TAA breaking with atmosphereless bodies and becoming a smearfest
- Fix TAA randomy disabling with TUFX
- Use TAA by default on the default preset and upwards, the lower 2 presets still use SMAA
- Expose TAA settings
- Fix UI window being unclickable/undraggable on lower screen resolutions
- Fix Bruneton tonemapper causing artifacts with bright colors

 

Link to comment
Share on other sites

3 hours ago, abbiii said:

Flags on crafts flicker with TAA enabled (latest version).

Bld6udj.gif

Getting similar problems especially with UI in map view. Submitted a issue on github with logs. Turning off TAA fixes it

Link to comment
Share on other sites

7 hours ago, blackrack said:

New build is up, mostly fixing TAA and enabling it by default.

Full changelog:

- Fix TAA breaking with atmosphereless bodies and becoming a smearfest
- Fix TAA randomy disabling with TUFX
- Use TAA by default on the default preset and upwards, the lower 2 presets still use SMAA
- Expose TAA settings
- Fix UI window being unclickable/undraggable on lower screen resolutions
- Fix Bruneton tonemapper causing artifacts with bright colors

 

I love you, blackrack.

Link to comment
Share on other sites

14 hours ago, abbiii said:

Flags on crafts flicker with TAA enabled (latest version).

I'm unable to reproduce this. And it looks more like z-fighting so maybe give it an inch of spacing or provide more info (check the OP: how to report issues section).

11 hours ago, Flipper028 said:

Getting similar problems especially with UI in map view. Submitted a issue on github with logs. Turning off TAA fixes it

Just noticed this. I don't think it's fixable without breaking the atmospheres in map view with TAA. The thing is TAA works by jittering the projection matrix to take offset samples over time, but the shaders have to work with it.

Could be fixed by overriding the orbit icons shader, I consider it quite mild though so probably not going to fix it.

Link to comment
Share on other sites

Posted (edited)
24 minutes ago, Poodmund said:

Is there any ability to set what layers the anti-aliasing affects?

The choice is limited to opaque and transparencies. The icons count as transparencies. Unfortunately it has to be applied to transparencies or other issues appear with the atmosphere, so not sure what else to do there, maybe just reverting to SMAA in map view.

Edited by blackrack
Link to comment
Share on other sites

I think the last update made the menus in the space center to shake. At least in my configuration.

I also saw the flag flickering and in map view things shaked too.

Reverting to previous version fixed all that.

Edited by Agustin
Link to comment
Share on other sites

23 hours ago, Agustin said:

I think the last update made the menus in the space center to shake. At least in my configuration.

I also saw the flag flickering and in map view things shaked too.

Reverting to previous version fixed all that.

I haven't seen any of these bugs, but being a 4K user, I don't use TAA either, so maybe that's what causes it.

Link to comment
Share on other sites

On 4/9/2022 at 6:06 AM, Agustin said:

I think the last update made the menus in the space center to shake. At least in my configuration.

I also saw the flag flickering and in map view things shaked too.

Reverting to previous version fixed all that.

This is an artefact of TAA’s implementation here. You can find a more detailed explanation above your post on this page.

Link to comment
Share on other sites

On 4/10/2022 at 6:04 AM, Agustin said:

Is there a way to scale down the stock sunflare texture? It looks so weird.

There are other sunflares available for Scatterer, like Sunflares of Maar. They look better but they are a little difficult to get working .

Link to comment
Share on other sites

With TAA (default settings), I'm noticing fairly obvious jittering on the map view. The whole scene is jittering randomly a pixel or 2. It's a bit nauseating. However, it does not do this at all in the tracking station. I switched to SMAA and the map view is OK now. 

I found that under Long Distance Terrain Shadows changing the 3 Shadow Cascade Splits settings from 0.015 to 0 pushed the shadow transitions out to farther distances which I prefer. With 0.015 settings, the closest and 2nd levels happen within the normal view distance of a ship and the abrupt edge between sharp and blurry shadows is distracting. 

Is certainly nice that all of these options are available to experiment with.

KSP 1.12.3, scatterer 834. I've got a GTX1060 with a 1920x1200 screen.

 

 

Link to comment
Share on other sites

6 hours ago, Krazy1 said:

With TAA (default settings), I'm noticing fairly obvious jittering on the map view. The whole scene is jittering randomly a pixel or 2. It's a bit nauseating. However, it does not do this at all in the tracking station. I switched to SMAA and the map view is OK now. 

I found that under Long Distance Terrain Shadows changing the 3 Shadow Cascade Splits settings from 0.015 to 0 pushed the shadow transitions out to farther distances which I prefer. With 0.015 settings, the closest and 2nd levels happen within the normal view distance of a ship and the abrupt edge between sharp and blurry shadows is distracting. 

Is certainly nice that all of these options are available to experiment with.

KSP 1.12.3, scatterer 834. I've got a GTX1060 with a 1920x1200 screen.

 

 

 

On 4/9/2022 at 3:06 PM, Agustin said:

I think the last update made the menus in the space center to shake. At least in my configuration.

I also saw the flag flickering and in map view things shaked too.

Reverting to previous version fixed all that.

Please read a few posts/pages back before reporting an issue that's already reported.

Link to comment
Share on other sites

Just chiming in to say that I also have the flag flickering. On top of that, I noticed black flickering on the inside of hot Restock engine bells. As for others, turning off TAA resolved this for me.

L8itgLs.png

Link to comment
Share on other sites

I'm having an issue with scatterer not loading all the settings from the config.cfg file. The changes I made are being saved correctly in the config.cfg but they don't all get loaded after restarting KSP.  Specifically: ocean underwater caustics, ocean sky reflections and long distance shadows. I have to enable them manually every time I launch KSP. Here's my CFG file. The CFG path is default, gamedata\scatterer\config. 

I removed scatter and purged contents in KCAN and redownloaded - same behavior. 

Steps: Do not open the KSC blue circle icon, use KAC to "jump to ship", then ESC to go back to KSC, then open the blue circle icon and check the 3 settings above. (maybe switching to a ship isn't needed; just what I did)

I also see an EXC in the KSP log when the blue circle icon is clicked.

Spoiler

[LOG 23:28:15.571] [UIMasterController]: ShowUI
[EXC 23:28:18.121] ArgumentException: Getting control 3's position in a group with only 3 controls when doing repaint
Aborting
    UnityEngine.GUILayoutGroup.GetNext () (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUILayoutUtility.BeginLayoutGroup (UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options, System.Type layoutType) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUILayout.BeginVertical (UnityEngine.GUIContent content, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUILayout.BeginVertical (UnityEngine.GUILayoutOption[] options) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    scatterer.MainOptionsGUI.DrawQualityPresets () (at <cfffef0e458b4b3d87698d7c7f3ab260>:0)
    scatterer.MainOptionsGUI.DrawOptionsMenu () (at <cfffef0e458b4b3d87698d7c7f3ab260>:0)
    scatterer.GUIhandler.DrawScattererWindow (System.Int32 windowId) (at <cfffef0e458b4b3d87698d7c7f3ab260>:0)
    UnityEngine.GUILayout+LayoutedWindow.DoWindow (System.Int32 windowID) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

It's not the only EXC though and I have a lot of mods installed.  

Forgot to get Player.log. Let me know if that helps.

Link to comment
Share on other sites

1 hour ago, Krazy1 said:

I'm having an issue with scatterer not loading all the settings from the config.cfg file. The changes I made are being saved correctly in the config.cfg but they don't all get loaded after restarting KSP.  Specifically: ocean underwater caustics, ocean sky reflections and long distance shadows. I have to enable them manually every time I launch KSP. Here's my CFG file. The CFG path is default, gamedata\scatterer\config. 

I removed scatter and purged contents in KCAN and redownloaded - same behavior. 

Steps: Do not open the KSC blue circle icon, use KAC to "jump to ship", then ESC to go back to KSC, then open the blue circle icon and check the 3 settings above. (maybe switching to a ship isn't needed; just what I did)

I also see an EXC in the KSP log when the blue circle icon is clicked.

  Hide contents

[LOG 23:28:15.571] [UIMasterController]: ShowUI
[EXC 23:28:18.121] ArgumentException: Getting control 3's position in a group with only 3 controls when doing repaint
Aborting
    UnityEngine.GUILayoutGroup.GetNext () (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUILayoutUtility.BeginLayoutGroup (UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options, System.Type layoutType) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUILayout.BeginVertical (UnityEngine.GUIContent content, UnityEngine.GUIStyle style, UnityEngine.GUILayoutOption[] options) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUILayout.BeginVertical (UnityEngine.GUILayoutOption[] options) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    scatterer.MainOptionsGUI.DrawQualityPresets () (at <cfffef0e458b4b3d87698d7c7f3ab260>:0)
    scatterer.MainOptionsGUI.DrawOptionsMenu () (at <cfffef0e458b4b3d87698d7c7f3ab260>:0)
    scatterer.GUIhandler.DrawScattererWindow (System.Int32 windowId) (at <cfffef0e458b4b3d87698d7c7f3ab260>:0)
    UnityEngine.GUILayout+LayoutedWindow.DoWindow (System.Int32 windowID) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <58f888e0d56a4620958c8e58a768c70d>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

It's not the only EXC though and I have a lot of mods installed.  

Forgot to get Player.log. Let me know if that helps.

I think this is your culprit

[LOG 23:20:15.562] Applying update Spectra/Spectra_scatterer/Scatterer_Settings/@Scatterer_config:AFTER[scatterer] to Scatterer/config/config.cfg/Scatterer_config
Link to comment
Share on other sites

1 hour ago, blackrack said:

Just pushed a small fix to a TAA smearing issue that affects Waterfall plumes when using Tufx HDR.

Did you get the issue fixed where TAA is disabled when switching to map view with TUFX?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...